MagIC Net

Current version: MagIC Net 3.2

MagIC Net controls the newest line of IC instruments (including the new Eco IC, 940 Professional IC Vario instruments, and the 930 Compact IC Flex instruments) and sample changers. It is 21 CFR Part 11 compliant and enables automation of the whole analysis including sample preparation steps.

MagIC Net 3.2 is delivered in English, German, Chinese and Traditional Chinese.

> Learn about the different MagIC Net versions and additional licences here.

Important hints

Never execute an upgrade without a valid licence code! Without a valid licence code you get only a demo version which expires after 30 days. A downgrade is not possible! To get a valid MagIC Net licence code, please contact your local Metrohm distributor.

Please be aware that a new version of MagIC Net might require also an update of the instrument firmware (internal instrument software) to be able to operate the system afterwards successfully. For further information please contact your local Metrohm distributor.

If you install the Chinese or traditional Chinese language update please make sure, that the respective character support is activated in the language settings of your personal computer.

In order to install a language update, extract and execute the EXE file from the downloaded and compressed ZIP file. Installation will then be carried out automatically.

MagIC Net 3.2

Download the MagIC Net 3.2 version here:

> Download MagIC Net 3.2

The following additional dialog languages can be downloaded for MagIC Net 3.2:

Downloads

MagIC Net 3.1

Download the MagIC Net 3.1 version with the newest upgrades here:

> Download MagIC Net 3.1
> MagIC Net 3.1 Patch 1 (this patch eliminates bugs in the program part Database)

The following additional dialog languages can be downloaded for MagIC Net 3.1:

Downloads

MagIC Net 3.0

Download the MagIC Net 3.0 version with the newest upgrades here:

> Download MagIC Net 3.0

> Patch 1 for MagIC Net 3.0 (this patch eliminates bugs in the program parts Workplace and Configuration) 

The following additional dialog languages can be downloaded for MagIC Net 3.0:

Downloads

MagIC Net 2.4

Download the MagIC Net 2.4 version with the newest upgrades here:

> Download MagIC Net 2.4

> Patch 1 for MagIC Net 2.4 (this patch eliminates bugs in the program parts Workplace) 

The following additional dialog languages can be downloaded for MagIC Net 2.4:

Downloads

MagIC Net 2.3

Download the MagIC Net 2.3 version with the newest upgrades here:

> Download MagIC Net 2.3

> Patch 1 for MagIC Net 2.3 (this patch eliminates bugs in the program parts Workplace and Database)

The following additional dialog languages can be downloaded for MagIC Net 2.3:

Downloads

MagIC Net 2.2

Download the MagIC Net 2.2 version with the newest upgrades here:

> Download MagIC Net 2.2

> Patch 1 for MagIC Net 2.2

This patch eliminates the following bugs:
  • In rare cases, gradient profiles were not processed correctly.
  • The column heater of the 881 Compact IC pro heated up to the maximum after a temperature below current column heater temperature was set.
We recommend to install the patch only if you encounter one of the above mentioned bugs.

The following additional dialog languages can be downloaded for MagIC Net 2.2:

Downloads

MagIC Net 2.1

Download the MagIC Net 2.1 version with the newest upgrades here:

> Download MagIC Net 2.1

Downloads

MagIC Net 2.0

Download the MagIC Net 2.0 version with the newest upgrades here:

> Download MagIC Net 2.0

Downloads

Compatibility of MagIC Net with Windows operating systems 


MagIC Net 3.2
MagIC Net
3.0 – 3.1
MagIC Net
2.2 – 2.4
MagIC Net
2.1 
MagIC Net
1.0 – 2.0 
Windows 10 Yes
No No
No
No
Windows 8.1  Yes No No No No
Windows Server 2012R2  Yes No No No No
Windows 8  Yes Yes No No No
Windows Server 2012  Yes Yes No No No
Windows Server 2008 R2  Yes Yes
Yes
Yes
(only 32 bit version supported)
No
Windows 7  Yes Yes
Yes
Yes
(only 32 bit version supported)
No
Windows Server 2008  Yes Yes
Yes
Yes
No
Windows Vista  Yes Yes
Yes
Yes
Yes
Windows Server 2003  Yes Yes
Yes
Yes
Yes
Windows XP Professional SP2  Yes Yes
Yes
Yes
Yes
Windows 2000 SP4  No No Yes
Yes
Yes

Important: Only Windows Vista Business/Enterprise/Ultimate, Window 7 Professional/Ultimate/Enterprise, Windows 8 Professional/Enterprise, and Windows 10 Pro/Enterprise are supported.