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1 General Information

1.1 Visit us on the internet

Metrohm web page contains updated information about Vision solutions
and patches. It also includes information about new hardware products,
applications, validation, and technical support. Plus, a schedule of upcom-
ing spectroscopy events and in-house training classes is available, to keep
you abreast of current NIR and Raman developments.

Our web address is:

https://www.metrohm.com/en/products/spectroscopy/.

On this page you will find lots of information about Metrohm spectro-
scopy solutions.

1.2 Help in Vision

Vision offers online help.

Online help

Click on [Help] and choose from:

Index – provides the following files in PDF format:

￭ Manual – Reference
￭ Manual – Theory
￭ Tutorial – Instrument Operation
￭ Tutorial – Diagnostics
￭ Tutorial – Instrument Calibration

[About Vision]: displays the version of Vision and Service Pack currently
installed.
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1.3 Documentation

The release notes are separate documents. The release notes are located
on the Metrohm website under Support and Service ▶ Software Cen-
ter ▶ Vision. You find the complete set of release notes under the fol-
lowing link:

https://www.metrohm.com/en/support-and-service/software-center/
vision/

2 Structure of Vision

2.1 Modes

Vision is based on the concept of a mode. Mode is a part of the program
that groups related software functions. There are 4 modes in Vision.

2.1.1 Data Acquisition Mode

Data Acquisition mode combines all functions related to instrument and
spectral management. Major functions of this mode include:

￭ Instrument configuration and diagnostics
￭ Spectral acquisition
￭ Spectra viewing and management
￭ Export and import of data, projects, and libraries
￭ Security

2.1.2 Qualitative Analysis Mode

Qualitative Analysis mode includes all functions related to the creation,
development and validation of pattern recognition libraries. Major func-
tions of this mode include:

￭ Sample selection
￭ Identification method development
￭ Qualification method development
￭ Library validation

2.1.3 Quantitative Analysis Mode

Quantitative Analysis mode involves all functions associated with calibra-
tion development and maintenance. Major functions of this mode include:

￭ Sample selection
￭ Equation development (regression)
￭ Equation development (leverage)
￭ Equation validation (predict)
￭ Unscrambler predict
￭ Pre- or Post-processing equations

https://www.metrohm.com/en-us/support-and-service/software-center/vision/
https://www.metrohm.com/en-us/support-and-service/software-center/vision/
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2.1.4 Routine Analysis Mode

Routine Analysis mode includes functions related to the routine acquisition
and storage of data, and qualitative or quantitative predictions, such as:

￭ Operations Method configuration
￭ Real time analysis
￭ Stored data analysis
￭ Report generation
￭ Results storage and management

2.2 Major Concepts

2.2.1 Databases

Vision software keeps all operational and configuration data in databases.
There are several types of databases involved in the software.

Security Database

The security database contains all the information necessary to recognize
multiple users and assigns to each of them the proper access to the soft-
ware. In specific, this database contains user IDs, passwords, security
access levels, and user preferences information.

Project Database

The project database is password protected and contains all spectral and
constituent information needed for qualitative or quantitative model
development.

Library Database

The library database contains qualitative models and pointers to spectra in
the appropriate project databases.

Diagnostics Database

The database stores the results of instrument diagnostics.

2.2.2 Data Collection Method

Data Collection Method (DCM) defines all instrument specifications
(instrument model, module and amplifier type, number of scans or acquis-
ition time) and selected performance test parameters (like pass/fail limits).
A project must have at least one DCM. However, DCMs are not shared
between projects. The user is prompted to define a DCM every time a new
project is created.

A single project can have many DCMs, and a project database can store
spectra acquired from different types of instruments and modules. During
sample selection the user specifies filter settings (amplifier type and spec-
tral region) which allows Vision to search the project for samples satisfying
these criteria.
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2.2.3 Sample Selection

Sample selection is a necessary step in model development. In qualitative
model development, all spectra transferred to the library product form a
temporary set and have to go through the sample selection procedure.
Sample selection divides them into a training set (good data), an accept-
ance set (redundant samples) if desired, and a rejection set (outliers). Only
when the sample selection results are saved, can the model be developed
from the training set. The same applies to quantitative model develop-
ment, where the analogous sets are called the calibration set, the valida-
tion set, and the outlier set.

2.3 Data, Methods, and Results Storage

Understanding how Vision stores information will help in proper software
operation.

Spectral data, constituent data, DCMs, and all parameters related to spec-
tral acquisition and manipulation (e.g., dates and times of acquisition,
audit trails) are kept in the Project Database.

All qualitative methods (identification and qualification method) and their
parameters, as well as the validation results are kept in the Library Data-
base.

Calibration equations are kept in the Project Database.

Operations Methods are stored in the Project Database.

Results and spectra from Routine Analysis are stored in an output project
database (created during the Routine Analysis set-up) and/or in other file
formats. ASCII files for example, are not associated with any database and
can be stored in any location, including network drives.

2.4 User Preferences

The security database contains preferences for each registered Vision user.
User preferences are a set of default parameters applied every time a
given user is logged into Vision. In general, these parameters include math
pretreatments and methods used in the last method development session.
These preferences are updated every time the user edits a method and
saves it. User preferences are local, i.e., each part of Vision software may
have its own set.

User preferences for qualitative and quantitative sample selection, identifi-
cation method development, qualification method development, and
regression can be viewed and modified before method development
starts.
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2.4.1 Intelligent Default System

Intelligent default system facilitates fast new methods development and
edition of existing methods. Methods that are being redeveloped have old
parameters as defaults. New methods take default values from user pref-
erences. When user preferences do not exist (a method of this kind has
never been developed in the past), the system defaults are applied.

3 Data Acquisition Mode

3.1 Introduction

Data acquisition mode controls instrument configuration and diagnostics,
spectral acquisition, spectra viewing and management, export and import
of data, and security. When the user logs into Vision, the Data Acquisition
mode is entered by default. The last active project is opened, and if the
instrument was connected during the last session, Vision tries to connect
it.

3.2 Creating and Configuring a New Project

The Project is a basic unit of data storage in Vision. Each Project represents
a separate database, which includes spectra, constituent values, and
instrument configuration. Before any data (instrument diagnostics or spec-
tral data) can be collected, a Project must be setup.

3.2.1 Creating a New Project
 

1 Click on File ▶ Project ▶ New on the main menu. If an existing
Project is currently open, you will be prompted to close it.

A Create New Project dialog box opens.

 

2 Enter a Project name and location for the Project. The default loca-
tion is C:\Vision unless specified; a [Browse] button is available for
easy access to other locations.

The Configure Data Sources window displays.
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3 Choose the proper instrument driver and click on [Configure].

Refer to corresponding analyzer User Manual for configuring the
connection.

 

4 From the Connect to Instrument dialog box, choose to [Acquire
data] or [Use Existing data].

If you choose to Use Existing data, Vision will open the new Project,
without connecting to the instrument.

If you choose to Acquire new data, Vision will try to connect the
instrument. The Select Data Collection Method dialog box
appears.
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Click on [New] if you do not have any DCMs in the Project. Follow
the instructions below on how to create a DCM.

Highlight the name of the DCM and click on [OK].

3.2.2 Creating Data Collection Method (DCM)
 

1 From the Select Data Collection Method dialog box click on
[New].

 

2 In the Edit Data Collection Method window, enter the data
acquisition parameters according to the type of the analyzer.

 

3 Click on [OK] when done.

3.2.3 Opening a Project
 

1 Click on File ▶ Project ▶ Open or on the Open Project icon:

 

2 Click on [OK] if prompted to close the active Project.

 

3 The Open Project window lists regular and output projects in sepa-
rate areas.

From the Open Project window select the Project you want to open
and click on [Open].

 

4 From the Connect to Instrument dialog box, choose either
[Acquire Data] or [Use Existing Data] .
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If you choose to use existing data, Vision will open the selected
Project without connecting to the instrument.

If you choose to acquire new data, Vision will try to connect the
instrument. The Select Data Collection Method dialog box
appears. Highlight the name of the DCM and click on [OK]. If you do
not have a DCM, you can create one by clicking on [New].

3.3 Data Acquisition

Spectra in Vision can be acquired manually, or this process can be automa-
ted using the data acquisition timer and the autosave feature.

Vision saves acquired spectra in the database of the active project. The
spectra of the same substance are usually saved in one product.

3.3.1 Acquiring Data
 

1 If you do not have a Project open, click on File ▶ Project ▶ Open
to select and open a Project.

 

2 If necessary, connect to the instrument by clicking on
Acquire ▶ Connect.

(If under Acquire you can see the Disconnect option instead of Con-
nect, you are already connected).

Select the DCM and click on [OK].
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3 Click on Acquire ▶ Reference to scan the reference. Alternatively,

you may click on the Reference icon: 

The red progress bar at the bottom of the screen shows the status.
After the scan is complete, click on the Reference tab at the top of
the screen to view the reference spectrum.

 

4 Click on Acquire ▶ Sample to scan the sample spectrum. Alterna-

tively, you may click on the Sample icon: 

The blue progress bar at the bottom of the screen shows the status.
After the scan is over, click on the Sample tab at the top of the
screen to view the sample spectrum. The last spectrum acquired is
displayed in black.

NOTICE

You can also scan reference and sample using the cuvette icons
located below the main menu. Place the cursor on the icon to
see its function.

3.3.2 Saving Spectra

You can save the last acquired spectrum as follows:

 

1

Click on Acquire ▶ Save or on the Save icon: 

The Enter Sample Information dialog box will be displayed:

 

2 In the Enter Sample Information dialog box, type in the Product
ID (or choose it from the dropdown list) and the Sample ID. Enter the
optional comment and click on [OK].

An example is given below:
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3 Vision will ask if you wish to create a new product:

 

4 In the Add New Product window enter the optional product class
and description. Click on [OK] when done.

The Edit Constituents window will be displayed:
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5 In the Edit Constituents window, click [Add] to enter a constitu-
ent.

 

6 Enter the constituent name, and click on [OK]. Constituents may be
added to the product at a later time, if that is more convenient.
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7 The constituent name “plasticizer” was added. Next, enter the units,
and decimal points to be displayed. In this case, “2” is entered, to
display 2 digits after the decimal point. Click on [OK].

This procedure holds for the first sample saved in a product. When next
samples are saved, Vision assumes the same product, class, and constitu-
ent configuration as for the previous sample. Alternatively, the user may
enter new information, to create a new product during the session.

3.3.3 Using the Stored Reference

Vision allows a reference scan to be saved and retrieved later. This is not
the normal procedure, as the stored reference can contribute to spectral
inaccuracy, under some conditions. Consult Metrohm NIRS representative
before implementation of a Stored Reference.

 

1 Click on Acquire ▶ Store Reference to save the last taken refer-
ence spectrum.

 

2 In the Store Reference window, enter the reference name and click
on [OK].

 

3 To retrieve a stored reference, click on Acquire ▶ Select Refer-
ence. In the Select Reference window, highlight the name of the
reference you want to use and click on [Load]. The loaded reference
will be the active reference until you acquire or load a new one.
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3.3.4 Using the External Reference

The External Reference feature in Vision allows for correction for the
fiber length or fiber characteristics on a 6500-Series Process instrument.
It is highly recommended for use in all 6500-Series process instruments.
XDS Process Instruments use Reference Standardization instead.

In normal data acquisition, the reference spectrum (in the log(1/R) form) is
subtracted from the analogous form of the sample spectrum, resulting in
the absorbance spectrum. This standard approach works very well for
instruments for which the reference light path (channel) is identical to the
sample light path (channel), most often laboratory systems.

On the other hand, on most process instruments the reference and the
sample fibers are separate. The reference fiber (channel) is identical on all
instruments. However, the sample fiber (channel) is most often much lon-
ger than the reference fiber; its length depends on the actual instrument
configuration. The qualitative or quantitative models created on such an
instrument depend on the difference of the lengths of reference and sam-
ple channels. These models work well on the instrument they have been
created for, but method transfer is often complicated.

The use of External Reference allows the user to get rid of the fiber char-
acteristics from the acquired spectra, and consequently from the analytical
methods.

The recommended way of using the External Reference feature is as fol-
lows:

 

1 Acquire a spectrum of the empty sample channel (no sample present,
e.g., empty process line).

 

2 Save the spectrum in a chosen product. This spectrum contains the
fiber characteristics.

 

3 When ready to take real spectra, click on Acquire ▶ Use External
Reference.

Vision will subtract the whole External Reference spectrum (empty channel
minus reference) from each acquired spectrum (filled channel minus refer-
ence). The reference channel is almost identical, so the reference spectra
will cancel out. The final result is that each acquired spectrum is corrected
for the empty channel.

This feature has been developed mainly for the process instruments, but it
is also possible to use it on laboratory systems. Consult a Metrohm repre-
sentative before using External Reference on an XDS system.
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Please note that the External Reference feature is different from Stored
Reference, where the data acquisition proceeds in a normal way using a
reference spectrum saved previously in the Project.

3.3.5 Using the Autosave Function

The Autosave function allows saving of an acquired spectrum in a speci-
fied product with a predefined name. To configure the Autosave:

 

1

Click on Acquire ▶ Autosave or the Autosave icon: 

 

2 In the dialog box select the product ID from the drop-down list. You
can also enter a new product name. In this case you will have to
define class and constituent parameters for this new product.

 

3 Enter the sample name prefix or enable the use of Date and Time as
sample name. Samples will be saved with names created from the
prefix with a 4-digit consecutive number appended.

 

4 To stop Autosave function, click on Acquire ▶ Autosave to disable
it.
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3.3.6 Using the Data Acquisition Timer

The data acquisition timer allows data acquisition to run automatically and
to scan the reference and samples in predefined time intervals. The
acquired spectra are saved by the Autosave function. This function is used
most often with process instruments. To program the timer:

 

1 Click on Acquire ▶ Timer/Auto referencing:

 

2 The Configure Timer/Reference(Dark) Frequency window
opens:

 

3 In the Sample Frequency field:
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￭ Enter the sample collection interval in seconds. Please note that
the additional time interval should be added to the duration of
one full measurement. For example, if the duration of the meas-
urement is 65 seconds with 15 seconds interval, the sample col-
lection interval should be set at 80 seconds.

￭ Enter the delay time for start of the timer

In the Reference Frequency field select the reference acquisition
interval.

￭ When sample and reference scans are coincident, Vision will scan
reference first, unless the check box is marked.

 

4 Click on [OK] when done.

 

5 Configure the Autosave function as described above.

 

6 Vision will start timed data acquisition according to the timer set-
tings. In order to stop the data acquisition timer click again on
Acquire ▶ Timer.

3.3.7 Changing the Data Collection Method
 

1 In order to change the DCM, click on Acquire ▶ DCM and select
the DCM.

You can also create a new DCM at this point.

NOTICE

Once a spectrum has been saved using an existing DCM, the DCM
cannot be changed.

3.3.8 Lamp Status Management

When closing a Project or exiting Vision when connected to the analyzer,
the program can turn the instrument lamp off, leave it on, or ask the user.

 

1 To configure this option, click on Configure ▶ Configuration from
Data Acquisition mode.
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2 Select the Logout Interval/Lamp Life tab on the dialog.

 

3 Select desired option, either Ask, Off or On. The default is Ask,
which means that Vision will ask whether the lamp is to be turn off
upon each exit.

This is the Vision dialog box:

If the instrument will be used again within a few hours, click on [No]
to leave the lamp on. If the instrument will not be used for some
time, such as overnight or over a weekend, click on [Yes] to turn the
lamp off.

NOTICE

The Lamp Status Management differs based on the configuration
and applies only if the Lamp Status jumper is used. Please bare in
mind that the jumper is used by default unless indicated otherwise.
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3.4 Viewing Constituent Data

 

1 In order to view constituent data, click on a product or sample spec-
trum to highlight it.

 

2 Click on Edit ▶ Constituent Values. A spreadsheet with constitu-
ent data will be displayed.

The data can be printed or the whole spreadsheet exported to Excel.

Click on tab Constituents to display the constituent values for all
constituents.

Click on tab Summary to display the statistics for all constituents:
maximum value, minimum value, mean, and standard deviation.

Click on the Correlations tab to display intercorrelations between
constituents.

3.4.1 Viewing and Hiding Spectra

As each sample is scanned it is displayed in black, and if it is not saved it is
replaced with the next sample scan. If the sample is saved, the spectrum
can be displayed in color, but stays in black until selected. The color of the
spectrum and the check symbol at the sample name are the same, and as
a sample is selected and deselected a predetermined series of colors are
used to identify the sample name and spectrum. Specific products or
groups of products can be viewed, and spectra can be “hidden” or
removed from the sample list.

To view a sample spectrum, expand the product it belongs to, and click on
the sample name. Click on the sample again to deselect it. You can display
multiple samples from various products by simply clicking on them in turn.
To display a range of sample spectra from a product, click on the first
spectrum in the range, and then holding down the Shift key click on the
last spectrum. To clear the spectral display, click on Edit ▶ Unselect All.

At the top of the sample list column, on the left side of the tool bar, is a
combo-box with a drop-down menu from which a display option can be
selected. The default setting for spectral display is to List All Products. To
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view spectra of a particular product, click on the combo box arrow and
select the desired product.

All samples of the selected Product are listed, and the samples which you
wish to view must be individually clicked on from the list.

View spectra from a subset of products by selecting that item from the List
Box. Select the products to display from the Define Subset list box which
appears. You must individually select which samples to plot by clicking on
the sample name.

The hidden samples remain in the project database, but they are neither
displayed nor used for the model development. There are 2 ways to hide
samples. The quickest is to click on and drag the sample name you wish
to hide down to the highlighted Hide Samples bar at bottom of the
sample list column. A sample can also be hidden by right-clicking on the
sample name and selecting Properties from the menu to bring up the
Sample Information dialog box, and clicking [Hide This Sample]. With
either hiding method a popup box asks for confirmation.

List hidden samples by double clicking on the Hidden Samples bar, or
by selecting Hidden Samples from the combo box. To retrieve hidden
samples either click and drag them to the Shown Samples bar at the
bottom of the list column, or by deselecting the Sample Information
check box, [Hide This Sample]. Double click on Shown Samples to
return to the shown samples list. You will not be asked to confirm
retrieved samples.

The button bar shown here is at the bottom of the display. Right-click on a
button to display the definition of its function.

The chart tool bar floats. Pick it up by clicking and holding the mouse but-
ton in the blank portion to the right of the buttons and drag it to the
desired location. Moving it may be necessary when displaying and chang-
ing background colors. To return the tool bar to its original position, dou-
ble click on the tool bar’s title bar. If the tool bar disappears, click on a
sample name to turn it back on.

To display absorbance and wavelength values, position the cursor
near a spectrum and hold down the left mouse button. A crosshair repla-
ces the mouse arrow and attaches to the spectrum. As the mouse moves,
the crosshair will follow the coordinates of the spectrum. At the top of the
display the wavelength and absorbance values for the crosshair position is
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displayed beneath a color band indicating the spectrum which has been
selected. In case multiple spectra are displayed, the crosshair will follow
the spectrum closest to the arrow tip when left-clicked.

At the bottom of the spectral display window there is a number of icons.

Copy spectra to the Windows clipboard by clicking the copy icon.
Select either a Bitmap or Windows Meta File (WMF) format. The WMF for-
mat is preferable because it is fully scalable. Only if your word processor
cannot handle WMF should you select Bitmap format. After copying the
spectrum to the clipboard, change to your processing software, click the
mouse pointer at the place in the document where you want the spec-
trum and select Edit and Paste to put it there.

Directly print a spectrum by clicking the printer icon. To change print
parameters, open the File menu and choose Print Setup. You will proba-
bly want to set the orientation to Landscape. After changing the orienta-
tion and exiting the Print Setup dialog, click on the print icon to reprint
the spectra. If adding a new printer, the Windows driver disks may be
required.

Change the display background color by clicking the color list arrow.
Click on the desired color to change the color in the box to the left of the
list arrow, then place the mouse button over the color box and hold down
the left arrow to drag a paint can to the desired area of the display and
release the mouse button. It is often helpful to change the background
color to white when taking a spectral plot to a word processor document.
In this case, color both the frame around the spectrum and the spectrum
background.

To annotate spectra, click on the paintbrush icon. The annotator
allows for drawing arrows and writing text descriptions. To draw an arrow,
position cursor at the end of the arrow, press the left mouse button, and
move the pointer to the front of the arrow. Release the mouse button. To
add text to the arrow, left-click it and choose Draw Text from the popup
menu. To delete the arrow, left-click it and choose Delete Arrow. This
action also deletes accompanying text, if it exists. The spectral window
should not be resized after arrows are drawn. The spectral view can be
copied to the clipboard with arrows and text as a bitmap.
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Copying as Windows Metafile will not include arrows. Deselect the icon
when done.

Add vertical or horizontal grids to the spectrum view by clicking the
grid icons.

Change the size of the data points with the bubble icon. There are 4
size levels ranging from none to large. Keep toggling this icon to return
data points to their original size.

The properties of the plot can be changed by clicking on the chart
properties icon. It is recommended to use the default properties.

Add a title to the spectra by selecting the chart properties icon the
Titles tab. The title appears in the top border of the display window.

To expand regions of the spectrum, click on [zoom] and the cursor
changes to a magnifying glass. Select an area to zoom by holding down
the left mouse button, dragging the cursor to the desired point and then
releasing it. A double click in the colored portion at the top of the new
spectrum display box or the maximize icon expands it to full screen size.
Double click again to return the box to its previous size. The zoomed in
area can be dynamically changed by dragging the zoom box in the origi-
nal display.

3.4.2 Using the Plot Sample Group Function

The Plot Sample Group Function is designed for displaying a large number
of spectra. It provides means of displaying only a representative subset of
selected spectra and also has color control for the spectra as a group.

 

1 Select the range of spectra or entire product.

 

2 Right click the selection and choose Plot Sample Group. The box
below is displayed. This dialog is self-explanatory. In this example, out
of the total of 9 spectra selected, 3 will be displayed, starting from
the second spectrum and displaying every third spectrum. Before dis-
playing, spectra will be sorted according to time. 2nd derivative spec-
tra will be shown.
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3 Click [Colors] to choose the color for the group. The window with
spectra stays on top, and the user can select another group and dis-
play it in the same window with different parameters.

3.4.3 Viewing Constituent Data
 

1 In order to view constituent data, click on a product or sample spec-
trum to highlight it.

 

2 Click on Edit ▶ Constituent Values. A spreadsheet with constitu-
ent data will be displayed.

The data can be printed or the whole spreadsheet exported to Excel.
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Click on tab Constituents to display the constituent values for all
constituents.

Click on tab Summary to display the statistics for all constituents:
maximum value, minimum value, mean, and standard deviation.

Click on the Correlations tab to display intercorrelations between
constituents.

3.4.4 Constituent Data Display Precision

The number of digits after the decimal point can be changed. The change
will affect all spreadsheets where constituent data or predicted values are
listed, including Routine Analysis Report.

To change the constituent data display precision:

 

1 In Data Acquisition mode click on Edit ▶ Products.

 

2 Select Constituents radio button and click on [Edit].

 

3 Enter the number of digits in the Decimal Points field and press
[Enter] key. The precision is defined for each constituent separately.
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NOTICE

The default precision is 4 digits.

3.4.5 Viewing Transducer (Analog) Values

Transducer Values are used in process applications.

 

1 Connect Transducer Values to a temperature sensor to collect quant
data for each sample in routine analysis.

 

2 To view transducer values, select a sample or product in Data
Acquisition mode, choose Spectra from Edit menu, and click on
the Analog tab in the spreadsheet.

3.4.6 Viewing Math Treated Spectra

Vision performs math conversions, but it does not save converted spectra
to the database.

The math treatments can be chained in the desired order and the results
displayed and inspected.

To view math treated spectra:

 

1 Click on Configure ▶ Math Treatments, to display the Select
Math Treatments dialog box.
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2 Select the desired treatments in the proper order from the menu that
is displayed. Click on [Add] when done.

 

3 From the Math Treatment Properties window, select the math
treatment parameters and click on [OK] when done.

 

4 When you are finished, click on [Close] to exit the math treatments
dialog box.

 

5 The spectral view page will now have tabs at the top denoting the
selected math treatments and their combinations. Click on a tab to
view the spectra with treatments applied.

 

6 Initially, the math treated spectra display is empty. Deselect all spectra
and select them again.

NOTICE

If you want to create 2 or more tabs with the same math treatment
type, Vision will prompt you to type new names for multiple tabs.
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3.5 Data Management

3.5.1 Sample Information
 

1 You can review sample information by right-clicking on the sample
name in the project tree window, and selecting Properties from the
displayed menu.

The sample information includes the sample and product ID, date
and time of collecting the spectrum, comment and audit trail, and
the DCM name.

 

2 You can view the Data Collection Method, constituent values, or
print the sample information by clicking on the appropriate button.
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3.5.2 Editing Product Information
 

1 You can view and edit product information by clicking on
Edit ▶ Products from the main menu.

This will display a spreadsheet with all products in the active Project.

 

2 You can add, edit, or delete products, classes, or constituents. Click
on [Done] to close the window.

3.5.3 Editing or Adding Constituent Values

Constituent values can be added or edited in the spreadsheet that displays
them in the following way:

 

1 In Data Acquisition mode select a spectrum or product and click
on Edit ▶ Constituent Values.

 

2 Enter the constituent value into the proper cell and press [Enter] key.
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NOTICE

It is possible to copy and paste columns of data from other Windows
applications and ASCII files.

If the column of data is pasted, make sure that the destination col-
umn is of the same length as selected in Vision.

3.5.4 Averaging Spectra

Spectra in Vision can be averaged in 2 ways. In manual averaging selected
spectra are averaged and the single result placed in the selected product.
In automatic averaging all spectra in the selected product are divided into
groups and spectra within groups averaged. The user has to define the
number of spectra in a group.

If selected spectra have constituent values, they are also averaged.

Manual Averaging of Spectra

To average spectra manually:

 

1 Select spectra to be averaged. Selected spectra will have check marks
next to them.

 

2 Click on Edit ▶ Average Samples.
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3 From the Save Averaged Sample dialog box, choose the product
where you want to save the averaged spectrum. You can also create
a new product by typing its name in the Product ID field. In this case
Vision will guide you through the product setup process.

 

4 Type in the sample ID and optional comment.

 

5 Click on [OK].

Automatic Averaging of Spectra

To average spectra automatically:

 

1 Select the product to be averaged by clicking on it.

 

2 Click on Edit ▶ Average Samples.
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3 In the Save Averaged Sample dialog box, type in the group size.
Vision will split spectra into groups in the order they appear on the
tree and calculate the average within each group.

 

4 Choose the product to save the averaged spectra. You can also cre-
ate a new product by typing its name in the Product ID field. In this
case Vision will guide you through the product setup process.

 

5 Define spectra ID. You can use the name of the first spectrum in each
group, or define a prefix, which Vision will append with four digits
consecutive number.

 

6 Type in an optional comment and click on [OK].
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NOTICE

Spectra for averaging have to be selected from the same product.
Constituent records of the averaged spectra and destination product
have to match. If they do not match, Vision issues an error message
and aborts averaging. Automatic averaging will average spectra in the
order they have been saved in the project. Re-sorting spectra before
averaging does not affect the order and results of averaging.

3.5.5 Spectral Manipulation

Spectral manipulation allows users to do addition or subtraction of spec-
tra, multiplication of a spectrum by a constant, and division by a constant.

To use the function:

 

1 Click Configure ▶ Spectral Manipulation from the Data Acquisi-
tion mode.

 

2 Select the desired operation. You can process raw or math treated
spectra.

 

3 From the next window select first spectrum and click [Next]. Select
the second spectrum (or the numerical factor for the division and
multiplication) and click [Finish]. The result is displayed in black
color.
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4 The resulting spectrum can be saved by clicking the Save icon and
typing a new name. In order to delete the result of the operation,
click Configure ▶ Spectral Manipulation ▶ Clear.

3.5.6 Computing Standard Deviation Spectra

The standard deviation spectrum of a group of spectra can be computed
and saved.

In order to compute the standard deviation:

 

1 Select the group of spectra in Data Acquisition. The selected spectra
are displayed. When computing the standard deviation of a whole
product, select the product name.

 

2 Click on Edit ▶ Compute Standard Deviation. The window that
opens shows available pretreatments (all pretreatments for which
tabs in spectral display window are created are available).
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3 Select pretreatment and click on [OK].

 

4 Select the product and new sample name in order to save it.

NOTICE

Important: Only spectra from a single product can be used. The mini-
mum number of spectra for calculation is 3.

3.5.7 Math Manipulation

Math manipulation function allows operations on raw and math-treated
spectra in the numerical form. Please note that in order to use the func-
tion, you have to select and configure appropriate math treatments on the
main Data Acquisition page.

 

1 Click on Configure ▶ Math Manipulation to open a blank spread-
sheet window. Please note that the top of the window contains tabs
that correspond to your selected math pretreatments.
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2 Click on the proper tab and the selected spectrum or spectra on the
left panel to import the numerical values. The example below shows
2 spectra imported into the spreadsheet as thickness corrected spec-
tra.

 

3 Spectral processing is done by means of icons at the bottom of the
page.

To print the spreadsheet, click on the printer icon.

To save the spreadsheet in the Excel format, click on the diskette
icon.
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Click on Designer mode icon (or double right-click the spread-
sheet) to open the Tidestone Formula One Workbook Designer. The
designer mode allows you to process spectral data using standard
Excel-compatible formulas.

Clicking on the Copy icon allows you to place selected part of the
spreadsheet in the Clipboard.

The Import Sample icon allows importing processed or external
data back to Vision as normal spectra. In order to import spectra to
Vision follow these steps:

￭ Open Math Manipulation window. Import data and perform
desired processing. Alternatively, paste into the spreadsheet spec-
tral data as a column of numbers. To paste data copied from
other application (such as Excel), select the cell at the top of the
page, and use Paste icon.

￭ Highlight the spectral values intended for import. For multiple
spectra highlight the range of values, for a single spectrum double
click the top value.

￭ Click on the Import icon. Vision will ask you to select the DCM,
product name, and sample name (in case of importing multiple
samples you will have to enter a name for each spectrum).

3.5.8 Sorting Spectra

Product spectra displayed on the tree can be sorted by constituent values,
sample ID, chronological order, or stored order.

To sort product spectra:

 

1 Select a product to be sorted by clicking on it.

 

2 Click on Edit ▶ Sort Product Samples. Choose the sorting criteria.

 

3 From the dialog box, choose the sorting order.
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4 Click on [OK] when done.

NOTICE

Sorting does not permanently change the order of spectra in a prod-
uct. Sorting by constituent values is possible only when the product
to be sorted has at least one constituent.

3.5.9 Copying Spectra between Projects and Products

You can copy spectra from one product or project to another. The copied
spectra are not removed from the original product.

In order to copy spectra:

 

1 Select spectra you want to copy by clicking on them. The selected
spectra will have a check mark next to them.

 

2 Click on Edit ▶ Copy (Paste).
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3 In the Open Project window, highlight the destination project. You
can copy spectra to the active project. Click on [Open] when done.

 

4 In the next window select the destination product and click on [OK].

 

5 If the copied spectra have constituents, the Match Constituents
window shows up. You can transfer constituent values to an existing
constituent, or create new name.

 

6 The next window displays the results of the operation.
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3.5.10 Moving Spectra between Projects and Products

You can move spectra from one product to another. The spectra selected
for moving are deleted from the original location and copied to the new
one. If 21 CFR Part 11 compliance is on, you will have to give reasons for
deleting and copying.

In order to move spectra:

 

1 Select spectra you want to move by clicking on them. The selected
spectra will have a check mark next to them.

 

2 Click on Edit ▶ Move. If in the Part 11 compliant mode, enter the
reason for deletion of spectra from the original location such as
"moving"

 

3 In the Open Project window highlight the destination Project. You
can move spectra to the active Project. Click on [Open] when done.
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4 If in the Part 11 compliant mode, enter the reason for copying spec-
tra to the new location:

 

5 In the next window select the destination product and click on [OK].

 

6 If the moved spectra have constituents, the Match Constituents win-
dow shows up. You can transfer constituent values to an existing
constituent, or create new name.

 

7 The next window displays the results of the operation.
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3.5.11 Printing Spectra with Associated Information

A selected spectrum can be printed with its properties on a single sheet of
paper. The properties include Project ID, product ID, sample ID, date and
time of acquisition, user ID, comment, and instrument serial number.

 

1 To print spectrum with properties select a spectrum and click on
Edit ▶ Print Sample Info.

3.5.12 Removing Spectra from Products

Although it is possible to delete spectra from products permanently, it is
strongly recommended to hide spectra. This will allow to add them back
to the sample set when necessary. Although hidden spectra formally still
belong to their products, they are ignored when a qualitative or quantita-
tive method is developed.

 

1 To hide a spectrum, highlight it and drag and drop it to the Hide
Sample area at the bottom of the Sample window.

You can also hide a sample from the Edit menu or from the Sample
Information window.

 

2

3.5.13 Expanding and Converting Vision Data

Expand and Convert functions bring older NSAS and Vision data to the
most recent format with spectral range 400 to 2500nm and 0.5nm data
resolution.

Expanding Project Data

Expand Project Data function increases the wavelength coverage of all
spectra in the project to the full range (400 to 2500nm). Missing parts of
spectra are filled with data points with value of 0.

In order to expand project data:

 

1 Click on File ▶ Project ▶ Expand Data. Vision will ask for confir-
mation:
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2 Click on [Yes] to confirm. After successful expansion Vision will dis-
play the confirmation message:

Converting Project Data

Vision provides utility to convert spectra from SystemII format (2nm spac-
ing) to XDS data format (0.5nm spacing). The conversion is done on all
spectra in an active project. During the conversion Vision gives an option
to reset the existing quant equations. If this option is chosen, all calibra-
tion constants are deleted, but the sample selection results remain intact.

In order to convert the spectra follow these steps:

 

1 Enter Data Acquisition mode and open the project to be conver-
ted.

 

2 Click on File ▶ Project ▶ Convert Data.

 

3 Confirm the operation:
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4 If the project contains calibrations, you will have an option to reset
the equations:

It is recommended to do so and redevelop calibrations; however in
some cases user may want to retain the old equation. In particular,
equations developed on 2nm (SystemII) data can be used to predic-
tion on XDS analyzers. In this case Vision will skip extra points and
apply SystemII calibration on XDS data correctly.

 

5 After successful conversion Vision displays the confirmation message:

Converting Library Data

Vision provides utility to convert libraries from SystemII format (2nm spac-
ing) to XDS data format (0.5nm spacing). The conversion is done on the
library and all spectra in projects linked to the library. During the conver-
sion Vision deletes all library methods (ID method and qualification meth-
ods). However, the sample selection results and library structure remain
intact.

In order to convert library follow these steps:

 

1 Enter Data Acquisition mode.

 

2 Click on File ▶ Library ▶ Convert Data. The Open Library win-
dow opens:
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3 Select the library to be converted from the list and click on [Open].

 

4 Confirm the operation from the next window:

 

5 If operating under 21CFR Part 11 compliance, you will have to give a
reason for methods deletion:

 

6 And confirm:
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7 After successful conversion Vision displays the confirmation message:

3.6 Spreadsheet Representation of Spectra

3.6.1 Absorbance Spectra
 

1 Click on the product name to highlight it.

 

2 Click on Edit ▶ Spectra (or right-click on the product name and
click on Spectra). This will display a window with a spreadsheet. The
spreadsheet contains columns with all spectra in the product.

The spreadsheet can be printed or saved in Excel format by clicking
on the appropriate button.
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NOTICE

Be aware that printing even a single spectrum will use a lot of paper.

3.6.2 Math-treated Spectra
 

1 Click on Configure ▶ Math Manipulation to open a spreadsheet
window. The window contains tabs that correspond to your selected
math pretreatments.

 

2 Click on the proper tab and the selected spectrum to import the
numerical values.

To print the spreadsheet, click on the printer icon. Please see the
note above.

To save the spreadsheet in the Excel format, click on the diskette
icon.

Clicking on the page icon allows you to cut and paste, enter your
own formulas, or do spreadsheet manipulation.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ Data Acquisition Mode

￭￭￭￭￭￭￭￭ 51

3.7 Editing Vision Configuration

Edit Configuration window allows to select visible elements of Vision inter-
face, lamp status for XDS instruments, logout interval and print and save
options. Additionally, the user is prompt to select the correct Technology
used as Vision currently accommodates both NIR and Raman technologies
within the same version.

 

1 Select Configure ▶ Configuration from the main menu. The Con-
figuration edit window will open:

NOTICE

Make sure to select the correct Technology used. For each Tech-
nology, NIR or Raman, the Project options as well as the Diag-
nostics are predefianed in Vision.

 

2 Select desired interface elements: Touch Screen Buttons, Easy Access
Buttons, Status Bar, Tooltips, and Time. All elements are active after
Vision installation by default.

The default White color scheme gives Vision appearance consistent
with most Windows applications. It can be changed to Grey to
improve contrast of spectra for visualization.

 

3 Vision allows the user for Miscellaneous configuration:
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Enable the preferred plot and special visualization options relevant to
chemometric model development.

 

4 For logout configuration and lamp management continue to Logout
Interval tab:

The Turn off lamp option permits the user to either turn the lamp
automatically, leave it on, or asks for action upon logout or when
exiting Vision. Most users stay with the default Turn on lamp with-
out asking setting, unless directed to set it otherwise. For more
information, please visit the Lamp Status Management (section
3.3.8).
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Logout Interval may be set as needed, up to 60 minutes as is shown
here. After the set time, Vision locks the screen and the user must
enter his password to continue.

When set to “0”, Vision never logs out. This setting is not applicable
to regulated environments, as it is not compliant with 21 CFR Part 11
rules.

 

5 For print and save options, click on Print Save tab:

Select whether you want to print your results or save them as PDF
file, as XLSX file or as XML file.

3.8 Configuring the Data Acquisition Options

Each Project has a number of specific options, which define the conditions
in which data can be acquired, and the general data acquisition defaults.

3.8.1 Changing the Options for the NIR Technology
 

1 Click on Configure ▶ Options to open the Edit Options window.

 

2 Click on the proper tab at the top of the window.

If System Project Defaults is selected, the defined options will
apply to all new Projects.

If the Project selection tab is selected, the defined options will
apply only to the current Project.
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3 Check the selected set of options.

￭ Instrument must stabilize before data acquisition. When
this option is checked, Vision will not acquire any data before the
instrument reaches the proper operating temperature.

￭ Performance Test must pass before data acquisition. When
this option is checked, Vision will not acquire any data before the
Performance Test passes.

￭ Run Performance Test after wavelength linearization.
When this option is checked, Vision will automatically run the Per-
formance Test every time the instrument is relinearized. This is not
necessary with the XDS and the DS2500 Solid Analyzer.

￭ Use autolinearization (XDS, DS2500 Solid Analyzer, PRO
Analyzer). When this option is checked, Vision will calculate fine
tuning corrections to the linearization constants every time a ref-
erence spectrum is collected. These corrections are not stored in
the instrument but applied only to the next spectrum collected.
It is recommended to have this option on at all times.

￭ Reference Standardization (XDS, DS2500 Solid Analyzer,
PRO Analyzer). Use this option to standardize the instrument
and acquire standardized spectra on reflectance measurements.
This option must be chosen before creating a DCM. If this option
is selected after creation of a DCM, it does not apply the change
to existing DCMs. You must create a new DCM to use Reference
Standardization.
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￭ Blank Correction. This option is used to create a correct trans-
mission reference on the XDS Rapid Liquid Analyzer.

￭ Use Instrument Calibration (XDS and DS2500 Solid Ana-
lyzer). This is a method used to adjust the instrument wavelength
profile to an external, traceable wavelength standard. This feature
must be used to assure method transferability.

￭ Use Window Correction (XDS Process and PRO Analyzer).
This is selected when using the XDS Process instrument with
either Transmission Pair or Interactance Immersion Probes. This
option should not be used with Interactance Reflectance.

3.8.2 Changing the Options for the Raman Technology
 

1 Click on Configure ▶ Options to open the Edit Options window.

 

2 Click on the proper tab at the top of the window.

If System Project Defaults is selected, the defined options will
apply to all new Projects.

If the Project selection tab is selected, the defined options will
apply only to the current Project.

 

3 Check the relevant set of options:

￭ Instrument must stabilize before data acquisition. When
this option is checked, Vision will not acquire any data before the
instrument reaches the proper operating temperature.

￭ Performance Test must pass before data acquisition. When
this option is checked, Vision will not acquire any data before the
Performance Test passes.
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￭ Use Auto-Raman Shift (PTRam). This is an option used to
adjust the Raman shift for the PTRam instrument. This feature
must be used to assure method transferability.

￭ Use Relative Intensity Correction Ratio 3 for B&W Tek. This
option allows to correct the spectral response against a known
reference. An instrument unit specific correction file is used for
this correction to function. This feature must be used to assure
method transferability.

3.9 Programmed Instrument Warm Up

This function of Vision allows the user to program the time when the
instrument lamp will turn on automatically, software will let the instru-
ment to warm up and stabilize, and then complete the performance test.

In order to use the Programmed Instrument Warm Up function, both the
computer and the instrument have to be on. However, the computer
monitor and the instrument lamp can both be turned off.

3.10 Export of Vision Data

Vision data from the active project can be exported and transferred to
other applications as either MVACDF files, NSAS, SPC or in the ASCII pro-
prietary format.

Vision also can export whole projects and libraries to be transferred to
other computers.

3.10.1 Export to ASCII, NSAS or SPC Format

A whole project, selected products, or selected spectra can be exported to
ASCII, NSAS or SPC formats. If you export whole products, each product is
saved as a separate file. For example, in order to export to ASCII format:

 

1 Click on File ▶ Export ▶ ASCII.
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2 From the Export to ASCII window, select Whole Project, Selec-
ted Product, or Selected Samples. Click on [OK] when done.

 

3 If you are exporting products or samples, choose them from the
selection window. Click on [Export].

 

4 In the Save As window, enter the location and the name of the
saved file.

3.10.2 Export to MVACDF format

The export to MVACDF format is applicable for Vision 4.0 and older ver-
sions.

In order to export spectra to MVACDF format follow these steps:

 

1 Open project with samples to be exported in Data Acquisition.

 

2 From the menu select File ▶ Export ▶ MVACDF. The following
window opens:
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3 The window lists all spectra in the project, with product name they
belong to. Select a spectrum by clicking on it. A range of spectra can
be selected by Shift+click, and multiple spectra by Control+click

 

4 Click on [Export] when all desired spectra are selected.

The spectra are saved in the project folder.

3.10.3 Exporting (Backing Up) Libraries

Vision has built-in an export libraries function. A library is compressed
before saving, so it occupies much less space than original data. There are
2 ways in which a library can be exported:

￭ A library can be exported together with all linked projects (i.e., projects
from which spectra are used in the library development). A library
exported this way can be further developed when it is imported to
another computer. In particular, new products can be added, or library
methods modified.

￭ A library can also be exported without the linked projects. A library
exported this way cannot be further developed or modified when
imported to another computer. It has to be used in Routine Analysis as
is.

Libraries can be exported to a hard disk, network drive or external drive.
Exporting libraries provides an easy way to transfer data and developed
qualitative methods between computers, as well as backing up the mod-
els.

A library is exported together with all qualitative methods (identification
and qualifications methods) developed for the library.

In order to export a library follow these steps:

 

1 Make sure you are in the Data Acquisition mode.
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2 Click on File ▶ Backup ▶ Backup Library.

 

3 From the Open Library dialog box, select the library to be exported
and click on [Open]. If in Part 11 compliance mode, you will be
asked for a reason.

 

4 From the next window, select the destination for the compressed
library. If necessary, click on the plus next to the drive or directory
name to expand it.
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5 If necessary, create a new directory by clicking on [Create Dir]. If
you do not want to create a new directory, click on [OK].

 

6 The next window prompts the user to select a way of export (export
linked projects/libraries). If you click on [Yes], the linked projects will
be exported together with the library. If you click on [No], the links
will be broken and the library will be exported alone. A library expor-
ted this way cannot be further developed or modified when impor-
ted to another computer. It has to be used in Routine Analysis “as is”.

Vision will save a single file in a ZIP format in the selected drive. It can
then be restored on another computer from the Vision software.
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3.10.4 Exporting (Backing Up) Projects

Vision has an export project function built-in. The projects are compressed
before saving, so they occupy much less space than original data. There
are 2 ways in which a project can be exported:

￭ A project can be exported together with a library linked to an Opera-
tions Method (if the Operations Method exists). A linked library expor-
ted with a project cannot be further developed or modified when
imported to another computer, unless it uses only spectra from the
exported project. It has to be used in Routine Analysis as is.

￭ A project can also be exported without the linked library or output
projects.

Calibration equations and Operations Methods that were created in a
project are always exported with the project. The Operations Method out-
put project is exported only when a linked library or project is exported.

If you want to export a project and be able to modify a library used by the
project Operations Method, make sure that all library spectra come from
the exported project. Export the project with links.

Projects can be exported to a hard disk, network drive or external drive.
Exporting projects provides an easy way to exchange data and develop
quantitative methods between computers.

In order to export a project, follow these steps:

 

1 Make sure you are in Data Acquisition mode.

 

2 Click on File ▶ Backup ▶ Backup Project.

 

3 From the Open Project dialog box select the project to be exported
and click on [Open].
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4 From the next window, select the destination for the compressed
library. If necessary, click on the plus next to the drive or directory
name to expand it.

 

5 If necessary, create a new directory by clicking on [Make New
Folder]. If you do not want to create a new directory, click on [OK].
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6 The next window prompts you to select a way of export (Export
linked projects?).

If you Click on [Yes], the linked library and output project (if exist)
will be exported together with the project Operations Method. If you
click on [No], the links will be broken and the project will be expor-
ted alone. A linked library exported with the project cannot be fur-
ther developed or modified when imported to another computer. It
has to be used in Routine Analysis as is.

Vision will save a single file in a ZIP format in the selected drive.

3.11 Importing Data

Vision can accept NSAS spectral and constituent files and import all the
information from these files into an active project database. In addition,
Vision can accept more file formats as ISI, JCamp, Vision Air, CSV or SPC.
All spectra from a single data file are imported as a separate product. The
product name is identical with the name of the spectral file.

Vision can also import previously exported projects and libraries.

3.11.1 Importing NSAS Data Files
 

1 Log into the desired project.

 

2 Click on File ▶ Import ▶ NSAS.
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3 In the Open dialog box enter the directory with the NSAS files.

 

4 Click on a file to highlight and select it.

You can select multiple files by holding down Control key while click-
ing on the files.

You can select a range of files by clicking on the first file in the range,
and then holding down the Shift key and clicking on the last file.

 

5 Click on [Open] when all the files you want to import are selected.

NOTICE

Vision creates a separate DCM for each imported file. Do not be
surprised by the number of DCMs in your project after the files
import. The DCM may not truly reflect how the original data was
collected as this information was not part of the original file.

NOTICE

Vision allocates a buffer to hold the names of spectral files to
import. The size of the buffer is sufficient to import approxi-
mately 100 files with typical name length. If the buffer gets over-
filled, import of data is not successful. In this case import your
files in several smaller groups.
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3.11.2 Import of Vision Air Data Files

Vision allows for import of data files created and saved in Vision Air soft-
ware. The files have an extension *.NIR, *CAL or *.XML and have to match
the Vision supported data points spacing to be successfully imported.

*.NIR and *.CAL files are imported by using the ISI data import. *.XML files
are imported by using the Vision Air import function.

 

1 In order to import a data file click on File ▶  Import ▶  ISI or
File ▶ Import ▶ Vision Air in the Data Acquisition Mode. The
following window opens:

 

2 Browse to the file location, select it, and click on [Open].

Within the current project Vision creates a new product with name
matching the name of the selected file, and transfers all the spectra
contained in the file to the product.

 

3 Some ISI data do not have the amplifier type attached. In this case
Vision will ask to choose Reflectance or Transmission amplifier:

Click on the proper amplifier type.

 

4 XML files do not include information about the used data collection
method (DCM). Vision will ask to define the correct DCM.

3.11.3 Importing (Restoring) Vision Projects

Previously exported Vision projects can be imported back to Vision and
restored. Vision will decompress the zipped projects file and create a new
project name in the security database.

If the project, was exported together with linked library and output
project, all databases will be added to the security database.

In order to import a project, follow these steps:

 

1 In the Data Acquisition mode click on File ▶ Restore ▶ Restore
Project.
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2 In the above window find the location of the zipped project file.
Highlight the file and click on [Open].

 

3 In the next window, select the project name and destination direc-
tory. Vision by default tries to restore the project with its original
name and location. If a project already exists, Vision will give you an
option to overwrite.

NOTICE

If the Project with the same name as the imported Project
already exists, you will be prompted to overwrite. The Project
can be renamed while being imported.

 

4 Click on [OK].

 

5 Repeat this for all linked projects and libraries.
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3.11.4 Importing (Restoring) Vision Libraries

Previously exported Vision libraries can be imported back to Vision. Vision
will decompress the zipped library file and create a new library name in
the security database.

If the library was exported together with linked projects, all projects will
be added to the Security Database.

In order to import a library, follow these steps:

 

1 In the Data Acquisition mode click on File ▶ Restore ▶ Restore
Library.

 

2 In the next window, find the location of the zipped library file, high-
light the file and click on [Open].

 

3 In the next window, select the library name and destination directory.
Vision, by default, tries to restore the library with its original name
and location. If a library already exists, Vision will give you an option
to overwrite.
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NOTICE

If the library name is already in use, you will be prompted to
overwrite. The file can be renamed on importing.

 

4 Click on [OK].

 

5 Repeat this for all linked libraries.

3.11.5 Adopting Vision Projects

Vision project can be opened by Vision if it is complete (all project data-
base files are present in the project folder) and if the location of the
project is in Vision security database. Projects backed up and restored in
Vision automatically create a record in the security database. However, if a
project is moved from one computer to another without backing up (as a
collection of project database files, whether compressed or not) restoring
it requires special tools.

Vision provides a function to adopt (restore) such databases. In order to
adopt Vision project follow these steps:

 

1 If the project is in a removable media (such as CD or memory stick)
insert the media into the drive or connect it into the USB port. Open
Windows Explorer and make sure Windows recognizes the media.

 

2 Inspect the project file. If it is in a compressed form (e.g., a ZIP file)
use appropriate program (such as WinZip) to unzip it. It is highly rec-
ommended to copy the project files from removable media to the
hard drive.

 

3 Open Vision. Click on File ▶  Project ▶ Adopt. The following win-
dow opens:

 

4 Click on [Browse] and in the new window find the project location.
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5 Select the ProjData.D01 file and click on [Save]. Vision defaults the
Project ID to the name of folder with project files. Modify it if neces-
sary. Enter optional description and click on [OK].

3.12 Transfer Data from System II to XDS

3.12.1 Transfer of Calibration Data on the same computer

A calibration equation developed on a System II instrument cannot be
used to predict on an XDS instrument. The spectra from the System II can
be used (after conversion) to create a new calibration for XDS predictions.

Before leaving the System II instrument, while in the project you want to
convert for use on the XDS instrument:

 

1 Go to Configure ▶ Options and select the option for Reference
Standardization followed by Acquire ▶ Connect.

 

2 At the Select Data Collection Method dialogue box, create a new
DCM for your instrument. The box for Reference Standardize
should be active. Select that DCM followed by [OK].

 

3 Move to Diagnostics ▶ Reference Standard ▶ Create Refer-
ence Standard.

 

4 Vision prompts for the ceramic reference. Position the ceramic refer-
ence and click on [OK] for scanning to begin.

 

5 Vision requests positioning of the 80% Reflectance Reference. Posi-
tion the correct reference standard for your instrument and click
[OK] to scan the Certified Reference.
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6 Vision then requests the Standard File for the Certified Reference.
This file is provided with the accompanying the Standard(s) and may
be copied to the Vision directory for ease of use. The file is contained
in RSSxxxx.da Click on the file, then click [Open].

 

7 Vision will plot the spectrum of the ceramic reference, click [OK];
plot the Reflectance Reference spectrum, click [OK]; and plot the
correction spectrum, click [OK]. Correction downloaded successfully
is now displayed.

 

8 Click [Close Report].

 

9 Choose Diagnostics ▶ Reference Standardization ▶ Reference
Standardize Project to Reference Standardize the current project.

 

10 Move to File ▶ Project ▶ Convert. The software will ask if you are
sure. Answer [YES]. Remember this is not reversible. Click [OK].

 

11 If your project data was collected from 1100-2500nm it must be
expanded to full range of 400-2500nm as all XDS instruments scan
full range. Go to File ▶ Project ▶ Expand to expand to full range.
If the original data was collected from 400 to 2500nm, this is not
necessary.

 

12 Now you can proceed to go through Sample Selection and Regres-
sion to develop a new calibration equation using the standardized,
converted, expanded data. Frequently the same math treatments and
regression techniques can be used.

 

13 Create a new Operations Method using the Reference Standardized
DCM and the new Calibration Equation.

3.12.2 Transfer of Library on the same computer

Before leaving the System II instrument, open the project from which you
developed the Library that you want to convert for use on the XDS instru-
ment:

 

1 Go to Configure ▶ Options and select the option for Reference
Standardization followed by Acquire ▶ Connect.

 

2 At the Select Data Collection Method dialogue box, create a new
DCM for your instrument. The box for Reference Standardize
should be active. Select that DCM followed by [OK].
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3 Move to Diagnostics ▶ Reference Standard ▶ Create Refer-
ence Standard.

 

4 Vision prompts for the ceramic reference. Position the ceramic refer-
ence and click on [OK] for scanning to begin.

 

5 Vision requests positioning of the 80% Reflectance Reference. Posi-
tion the correct reference standard for your instrument and click
[OK] to scan the Certified Reference.

 

6 Vision then requests the Standard File for the Certified Reference.
This file is provided accompanying with the Standard(s) and may be
copied to the Vision directory for ease of use. The file is contained in
RSSxxxx.da Click on the file, then click [Open].

 

7 Vision will plot the spectrum of the ceramic reference, click [OK];
plot the Reflectance Reference spectrum, click [OK]; and plot the
correction spectrum, click [OK]. Correction downloaded successfully
is now displayed. Click [Close Report].

 

8 Choose Diagnostics ▶ Reference Standardization ▶ Reference
Standardize Project to Reference Standardize the current project.

 

9 Move to File ▶ Project ▶ Convert. The software will ask if you are
sure. Answer [YES]. Remember this is not reversible. Click [OK]

 

10 If your project data was collected from 1100-2500nm it must be
expanded to full range of 400-2500nm as all XDS instruments scan
full range. Go to File ▶ Project ▶ Expand to expand to full range.
If the original data was collected from 400 to 2500nm, this is not
necessary.

 

11 Go to File ▶ Library ▶ Convert to prepare the Library structure to
accept 0.5nm data. Library Products and their Sample Selection
Results will remain intact.

 

12 The ID and Qual methods developed for System II are automatically
deleted when you do a Library Convert. Recreate the ID and Qual
methods for your Library.
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NOTICE

NOTE: When you recreate these methods the previously used
parameters - wavelength regions, math pretreatments, etc., will
appear as User Preferences and can be used for redeveloping the
models. Even if the red “Q” remains after Library Convert. The
previous models cannot be used in Routine Analysis.

 

13 Create a new Operations Method using the Reference Standardized
DCM and the new Library.

3.12.3 Transfer to another computer

When moving from a System II instrument to an XDS instrument and you
also want to move your data from a previous computer (A) to a new com-
puter (B), follow this approach:

 

1 Follow the “same computer” steps to prepare your Calibration Equa-
tions and Libraries on computer A.

 

2 If you only have (or care about) Calibration Equations, go to
File ▶ Backup ▶ Backup Project. When asked about “with linked
projects and Libraries” answer [NO]. Do the Backup to a network
drive or separate storage device such as flash memory or CD.

 

3 Move to the new computer (B) and Restore the Project.

 

4 If you have only a Library, go to File ▶ Backup ▶ Backup Library.
When asked about “with linked projects” answer [YES]. Do the
Backup to a network drive or separate storage device such as flash
memory, or CD.

 

5 Move to the new computer (B) and Restore the Library with links.

 

6 If you have both a Calibration Equation and a Library, go to
File ▶ Backup ▶ Backup Project. When asked about “linked
projects and Libraries” answer [YES]. Do the Backup to a network
drive or separate storage device such as flash memory, or CD.

 

7 Move to the new computer (B) and Restore the Project with Links.
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3.13 Archiving in Vision

Vision software provides a tool for data archiving in many format types
supported by different Data Management Systems.

For example, an archive in XML format consists of two files. The first file is
the Vision backup file with extension ZIP. The second file is called meta-
data file. It contains information about contents of the archive.

Names of archives are composed of the name of the archived unit and
dates and times of the first and the last piece of data in the unit.

For example, the archive of a unit named:

"MyProject" storing data created between June 4, 2021 at 9:02:23 and
July 9, 2021 at 15:45:21

will be named:

"MyProject_20210604090223_20210709154521.ZIP".

The associated metadata file will be named:

"MyProject_20210604090223_20210709154521.ZIP.NGA".

The 24hour clock is used to define names.

The archival of main projects or libraries is done manually, and archival of
output projects is done automatically using the scheduler in Routine Anal-
ysis. Raw data from output projects will be removed during the archiving
by the scheduler or manual archiving through the function in Routine
Analysis. Data from main projects and libraries will not be removed during
manual archiving.

3.13.1 Manual Archiving

The manual archival can be set it in the Account Policy window. This
requires the system to be CFR 21 part 11 compliant.

 

1 Enter the Data Acquisition mode and click on Config-
ure ▶ Account Policy.
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2 The Account Policy window will appear and you must select CFR
21 Compliance and then XML Backup File.

 

3 When you select XML Backup File, this window is displayed.
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Using the browse button at the right […], find the location of the
DTD file which comes with NuGenesis and defines the metadata file
format (pftemplate.DTD).

 

4 One can also set the frequency with which the system will prompt
the user for the backup as the Maximum Backup Age (default is 7
days).

3.13.2 Automatic Archiving

The setup of automatic archival of an Output Project is done in the Opera-
tions Method.

 

1 From the Data Acquisition mode, click on Mode ▶ Routine
Analysis ▶ Define Operations Method.

 

2 Select an existing Operations Method or create a new one. The Edit
Operations Method window appears.

 

3 Click on [Output Setup]. This will display the following dialog:
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4 Select XML Archive File to enable archiving of the output projects
(if the path to the DTD file has not been defined yet, Vision will
prompt you to find it).

 

5 Click on [OK].

 

6 Back in the Edit Operations Method dialog, click on [Enable
Archive] to setup the scheduler for automatic archiving.

 

7 Click [Archive Configuration] to setup the archiving scheduler:
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3.14 Communicating with Metrohm Raman Instruments

To communicate with a Metrohm Raman instrument, the user must con-
nect the instrument directly at the same computer with a compatible
Vision version (versions higher than 4.1.1.156).

3.14.1 Mira DS/P Instrument Driver
 

1 Click on File ▶ Project ▶ New on the main menu. If an existing
Project is currently open, you will be prompted to close it.

Enter a Project name and click OK

 

2 The Configure Data Sources window displays. Choose the Metrohm
Mira DS/P Instrument Driver as you can see below:
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3 Click on [Configure]:

NOTICE

Please refer to the corresponding User Manual for configuring
the connection properly

 

4 Click on the correct COM Port and on the single option for the Baud
Rate:
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Click [OK] to the above and the following window:

 

5 From the Connect To Instrument dialog box, choose to [Acquire
New Data] or [Use Existing Data].
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If you choose to Use Existing Data, Vision will open the new Project,
without connecting to the instrument.

If you choose to Acquire New Data, Vision will try to connect the
instrument.

 

6 The Select Data Collection Method dialog box appears:

The [Sample default] is the default DCM method. Click on [Mod-
ify/View] to select the correct Raman Range based on the type of
the instrument from the drop-down down menu:
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At this point, the user can set the integration time in ms or keep the
default auto-integration option set at [0], the number of averages
per sample measurement, and the Laser Power using the drop-down
menu:

Modify the default name of the DCM, if desired, and click on [OK].
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3.15 Communicating with B&W Tek Instruments

To communicate with a B&W Tek series instrument driver, the user should
connect the instrument directly at the same computer with a compatible
Vision version (versions higher than 4.1.1.156).

 

1 Click on File ▶ Project ▶ New on the main menu.

If an existing Project is currently open, you will be prompted to close
it.

 

2 The Configure Data Sources window displays. Choose the B&W Tek
series Instrument Driver as you can see below:
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Vision will prompt the user to click [OK] to the information below:

 

3 The Select Data Collection Method dialog box appears:
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Click on the [New] to create a DCM:

The instrument information is displayed automatically. At this point,
the user can set the integration time in ms, enable or disable the use
of an external trigger to acquire a measurement, use sample averag-
ing or modify the Laser Power, and click on [OK].

 

4 Select the previously created DCM and click [OK]
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5 The Instrument Configuration window appears with relevant infor-
mation. Simply click [OK]and continue.

3.16 Communicating with Metrohm NIRSystems XDS Instruments

To communicate with a Metrohm NIRSystems XDS instrument, the user
must have Vision software on a computer capable of supporting it.

3.16.1 Static IP Address (or direct connection)

If the instrument is connected to a network with a standard Ethernet
cable and no DHCP Server is available, the user is responsible to make sure
the IP address of the computer where Vision resides is compatible with the
IP address of the instrument. (169.254.0.2). If not, Metrohm Support can
help you to change the IP address within the instrument for compatibility
or the user can change the IP address in the computer.

If the instrument is not connected to a network, use a crossover cable to
connect between the computer and the instrument and the static IP
address will be assigned. This will work most of the time; however, a
crossover cable is not the most reliable approach to communication.
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3.16.2 Cable Connections

Network Connections – one standard Ethernet cable from the instrument
to a network connection, and one standard Ethernet cable from the com-
puter to a network connection.

Direct Connect or Crossover connection – one crossover cable (gray) from
computer to instrument.

Hub Connection – one standard Ethernet cable (blue) from the computer
to the hub, and one standard Ethernet cable (blue) from the hub to the
instrument.

3.16.3 Troubleshooting

If Vision “doesn’t see instrument” it may be caused by incompatible IP
Address and/or Subnet Mask.

￭ Change IP Address as explained later in this section.
￭ Change the Subnet Mask as explained later in this section. The Subnet

Mask is listed in the 4th line of the Notepad entry (ex. Sub-
net=255.255.255.0).

￭ If 2 network cards are used (not recommended mode of operation!),
and Subnet masks and IP addresses are compatible and you still can’t
see the instrument, type in “XXX.XXX.XXX.XXX, port=2083” in Config-
ure/Input Menu, inside IP Address box in NIRSystems XDS-series Instru-
ment Configuration, and try to connect.

Figure here

3.16.4 Windows or third party firewall configuration

Windows Firewall

 

1 In Windows, go to Programs ▶ Windows Firewall.

 

2 Select the Exception tab.

 

3 Click on [Add Program].

 

4 Select Vision.exe or use [Browse] to locate the Vision directory fol-
lowed by the Vision.exe file.

VPN-1

VPN-1 (usually installed on laptops), Citrix through Metrohm, or any other
software which provides secure channel communication.

￭ For VPN-1, older versions, locate the VPN-1 icon on the lower tool
bar, right click on it and choose the option to Close.
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￭ For VPN-1 newer versions, close it as above and then turn it off by
going to Windows ▶ Network Connections ▶ Properties. Dese-
lect VPN-1 from the list.

￭ For Citrix, treat like older version of VPN-1 and right click on the icon
located on the bottom toolbar and choose close.

￭ For other software packages that provide similar secure channel com-
munication you will have to look. There should be a screen similar to
the one for Windows Firewall.

￭ Network cards: Metrohm does not recommend the use of 2 network
cards. If multiple communication channels are required, use a hub.

3.16.5 Changing the IP Address

Changing the IP Address of the computer:

 

1 Use the IPConfig Utility in Windows.

Changing the IP Address of the XDS instrument:

 

1 Go to Windows ▶ Accessories ▶ Notepad.

 

2 Enter the following exactly as shown:

￭ [Set IP]
￭ Do Update=1
￭ IP=XXX.XXX.XXX.XXX
￭ Subnet=XXX.XXX.XXX.XXX

Optionally add the line

￭ Gateway=63.121.141.1

This is usually done by IT people who know if this line is required.

 

3 Fill in IP address you need to replace XXX. The same for Subnet mask.

 

4 Save the file as “xds_set_ip.ini” in the Vision directory.

 

5 Open Vision and go to Status on the tool bar.

 

6 When the Status dialogue is displayed, click on [Update]. A message
“The IP address has been changed successfully” will be displayed.

 

7 Close Vision, recycle power to the instrument and reopen Vision. You
are ready to go!
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3.17 Communicating with Metrohm DS2500 Solid Analyzer

To communicate with a Metrohm DS2500 Solid Analyzer, the user must
have Vision software on a computer capable of supporting it.

3.17.1 Dynamic IP Address

If the instrument is connected to a network using standard Ethernet cable
where DHCP server resides, a compatible IP address will be assigned.

Use a standard Ethernet cable.

4 Migration to Vision Air

NOTICE

Warning: In certain cases, the DeTrend pretreatment might deviate
between Vision and Vision Air. If you use DeTrend on a small seg-
ment, ensure that the model works correctly in Vision Air.

4.1 Export Library Models

 

1 Open an appropriate Project.

 

2 Perform the following Menu operations:

Mode ▶ Qualitative Analysis ▶ Qualify Method Development

 

3 Select a library to work on from the drop down list.

 

4 Perform the following Menu operations:
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File ▶ Library ▶ Export Qual and Indent Models

The following dialog is presented which shows the available Library
Model Names in an expanded treelist format.

 

5 Select one or more Library Model Names for Export and click on
[Export selected].

 

6 In the following Dialog create a new folder.

NOTICE

Note: Creating a new folder is needed.

 

7 Rename the new folder and press [Enter].
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8 Press [OK] to start the Export progress.

4.2 Export Quant Models

 

1 Open an appropriate Project.

 

2 Perform the following Menu operations:

File ▶ Project ▶ Export Quant Models

The following dialog is displayed which shows the Quant Models
that are available for Exporting:

 

3 Select one or more Quant Model Names for Export and press
[Export Selected].

 

4 In the following Dialog create a new folder.
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NOTICE

Note: Creating a new folder is needed.

 

5 Rename the new folder and press [Enter].

 

6 Press [OK] to start the Export progress.

The option Export for XDS Masterlab (Transmission) is available if one
of the following units is used for the calibration.

Table  1 Units for Export for XDS Masterlab

% # #-% µg/L

µm 1000/mL Absorbance Units g/L

g/mL mg/dL mg/L mK

mL/100g mM mmol/10kg mmol/L

°Brix °C °TH °SH

Volume-% Weight-% "mm kg/hL

Ib/Bu mm3 cm3 mmol/kg

Mcal/lb Mcal/kg ppm ppb

g/lb mg/lb meq mL

mg/100g mgN/dL kg g

lb rpm J mg/g
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in kJ/kg   

4.3 Export Operation Method

 

1 Open an appropriate Project.

 

2 Perform the following Menu operations:

File ▶ Project ▶ Export Operation Method

The Export Routine Analysis OM’s dialog is displayed which
shows all Operation Methods.

 

3 Select one or more Operation Methods for Export and press
[Export Selected].

 

4 In the following dialog choose a folder for the exported OM file and
press [OK].
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The Exporting to Mosaic MCF file dialog shows the Export
Operation Model progress.

This dialog shows the result of the Export.

4.4 Export Data Collection Method

NOTICE

Warning: Keep in mind that the maximum number of subscans dif-
fers between Vision and Vision Air. During migration a higher number
defined in Vision (1-9999) will automatically be cut to fit Vision Air
requirements (1-99).

 

1 Open an appropriate Project.

 

2 Perform the following Menu operations:

File ▶ Project ▶ Export DCM

The dialog Export DCM is displayed and shows all DCMs.
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3 Select one or more DCMs for Export and press [Export Selected].

 

4 In the following dialog choose a folder for the exported DCM files
and press [OK].
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The Exporting to Mosaic MCF file dialog shows the Export
Method progress.

4.5 Versioning of Vision Air Models

If the user exports a model for the first time, it gets version 1.0.0.0 and a
unique ID. If the user exports the model again to the same folder, the ver-
sion number is increased to 2.0.0.0. The ID is maintained. This enables the
possibility to upgrade the model when importing it in Vision Air. If the user
does not want to upgrade the model, then the user has to remove or
rename the old version before exporting the new version.

5 Qualitative Analysis Mode

5.1 Introduction

A library is composed of products, each product being represented by a
set of spectra. The two major purposes of the library are to identify and to
qualify incoming spectra. In identification, the whole or part of a library is
searched to find a library product or products that match an unknown
spectrum according to the criteria of the identification method. The list of
possible matches (which may contain one or more products) may be
passed to a qualification step, where even more rigorous methods confirm
the identity of an unknown spectrum and establish its quality.

In Qualitative Analysis mode, the library model is developed and validated.
The library model is made up of at least one method, but the fully devel-
oped library may include a number of identification methods and a qualifi-
cation method for each product.

Before sample spectra can be used for method development, they must
be processed through the sample selection routine and the results are
saved. Only then can a method or a series of methods be developed and
validated.
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5.2 Sample Selection

The purpose of sample selection is to identify outliers as well as redundant
samples. Dragging and dropping samples from the project product to the
library product creates a temporary set (denoted by question marks to the
left of the sample spectra names). A library product with the temporary set
may be created from a single project product, or it can contain spectra
from many different products.

Since spectra from various products may not be compatible in terms of
spectral ranges or detector used, spectra from the temporary set are fil-
tered prior to sample selection, according to the criteria specified in the
Edit Sample Selection Parameters dialog box. Only the spectra fitting these
criteria (detector cell type and wavelength range) will be let through sam-
ple selection.

Sample selection can be performed on raw spectra. In order to get rid of
scattering effects or to emphasize spectral features, one can use any com-
bination and order of available math treatments.

During sample selection, suspected outliers and redundant spectra are
identified according to the threshold that the user can modify. Outliers are
placed in the rejection set and redundant samples into the acceptance set.
Good samples carrying unique spectral information are selected and
placed into the training set.

5.2.1 Methods of Sample Selection

3 methods are available: random selection, selection by Principal Compo-
nent Analysis (PCA), and selection by wavelength distance. Optionally,
each of these methods can be followed by manual sample selection.

Random Selection

The Random Selection method selects samples at random for training and
acceptance sets.

No rejection set is created when this method is used.

If all product spectra are to be included in the training set choose Random
Selection and declare 100% of the spectra to be in the training set. The
Math Treatment option is not available when Random Selection is chosen.

Selection by Mahalanobis Distance

Selection by PCA first calculates a principal component model for a prod-
uct. All samples with Mahalanobis distances from the center of the distri-
bution greater than a user defined threshold (default 3.0) are flagged as
outliers. Samples located in high density regions of the population (nearest
neighbors) are identified as redundant, so that the Euclidean distances
between sample PCA scores in the training set is greater than the thresh-
old (default 0.6).
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Selection by Wavelength Distance

Selection by wavelength uses a maximum distance concept (maximum
conformity index) to identify outliers. Samples with the maximum distance
from the mean product spectrum greater than the threshold (default value
3.0) are placed in the rejection set. Selection of redundant samples uses a
method similar to selection by Mahalanobis Distance, except that the
Euclidean distance in wavelength space is used.

5.2.2 Sample Selection Procedure

Preparation

 

1 Enter Sample Selection by choosing Mode ▶ Qualitative Analy-
sis ▶ Sample Selection from the main menu. In the left window of
the Sample Selection screen, project folder(s) are displayed in
green and red library folder(s) are displayed in red.

 

2 Optionally, create a new library by selecting File ▶ Library ▶ New
from the menu.

5.2.3 Automated Library Development

Vision allows pre-configuring sample selection methods (method’s algo-
rithm, outlier and redundant sample detection) and performing sample
selection unsupervised on a range of selected products. To perform auto-
mated library development:

 

1 Enter Qual Sample Selection mode. Make sure only one library
(the one to be developed) is opened.

 

2 Click on Configure and from the proper menu configure outlier and
redundant sample selection, select method, and configure its param-
eters:
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3 Select products to be processed from project by clicking on them.
You can also Shift+click to select a range of products. Selected prod-
ucts acquire a check mark.

 

4 Click on Edit ▶ Add Selected Products To Library to start.

NOTICE

Note: If a selected product already exists in the library, Vision will skip
it.
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5.3 Library and Library Project Management

Sample Selection program includes options for library and library products
editing and management.

Sorting products

To be able to manage big projects and libraries, both project and library
products can be sorted by name, time, or storing order.

 

1 To sort, right-click on project or library and select Sort Products
from the menu.

Deleting library products

 

1 To delete a library product, highlight it and choose Prod-
ucts ▶ Delete from the main menu.

Deleting a library

 

1 A library can be deleted only from the Data Acquisition mode.
Click on File ▶ Library ▶ Delete, select a library from the list and
click on [Delete].

Displaying library information

 

1 To display all samples in the library, right-click on the library name
and choose Info from the menu that opens:

 

2 To display all samples in a given product, right-click on the product
name and choose Properties from the menu that opens.
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Displaying summary of library methods

 

1 To display the summary of all methods created for a library, right-click
on the library name and choose Properties from the menu that
opens.

The summary window displays information about global ID method,
qualification methods for all library products, validation information
and status, and library compositions.

5.4 Identification Method Development

5.4.1 Introduction

Identification is a very important step in qualitative analysis.

A single identification method can be developed. This method is global for
the library in the sense that it applies to all the products in the library with
a single identification threshold. On the other hand, if a Principal Compo-
nent based identification method is used (Mahalanobis distance or Resid-
ual Variance), a local PC model for each product is calculated.

Since the PC models are local, it is strongly recommended that each library
product contain at least 30 sample spectra when identification by Mahala-
nobis distance or Residual Variance is attempted.

5.4.2 Cross-checking of Library Samples

The identification method development program checks for misidentified
samples and conflicting products when the method parameters are calcu-
lated. This in fact is a full validation of the method. The results are dis-
played in the form of a 3D histogram and in numerical format.
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5.4.3 Identification Methods and Types of Thresholds

There are 4 identification methods available: Mahalanobis Distance in
Principal Component space, Residual Variance in Principal Component
space, Maximum Distance in Wavelength space, and Correlation in
Wavelength space.

For Mahalanobis distance and Residual Variance methods it is possible to
calculate the probability that a given spectrum belongs to the distribution
represented by the product spectra. Therefore, for those methods, Vision
offers 2 kinds of thresholds: match value (the actual number representing
distance or residual variance), and the probability level. For the 2 remain-
ing methods, only the match value type of threshold is possible.

Any combination of available math pretreatments can be applied to the
spectra with each of the methods.

Mahalanobis Distance in Principal Component Space

In this method, the local Principal Component model is calculated for each
product in the library. During the analysis, the unknown spectrum PC
scores are calculated for each product model and Mahalanobis distance is
calculated. The unknown is identified as a product when the Mahalanobis
distance for this product is within the threshold value. The default thresh-
old is 0.6 for match value and 0.84 for probability level.

Residual Variance in Principal Component Space

In this method, the local Principal Component model is calculated for each
product in the library. Each product Principal Component model is used to
reconstruct the unknown spectrum. The difference between original and
reconstructed spectrum is used to calculate the residual variance. The
unknown is identified as a product when the residual variance for this pro-
duct’s Principal Component model is within the threshold value. The
default threshold is 3 for match value and 0.84 for probability level.

Maximum Distance in Wavelength Space

Maximum distance belongs to the group of wavelength methods. For
each product, the training set of spectra is used to calculate the mean
product spectrum and the inflated standard deviation spectrum. During
the analysis, the unknown spectrum is subtracted from the mean product
spectrum and divided by the standard deviation at each wavelength. The
unknown is identified as a product when the maximum value is within
threshold limits. The default threshold is 3.

Correlation in Wavelength Space

Wavelength correlation is an example of another wavelength method.
During the analysis, the dot product is calculated between the unknown
spectrum and the mean spectrum of each library product. The unknown is
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identified as a product when the value is higher than the threshold. The
default value of the threshold is 0.85.

5.4.4 Identification Method Development Procedure

Preparation

 

1 From the main menu, select Mode ▶ Qualitative Analy-
sis ▶ Identify Method Development to enter the Identification
Development program.

 

2 Open the combo box and double click the library name for which
you want to create the method.

Define the identification parameters

 

1 From the menu select Identify ▶ Apply Math.

 

2 In the Edit Identify Method dialog box configure the following
parameters:
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￭ From the Identification Method list choose the method.
￭ From the Pretreatment Method list choose the desired math

pretreatment methods. You can choose multiple methods; they
will be applied in the order of choice.

￭ In the Wavelength box specify the overall wavelength range.
￭ In the Threshold box declare the preferred type of threshold

(match value or probability, when appropriate). Optionally edit the
threshold value.

￭ Check the Identify Acceptance Set box if you want Vision to
identify samples in the Acceptance Set.

￭ Check the Identify Rejection Set box if you want Vision to iden-
tify samples from the Rejection Set.

￭ When wavelength maximum distance is chosen as the identifica-
tion method, the Library Stabilization box appears. You can
change the default value (0nm) of the stabilization constant to
remove false negative results caused by zerocrossovers.

 

3 Click on [OK] when done.

 

4 In the Edit Math Properties dialog box configure the following
parameters:

￭ In the Wavelength Region box, declare up to 8 wavelength
regions.

￭ If the Mahalanobis Distance or Residual Variance method is
used, in the Components box define how many PCs Vision
should use. Specify either the number of PCs or the percent of
cumulative variance to calculate this number.

￭ If Wavelength Distance is used, you can declare a Minimum
Variance value. The calculated standard deviation spectrum will
not have values lower than this parameter.
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￭ If a math pretreatment was chosen, you can change defaults by
clicking on the proper tab.

 

5 Click on [OK] when done.

Visual Display of Results

The right side of the results screen contains a series of graphs.

The results utilize a uniform color code to denote spectra. The red color
designates outsiders, the spectra that failed identification to their own
products. The dark blue spectra (insiders) are the spectra that were identi-
fied correctly. The left hand side of the screen shows the library tree.

The first graph shows outsiders. If there are no outsiders in the library, it is
blank. Initially the display shows the overall library information. In order to
obtain the specific information about the given product, click on this prod-
uct on the library tree.

The second graph contains 3 pages that can be displayed by clicking on
the proper tab. The Library screen shows the 3D histogram with bars rep-
resenting misidentified samples and conflicting products. The Product Bins
page shows the percent outsiders in all library products. The Product
In/Out page shows individual products, after the product name is clicked
on in the library tree.

The third graph is the histogram of the samples distribution. Initially the
display shows the overall library information. In order to obtain the spe-
cific information about the given product, click on this product on the
library tree.

If the maximum distance is the identification method, the third graph
includes a page displaying mean product spectra with a standard devia-
tion envelope around them. The number of standard deviations corre-
sponds to that parameter chosen for the identification method.
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The fourth graph contains 2 pages that can be displayed by clicking on
the proper tab. The Summary page shows the overall library information.
The Samples screen shows the details of the method validation. Asterisks
below the sample name mean that this sample was identified as more
than one product.

The graphs can be easily rescaled by dragging the division lines to the
desired position.

Saving the identification method

 

1 Click on Identify ▶ Save Results to save the created identification
method in the library.

5.5 Qualification Method Development

5.5.1 Introduction

Qualification is the final step in the analysis. Qualification method helps to
confirm the identity of the unknown, and to establish if the quality of the
sample fits the method’s criteria.

Each product in the library may have its own qualification method with a
different threshold. Methods have to be created separately for each prod-
uct.

It is strongly recommended that each library product contain at least 30
sample spectra when qualification by Mahalanobis Distance or Residual
Variance is attempted.

5.5.2 Qualification Methods and Types of Thresholds

There are 4 qualification methods available: Mahalanobis Distance in
Principal Component space, Residual Variance in Principal Component
space, Maximum Distance in Wavelength space, and Correlation in
Wavelength space.

For Mahalanobis Distance and Residual Variance methods it is possible to
calculate the probability that a given spectrum belongs to the distribution
represented by the product spectra. Therefore, for those methods, Vision
offers 2 kinds of thresholds: match value (the actual number represent-
ing distance or residual variance), and the probability level. For the 2
remaining methods, only the match value type of threshold is possible.

Any combination of available math pretreatments can be applied to the
spectra with each of the methods.

Mahalanobis Distance in Principal Component Space

In this method, the local Principal Component model is calculated for the
product. During the analysis, the unknown spectrum PC scores are calcu-
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lated from the identified product model and Mahalanobis distance is cal-
culated. The unknown is qualified as the product when the Mahalanobis
distance is within the threshold value. The default threshold is 0.5 for
match value and 0.95 for probability level.

Residual Variance in Principal Component Space

In this method, the local Principal Component model is calculated for the
product. The product’s Principal Component model is used to reconstruct
the unknown spectrum. The difference between original and reconstruc-
ted spectrum is used to calculate the residual variance. The unknown is
qualified as the product when the residual variance for the product’s Prin-
cipal Component model is within the threshold value. The default thresh-
old is 2.5 for match value and 0.95 for probability level.

Maximum Distance in Wavelength Space

Maximum Distance belongs to the group of wavelength methods. For
each product, the training set of spectra is used to calculate the mean
product spectrum and the inflated standard deviation spectrum. During
the analysis, the identified spectrum is subtracted from the mean product
spectrum and divided by the standard deviation spectrum at each wave-
length. The sample is qualified when the maximum value is within thresh-
old limits for the product. The default threshold is 3.

Correlation in Wavelength Space

Wavelength Correlation is an example of another wavelength method.
During the analysis, the dot product is calculated between the identified
spectrum and the mean spectrum of the library product. The sample is
qualified when the value is higher than the threshold for the product. The
default value of the threshold is 0.9.

5.5.3 Qualification Method Development Procedure

Preparation

 

1 From the main menu, select Mode ▶ Qualitative Analy-
sis ▶ Qualify Method Development to enter the Qualification
Development program.

 

2 Open the Combo box and select the library for which you want to
create methods.
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Define the qualification parameters

 

1 Expand the library tree by clicking on the plus next to the library
name. Double click the product for which you want to develop a
qualification method. When selected, the product icon will turn gray.

 

2 From the menu choose Select ▶ Apply Math.

In the Edit Qualify Method dialog box, configure the following
parameters:

￭ From the Method list, choose the method.
￭ From the Pretreatment Method list, choose the desired math

pretreatment methods. You can choose multiple methods; they
will be applied in the order of choice.

￭ In the Wavelength box, specify the overall wavelength range.
￭ In the Threshold box, declare the preferred type of threshold

(match value or probability, when appropriate). Optionally edit the
threshold value.

￭ When wavelength maximum distance is chosen as the qualifica-
tion method, the Library Stabilization box appears. You can
change the default value (0nm) of the stabilization constant to
remove false negative results caused by zerocrossovers.

 

3 Click on [OK] when done.
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4 In the Edit Math Properties dialog box configure the following
parameters:

￭ In the Wavelength Region box define up to 8 wavelength
regions.

￭ If the Mahalanobis distance or residual variance method is used,
in the Components box define how many PCs Vision should use.
Specify either the number of PCs or the percent of cumulative var-
iance to calculate this number.

￭ If maximum distance is used, you can declare a Minimum Var-
iance value. The calculated standard deviation spectrum will not
have values lower than this parameter.

￭ If a math pretreatment was chosen, you can change defaults by
clicking on the proper tab.

 

5 Click on [OK] when done.

Visual Display of Results

The right side of the results screen contains a series of graphs, the number
and kind of graph depends on your choice of qualification method.
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The results utilize a uniform color code to denote spectra. The red color
designates spectra that failed qualification to their own products. The dark
blue spectra are the spectra that were qualified correctly.

The left hand side of the screen shows the library tree. When the product
for which the method has just been created is expanded, the names of
spectra are also color coded.

If a Principal Component method is used for qualification, you can
identify samples on the 3D cluster plot by doubleclicking on the cross rep-
resenting a sample. A yellow check mark will appear next to the sample
name.

Creating a new Qualification method

It is possible to try a new qualification method without losing the result of
the previous trial. In order to do it:

 

1 Click on Select ▶ New Method.

 

2 Click on Select ▶ Apply Math and follow the standard procedure.

 

3 The results of previous qualification methods can be viewed by
choosing the proper method screen from the Window submenu.

Saving the Qualification method

 

1 If multiple qualification methods were attempted, make sure that the
method you want to save is in the active window. If necessary, switch
to the proper method.
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2 To save the results in the library, choose Select ▶ Save Results. A
red “Q” will appear next to the product name to designate that the
product has been qualified and saved.

Displaying the method properties

 

1 Information about math treatment, wavelength ranges, and Principal
Component’s details can be displayed by selecting a library product
and clicking on Edit ▶ Qual Method on the main menu.

Displaying summary of library methods

Information about the qualification method choice and threshold can be
found in the library summary window.

 

1 To display it, select a library and click on Edit ▶ Properties on the
main menu.

5.6 Library Validation

5.6.1 Introduction

Library validation is an important step in the process of qualitative method
development. It evaluates the suitability of a library for use in Routine
Analysis. The test determines whether all samples were correctly assigned
to their corresponding products, detects conflicting products, and helps to
establish correct thresholds. This test is essential in identification and is
important for qualification as well.

During the validation process, Vision processes all library spectra. Each
spectrum is run through all existing library methods, identification, and
qualification. If any of the methods does not exist, Vision will bypass the
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test and the N/A (not applicable) statement will appear in the proper place
on the validation report.

5.6.2 Library Validation Procedure

Preparation

 

1 From the main menu, select Mode ▶ Qualitative Library Valida-
tion to enter the library validation program.

 

2 In the Open Library dialog box, highlight the library which you
want to validate and click on [Open].

Run Validation

 

1 Choose Run Validation from the Library menu.
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2 Click on [Start] to begin validation. Progress bars show the status of
the validation. After the operation is completed, you can save the
results by clicking on [Save].

 

3 Click on [Close] to return to the main validation screen.

Viewing the Results

 

1 The results screen contains 2 graph displays and 2 result displays.
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2 The spectral display graph displays a spectrum after it is clicked on
the library tree. The 3D bar graph shows the percent of misidentified
spectra in each product.

 

3 The 2 result displays show the validation results at the product and
sample level.

Printing and Saving the Validation Results

 

1 To print the validation report, choose Print Report from the library
menu.

 

2 Click on Library ▶ Save Results to save the validation report. Type
in optional comments and click on [OK].

5.6.3 Library Validation Report Viewer

The viewer opens the validation report in a separate window, and allows
users to save the report as Excel Report, HTML Report or PDF Report. To
save a report with more than 30,000 samples, the user can choose
between HTML Report and PDF Report. To open the viewer click on
Library ▶ View Report after the validation is completed.
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5.6.4 The Library Validation Report

The library validation report contains a lot of information. This section will
describe the report layout and its information content in detail.

The first page of the validation report contains the general library informa-
tion, like the library name, number of products and spectra, operator ID,
time of validation, library methods and pretreatments used.

Following this information is a table which details how each spectrum was
analyzed by the library methods. The table is made up of 12 columns. The
columns contain the following information:
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1. Sample name.
2. Name of the product the sample belongs to.
3. Type of set (training, acceptance, or rejection).
4. Identification result (pass or fail).
5. Identification value (correlation, maximum distance, Mahalanobis dis-

tance, or residual value).
6. Product to which a spectrum was identified as (based on the closest

match).
7. Identification method threshold.
8. Identification method symbol and the threshold type symbol (symbols

are explained in the report header).
9. Qualification result (pass or fail).
10. Qualification values (correlation, maximum distance, Mahalanobis dis-

tance, or residual value).
11. Qualification method threshold.
12. Qualification method symbol and the threshold type symbol. The fol-

lowing symbols are used:
a. WD - maximum wavelength distance
b. WC - wavelength correlation
c. MD - Mahalanobis distance
d. RV - Residual Variance
e. PL - probability level
f. MV - match value

Each sample is passed through the following sequence: clustering, identifi-
cation, and qualification. If a given stage of this sequence does not have a
method created, Vision bypasses this step (N/A appears on the report). If a
sample fails at any stage, the consecutive steps are not executed (N/A
appears on the report).

The nomenclature used in the validation is complicated and needs closer
description:

1. Samples that did not pass clustering method show FAIL CLUSTERING
result.

2. Sample that can be uniquely identified and/or qualified, show PASS in
the result column.

3. Samples that cannot be identified and/or qualified to the proper
product show FAIL result.

4. Multiple lines with asterisks designate an ambiguous sample, i.e., a
sample that was identified to more than one product. In this case
Vision will try to qualify the sample using qual methods of all identi-
fied products. If the sample qualifies as the correct product, it is flag-
ged as PASS. If the library does not have qualification methods, or is
qualified to more than one product, the sample remains flagged as
AMBIGUOUS.

5. MISMATCH means that the sample was identified or qualified to a
wrong product.
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6. NO MATCH means that the sample was not identified or qualified to
any product in the library.

6 Quantitative Analysis Mode

6.1 Introduction

Quantitative Analysis mode is the part of Vision where calibration equa-
tions are developed and tested. The created calibration equations can be
used in Routine Analysis to predict unknown sample composition in real
time.

In order to develop a calibration equation, a set of spectra with corre-
sponding constituent data from reference analysis is needed. These data
have to be processed through the sample selection program to detect out-
liers and redundant samples (in some cases the sample selection can be
performed before the reference analysis, as described in the sample selec-
tion part.)

Once the calibration set of spectra has been selected, it is used to develop
a calibration equation. The calibration equation relates spectral and con-
stituent data, and can be developed using various methods.

It is also possible to import calibration equations saved in the NSAS for-
mat. This can be done in the Sample Selection program.

6.2 Sample Selection

6.2.1 Types of Sample Selection

Vision offers 2 basic types of quantitative sample selection. The first type is
based on spectral data only and allows to detect spectral outliers and
redundant samples. The second type looks at the constituent data and
allows to manipulate the data set to obtain optimum boxcar distribution.
Those methods can be used independently and their results saved and
passed to the regression program.

The purpose of sample selection in quantitative analysis is somehow differ-
ent from the qualitative approach. In qualitative analysis sample selection
is a way to detect outliers and redundant samples from spectral data only.

In quantitative analysis, the situation is more complicated. Sample selec-
tion should be able to detect spectral outliers, indicate a possible typing
error in constituent values, and make it possible to inspect and correct the
distribution of constituent values for a product. Since the reference analy-
sis is expensive and time consuming, another purpose of quantitative sam-
ple selection is to pick from many collected sample spectra the optimal
subset. This subset is then analyzed and used to develop the calibration
equation.
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Vision fulfills all these requirements by an optional twostep sample selec-
tion. In the first step, the initial set of spectra (without constituent values)
undergoes the sample selection based on spectral information. Once the
spectral outliers and redundant samples have been detected and set aside
in validation and outlier sets, the spectra forming the calibration set are
analyzed. At the second step of sample selection, some spectra can be
removed from the calibration set to improve the distribution.

Additional possibility of outlier detection exists in the regression program.
During regression possible outliers can be removed from the training set
without having to return to the sample selection stage.

6.2.2 Spectral Data Sample Selection Methods

3 methods are available for sample selection based on spectral informa-
tion: random selection, selection by PCA, and selection by wavelength dis-
tance.

Random Selection

The Random Selection method selects samples at random for calibration
and validation sets. No outlier set is created when this method is used.

The Math Treatment option is not available when Random Selection is
chosen.

Selection by Mahalanobis Distance

Selection by PCA first calculates a principal component model for a prod-
uct. All samples with Mahalanobis distances from the center of the distri-
bution greater than a user defined threshold (default 0.6 for match value
or 0.95 for probability) are flagged as outliers. Samples located in high
density regions of the population (nearest neighbors) are identified as
redundant, so that the Euclidean distances between samples in the train-
ing set is greater than the threshold.

Selection by Wavelength Distance

Selection by wavelength distance uses a maximum distance concept (max-
imum conformity index) to identify outliers. Samples with the maximum
distance from the mean product spectrum greater than the threshold
(default value 3.0) are placed in the outlier set. Selection of redundant
samples uses a method similar to selection by PCA, except that the Eucli-
dean distance in the wavelength space is used.

Lab Data Sample Selection Method

This sample selection method is based on the results from the reference
analysis. The program displays the histogram of the reference values distri-
bution, and allows user to correct this distribution by moving samples
between calibration, validation, and outlier sets. Also, the errors from
entering incorrect concentration values can be corrected.
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Combined Sample Selection Method

In this method, the user can create a temporary set of samples without
knowing the corresponding reference values. The temporary set is pro-
cessed by spectral sample selection, and the calibration, validation, and
outlier sets are saved. The samples belonging to the calibration set are
then analyzed.

The saved set undergoes the Lab Data Direct Sample Selection. This sam-
ple selection method does not start from the temporary set, but uses the
previously saved sets. The reference values are entered into Vision, and the
sample distribution corrected as necessary.

This type of sample selection is useful when dealing with large sample set,
and/or limited access to the reference analysis.

6.2.3 Sample Selection Procedure

Preparation

 

1 Enter Sample Selection by choosing Mode ▶ Quantitative Analy-
sis ▶ Sample Selection from the main menu. The last active
project is opened and displayed in the left window of the Sample
Selection screen.

 

2 If you want to work with a different project, click on
File ▶ Project ▶ Open from the main menu (make sure that the
left window is in focus).

The Open Project window opens.
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3 You can preview spectra from a product by expending the product
and selecting spectra for display. To view a sample spectrum, click on
the sample name. Click on the sample again to deselect it. You can
display multiple samples from various products by simply clicking on
them in turn. To display a range of sample spectra from a product,
click on the first spectrum in the range, and then holding down the
Shift key click on the last spectrum. To clear the spectral display, click
on Edit ▶ Unselect All.

Creating Equations and Temporary Sets

 

1 Select product from the project folder by clicking on
Select ▶ Select Product from the menu and choosing the product
from the dropdown list.

The selected product icon turns gray.

 

2 You can also select a product by double-clicking it, selecting it from
the combo box, or right-clicking on it.

 

3 Drag and drop the chosen product spectra to the Equation icon.

 

4 You can drag and drop the whole product or selected spectra. You
can also select spectra, click on Edit ▶ Copy, highlight the Calibra-
tion Equation field, and click on Edit ▶ Paste.

 

5 When the product is dragged to the equation, you will be prompted
to select the constituent:
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and the equation name:

The default equation name is the name of the constituent.

 

6 Question marks next to the sample names in newly created equation
indicate that the samples form the temporary set:
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Dragging spectra to the saved equation will destroy its structure and
place all existing product spectra together with new spectra back in
the temporary set. When this is done by mistake, it can be reversed
by exiting the Sample Selection program and re-entering it.

You can create a new constituent by entering a new name in the
Select Constituent box. The initial constituent values will be all
zeroes.

Performing Spectral Data Type of Sample Selection

 

1 Click on the equation containing the temporary set.

 

2 Choose Select ▶ Apply Math to start sample selection.
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3 From the upper part of the Edit Sample Selection Parameters
dialog box choose the selection method and math treatment.

 

4 From the lower part of the Edit Sample Selection Parameters
dialog box choose the filter options. Only the spectra fitting these cri-
teria (detector cell type and wavelength range) will be let through
sample selection. Click on [OK].

 

5 If Random Selection method was chosen, define the distribution of
spectra between sets and click [OK]. Continue with step 8.

 

6 If selection by PCA or Wavelength was chosen, from the Edit
Math Properties box choose appropriate parameters for the selec-
tion method and math treatment, then click [OK].

 

7 In the Sample Selection Options dialog box optionally check the
Redundant and Outliers boxes, configure the appropriate parame-
ters of outlier and redundant sample detection, and click [OK].

 

8 The Sample Selection algorithm will proceed with calculations and
display results.
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The right side of the screen contains a series of graphs, the number
and kind depending on your choice of sample selection method. The
results utilize a uniform color code to denote spectra. The red color
designates outliers, and light blue redundant samples. The dark blue
samples are the calibration set spectra. The left hand side of the
screen shows the product tree and the distribution of samples
between the calibration, validation, and outliers sets.

 

9 Choose Select ▶ Save Results to save the results of the sample
selection. If the Validation or Outliers set contained any spectra, you
will have an option to save them for validation purposes.

Performing Lab Data Type of Sample Selection

 

1 Click on the equation containing the temporary set.

 

2 Choose Select ▶ Lab Data to start sample selection.

 

3 From the Spectral Filtering Parameters choose the filter options.
Only the spectra fitting these criteria (detector cell type and wave-
length range) will be let through sample selection. Click on [OK].
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4 The sample selection algorithm will proceed with calculations and
display results.

The right side of the screen contains complete information about the
data set: a spreadsheet with sample names and constituent values, a
plot with spectra, and a histogram showing the distribution of the
constituent values. The results utilize a uniform color code to denote
spectra. The red color designates outliers, and light blue redundant
samples. The dark blue samples are the calibration set spectra. The
left hand side of the screen shows the product tree and the distribu-
tion of samples between the calibration, validation, and outliers sets.

Initially, all samples from the temporary set are placed in the calibra-
tion set. Double-clicking on any histogram bar will change the color
of the corresponding spectra to yellow. It will also highlight the cor-
responding spectra in the spreadsheet and on the product tree. The
selected spectra can be dragged from a given set and dropped into
another. Also, the reference values can be corrected in the spread-
sheet.

 

5 Choose Select ▶ Save Results to save the results of the sample
selection. If the Validation or Outlier set contained any spectra, you
will have an option to save them for validation purposes.

Performing Combined Sample Selection

 

1 Follow the procedure for spectral data type sample selection.

 

2 After saving the results, choose Select ▶ Lab Data Direct.
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You will enter the Lab Data sample selection with the spectra
already distributed between sets. You can type in the constituent val-
ues, and move samples between sets as described above.

 

3 Choose Select ▶ Save Results to save the results of the sample
selection. If the Validation or Outlier set contained any spectra, you
will have an option to save them for validation purposes.

Creating Multiple Sample Selection Methods

A newly created Sample Selection method may be tested, without los-
ing the result of the previous trial. In order to do this:

 

1 Click on Select ▶ New Method. All graphs will reset.

 

2 Follow the standard sample selection procedure.

 

3 The results of previous sample selection methods can be viewed by
choosing the proper method screen from the Window submenu.

 

4 If multiple sample selection methods were attempted, make sure that
the method you want to save is in the active window before saving.
If necessary, switch to the proper method.

If the user attempts to create a new product before the created temporary
set undergoes sample selection, a multiple choice window will be dis-
played. The user can select to proceed with previous product sample
selection, save all samples from the temporary set to the training set, or
empty the temporary set.

After saving the sample selection results, the equation icon changes from
a gray cuvette symbol to a question mark. This signifies that the calibra-
tion set is ready for equation development.
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6.3 Creating Custom Equations

Vision allows creation of a one term MLR equation with manually entered
bias and slope. Custom equations can be created in Quantitative Sample
Selection. To create a custom equation:

 

1 Follow sample selection procedure to a temporary set stage.

 

2 Click on Select ▶ Create Custom Equation.

 

3 From the Custom Equation Parameters dialog box, select wave-
length, slope, bias, and math pretreatment.

 

4 Click on [OK].

6.4 Regression

Regression program allows users to develop a calibration equation from
the calibration set. Vision offers 2 types of calibration development: Multi-
linear Regression and Partial Least Squares.

6.4.1 Multilinear Regression

Multilinear Regression (MLR) is a least squares method that uses spectral
information at one or several wavelengths. In the simplest case (one
wavelength), the method reduces to simple Linear Regression.

Preparation

 

1 Click on Mode ▶ Quantitative Analysis ▶ Regression to enter
the calibration development program. The last active project will be
opened. Expand the product for which you want to create the equa-
tion. The product should have the calibration set saved from the sam-
ple selection program.

 

2 Select the proper equation by doubleclicking on it. The equation icon
will turn in color.
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Configuring the Method

 

1 Click on Regression ▶ Edit Regression Method.

 

2 From the Edit Regression Method dialog box select Multiple Lin-
ear Regression, proper math pretreatments, and the wave-
length region.

Optionally enter the value for Wavelength Shift parameter (in
nanometers). If the parameter is different from 0, Vision will use its
value to shift every spectrum in the calibration set left and right along
the wavelength axis. The resulting set of spectra, 3 times larger than
the original set, is used for calibration. Constituent values of the shif-
ted spectra are identical with these of the original spectrum.

If you know what wavelengths you want to use, or if you want to
use analog (transducer) values in the equation, click on Preselect Val-
ues in the Manually Enter Terms field.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

128 ￭￭￭￭￭￭￭￭

Specify the number of terms to be used in the equation. Click on
[OK] when done.

 

3 In the Regression Treatment Properties dialog box, define the
math treatment parameters and the wavelengths or transducers val-
ues (if you selected Manually Enter Terms in the above step)

 

4 Click on [OK] when done. Vision will perform calculations and dis-
play results.
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Displaying the Results

The upper part of the results screen shows a correlation plot (green), sen-
sitivity plot (magenta), and the spectra that correspond to the lowest and
the highest constituent values (red and blue). The lower part of the screen
contains a series of graphs that can be displayed by clicking on the appro-
priate tab:

￭ 45 degree plot (calculated vs. lab data)
￭ residuals vs. calculated values
￭ residuals vs. lab values
￭ calculated % (prediction of the calibration set)
￭ summary of results showing the wavelengths, calibration constants,

correlation, standard error of calibration and F statistics
￭ average differences control chart X with confidence limits
￭ range of differences control chart R with confidence limit
￭ term intercorrelation table

The graphs can be displayed by clicking on the proper tab at the bottom
of the display. If the validation set or outlier set was saved, they can be
displayed by clicking on View and selecting the proper set to be shown.

Equation Editing

Vision selects the wavelength or wavelengths so that the maximum corre-
lation is obtained. The last active wavelength is shown by the gray bar on
the upper display. This wavelength can be changed by dragging the bar to
the desired wavelength position, or by clicking on Regression ▶ Edit
Wavelength and typing in the value.

To add a new wavelength to the equation by clicking on Regres-
sion ▶ Add Term. The equation parameters, statistics, and graphs are
recalculated and views updated.
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The last wavelength can be removed from the MLR equation by clicking
on Regression ▶ Rollback Term. The equation parameters, statistics,
and graphs are recalculated and views updated.

To move spectra between calibration, validation, and outlier sets, right
click on a dot representing a spectrum in any plot or the spectrum name
in the equation tree. Vision will reset the MLR equation to the first term.
The equation parameters, statistics, and graphs are recalculated and views
updated.

To change the control chart options, click on View ▶ Control Chart
Parameters.

To save the equation, click on Regression ▶ Save Equation. To save the
equation under a different name, click on Regression ▶ Save Equation
As.

6.4.2 Partial Least Squares

Partial Least Squares (PLS) regression allows a user to use the spectral
information of a whole range of wavelengths, even the full spectrum. This
method eliminates colinearity (high correlation between wavelength
terms) that are difficult to overcome with classical methods.

Preparation

 

1 Click on Mode ▶ Quantitative Analysis ▶ Regression to enter
the calibration development program. The last active project will be
opened. Expand the product for which you want to create the equa-
tion. The product should have the calibration set saved in the sample
selection program.

 

2 Select the proper equation by doubleclicking on it. The equation icon
will turn color.

Configuring the Method

 

1 Click on Regression ▶ Edit Regression Method.
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2 From the Edit Regression Method dialog box, select Partial Least
Squares, desired Math Pretreatments, and the Wavelength
Region. In the Maximum Number of Factors field you can spec-
ify the number of factors to be calculated. Click on [OK] when done.

Optionally enter the value for Wavelength Shift parameter (in
nanometers). If the parameter is different from 0, Vision will use its
value to shift every spectrum in the calibration set left and right along
the wavelength axis. The resulting set of spectra, 3 times larger than
the original set, is used for calibration. Constituent values of the shif-
ted spectra are identical with these of the original spectrum.

 

3 In the Regression Treatment Properties dialog box define the
Wavelength Regions, Math Treatment parameters, and the
Validation method.
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PLS equation validation is a procedure that helps to establish the
optimum number of factors for the equation. This is done by finding
a minimum of the PRESS value.

Vision offers 4 validation methods:

￭ Self Validation - the equation is developed from the training set of
spectra, and the validation set is predicted. The PRESS value is cal-
culated as the sum of squared residuals.

￭ Cross Validation - a moving segment is removed from the training
set and predicted by the equation developed from the remaining
samples. In full cross validation only one sample is removed at a
time. The PRESS value is calculated as the sum of squared residu-
als.

￭ Leverage Validation - the training set itself is predicted. The residu-
als are then corrected by the leverage factor. The PRESS value is
calculated as the sum of squared residuals.

￭ External Validation - allows the use of selected samples from
another product as a prediction set. The PRESS value is calculated
as the sum of squared residuals.

 

4 Click on [OK] when done to proceed with PLS calculations.

Displaying the Results

The upper part of the results screen shows PLS loadings and weights, and
the PRESS or standard error as a function of the number of factors. The
lower part of the screen contains a series of graphs:

￭ 45 degree plot (calculated vs. lab data )
￭ residuals vs. calculated values
￭ residuals vs. lab values
￭ calculated %
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￭ summary of results showing for each factor the correlation, standard
error of calibration, PRESS and F statistics

￭ average differences control chart X with confidence limits
￭ range of differences control chart R with confidence limit

The graphs can be displayed by clicking on the proper tab at the bottom
of the display. If the validation set or outlier set was saved, they can be
displayed by clicking on View and selecting the proper set to be shown.

Equation Editing

Initially, the displayed results are based on the number of factors recom-
mended by Vision, i.e., corresponding to the minimum on the PRESS plot.
You can change the number of factors in the equation by clicking on
Regression ▶ Edit Factors.

The equation parameters, statistics, and graphs are recalculated and views
updated.

To move spectra between calibration, validation, and outlier sets, right
click on a dot representing a spectrum in any plot or the spectrum name
in the equation tree. The equation parameters, statistics, and graphs are
recalculated and views updated.

To display a different number of loadings and weights, click on the factor
number on the spreadsheet with equation parameters (i.e., summary tab).

To save the equation, click on Regression ▶ Save Equation. To save the
equation under a different name, click on Regression ▶ Save Equation
As.

6.4.3 Trend Analysis

Trend Analysis is located in the Regression part of Vision. However, no lab
data are necessary to perform trend analysis. Trend analysis has been
designed to look at the trend of spectral values at selected parts of spec-
tra, and judge the progress of a reaction based on the trend direction and
magnitude.

The trend function is calculated over a defined wavelength range and can
be defined in several ways:

￭ As an average spectral value over the range
￭ As the highest or lowest spectral value within the range
￭ As an integral of spectral values within the range
￭ As standard deviation of spectral values within the range
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The spectral values can be simply absorbance, or any combination of avail-
able math pretreatments can be used. The chosen pretreatment type is
global to all selected ranges.

Up to 8 wavelength ranges can be used, and each can have a uniquely
calculated trend magnitude. Trend magnitudes from multiple regions can
be combined in the final expression, using basic mathematical operations.

A range can contain only one data point. In this particular case, trend
analysis allows the user to create a custom equation with up to 8 wave-
lengths, with manually entered constants.

To create an equation for trend analysis:

 

1 Perform the standard quantitative sample selection.

 

2 Click on Mode ▶ Quantitative Analysis ▶ Regression.

 

3 Select the equation and click on Regression ▶ Edit Regression
Method.

 

4 From the dialog box that opens select Trend Analysis and the
appropriate combination of pretreatments. Click on [OK].

 

5 Configure pretreatment properties (if used) and click on [OK].
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6 The screen that opens is made of 4 panels:

The left panel shows the project tree and hints. The top right panel
shows calibration set spectra with pretreatment(s) applied. The bot-
tom right panel shows ranges and allows creating formulas. The
remaining panel shows results of the trending equation.

 

7 To select the first range click on the Range1 check box. Click on Set
Range – Start and enter the minimum and maximum wavelengths
of the range. Click on Set Range – Done when finished.

Repeat the previous step for the rest of the ranges.

 

8 When all ranges are selected, click on Set Formula. The following
dialog is displayed:
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This dialog defines functions used on each range, and the overall for-
mula combining the functions. To create a formula, click on the func-
tion, then on the desired region. Add another segment to the for-
mula using provided operands and constants. The created formula is
listed below functions and ranges.

To apply the formula on the calibration spectra:

 

1 Click on [Set Formula] and then on [Close]. The plot shows the
trend resulting from the created formula applied on the calibration
spectra:

 

2 Click on the Save icon to save the formula. The created formula can
be used in Routine Analysis and the results displayed on a Trend
Chart.
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6.5 Leverage Calculation Equation

The [Leverage] value is in simple words a measure to evaluate the influ-
ence of a sample in a PCA model. Usually a sample with high leverage, is a
sample with high influence on the model. In a dataset, the samples with
high leverage need to be evaluated carefully as they indicate unusual var-
iation of a constituent and as a result, they can bias the model signifi-
cantly.

During Routine Analysis, a PLS model is used to predict values for a partic-
ular constituent and application. Vision allows the calculation of the lever-
age value, strongly connected to a specific PLS model, for every new sam-
ple tested. The leverage calculation in combination with the PLS model
used for quantification, increase the confidence in the quantitative predic-
tions as possible outliers are detected on the go.

NOTICE

Only Vision version 4.1.1.156 or higher should be used for the lever-
age calculation functionality to work.

Preparation

Create a PLS model

 

1 Click on Mode ▶ Quantitative Analysis ▶ Sample Selection to
enter the sample selection program. The last active project will be
opened. Expand the product for which you want to create the equa-
tion as you can see below:
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2 Drag and drop the product [Hi Pro] to [Eq]. Select the constituent of
interest and click [OK].

 

3 Give a unique name for this new equation:

 

4 Make sure that the newly created equation is highlighted and con-
tinue by clicking on [Apply Math]:
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5 Choose the [Selection Method]and [Math Treatment]:

NOTICE

The [Spectral Filtering Parameters]are relevant to the opera-
tional spectral range of the instrument which generated the data
and not to the wavelength regions used for model development.

 

6 The user can setup the [Edit Math Properties] following all the
steps as described in the Regression ▶ Partial Least Squares sec-
tion of this manual:
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After finishing configuration, click [OK]:

 

7 Parametrize the [Sample Selection Options]:

Click on the [Save] icon on the upper left side of the [Quant Sam-
ple Selection] screen and continue to [Regression].

 

8 Click on [Regression] and navigate to the equation that was created
previously Xdsstart ▶ Hi Pro ▶ f(x) Equations. Click on the [Pro-
teinPLS] equation:
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9 Click on [Edit Regression] and select the [Regression] and the
[Pre-Treatment Method]:

 

10 Enter the [Wavelength Region(s)]:
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11 Continue to the [Edit Validation]:

And finish by configuring the [2nd derivative]:
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12 Evaluate the performance of the PLS model and modify accordingly.

 

13 Click on the [Save] icon. Vision confirms that the [ProteinPLS]
equation is saved:
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Create Leverage Equation

 

1 Go to Quantitative Analysis ▶ Sample Selection. Drag and drop
the product containing the PLS equation, [Hi Pro]to [Eq] and select
the same constituent for which you want to create the leverage
equation:

 

2 Provide a unique name for the leverage equation:

Click [OK] and make sure that the equation was created successfully:
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3 Go to Select ▶ Create Equation for Leverage Error Calcula-
tion:

 

4 Enter the name of the library you want to create and provide a rele-
vant name:
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Click on [OK] and [Yes] to create the database:

 

5 Vision will immediately inform the user to use the same configuration
used for the creation of the PLS model, for the subsequent successful
creation of the leverage equation:

 

6 Select the Method [Mahalanobis Distance in Principal Compo-
nent Space] and the Pre-Treatment Method as in the [ProteinPLS]
as well as for the rest of the settings:
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7 Vision develops a qualification method, save, and click on [Yes].
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8 The Leverage equation has been created successfully and it is ready
to be used for Routine Analysis.

6.6 Viewing Equation Properties

The calibration equation sample sets and equation properties can be dis-
played and inspected.

6.6.1 Calibration Equation Sets
 

1 In order to view sample sets used for calibration equation develop-
ment, enter the Quant Sample Selection program.

 

2 Select the product and constituent.

All calibration equations for the selected product and constituent will
be displayed.

 

3 Highlight the chosen equation and click on Edit ▶ Properties.

This will display a spreadsheet with sample sets.

6.6.2 Calibration Equation Parameters
 

1 In order to view parameters of a calibration equation, enter the
Quant Regression program.

 

2 Expand the chosen product and right click on the equation name.

 

3 Select Properties from the menu.
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The Properties window displays calibration constants, math treat-
ments, corrections, Standard Error of Calibration, and squared corre-
lation.

The Properties window is empty if no calibration equation has been
developed.

6.7 Import of NSAS Calibration Equations

Vision supports the NSAS calibration equation format. The NSAS equations
can be imported to Vision in the Quantitative Sample Selection. An
equation is linked to a particular product and its particular constituent.
The imported equation cannot be modified.

Calibration Equation Import Procedure

 

1 Enter Sample Selection by choosing Mode ▶ Quantitative Anal-
ysis ▶ Sample Selection from the main menu. In the left window
of the Sample Selection screen, the project recently worked on is
displayed in green.

 

2 If you want to work with a different project, click on
File ▶ Project ▶ Open from the main menu.

 

3 Click on File ▶ Import from the main menu.
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4 In the Open dialog box enter the directory with the NSAS files. Click
on a file to highlight and select it. Click on [Open].

 

5 From the Select Product dialog box choose the product to which
you want to link the calibration equation. Click on [OK].

 

6 From the Select Constituent dialog box choose the constituent to
which you want to link the equation. You can also create a new con-
stituent by typing the name. Optionally enter the units. Click on [OK]
when done.

NOTICE

NOTE: If you want to export your data to Vision Air, additional
rules have to be fulfilled. Only a list of predefined units are sup-
ported.

 

7 In the Calibration Equation dialog box optionally edit the calibra-
tion equation name and enter a comment. Click on [OK].
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6.8 Prediction and Equation Adjustment

Vision allows you to use either a validation set or an external prediction
set in order to check the performance of the calibration, and, if necessary,
to correct bias and/or slope.

The [Prediction] functionality accommodates regular chemometric mod-
els developed within Vision and furthermore, [Unscrambler Predict]
allows the direct use of models, previously developed by [Unscrambler]
software (Camo Analytics).

6.8.1 Prediction Procedure
 

1 Click on Mode ▶ Quantitative Analysis ▶ Predict to enter the
prediction program. All your projects will be displayed. Expand the
project and product with the equation.

 

2 Select the equation by double-clicking on it. The equation icon will
turn in color.

 

3 Select the constituent of the product to be predicted by double-click-
ing on it. Select the product spectra for prediction by clicking on each
spectrum. You can also select a range of spectra by clicking on the
first spectrum in the range and Shiftclicking on the last one.

Make sure that the constituent and spectra come from the same
product.

 

4 Click on Regression ▶ Evaluate Samples to predict the selected
samples.
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5 The upper part of the results screen shows the predicted spectra. The
lower part of the screen contains a series of graphs that can be dis-
played in 2 panes:

￭ 45 degree plot (calculated vs. lab data)
￭ residuals vs. calculated values
￭ residuals vs. lab values
￭ calculated % (prediction results)
￭ summary of results
￭ average differences control chart X with confidence limits
￭ range of differences control chart R with confidence limit

The graphs can be displayed by clicking on the proper tab at the bot-
tom of the display.

The spreadsheet with summary of results displays the SEP before adjust-
ment, correlation and SEP after adjustment, and correction factors
together with their confidence limits.

To adjust the equation, click on Regression ▶ Adjust Equation and
choose Bias Adjustment or Bias and Slope Adjustment from the dia-
log box.

To save the adjusted equation, click on Regression ▶ Save Adjusted
Equation. If you do not want to save the adjusted equation, simply exit
the prediction program.

The spreadsheet can be displayed in Designer Mode by a double right-
click. Designer Mode allows copying results or saving the spreadsheet in
Excel format.

6.8.2 Unscrambler Prediction Procedure

This feature requires the following prerequisites to function:

￭ Unscrambler X Prediction Engine: this is a necessary piece of soft-
ware designed to interface with Vision software and our NIRS ana-
lyzers.

￭ Unscrambler X model: offline model developed using Unscrambler X
software.

￭ Vision: a version of 4.1.1.156 or higher needs to be used.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ Quantitative Analysis Mode

￭￭￭￭￭￭￭￭ 153

NOTICE

The Unscrambler X software for model development does not form
part of the Unscrambler X Prediction Engine package

 

1 Initiate Vision and open the project that contains the samples to be
used for Unscrambler Prediction.

 

2 Go to Mode ▶ Quantitative Analysis ▶ Unscrambler Predict:

 

3 The predictor client opens:

Click on File ▶ Load Model:
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4 Select the Unscrambler equation by choosing the correct unsb file:

Make sure you choose the appropriate model:

 

5 Click on File ▶ Import ▶ Vision:
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6 Select the spectrum for prediction by expanding the navigation tree:

Note the [Input data] is filled in:

 

7 Click on Predict ▶ One sample:
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8 The outcome, whether the sample is an outlier or not, is displayed at
the bottom right:

NOTICE

Note that batch prediction of multiple samples is not supported
at the moment
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6.9 Pre- and Post-Processing

Pre- and post-processing allows users to setup a parametric calibration
equation. Parametric calibration predicts results from NIR spectra and a
number of parameters, different for each sample.

For example, a standard equation applied to a sample spectrum will calcu-
late the concentration of the component of interest. If the user is interes-
ted in the amount of the component, the result needs to be multiplied by
the mass of the analyzed sample. Parametric equation will allow the oper-
ator to enter the independently measured sample mass during Routine
Analysis, and will do the multiplication (post-processing) automatically.

It may be expected that the above example input data for calibration will
consist of reference method results in the form of the amount of the com-
ponent in each calibration sample, and the corresponding sample mass.
Vision can calculate the concentration values in the step called pre pro-
cessing (by dividing the amount by mass), and then proceed with calibra-
tion based on concentration.

More than one parameter can be used for pre- and post-processing. For
example, calculation of the tablet adjusted potency involves tablet weight
and thickness. The mathematical operation is not limited to multiplication
and division. Subtraction and addition can also be used.

One can easily notice that pre and post processing steps are exactly oppo-
site. Pre- and post-processing should be used in cases when a calibration
cannot be developed directly, but the reference values can be transformed
to a form directly related to the NIR spectrum.

Procedure for developing Pre-Processing equations:

(The following procedure lists steps for the above described example of
predicting amount of the component in a sample by indirect measurement
of concentration.)

 

1 The calibration development should start with collecting spectra of
the calibration samples. For each sample the amount of the compo-
nent and sample weight should be known. These should be entered
into Vision as regular constituents.

After checking product constituent values, they should be displayed
as shown below:
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2 The next step (pre-processing), will create a new constituent by com-
bining the values of the Amount and Weight into Concentration.

Click on Mode ▶ Quantitative Analysis ▶ Sample Selection.

Drag and drop the product with calibration spectra to the Equation
field. Select the constituent as shown:

And the equation name:

NOTICE

It is not important at this point to select any particular constitu-
ent
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Click on Select ▶ Create Equation for Pre-Processing. If the
menu item is not active, make sure the newly created equation is
selected and highlighted. Vision displays a window. Type in the pre-
processing constituent name, in our case Concentration.

Click on [OK] and confirm the creation of the new constituent.

This will automatically save the equation. You will also notice that the
equation name has been changed. A prefix Pre_ has been added, so
now the equation name is Pre_PREPROCESS.

 

3 The next step is to define the pre-processing formula.

Click on Mode ▶ Quantitative Analysis ▶ Regression.

Select the equation and click on Regression ▶ Adjust Constituent
(Pre-processing).

Vision will display the following window:
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This window works as a calculator and can create formulas combin-
ing various constituents.

In our example dividing amount by weight creates the formula for
concentration.

It can be entered by clicking on the AMOUNT constituent, then the
division symbol, and finally the WEIGHT constituent.

The formula below will be shown:

Click on [Save] to save the formula and close the window.
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4 Vision will display the spreadsheet with the new calculated constitu-
ent values.

Procedure for developing Post-Processing equations:

 

1 The next step consists of creating and developing a standard calibra-
tion based on spectral data and the new constituent [Concentra-
tion] created as the result of pre-processing.

In our example, the regression will be performed on spectra from
product Calibration Set and constituent Concentration.

The regression can be done using either the MLR or PLS method. This
step is discussed in other parts of the manual and will not be descri-
bed here in detail.

 

2 The post-processing equation needs to be created and configured.

Enter the Quantitative Sample Selection and drag product with
calibration samples into the Equation field. Select the constituent
Concentration and enter Amount as the equation name:

Make sure the new equation is highlighted, and click on
Select ▶ Create Equation for Post-Processing:
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NOTICE

Note that Vision adds the prefix Post_ in front of the equation
name

 

3 Proceed to Operations Method setup.

Configure the Operations Method as described in the appropriate
part of the manual.
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Click on [Quant Setup]. Select the product and expand the tree to
find the equations created for product with calibration samples
(please note that pre-processing equation is not listed).

Double-click first the standard equation (called CALIBRATION in this
example), and then the post-processing equation. Click on [Save].

The screen should look like this:

 

4 Click on the spreadsheet header to highlight the column with the
post-processing equation.

Click on [Edit Formula]. Select the post-processing equation and
click on Modify ▶ View.
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The windows that opens allows one to combine equations and con-
stituents into a formula for post-processing.

In our example, the Amount will be calculated as a product of Con-
centration and Weight.

Click on E_Concentration (E_ denotes equation), multiplication oper-
ator, and the constituent Weight.

This is shown below:

 

5 Click on [Save] and close all windows.
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When the Routine Analysis is performed, Vision will display the box
where the value of Weight needs to be entered. Amount calculation
is based on this value, and the Concentration is calculated from a
spectrum.

6.10 Copying Calibrations Between Projects

Calibrations can be copied between projects.

 

1 To copy a calibration, enter the Quant Regression development
mode.

 

2 Select the equation to be copied, right-click on it, and click on Copy
Equation to Project.
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3 Select the destination project. A calibration in the destination project
will be overwritten if it exists. An empty product will be created in
the destination project if necessary.

7 Routine Analysis Mode

7.1 Introduction

Routine Analysis combines data acquisition parameters with the library
model and calibration equations for use in real time analysis or analysis of
stored data.

All Routine Analysis parameters are brought together in the Operations
Method. If those parameters come from both project database and library
database, the library used within the Operation Method is linked perma-
nently to the project database and can not be changed. In order to use a
different library, the user has to create a new Operations Method. This is
the case of calibration equation and multiplexer set up.

An Operations Method is used for qualitative and/or quantitative analysis
of unknowns in real time or from stored data. Routine Analysis mode also
allows the user to recall the results of all analyses done within a specific
period of time.

A sample can be analyzed as an unknown or as a known product.

If a sample is analyzed as an unknown, it has to first be identified and
qualified by the qualitative library. In the next step the sample spectrum
can be optionally quantified by a calibration equation linked to the identi-
fied product.

If a sample is analyzed as a known product, it can be qualified by the
library and then optionally quantified. In this mode of analysis the qualita-
tive step can be skipped completely, and the known product just quanti-
fied by a calibration equation developed for this product.
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7.2 Operation Method Set-up

Since the Operations Method includes data acquisition parameters, it can
be set up only from the Data Acquisition mode. There is a wizard available
for creating an operations method, described later in this chapter.

7.2.1 Preparation
 

1 If necessary, enter the Data Acquisition mode by clicking on
Mode ▶ Data Acquisition.

 

2 Click on Mode ▶ Routine Analysis ▶ Define Operations
Method to start the set up.

 

3 In the Select Operations Method dialog box click on [New] to
configure a new method. You can also retrieve an existing method by
highlighting its name on the list and clicking on Modify ▶ View.

Choose Standardization Method and click [OK].
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7.2.2 Operations Method Configuration

The blank Edit Operations Method dialog box appears.

The window contains a number of fields and buttons, which are outlined
below.

Right before opening the Edit Operations Method dialog, Vision may
display one or more error messages. This occurs when some Projects
and/or Libraries have been deleted through Windows Explorer, and Vision
cannot find them in locations specified in the Security Database. Never
delete Vision Projects or Libraries using Windows Explorer.

Method Field

Enter the name of the Operations Method in this field.

Library Field

Select the library with qualitative methods from the drop-down list. Select
None if only the quantitative analysis is to be performed.

Only libraries consistent with the standardization type chosen for the
Operations Method are displayed.

Report Field

Select the report format from the drop-down list. The default format is
RESULTS.XLS. It is used for single constituent quantification. Apart from
this format, additional options exist:

￭ BATCHRXM.XLS – used for ReactSys (Batch Reaction Monitor)
￭ CUTEST.XLS – used with Multitab for Context Uniformity Test
￭ MUXRSLT.XLS – used with multiplexer for a single constituent
￭ MUXRSLTL.XLS - used with multiplexer for a single constituent and a

Leverage or Unscrambler equation
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￭ MUXRSLT2.XLS - used with multiplexer for 2 constituents
￭ RESULTSL.XLS – used for 1 constituent with a Leverage or Unscrambler

equation (single point system)
￭ RESULTS2.XLS – used for 2 constituents (single point system)
￭ RESULTSBWIQ.XLS– used for BWIQ equation (single point system)
￭ RESCOMM.XLS – displays sample comment in the prediction table
￭ RESHORT – does not include Details page

For number of constituents not listed above, use a report with the number
of constituent higher than required. The list box displays also templates
used for reporting diagnostics results.

Acquisition Setup Field

Acquisition Setup field configures the acquisition parameters:

 

1 Click on [Timer] to program the data acquisition timer for continu-
ous or non-continuous data collection.

The timer option allows configuration of Vision for the Sample Fre-
quency, Timer Mode and Reference Frequency.

[Timer Mode]: check the Timed Sample Acquisition box for continu-
ous sample analysis. If this box is not checked, Vision will analyze
only a single sample at a time.

[Sample Frequency]: enter interval between samples in seconds, or
“0” for no delay [Sample Collection Interval (sec)]. Do not check
the “If coincident, take sample first” box.

[Time to Start (sec)]: enter a time in this box to set a delay prior to
sample analysis.
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[Reference Frequency]: in this field, the method in which the refer-
ence spectrum is acquired can be configured. Typically, “Every Sam-
ple” is collected, however the reference can be acquired “Manually”
or by “Every X Minutes” or “Every X Samples”, where X is specified in
the “Frequency X” box.

 

2 Choose Data Collection Method from the drop-down list in the
DCM field. Only DCMs consistent with the standardization type are
displayed.

External Reference Field
 

1 If a stored reference exists in the project, you can select it after
checking the Use Stored Reference check box.

 

2 Optionally select an external reference:

Output Project Field
 

1 Click on Output Project to create an output project. Output
projects store saved spectra and results from Routine Analysis. You
can create a new output project or use an existing one.
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2 Select Enable Archive to configure the archiving scheduler.

The scheduler makes it possible to automatically archive the output
project on a timely basis without interrupting Routine Analysis. Dur-
ing scheduled archiving the existing output project is emptied, and
the archive ZIP file is saved into the Vision installation folder. The
name of the archive file includes the name of the output Project, and
date and time of archiving.

 

3 Clicking on Archive Configuration displays the scheduler.
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4 Select the appropriate frequency, and click on [Save] and then on
[Close].

NOTICE

If automatic archiving is to be used, the spectra in Routine Anal-
ysis cannot be acquired continuously. There must be a delay
between spectra. The archiving scheduler does not work when
analyzing stored data.

Identify, Qualify, Always do Quant, Only do Quant, Reference
Standardized, Master Standardized, Content Uniformity
check boxes

￭ Select the desired combination of qualitative analysis options including
Identification, and/or Qualification.

Leave all boxes blank if only quantitative analysis is to be performed.

￭ If the Always Do Quant if Qualification Fails option is selected,
Vision will perform quantitative predictions even if qualification fails.

The Always Do Quant option becomes active only after a calibration is
connected to a product.

￭ If the Only Do Quant if Qualification Fails option is selected, Vision
will perform quantitative predictions only when qualification fails.

￭ Check Reference Standardized box if your methods are reference
standardized. All elements of the Operation Method (DCM, qualitative,
and quantitative methods) should have the same standardization type.
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￭ If the Use Cascading Libraries box is checked, the selected Cascad-
ing libraries are activated. To select the libraries, click on the icon with
the 3 dots on the right side of the check box.

￭ If Content Uniformity Test is checked, Vision will perform the test
automatically. This option requires a Multi-Tab Data Collection Method,
and use of the Multi-Tab Analyzer.

Comments Field

Comments field allows to enter a comment or description of the Opera-
tions Method:

Configure Views Button

 

1 Click on [Configure Views] to select the Routine Analysis output
screen and report:

 

2 Select up to 8 views from the list and click on [Next].
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3 Choose the layout of the views by clicking on the view in the list, and
then on the proper rectangle representing the view location.

 

4 Click on [Next] and [Finish] buttons to return to the wizard.

The following views are available for display:

￭ Sample Spectra – displays last acquired sample spectra.
￭ Conformity Index – displays conformity index spectrum from

the qualification step if maximum distance is used as a qualifica-
tion method. If Mahalanobis distance or Residual Variance is used
as a qualification method, the view displays residual spectrum (the
part not modeled by PC method). If correlation or no qualification
method is used, or sample spectrum does not pass identification,
the display is empty.

￭ Sample + Conformity Index – displays last acquired sample
spectrum and conformity index spectrum on one plot.

￭ Reference Spectra – displays last acquired reference spectrum.
￭ Reference + Sample Spectra – displays last acquired reference

and sample spectra on one plot.
￭ Results Report – displays the report with Routine Analysis

results.
￭ X Control Chart – displays the average differences control chart.

The chart has to be configured in Quant Setup.
￭ R Control Chart – displays the range of differences control chart.

The chart has to be configured in Quant Setup.
￭ Running Standard Deviation – displays the control chart with

running standard deviation. The chart has to be configured in
Quant Setup.

￭ Trend Chart – displays predicted results vs. time chart. The chart
has to be configured in Quant Setup.

￭ ID Trend – displays the trend chart of predicted ID values.
￭ Running Average – displays the control chart with running aver-

age. The chart has to be configured in Quant Setup.
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￭ Running Residual Standard Deviation – displays the control
chart with residual standard deviation. The chart has to be config-
ured in Quant Setup.

￭ Grand Average – displays the control chart with grand average.
The chart has to be configured in Quant Setup.

￭ Grand Standard Deviation – displays the control chart with
grand standard deviation. The chart has to be configured in Quant
Setup.

￭ Grand Residual Standard Deviation - displays the control
chart with grand residual standard deviation. The chart has to be
configured in Quant Setup.

￭ Combined X Chart – displays single average differences control
chart for all constituents in the selected product. The chart has to
be configured in Quant Setup.

￭ Combined Trend Chart - displays single results vs. time chart for
all constituents in the selected product. The chart has to be con-
figured in Quant Setup.

￭ Evolving Factors – displays Evolving Factors plot. The plot has to
be configured from Operations Method setup window.

￭ Block Average - displays the control chart with averages calcula-
ted on blocks of results. The chart has to be configured in Quant
Setup.

￭ Block RSD - displays the control chart with Residual Standard
Deviation calculated on blocks of results. The chart has to be con-
figured in Quant Setup.

￭ Qual Trend - displays the trend chart of predicted Qual values.
￭ Combined Block RSD - displays the control chart with Residual

Standard Deviation calculated on blocks of results for all constitu-
ents in the selected product. The chart has to be configured in
Quant Setup.

Trend Chart with End Point Estimation

Trend chart can be used to estimate the end point of a batch reaction.
When the trend chart is used for this purpose, Vision fits a pre-defined
curve (straight line, exponent, or parabola) to the block of last acquired
analytical results (the size of the block is configured by the user). Then
Vision extrapolates the curve and calculates the time left to reach the end
point (target value). The calculated time is displayed on the trend chart.

To configure Vision for end point estimation:

 

1 Click on [Output Setup] button to configure items to be saved, dis-
played, and printed during routine analysis.
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2 In the Save field, click on the appropriate boxes for desired informa-
tion such as results, all spectra, spectra out of tolerance, ASCII spec-
tra, ASCII results, and others. Results and spectra are saved in the
output project. MVACDF spectra, binary (NSAS) spectra, ASCII results,
ASCII spectra, and SPC spectra are saved in the output project folder
(one per analysis). Archiving in the XML format requires the DTD file
(definition of the XML file format) to reside on the computer and the
path to this file to be defined in Account Policy window.

In the Auto Print field, check the appropriate options. You can
automatically print a general results report with running average
and/or details report.

Maximum number of report rows defines the number of samples
analyzed before the Results page prints. When the report reaches this
number, the results table maintains a constant size.

Maximum number of chart results defines the maximum number
of result points displayed on trend chart and control charts. After
reaching this number, the chart starts to scroll.

Maximum number of marbles defines the maximum number of
result points displayed on standard deviation, RSD, and average
charts. After reaching this number, the chart starts to scroll.

Aux I/O Setup Button



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

178 ￭￭￭￭￭￭￭￭

Configure Auxiliary I/O dialog define data exchange protocol with process
control or data archiving systems in order to establish one- or two-way
communication with device such as Distributed Control System (DCS) or
Programmable Logical Controller (PLC).

Through Auxiliary I/O Vision supports analog protocols such as 4 - 20 mA,
or multiple digital protocols such as OPC, Modbus, or Profibus. For com-
plete list of supported protocols please contact Metrohm representative.
Auxiliary I/O also can provide communication through Vision ActiveX con-
trol with third party software capable of supporting ActiveX. Please con-
tact Metrohm representative for details.

Please note that external communication is not included in the basic
Vision package and requires purchase of additional software or hardware.
Please contact Metrohm representative for details.

Use Digital Protocol (DDE1.1) box must be checked in order to use
external communication with any digital or analog protocol.

Use Digital Protocol (DDE1.2) and Use External Processing (DDE2)
boxes should not be checked in most situations. This communication
channel is used for custom software development, where acquired spec-
trum needs to be moved outside Vision for processing by external soft-
ware, and the calculated result passed back to Vision to be displayed and
saved in Vision database. Please contact Metrohm representative for more
details.

Use External Sample Name box becomes active when one of the pro-
tocols is selected. This option allows passing the sample name from exter-
nal software or process control system to Vision through digital protocol
or ActiveX (not available for analog 4 - 20 mA communication).

External Product box becomes active when one of the protocols is
selected. This option allows external software or process control system to
define product to be analyzed by a specific calibration equation attached
to this product in Vision Routine Analysis. In order to link the product
name to a specific number, click on [Product Setup] Button. The follow-
ing Window opens:
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The list of Products Available displays all products with calibration
attached. Select a product and click [Add] to link the product with the
next available number. Click on [OK] when done. This option can be used
with both digital protocols and analog communication.

IQ Analog Out is used to configure identification and qualification results
for analog 4 - 20 mA communication. After clicking the button the follow-
ing window opens:

Select the output channel for Identification or/and Qualification and enter
scaling factors. In the example above, the Identification result is passed
out on Channel 1, and it is scaled so the match value of 0.0 corresponds
to 4 mA, and the match value of 1.0 corresponds to 20 mA.
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Configuring Auxiliary I/O is described in more detail in Vision I/O Module
manual and in Digital Protocols manuals.

Sample Avg Setup Button

Click on this button to display Configure Sample Averaging dialog. This
dialog allows you to define how many spectra will be averaged for further
processing.

N Samples In Average field defines the number of spectra that will be
averaged before qualitative and/or quantitative results are calculated.

If the Average N good samples or Average good samples out of N
taken option is chosen, Vision applies the identification method first. Only
the samples that pass identification are averaged, samples that fail are
rejected.

In the Group field define the number of results to be averaged before dis-
played on the control chart.

Moving Average defines the number of results used to calculate moving
average and moving standard deviations.

Block Avg/RSD defines the number of results used to calculate block
average and block Residual Standard Deviations.

Vision also offers the calculation of grand average and grand standard
deviation. Those parameters do not reset by stopping Routine Analysis or
exiting Vision. To reset them, click on Mode ▶ Routine Analy-
sis ▶ Reset.

Quant Setup Button

If a library has been selected in the Library field of the Edit Operations
Method dialog box, you can attach calibration equations from all projects
to any product from this library. If no library has been selected, you can
attach calibration equations from any project to any product from the
active project.

NOTICE

Once a calibration equation is connected to a library in the Opera-
tions Method, you will not be able to change the library specified for
this method
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NOTICE

Leverage or Unscrambler equations require extra setup steps. Make
sure to read the respective procedures carefully

Vision Quant Equations

 

1 Click on [Quant Setup] to attach calibration equations to library or
project database products. The Operations Method Product
Selection window appears.

 

2 From the Product drop-down list select a product from the selected
library or the active project.

 

3 Expand the tree with projects below and double-click on the equa-
tion you want to link to the product.

 

4 Click on the letter designating the empty column to highlight the
whole column and then double-click on the new equation in the
project tree, if you want to add more equations.

 

5 To enter the tolerance limits and control chart parameters, click on
the proper cell of the spreadsheet and typing in the numbers.

 

6 To replace the existing equation, click on the constituent name to
highlight the whole column and then double-click on the new equa-
tion in the project tree. Select the Insert Mode from the field below
the tree. If you are in the Change Constituent mode, the whole
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equation is replaced. If you are in the Change Equation Only
mode, the constituent name is not replaced.

 

7 To delete an equation from a product, click on the constituent name
to highlight the whole column and then click on [Delete].

 

8 Click on [Save] to complete the links and on [Done] to close the
window.

Only the equations consistent with the selected DCM and standardi-
zation type are displayed and can be connected to a product.

Vision Leverage Equations

 

1 In the [Quant Setup], double-click on the PLS equation [Pro-
teinPLS] for which the Leverage equation was created at a posterior
step:

 

2 Next, double-click on the Protein_Leverage equation. Select the cor-
rect library [protein_lev_lib] and click on the correct equation.
Make sure the [Q] is displayed:
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3 The Leverage equation is now in the second column. The user can
configure tolerance limits, control charts limits as well as analog out-
put, if desired.

Click [OK] and Save.

NOTICE

Make sure to use the correct report to be able to visualise prop-
erly the leverage results during Routine Analysis mode
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Unscrambler X Equations

 

1 Click on [Quant Setup]. Navigate in the project of interest, to the
constituent to be used for prediction. Right-click on the constituent
node and click on [Create Unscrambler Equation]:

 

2 Provide a name for the equation and click [OK]:

 

3 Select the unsb file you created with the Unscrambler software, click
[Open], and select the model from the drop-down list:
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4 The equation appears in the first column on the right:

Scroll down until you can see [OLUP Model] and verify that the cor-
rect model is selected:
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5 Click on [OK] and confirm the changes:

NOTICE

Make sure you use the correct report type: ResultswwL, where
ww is the number of constituents used

Delete Products Button

The user can create a product by entering a new product name while
operating routine analysis. These products appear in the output project.
Click on [Delete Products] to remove these products from the list of
available products.

Mux Setup Button

 

1 Click on [Mux Setup] to configure the online multiplexer. A typical
screen is shown:
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2 For each channel choose the product name. If you have a library with
an identification method declared in the Operations Method, you can
also analyze Unknown product. Only products with equations con-
nected are displayed.

 

3 In the # Samples field enter the number of spectra acquired for a
given channel.

 

4 In the Delay field enter the time delay before sampling a given chan-
nel.

 

5 In the Multiplexer Sequence box define the sampling sequence for
the channels (up to 32 entries). The channel numbers should be sep-
arated by spaces. This sequence will be repeated in a loop.

 

6 Click on [OK] when done.

Evolving PC Plot Button

Evolving PC plot displays Principal Component scores calculated on a mov-
ing block of spectra. A predefined number of last acquired spectra in Rou-
tine Analysis (block size) are used to calculate a Principal Components
model. Principal Component scores of all spectra scanned since the start
of Routine Analysis are calculated based on this model and displayed.

In order to configure the evolving PC plot follow these steps:

 

1 Click on [Evolving PC Plot].
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2 Select the block size and spectral pretreatment. Select the Mean
Center check box if the spectra need to be mean-centered before PC
calculation. Click on [OK].

 

3 Select wavelength ranges, configure pretreatment, and click on [OK].

 

4 From Configure Views options, select Evolving Factors view.

 

5 Run Routine Analysis.

Purge Setup Button

This option is to be used only in combination with Spoon Probes which
require a solenoid valve which in turn is controlled by Vision.
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1 Click on [Purge Setup]

 

2 This dialog box is displayed:

The values for “Purge Time” and “Duty Cycle” are default values,
which remain until changed and saved.

Please proceed.

 

3 Enter a value of 1 to 3 seconds for the “Purge Time” (3 is the maxi-
mum allowed). The time entered will depend upon your application
considerations. Enter “80” for the “Duty Cycle”. This is an optimum
value for the solenoid under these conditions.

Click “OK” to save these values and close.
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NOTICE

Please set appropriate “Sample Collection Interval” at the
"Timer" section.

If the purge is 3 seconds, an entry of 5 seconds in this field
allows time for the sample to settle before another sample is
acquired. This time example varies with the application. If this
timer setting is too short, the data may be meaningless.

Click [OK].

7.2.3 Operations Method Wizard

An alternative method of configuring an Operation Method is to use the
Operation Method Wizard. The wizard leads the user through a series of
setup screens. All options available in standard setup are accessible
through the wizard. For simple Operation Methods most wizard screens
can be skipped by just clicking on [Next] button and advancing to the
next screen.

Please refer to the Operation Method Setup section for detailed descrip-
tion of individual options.

In order to configure an Operation Method using the wizard follow these
steps:

 

1 Click on Mode ▶ Routine Analysis ▶ OM Wizard.
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2 From the Select Operations Method window select an existing
Operation Method and click on [Modify/View] if it needs editing. If
creating a new method, click on [New].

If a new method is chosen, Vision will display the following window:

Please note that this window is not displayed if an existing method is
edited.

 

3 Select the standardization type compatible with your data and mod-
els. During the Operations Method setup Vision will display only
items (DCMs and models) consistent with chosen standardization.
Other items will be filtered out.

Click on [OK].

 

4 On the next screen, type in the Operation Method name (if the new
method is being created). Click on [Next].
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5 From the next screen select the Data Collection Method from the list:
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By clicking on [Timer] you can define the reference and sample
acquisition frequency. This configuration is optional and recommen-
ded only for process analyzers.

If automatic archiving is to be used, the spectra in Routine Analysis
cannot be acquired continuously. There must be a delay between
spectra. The archiving scheduler does not work when analyzing
stored data.
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NOTICE

For a detailed information, please refer to the Operations
Method Configuration section

 

6 After configuration, click on [OK] to return to the previous screen.
Click on [Next].

The next screen defines output project which stores are Routing
Analysis results. It also configures the results archiving.
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7 Click on [Output Project] to create a new output project or attach
an existing one to the Operation Method.

If the analysis results are to be archived, check the Enable Archive
box. The [Archive Configuration] button becomes active. Click on
it to configure the archiving frequency.

By default the results are archived to C:\Vision. You can change this
location by clicking on [Set Archive Directory] button.

 

8 Click on [Next] to advance to the next screen.

The Select Reference Screen opens. This screen allows selecting
stored or external reference to be used in Routine Analysis. Please
note that [Use Stored Reference] button is inactive when no
stored reference is saved.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

196 ￭￭￭￭￭￭￭￭

 

9 Click on [Next] to advance to the next screen.
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The Sample Averaging Options screen defines the number of
spectra to be averaged for further processing defines sample groups
for charts, and parameters for blending analysis.

￭ N Samples in Average defines the number of spectra that will
be averaged before qualitative and/or quantitative results are cal-
culated.

￭ If the Average N good samples or Average good samples
out of N taken option is selected, Vision applies the identifica-
tion method first. Only the samples that pass identification are
averaged and passed to the quantification step. Samples that fail
ID are rejected.

￭ In the Group Size for Control Chart field, define the number of
results to be averaged before display on the control chart.

￭ Moving Average defines the number of results used to calculate
moving average and moving standard deviations.

￭ Block Size defines the number of results used to calculate block
average and block Residual Standard Deviation.

￭ Blending Configuration defines the number of spectra to skip
after the identification starts to pass and the number of spectra to
analyze after skipping.

 

10 Click on [Next] to advance to the next screen.
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The next screen configures the diagnostic timer.

 

11 Check the Enable Diagnostic Timer box to activate the [Config-
ure Diagnostic Timer] button. Click on the button to configure the
timer:

 

12 Select appropriate value and click on [OK] to return to the previous
screen.

 

13 Click on [Next] to advance to the next screen.

The Save and Print Options screen configures items to be saved,
displayed, and printed during routine analysis.
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￭ In the Save field, click on the appropriate boxes for desired infor-
mation such as results, all spectra, spectra out of tolerance, ASCII
spectra, ASCII results, and others. Results and spectra are saved in
the output project. MVACDF spectra, binary (NSAS) spectra, ASCII
results, ASCII spectra, and SPC spectra are saved in the output
project folder (one per analysis). Archiving in the XML format
requires the DTD file (definition of the XML file format) to reside
on the computer and the path to this file to be defined in
Account Policy window.

￭ In the Auto Print field, check the appropriate options. You can
automatically print a general results report with running average
and/or details report.

￭ Maximum number of report rows defines the number of sam-
ples analyzed before the Results page prints. When the report rea-
ches this number, the results table maintains a constant size.

￭ Maximum number of chart results defines the maximum
number of result points displayed on trend chart and control
charts. After reaching this number, the chart starts to scroll.

￭ Maximum number of marbles defines the maximum number
of result points displayed on standard deviation, RSD, and average
charts. After reaching this number, the chart starts to scroll.

 

14 Click on [Next] to advance to the next screen.
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The Select Library screen allows choosing the desired combination
of qualitative analysis options.

Select library to be used and options for which methods were devel-
oped in the defined library. Leave all boxes blank if only quantitative
analysis is to be performed.

NOTICE

For a detailed information, please refer to the Operations
Method Configuration section

 

15 Click on [Next] to advance to the next screen.

In the Quant Setup window user can link calibrations to products
and define parameters of control and trend charts.
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If a library has been selected in the previous wizard screen, you can
attach calibration equations from all Projects to any product from this
library. If no library has been selected, you can attach calibration
equations from any project to any product from the active project.

Once a calibration equation is connected to a library in the Opera-
tions Method, you will not be able to change the library specified in
this operations method.

In order to link calibrations to library or project products follow these
steps:

 

16 Click on [Quant Setup] to attach calibration equations to Library or
Project database products. The Operations Method Product
Selection window appears.
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From the Product drop-down list, select a product from the Library or
the active Project.

Expand the tree with Projects below, and double-click on the equa-
tion to be linked to the product. Only the equations consistent with
the selected DCM and standardization type are displayed and can be
connected to a product.

To add more equations click on the letter designating the next empty
column to highlight the whole column, and double-click on the new
equation in the Project tree.

To enter tolerance limits and control chart parameters, click on the
proper cell of the spreadsheet and type in the numbers.

To replace the existing equation, click on the constituent name to
highlight the whole column, and then double-click on the new equa-
tion in the Project tree. Select the Insert Mode from the field below
the tree. If you are in the Change Constituent mode, the whole
equation is replaced. If you are in the Change Equation Only
mode, the constituent name is not replaced.

To delete an equation from a product, click on the constituent name
to highlight the whole column and then click on [Delete].

NOTICE

For Leverage or Unscrambler equations, please refer to the
Quant Setup at Operations Method Configuration

 

17 Click on [Save] to complete the links, and on [OK] to close the win-
dow and return to the wizard.
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If the Always Do Quant option is selected, Vision will perform
quantitative predictions even if qualification fails.

If Content Uniformity Test is checked, Vision will perform the test
automatically. (This option requires a MultiTab Data Collection
Method, and use of the MultiTab Analyzer.)

The Always Do Quant option becomes active only after a calibra-
tion is connected to a product.

 

18 Click on [Next] to advance to the next screen.

The Auxiliary I/O screen allows connection to Vision I/O module
(used for analog 4 - 20 mA process communication) and process dig-
ital protocols.
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19 Checking Use Digital Protocol (DDE11) box connects routine
analysis output to external process control system through 4 - 20 mA
link or through digital protocols such as OPC, Modbus, or Profibus.
For list of available protocols please contact Metrohm representative.

Configuration of other options can be found in digital protocols or
Vision I/O Module manuals.

 

20 Click on [Next] to advance to the next screen.

The Configure Output screen allows choosing views available dur-
ing routine analysis.
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21 Click on [Configure Views] to select the Routine Analysis output
screen and report:

 

22 Select up to 8 views from the list and click on [Next].
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Choose the layout of the views by clicking on the view in the list, and
then on the proper rectangle representing the view location.

 

23 Click on [Next] and [Finish] to return to the wizard.

The following views are available for display:

￭ Sample Spectra – displays last acquired sample spectra.
￭ Conformity Index – displays conformity index spectrum from

the qualification step if maximum distance is used as a qualifica-
tion method. If Mahalanobis distance or Residual Variance is used
as a qualification method, the view displays residual spectrum (the
part not modeled by PC method). If correlation or no qualification
method is used, or sample spectrum does not pass identification,
the display is empty.

￭ Sample + Conformity Index – displays last acquired sample
spectrum and conformity index spectrum on one plot.

￭ Reference Spectra – displays last acquired reference spectrum.
￭ Reference + Sample Spectra – displays last acquired reference

and sample spectra on one plot.
￭ Results Report – displays the report with Routine Analysis

results.
￭ X Control Chart – displays the average differences control chart.

The chart has to be configured in Quant Setup.
￭ R Control Chart – displays the range of differences control chart.

The chart has to be configured in Quant Setup.
￭ Running Standard Deviation – displays the control chart with

running standard deviation. The chart has to be configured in
Quant Setup.

￭ Trend Chart – displays predicted results vs. time chart. The chart
has to be configured in Quant Setup.

￭ ID Trend – displays the trend chart of predicted ID values.
￭ Running Average – displays the control chart with running aver-

age. The chart has to be configured in Quant Setup.
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￭ Running Residual Standard Deviation – displays the control
chart with residual standard deviation. The chart has to be config-
ured in Quant Setup.

￭ Grand Average – displays the control chart with grand average.
The chart has to be configured in Quant Setup.

￭ Grand Standard Deviation – displays the control chart with
grand standard deviation. The chart has to be configured in Quant
Setup.

￭ Grand Residual Standard Deviation - displays the control
chart with grand residual standard deviation. The chart has to be
configured in Quant Setup.

￭ Combined X Chart – displays single average differences control
chart for all constituents in the selected product. The chart has to
be configured in Quant Setup.

￭ Combined Trend Chart - displays single results vs. time chart for
all constituents in the selected product. The chart has to be con-
figured in Quant Setup.

￭ Evolving Factors – displays Evolving Factors plot. The plot has to
be configured from Operations Method setup window.

￭ Block Average - displays the control chart with averages calcula-
ted on blocks of results. The chart has to be configured in Quant
Setup.

￭ Block RSD - displays the control chart with Residual Standard
Deviation calculated on blocks of results. The chart has to be con-
figured in Quant Setup.

￭ Qual Trend - displays the trend chart of predicted Qual values.
￭ Combined Block RSD - displays the control chart with Residual

Standard Deviation calculated on blocks of results for all constitu-
ents in the selected product. The chart has to be configured in
Quant Setup.

 

24 Click on [Next] to advance to the next screen.

 

25 This is the last wizard screen. Enter optional comment.
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26 Click on [Finish] to complete the Operation Method setup.

7.3 Running Routine Analysis

Once the Operations Method is configured properly, you can run Routine
Analysis to analyze samples in real time. Vision will automatically open the
Routine Analysis output project. If data acquisition timer has been config-
ured, Vision will start to acquire sample spectra automatically.

7.3.1 Routine Analysis Procedure
 

1 Click on Mode ▶ Routine Analysis ▶ Run Routine Analysis to
start the program.
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2 From the Select Operations Method dialog box choose the Oper-
ations Method.

 

3 If the data acquisition timer is not set up, click on the reference
icon to collect the reference spectrum, and then on the spectrum
icon.

 

4 The Enter Sample Information dialog box shows up. Enter the
necessary information into the box:

From the Product ID dropdown list choose the Unknown or the prod-
uct name.

Click on [OK] when done.

 

5 The X and Y axes can be manually configured on trend charts and
control charts. To configure axes click on the configuration icon
next to the appropriate graph.

 

6 Vision will start the data collection. After the spectrum is acquired,
Vision will perform the analysis and display the results.

 

7 Click on Mode ▶ Routine Analysis ▶ Run Routine Analysis and
unselect it to quit Routine Analysis. During spectral acquisition click
on the Stop icon first.

You can print the results of Routine Analysis at any time by clicking
on File ▶ Print. Make sure that the results view is the active win-
dow.

Comments entered into Sample Information window are transfer-
red to the report spreadsheet and displayed in Details sheet. If a
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number is entered instead of comment, it can be used in the report
spreadsheet for results postprocessing. This requires report modifica-
tion.

7.3.2 Viewing Best Matches

Up to 10 best qualitative matches can be displayed in Routine Analysis. To
view best matches, click on the 10 best matches icon (leftmost icon on
the toolbar). When clicked, Vision displays a window with up to 10 library
products arranged according to decreasing similarity to analyzed sample,
together with match values. This feature uses library identification function
to create the list of best matches.

7.4 Analyzing Stored Data

Vision allows for analysis of spectra stored in a project using an appropri-
ate Operations Method.

Stored Spectra Analysis Procedure:

 

1 Click on Mode ▶ Routine Analysis ▶ Analyze Stored Data to
start the program.

 

2 From the Select Samples to Analyze dialog box expand the
project and product from which you want to analyze spectra. Select
spectra by clicking on them. Click on [OK] when done.
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3 From the Select Operations Method dialog box choose the Oper-
ations Method and click on [OK].

 

4 The Enter Sample Information dialog box shows up. Enter the
necessary information into the box:

From the Product ID dropdown list choose the Unknown or the prod-
uct name.

Click on [OK] when done.
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5 Vision will perform the analysis of the first selected spectrum and dis-
play the results.

The displayed window allows you to analyze samples one by one or
continuously.

 

6 Click on Mode ▶ Routine Analysis ▶ Analyze Stored Data and
deselect it to quit the program.

You can print the results of Stored Data Analysis at any time by clicking on
File ▶ Print. Make sure that the results view is the active window.

7.4.1 One-click Analysis of Stored Data

Stored data can be easily and quickly analyzed from the Data Acquisition
window.

 

1 Open project with spectra to be analyzed and select desired spectra
or the entire product. From the main menu select Edit ▶ Run Rou-
tine Analysis. The following window opens:
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2 Select the Operations Method to use for the analysis.

 

3 Click on Mode ▶ Data Acquisition to return to Data Acquisition
mode.

7.5 Recalling Results

Vision allows you to recall results stored in the output project even if the
spectra were not saved.

 

1 Click on Mode ▶ Routine Analysis ▶ Recall Results to start the
program.

Select the Routine Analysis results or Content Uniformity Test results.

 

2 In the Recall Stored Results dialog box select the time period for
recalling results. Click on [OK] when done.
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3 From the Select Operations Method dialog box, choose the Oper-
ations Method and click on [OK].

 

4 The results will be displayed.

 

5 Click on Mode ▶ Routine Analysis ▶ Recall Results and unselect
it to quit the program.

You can print the results of Stored Data Analysis at any time by clicking on
File ▶ Print. Make sure that the results view is the active window.
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7.6 Unattended Routine Analysis

Vision, when started in the unattended mode, enters Routine Analysis
directly, without logging in. It opens selected Operations Method and ini-
tiates scanning. The unattended mode also constitutes the lowest level of
access – the user’s functions are limited to running Routine Analysis and
exiting Vision. The user does not have access to other parts of Vision.

After entering Routine Analysis, Vision may display Sample Information
window which requires entry from the operator. However, under certain
circumstances, the window is suppressed and Vision starts data acquisition
without operator’s intervention. Apart from the Timer being enabled in
the Operations Method, one of the following conditions has to be fulfilled
for Vision to start Routine Analysis data acquisition:

￭ The Operations Method uses identification that precedes quantification
step, with calibrations linked to library products, or

￭ The project with Operations Method linked to it has only one product,
and the calibration is attached to that product in the Operations
Method.

This configuration allows Vision to recognize which product should be
analyzed with proper calibration equation.

To enter the unattended mode, Vision has to be run with inline parame-
ters, which are the name of the Operations Method and the name of the
project where the method has been created. For example, if the name of
the Operations Method is OpMet, and the name of the project is MyProj,
executing the following command will start Vision in the unattended
mode:

C:\Vision\Vision.exe_ /*MyProj_/OpMet (where the symbol “_” stands for
space).

This assumes that executable program Vision.exe is located in folder
C:\Vision\.

To run Vision Routine Analysis in the unattended mode:

 

1 In a project called MyProj create and configure an Operations
Method. In this example we will use the name OpMet.

 

2 Close Vision.

 

3 Run Vision with inline parameter: C:\Vision\Vision.exe_/* MyProj_/
OpMet.

To start analysis automatically, make sure that:



Setting up the Routine Analysis (RA) Operator ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

216 ￭￭￭￭￭￭￭￭

 

1 Vision is closed with instrument connected.

 

2 The Operations Method Timer is enabled and configured.

 

3 The Operations Method uses identification, or

 

4 When the library is not used, the project has only one product with
calibration attached.

Vision can be started with inline parameter from Run window (click on
Start ▶ Run) or you can create a shortcut with the inline parameter.
Optionally, the shortcut can be added to Windows Startup folder. In this
case Vision automatically will resume Routine Analysis after power is cut
off and restored.

7.7 Setting up the Routine Analysis (RA) Operator

The RA Operator can perform only limited set of functions:

￭ Run Routine Analysis with preconfigured Operations Method
￭ Change own password
￭ Exit Vision
￭ Archive output project

The Operations Method for RA Operator has to be configured by the Sys-
tem Manager. To setup the RA Operator follows these steps:

 

1 Make sure you are logged into Vision as a System Manager.

 

2 Create and configure Operations Method so it is ready to use.

 

3 Create and configure the RA Operator user.

 

4 Give the user ID and password to the Routine Analysis Operator.
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5 Give the RA Operator user access to the project with Operations
Method. Make sure the proper project is opened. Click on
File ▶ Project ▶ Edit Users from Data Acquisition menu. The fol-
lowing window opens:

 

6 Click on the User ID (in this case RAOPER) to highlight it and then
click on [Toggle Access] button. The user acquire a check mark
next to the User ID:

Click on [OK] when done.

 

7 Log out of Vision (DO NOT EXIT) and log in as the RA Operator. Click
on Open Project icon and open the project with the Operations
Method (only one project should show in the Open Project dialog).
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Close Vision.

When the Routine Analysis Operator starts Vision and logs in with RA
Operator credentials, the Connect To Instrument window opens.

 

8 The Select Operations Method dialog will open and direct the RA
Operator to the Routine Analysis.

It is recommended that in the regulated environment the RA Opera-
tor change the password immediately after the first login to Vision.
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7.8 Using Bar Code Reader for Product Qualification

Vision includes a method to use a bar code reader and read coded sample
name directly from the container label without operating keyboard or
mouse. The bar code reader has to be of the “wedge” type, plugged
between keyboard and the computer. It has to be programmable, i.e., it
has to be able to automatically send preamble and postamble (string of
ASCII characters added before and after the scanned bar code) informa-
tion to Vision.

To use this option:

 

1 Program the bar code reader so that preamble is made of one hori-
zontal tab (ASCII symbol HT, decimal code 009) and the postamble is
made of 2 tabs and an enter (ASCII symbol CR, decimal code 013.
Please note that the bar code reader may insert Enter after each
transmission by itself. If you want to see and check what you did,
open Word and scan any bar code. If you click on Show/Hide icon
(kind of funny double letter P with the belly backwards) you will see
the symbols on the screen.

 

2 Create an Operations Method. Configure the method in a standard
way and click on [Timer]. In the timer window select Timed Acquisi-
tion and Prompt for Sample/Product Information. Make sure that No
Delay Between option is selected. Choose the reference frequency
and click on [OK].

 

3 Now you can start Routine Analysis. After the reference is taken, the
Sample Information window is displayed. Vision attempts to analyze
as Unknown when Identify is selected in Operations Method, and as
a product when only Qualify is checked. If you change to a different
product, it will become a default analyzed product.

 

4 Scanning a bar code (with the reader properly programmed) will
enter the code into the Sample ID field, and close the Sample
Information window. Pulling the Smart Probe trigger will start spec-
tral acquisition.

 

5 As soon as the acquisition is complete and results calculated, the
new Sample Information window is displayed waiting for the new
bar code.

Bar code reader feature is intended to be used with Smart Probe, but can
be used with other sampling modules as well. In this case it is recommen-
ded to select Keyboard Sample Ready Driver. When Continuous
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Sample Ready driver is selected, Vision will start data acquisition imme-
diately after the bar code is scanned.

8 Security in Vision

8.1 Default User

When Vision software is installed, a default user NIRS with the password
NIRS is created.

This user ID and password should be used for login into Vision the first
time.

The default NIRS user is a System Manager. It has access to all software
functions, including security setup.

8.2 Security Access Levels

Vision allows you to create 4 types of users: System Manager, Developer,
Operator, and Routine Analysis Operator. These types of users differ by the
level of access to software functions.

8.2.1 System Manager

The System Manger has access to all software functions, including security
and 21 CFR Part 11 functions. In particular, the System Manager can cre-
ate new users, including other System Managers.

The System Manager has access to all projects that exist and also access to
all libraries.

System Managers can grant access to their projects to other users at the
Developer or Operator level. In order to grant access to a project:

 

1 If necessary, switch to Data Acquisition mode.

 

2 Open the project to which you want to grant access.

 

3 Click on File ▶ Project ▶ Edit Users.
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4 The Edit Project User Access window lists all developers and oper-
ators.

The users with a check mark next to the User ID have access to this
particular project.

 

5 You can grant or deny access to the project by highlighting the user
ID and clicking on [Toggle Access].

System Managers can grant access to libraries to other users at the devel-
oper level. In order to grant access to a library:

 

1 Enter Qualitative Sample Selection mode.

 

2 Open the library to which you want to grant access.

 

3 Click on File ▶ Project ▶ Edit Users.
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4 The Edit Project User Access window lists all users. The users with
a check mark next to the User ID will have access to the opened
library.

 

5 You can grant or deny access to the project by highlighting the user
ID and clicking on [Toggle Access].

8.2.2 Developer

The Developer has access to all software functions, excluding security.

Developers have access to projects and libraries that they created or were
granted access to by the System Manager.

Developers can grant access to their projects to other users at the opera-
tor level. In order to grant access to a project:

 

1 If necessary, switch to Data Acquisition mode.

 

2 If necessary, switch to Data Acquisition mode.

 

3 Click on File ▶ Project ▶ Edit Users.
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4 The Edit Project User Access window lists all operators. The users
with a check mark next to the User ID have access to the opened
project.

 

5 You can grant or deny access to the project by highlighting the user
ID and clicking on [Toggle Access].

Developers can grant access to their libraries to other users at the devel-
oper level. In order to grant access to a library:

 

1 Enter Qualitative Sample Selection mode.

 

2 Open the library to which you want to grant access.

 

3 Click on File ▶ Library ▶ Edit Users.

 

4 The Edit Project User Access window lists all users. The users with
a check mark next to the User ID will have access to the opened
library.

 

5 You can grant or deny access to the project by highlighting the user
ID and clicking on [Toggle Access].

8.2.3 Operator

The Operator has limited access to Vision functions, including:

￭ creating a new project
￭ opening and closing accessible projects
￭ running Performance Test
￭ acquiring and saving spectra
￭ changing own password
￭ running Routine Analysis when an Operations Method is configured by

a higher security access user
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8.2.4 Routine Analysis (RA) Operator

The RA Operator can perform only the following functions:

￭ running Routine Analysis with preconfigured Operations Method
￭ changing own password

8.3 Setting Up Security

8.3.1 Adding a New User

Only a System Manager can add a new user. To add a new user follows
these steps:

 

1 Make sure you are logged into Vision as a System Manager.

 

2 If necessary, enter the DA mode.

 

3 Click on Configure ▶ Security. The System Security window
shows up.

 

4 Click on [Add].

 

5 In the Add User window type in the user ID and user name. Choose
the access level from the dropdown list. Click on [OK] when done.

 

6 Note the user’s password (it can be changed later).
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7 Close the System Security window.

8.3.2 Deleting a User

Only a System Manager can delete an existing user. To delete a user follow
these steps:

 

1 Make sure you are logged into Vision as a System Manager.

 

2 If necessary, enter the DA mode.

 

3 Click on Configure ▶ Security. The System Security window
shows up.

 

4 Highlight the User ID to be deleted by clicking on it.

 

5 Click on [Delete].

 

6 Confirm the deletion.

 

7 Close the System Security window.

8.3.3 Editing a User

Only a System Manager can edit an existing user. To edit a user follow
these steps:

 

1 Make sure you are logged into Vision as a System Manager.

 

2 If necessary, enter the DA mode.
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3 Click on Configure ▶ Security. The System Security window
shows up.

 

4 Highlight the User ID to be edited by clicking on it.

 

5 Click on [Edit].

 

6 Edit the User ID, name, or access level.

 

7 Click on [Password] to change it.

 

8 Close the System Security window.

NOTICE

The System Manager does not have to know the old user password in
order to change it.

8.3.4 Printing the List of Users

Only a System Manager can print a list of existing users. To print a list of
users follow these steps:

 

1 Make sure you are logged into Vision as a System Manager.

 

2 If necessary, enter the DA mode.

 

3 If necessary, enter the DA mode.

 

4 Click on [Print].

 

5 Close the System Security window.
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8.3.5 Changing a Password

Each Vision user can change his/her own password regardless of the
security access level. The knowledge of the old password is required to
change it. To change a password follow these steps:

 

1 If necessary, enter the DA mode.

 

2 Click on Configure ▶ Password.

 

3 In the Change Password dialog box type in the old password, the
new password, and the confirmation.

 

4 Click on [OK] when done.

8.4 Log-out Interval

If Vision is not operated for a given period of time, you will have to reen-
ter the password to continue operation. If instead of entering a password,
a [Cancel] button is clicked on, Vision will close all active projects and
libraries and logout from the current user.

The default logout interval is 15 minutes. This time can be changed to any
value. If you want to disable this function, define the logout interval value
of 0.

To change the logout interval value follow these steps:

 

1 Enter the Data Acquisition mode.

 

2 Click on Configure ▶ Configuration.

 

3 In the Edit Configuration window, click on the Logout Interval
tab.
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4 Type in the desired value and click on [OK].

Only a System Manager can configure logout interval.

If the logout time expires when data acquisition timer is running, Vision
will continue spectral acquisition. The acquired spectra will be saved in the
normal way, although a window prompting you to reenter the password
will show up.

8.5 Lock Function

Lock function temporarily disables Vision and could be used instead of
logout when the operator leaves workstation for short time. The program
can not be accessed until a password is reentered.

 

1 To use, click on File ▶ Lock Vision or press [CTRL]+[ALT]+[L] from
any place in Vision.

 

2 The screen below will be displayed. Enter valid password to resume
operation.
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NOTICE

Note: Locking Vision will not stop Performance Test, Data Acquisition,
or Routine Analysis in progress.

9 21 CFR Part 11 Compliance Features

Important:

This version of Vision software is compliant with 21 CFR Part 11 (electronic
records). The new features that make Vision compliant may make soft-
ware operation too cumbersome for users who do not need to be compli-
ant. During software installation a user has to decide whether Vision
needs to be compliant with 21 CFR Part 11 regulations. Choosing non-
compliant installation will disable some of features described later in this
chapter.

Those features can be disabled or enabled by the System Manager after
Vision is installed. The way to do it is described later in this chapter.

Please note that the 21 CFR Part 11 compliance are not available in the
standard version of Vision.
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9.1 Configuration screen for 21 CFR Part 11 Enhancements

Only the System Manager has authority to configure 21 CFR Part 11 fea-
tures.

 

1 In Data Acquisition mode, click on Configure ▶ Account Policy.
This opens the Account Policy configuration window. This win-
dow (shown below) contains a number of check boxes and fields.

9.1.1 CFR11 Compliance Check Box

This box toggles the compliance on and off. When the compliance is disa-
bled, the System Manager has to confirm and sign the change. All
changes in the compliance status are logged into Audit Trail.

9.1.2 Maximum Password Age

This configurable list box defines the number of days after which Vision
will request password change.

9.1.3 Password Uniqueness

This configurable list box defines the number of unique passwords that
have to be created for a particular user before an old password can be
reused.
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9.1.4 Minimum Password Length

This configurable list box defines the minimum number of characters in a
password.

9.1.5 Require Reset Password When Login First Time

When this option is selected, the system requires a password reset at the
first login.

9.1.6 Lockout After X Bad Login Attempts

This configurable list box defines how many times Vision allows users to
try to login. When this number is exceeded, Vision locks out.

9.1.7 Lockout Duration Forever

This option will cause lockout to last until System Manager logs in with his
user ID and password.

9.1.8 Lockout Duration X Minutes

This option will unlock Vision and allow for another login attempt after
specified number of minutes.

9.1.9 Maximum Backup Age

When the number of days from the last library or project backup exceeds
the number defined in this list box, Vision issues a backup reminder when
a project or a library is opened.

9.1.10 Digital Signature/Signing Saved Items

When this option is selected, the user has to sign each spectrum or result
with his password. This option is available only in 21 CFR Part 11 compli-
ant mode.

Before raw data or a method can be changed, the user has to enter the
reason for change when compliant with 21 CFR Part 11. In many cases
Vision will provide a list of standard reasons to choose from, or the user
can type in a reason as a comment.

If the reason for change is not given, the change will not be implemented.

All changes are logged into the Audit Trail.

9.1.11 Co-Signing Reports

When this option is selected, Vision will prompt for report signing. All
reports printed or saved to Excel format have to be signed by reviewer or
approver. This includes Routine Analysis reports, Library Validation reports,
and Performance Test reports. The person signing reports has to have a
user ID and password different from the user logged in during the task.



Audit Trail ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

232 ￭￭￭￭￭￭￭￭

9.2 Audit Trail

Vision has built-in an Audit Trail, which stores all activities and changes
done on projects, calibrations, libraries, operations methods, and security.

To view the Audit Trail, click on View ▶ Show Audit Trail Records.
Vision displays a window composed of a tree view and a spreadsheet.

The tree view includes 3 major branches – Security, Projects, and Libraries.
The branches and their sub-branches can be expanded or collapsed by
clicking on + or – before the branch name.

The spreadsheet includes fields with date, time, user, change or activity
description, and optional reason (comment).

In order to close the Audit Trail viewer, click on View ▶ Close Audit
Trail Records.
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