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StabNet 1.x

Installation

1 Minimum system requirements

Operating system 32-bit version of:

￭ Windows 8.1 Professional / Enterprise
￭ Windows 8 Professional / Enterprise
￭ Windows 7 Professional / Ultimate / Enterprise
￭ Windows Vista Business / Enterprise / Ultimate
￭ Windows XP Professional SP2
￭ Windows Server 2008 R2
￭ Windows Server 2008
￭ Windows Server 2003

64-bit version of:

￭ Windows 10 Pro / Enterprise
￭ Windows 8.1 Professional / Enterprise
￭ Windows 8 Professional / Enterprise
￭ Windows 7 Professional / Ultimate / Enterprise
￭ Windows Server 2012 R2
￭ Windows Server 2012
￭ Windows Server 2008 R2

RAM 2 GB

Hard disk space Program: 1 GB

Data: 2 GB

Serial ports for devices with RS-232 interface

USB ports for devices with USB interface

Screen Resolution: 1024 x 768

Network 10 Mbit/s, stable and permanent

Communication via TCP/IP

The Windows user must have administrator rights in order to be able to install
the StabNet software.
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CAUTION

Data loss may occur if the PC switches to sleep mode during a determina-
tion. The sleep mode should therefore be disabled in the energy settings
of the operating system.

2 Single workplace installation

With the single workplace version StabNet Full, you can install the client and
the database on your computer.

1 The installation process starts automatically when you insert the CD into
the drive. If this option is deactivated on your computer, double-click on
the setup.exe file.

If the minimum system requirements are not met (see above) an appropri-
ate message appears. Click on [Yes] if you would like to install the pro-
gram nonetheless.

Afterwards, click on [Next >].

 

2 After having read the license agreement for StabNet and accepted it
with [Yes], a window will appear where you can enter the license code.

 

3 Enter the license code for StabNet Full and then click on [Next >].

 

4 Now confirm the target folder for the StabNet installation with [Next >]
or select a different target folder with [Browse…].

 

5 You can define the paths for the database and default backup files in the
Additional installation information window:
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NOTE

The default paths are different for Windows XP, Windows Vista, Win-
dows 7 and Windows 8.

The database path must not be on a network drive.

The default backup path may be on a network drive.

You can change the ports StabNet uses to communicate with the data-
base server and the administration server with the [Advanced…] button.
If the ports are already used, an appropriate error message will appear.
Ask your system administrator for more information about this. Continue
with [Next >].

 

6 Follow the instructions of the program until the following message
appears:

This message points out again which ports StabNet uses. Write down
these ports and inform your system administrator in case StabNet is not
able to connect to the database. Confirm the message with [OK].

StabNet will now be installed.

 

7 Once the copying procedure has been completed you can make further
workplace settings:
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The option This client ID must exist in the current StabNet system.
can only be activated if a database from a previous installation already
exists on your computer or if you want to connect to a database server
which is installed on another computer.

If you enable this option, then StabNet checks whether the identifier you
have entered exists in the database. If this is true the identifier and all
associated settings will be adopted. With this option reinstalling a client is
much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.

 

8 At the end of the installation, the file info.txt will be created. This file
contains all relevant information concerning your current StabNet instal-
lation. Save this file on your hard drive for future reference and print it
(add to IQ).

NOTE

An InstallLog file can be found in the installation directory of StabNet
under …bin\InstallLog. It contains a listing of all files copied to your
computer during the installation and a confirmation that the installa-
tion has been successfully completed.

 

9 Complete the installation with [Finish].
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3 Client/server installation

With the StabNet Multi version (client/server version with three licenses) you
can select during the installation whether you want to install a client or the
server (incl. client) on your computer.

If you want to install only a client on your computer, a server to which the cli-
ent will be connected must have been previously installed on another com-
puter.

1 The installation process starts automatically when you insert the CD into
the drive. If this option is deactivated on your computer, double-click on
the setup.exe file.

If the minimum system requirements are not met (see above) an appropri-
ate message appears. Click on [Yes] if you would like to install the pro-
gram nonetheless.

Afterwards, click on [Next >].

 

2 After having read the license agreement for StabNet and accepted it
with [Yes], a window will appear where you can enter the license code.

 

3 Enter the license code for StabNet Multi and then click on [Next>].

 

4 Now confirm the target folder for the StabNet installation with [Next >]
or select a different target folder with [Browse…].

 

5 The Additional installation information dialog appears. Here you can
select whether you want to install a client or the server:
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The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.

NOTE

The default paths are different for Windows XP, Windows Vista, Win-
dows 7 and Windows 8.

The database path must not be on a network drive.

The default backup path may be on a network drive.

With Client, only the client will be installed and you have to select the
database server (has to be installed in advance!) you would like to use

with the  button. The network server name or the IP address is accep-
ted as the name.

You can change the ports StabNet uses to communicate with the data-
base and administration server with the [Advanced…] button. If the
ports are already used, an appropriate error message will appear. Ask your
system administrator for more information about this. Continue with
[Next >].

 

6 All further installation steps correspond to those of the single workplace
installation from point 6 onwards.

4 Modifying/repairing/removing the installation
and upgrading the license

In order to carry out modifications on the current StabNet installation, start
the setup.exe file on the installation CD or click under:

￭ in Windows XP and older - Control Panel ▶ Software
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￭ in Windows Vista / Windows 7 - Control Panel ▶ Programs and Fea-
tures

￭ in Windows 8 - Control Panel ▶ Programs and Features

on Metrohm StabNet. Then select Change/Remove:

Modify

With this option you can adjust the paths to the database and backup files and
change the ports which StabNet uses for communication. With the StabNet
Multi version you can additionally change the path to the database server.

If the database path is changed, the existing databases are automatically cop-
ied to the new location.

Repair/Update

With this option you can repair an existing defective installation or update an
older installation.

￭ Repairing the installation
In case of a defective StabNet installation because, for instance, a DLL file
is missing or a program file has been deleted by mistake, StabNet can be
repaired with this option.

￭ Updating the installation
In case an older version of StabNet is installed, it will be updated to the
new version of StabNet.

License upgrade

A direct upgrade of your current installation to a StabNet version with addi-
tional features is possible with this option:

￭ StabNet Full to StabNet Multi

In order to do this, enter your new license code in the next dialog window.
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Remove

This option removes your StabNet installation. Data which has been gener-
ated after the installation (e.g. database entries, log files, exported data, etc.)
will not be deleted.

5 Program update with StabNet Full

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically upda-
ted for further use.

NOTE

The files in the database and backup directory will be retained when the
program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

1 Save the configuration database into an external directory using the
backup function of StabNet. In the Configuration program part, select
the File ▶ Backup ▶ Manually menu item. Select the Backup direc-
tory, enter a name for the backup file and click on [Start]. The backup is
created. Afterwards, copy the backup file to CD/DVD.

 

2 If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. In the
Method program part, select the File ▶ Method manager... menu
item. Select the desired Method group, mark all methods to be expor-
ted and click on [Edit] ▶ Export.... Select the desired export directory
and click on [OK]. The methods are exported into the desired directory.
Afterwards, copy the method files to CD/DVD.

 

3 Save all determination databases created by you into an external directory
using the backup function of StabNet. In the Database program part,
select the File ▶ Database manager... menu item. Select the desired
database and click on [Backup]. Select the Backup directory, enter a
name for the backup file and click on [Start]. The backup is created.
Afterwards, copy the backup file to CD/DVD.

 

4 Save further files created by you in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

 

5 Close StabNet. Insert the installation CD and double-click on the
setup.exe file. Then select Repair/Update and click on [Next >].
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6 Enter your update license code and click on [Next >].

 

7 Complete the installation with [Finish].

An UpdateLog file with a list of all files that have been copied to your
computer during the program update and with a confirmation of a suc-
cessful installation is saved in the StabNet installation folder (default: C:
\Program Files\Metrohm\StabNet) under bin\InstallLog.

6 Program update with StabNet Multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with the new
version of StabNet Multi.
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NOTE

The files in the database and backup directory will be retained when the
program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

1 Make sure StabNet Multi is closed on all clients.

NOTE

In the bin subdirectory of the StabNet installation, you can find the
Clients.exe application, with which all clients and their status can be
displayed.

 

2 Open StabNet Multi on the server and save the configuration database
into an external directory using the backup function of StabNet. In the
Configuration program part, select the File ▶ Backup ▶ Manually
menu item. Select the Backup directory, enter a name for the backup
file and click on [Start]. The backup is created. Afterwards, copy the
backup file to CD/DVD.

 

3 If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. In the
Method program part, select the File ▶ Method manager... menu
item. Select the desired Method group, mark all methods to be expor-
ted and click on [Edit] ▶ Export.... Select the desired export directory
and click on [OK]. The methods are exported into the desired directory.
Afterwards, copy the method files to CD/DVD.

 

4 Save all determination databases on the server into an external directory
using the backup function of StabNet. In the Database program part,
select the File ▶ Database manager... menu item. Select the desired
database and click on [Backup]. Select the Backup directory, enter a
name for the backup file and click on [Start]. The backup is created.
Afterwards, copy the backup file to CD/DVD.

 

5 Save further files created by you in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

 

6 Updating the server

Close StabNet Multi on the server and on all clients. Insert the installa-
tion CD on the server and double-click on the setup.exe file. Then select
Repair/Update and click on [Next >].
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7 Enter the update license code for StabNet Multi and click on [Next >].

 

8 NOTE

The update of StabNet Multi consists of the server license and three
client licenses. If an existing installation contains additional client licen-
ses, these will be deleted.

Click on [OK] in the corresponding message in order to continue the
installation.

 

9 Complete the installation with [Finish].

An UpdateLog file with a list of all files that have been copied to the
server during the program update and with a confirmation of a successful
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installation is saved in the server's StabNet installation folder (default: C:
\Program Files\Metrohm\StabNet) under bin\InstallLog.

 

10 In case additional licenses have been removed during the server update or
if further additional licenses are to be added, the Administrator can
enter them in StabNet (dialog: Configuration ▶ Tools ▶ Program
administration... ▶ Licenses ▶ Add licenses).

 

11 Updating clients

For each client, insert the installation CD and double-click the setup.exe
file. Then select Repair/Update and click on [Next >]. Complete the
installation with [Finish].

NOTE

In order to facilitate the updating of many clients, the installation can
be copied from the CD to a writeable medium and the file stab-
net_init.ini can be modified. There, user-defined parameters for the
installation (license code, installation path, server name, etc.) can be set
in advance, which allows you to only have to click through the installa-
tion.

An UpdateLog file with a list of all files that have been copied to the cli-
ent computer during the program update and with a confirmation for a
successful installation is saved in the client's StabNet installation folder
(default: C:\Program Files\Metrohm\StabNet) under bin\InstallLog.

7 Adding additional licenses with Windows Vista
or newer

General

Starting with Windows Vista, Microsoft has introduced the UAC (User Account
Control), which permits running tasks either as non-administrator or as admin-
istrator (without changes of user, switching off or similar).

http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx

http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx

This function can, however, cause difficulties with client/server installations of
StabNet.

Problem description

A user would like to add additional licenses for the program; the license code
for an additional five licenses, for example, is added (on the server) in the Con-
figuration program part in the Program administration dialog window
(accessible via the Tools ▶ Program administration... menu item, Licenses
tab).

http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx
http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx
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The file license.mlic, which contains the standard license code and the addi-
tional license codes, is stored in the bin directory of the program installation
(C:\Program Files\Metrohm\StabNet\bin).

If the user adds the five licenses and then looks at this license.mlic file, only
the standard license code will be listed (for three licenses).

If the user highlights the license.mlic file and clicks on Compatibility files in
the bar, then he or she will be taken to the C:\Users\'User'\AppData\Local
\VirtualStore\Program Files\Metrohm\StabNet\bin directory ('User'
being the unique identifier (UID) of the user logged in on the operating sys-
tem). The license.mlic file with the license codes for the standard licenses and
the five newly added licenses can be found here, i.e., the additional licenses
are stored in the VirtualStore only for the Windows user who was logged in
on the PC at the time the additional licenses were added.

On the server, the program recognizes all of the licenses. The operating system
adds the license.mlic file from the C:\Users\'User'\AppData\Local\Virtual-
Store\Program Files\StabNet\bin directory to the detail list of the C:\Pro-
gram Files\Metrohm\StabNet\bin directory.

For the client/server functionality of the database server, however, the
license.mlic file in the C:\Program Files\Metrohm\StabNet\bin directory is
relevant, and here only the basic license is listed. Therefore, problems are to be
anticipated when adding additional clients (more than the three clients present
in the default settings).

Remedy

￭ For new installations
– To enter additional licenses, you must start the program as an admin-

istrator (right-click on the program icon and select Run as adminis-
trator there).

– If you then add the license code for additional licenses in the usual
way, then the license.mlic file in the C:\Program Files\Metrohm
\StabNet\bin directory will contain both license codes.

￭ For existing installations
– First of all, the license.mlic file in the C:\Users\'User'\AppData

\Local\VirtualStore\Program Files\Metrohm\StabNet\bin direc-
tory must be deleted.
This file must not be present in the VirtualStore of any user – you
must check to make sure this is the case, and any such files which
may be found must be deleted.

– Afterwards, you must start the program as an administrator (right-
click on the program icon and select Run as administrator there).
If you then add the license code for additional licenses in the usual
way, then the license.mlic file in the C:\Program Files\Metrohm
\StabNet\bin directory will contain both license codes.
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8 User rights for StabNet

In order for the logged-in user to be able to access all functions with StabNet,
the Windows system administrator must ensure that the permissions are set for
the directories as listed below:

Directory Permission Group name or
user name

Database directory

Directory where the databases will be saved (…\Data).

Modify SYSTEM

User*

Backup directory

Directory where the backups will be stored (…\Backup).

Modify User*

%ALLUSERSPROFILE%\Application Data\Metrohm
(Windows XP)**

Modify User*

%PROGRAMDATA%\Metrohm (Windows Vista and
higher) **

Modify User*

Export directories

Directories where the exported files are to be saved.

Modify User*

PDF directories

Directories where the PDF files are to be saved.

Modify User*

Desktop Modify User*

%PROGRAMFILES%\Metrohm\StabNet

(32-bit version of Windows versions)

Read & execute User*

%PROGRAMFILES(x86)%\Metrohm\StabNet

(64-bit version of Windows versions)

Read & execute User*

* User = name of the user who is logged in

** During installation of StabNet the permission Full Control is set for the following groups: SYS-
TEM, Administrators, Users, Guests, Main users.

NOTE

The BackupServer.exe process must be started for carrying out a backup
(backup of the configuration database and of the determination databases).
You can check this under "Windows Task Manager".

The user must be logged in during the whole backup process.
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