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Installation

1 Minimum system requirements
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Operating system

RAM
Hard disk space

Serial ports
USB ports
Screen

Network

32-bit version of:

= Windows 8.1 Professional / Enterprise

= Windows 8 Professional / Enterprise

= Windows 7 Professional / Ultimate / Enterprise
= Windows Vista Business / Enterprise / Ultimate
= Windows Server 2008 R2

= Windows Server 2008

= Windows Server 2003

64-bit version of:

=  Windows 10 Pro / Enterprise

= Windows 8.1 Professional / Enterprise

= Windows 8 Professional / Enterprise

= Windows 7 Professional / Ultimate / Enterprise
= Windows Server 2012 R2

= Windows Server 2012

= Windows Server 2008 R2

4GB

Program: 1 GB

Data: 64 GB

for devices with RS-232 interface
for devices with USB interface
Resolution: 1024 x 768

10 Mbit/s, stable and permanent

Communication via TCP/IP

The Windows user must have administrator rights in order to be able to install

the viva software.



CAUTION

Data loss may occur if the PC switches to sleep mode during a determina-
tion. The sleep mode should therefore be disabled in the energy settings
of the operating system.

2 Single workplace installation

With the single workplace version viva Full, you can install the client and the
database on your computer.

1 The installation process starts automatically when you insert the CD into
the drive. If this option is deactivated on your computer, double-click on
the setup.exe file.

If the minimum system requirements are not met (see above) an appropri-
ate message appears. Click on [Yes] if you would like to install the pro-
gram nonetheless.

Afterwards, click on [Next >].

2 During the installation process, the Welcome screen appears first. Click on
[Next >] to install the software.

Metrohm viva 2.0 Setup

Welcome to the InstallShield Wizard for viva

The InztallShield® Wizard will inztall viva on pour
computer. To continue, click Mest.

vIva
o’

< Back [ Mext » ][ Cancel

3 After having read the license agreement for viva and accepted it with
[Yes], a window will appear where you can enter the license code.

4 Enter the license code for viva Full and then click on [Next >].
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Metrohm viva 2.0 Setup @

License code

Please type in pour license code. n Metrohm

License code [VAT0 |-

< Back |[ Mext » ]l Cancel

5 Now confirm the target folder for the viva installation with [Next >] or
select a different target folder with [Browse...].

6 You can define the paths for the database and default backup files in the
Additional installation information window:

Metrohm viva 2.0 Setup @

Additional inztallation information.

Please enter the necessany information n Me'rohm

for the operation.

@ Eweny uzer needs readAwrite rights for the specified directoriss!

[atabaze path [C:4ProgramD ata'etrobmwivaiD ata i

Default backup path |C:'\F'rogramD atatMetrahmbvivahB ackup )
Advanced...

< Back |[ Mext » ] | Cancel |

ﬂ NOTE

The default paths are different for Windows Vista, Windows 7 and
Windows 8.

The database path must not be on a network drive.

The default backup path may be on a network drive.

You can change the ports viva uses to communicate with the database
server and the administration server with the [Advanced...] button. If
the ports are already used, an appropriate error message will appear. Ask
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your system administrator for more information about this. Continue with
[Next >].

.

Metrohm viva 2.0 Setup @

i e ) If you use a firewall program please check its settings.
X ' wiva uses the following ports:
6751, 6752, 5845, 5846

This message points out again which ports viva uses. Write down these
ports and inform your system administrator in case viva is not able to
connect to the database. Confirm the message with [OK].

viva will now be installed.

Once the copying procedure has been completed you can make further
workplace settings:

Metrohrn viva 2.0 Setup @
Workplace settings
Please et your client ID and your n Mel’rohm

preferred language.

Client 1D [
Thiz client ID must exist in the curent
wiva spstem.

Language Enalizh -

< Back Mewt » Cancel

The option This client ID must exist in the current viva system. can
only be activated if a database from a previous installation already exists
on your computer or if you want to connect to a database server which is
installed on another computer.

If you enable this option, then viva checks whether the identifier you
have entered exists in the database. If this is true the identifier and all
associated settings will be adopted. With this option reinstalling a client is
much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.
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9 At the end of the installation, the file info.txt will be created. This file
contains all relevant information concerning your current viva installation.
Save this file on your hard drive for future reference and print it (add to

Q).

E NOTE

An InstallLog file can be found in the installation directory of viva
under ...bin\InstallLog. It contains a listing of all files copied to your
computer during the installation and a confirmation that the installa-
tion has been successfully completed.

10 Complete the installation with [Finish].

3 Client/server installation
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With the viva Multi version (client/server version with three licenses) you can
select during the installation whether you want to install a client or the server
(incl. client) on your computer.

If you want to install only a client on your computer, a server to which the cli-
ent will be connected must have been previously installed on another com-
puter.

1 The installation process starts automatically when you insert the CD into
the drive. If this option is deactivated on your computer, double-click on
the setup.exe file.

If the minimum system requirements are not met (see above) an appropri-
ate message appears. Click on [Yes] if you would like to install the pro-
gram nonetheless.

Afterwards, click on [Next >].

2 During the installation process, the Welcome screen appears first. Click on
[Next >] to install the software.



Metrohm viva 2.0 Setup

Welcome to the InzstallShield Wizard For viva

The InstallShisld® Wizard will install viva on your
caorputer. Tao contitue, click Mest.

< Back [ Mext » }l Cancel

3 After having read the license agreement for viva and accepted it with
[Yes], a window will appear where you can enter the license code.

4 Enter the license code for viva Multi and then click on [Next>].

Metrohm viva 2.0 Setup
License code
Flease type in vour icense code. n MetrOhm

License code [VAT0 |-

InstallShield

< Back ][ Mest = ]l Cancel

5 Now confirm the target folder for the viva installation with [Next >] or
select a different target folder with [Browse...].

6 The Additional installation information dialog appears. Here you can
select whether you want to install a client or the server:
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Metrohm viva 2.0 Setup @

Additional installation information.

Flease enter the necessary information n Meﬂ'ohm

for the operation.

@ Client/Server

@ Every user needs readAwrite rightz for the specified directories!

[atabaze path [C:\ProgramD ata\M etrobmbwivahD ata I:I

Diefault backup path [C:AProgramD atath etrokmtwivaB ackup I:I
Client

| Advanced.. |

| < Back |[ Mexst » ] | Cancel |

The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.

E NOTE

The default paths are different for Windows Vista, Windows 7 and
Windows 8.

The database path must not be on a network drive.

The default backup path may be on a network drive.
With Client, only the client will be installed and you have to select the
database server (has to be installed in advance!) you would like to use

with the l:=-| button. The network server name or the IP address is accep-
ted as the name.

You can change the ports viva uses to communicate with the database
and administration server with the [Advanced...] button. If the ports are
already used, an appropriate error message will appear. Ask your system
administrator for more information about this. Continue with [Next >].

7 All further installation steps correspond to those of the single workplace
installation from point 7 onwards.

4 Modifying/repairing/removing the installation
and upgrading the license

In order to carry out modifications on the current viva installation, start the
setup.exe file on the installation CD or click under:

= in Windows Vista / Windows 7 - Control Panel » Programs and Fea-
tures
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Modify

Repair/Update

License upgrade

Remove

= in Windows 8 - Control Panel » Programs and Features

on Metrohm viva. Then select Change/Remove:

Metrohm viva 2.0 Setup @
Welcome
todify, repair, update, or remave the program. n Me"‘ohm

‘Welcome to the wiva Setup Maintenance pragram. This program lets you modify the current
ingtallation. Click one of the options below.

 adify
ﬁ Select new program features to add or select currently installed features to
TEMOvE,
@ Repair/Update
ﬁ Fieinstall all program features installed by the previous setup.

License upgrads

= Mew licenze
i

Remaove

@ Remave all installed features,

< Back Memt » l| Carcel

With this option you can adjust the paths to the database and backup files and
change the ports which viva uses for communication. With the viva Multi
version you can additionally change the path to the database server.

If the database path is changed, the existing databases are automatically cop-
ied to the new location.

With this option you can repair an existing defective installation or update an
older installation.

» Repairing the installation
In case of a defective viva installation because, for instance, a DLL file is
missing or a program file has been deleted by mistake, viva can be repaired
with this option.

= Updating the installation
In case an older version of viva is installed, it will be updated to the new
version of viva.

A direct upgrade of your current installation to a viva version with additional
features is possible with this option:

= viva Full to viva Multi

In order to do this, enter your new license code in the next dialog window.

This option removes your viva installation. Data which has been generated
after the installation (e.g. database entries, log files, exported data, etc.) will
not be deleted.

8.103.8022EN / 2015-05-25



5 Program update with viva full
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During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically upda-
ted for further use.

H NOTE

The files in the database directory and the backup directory will be retained
when the program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

1 Save the configuration database into an external directory using the
backup function of viva. In the Configuration program part, select the
File » Backup » Manually menu item. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is cre-
ated. Afterwards, copy the backup file to CD/DVD.

2 |If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. In the
Method program part, select the File » Method manager... menu
item. Select the desired Method group, mark all methods to be expor-
ted and click on [Edit] » Export.... Select the desired export directory
and click on [OK]. The methods are exported into the desired directory.
Afterwards, copy the method files to CD/DVD.

3 Save all determination databases created by you into an external directory
using the backup function of viva. In the Database program part, select
the File » Database manager... menu item. Select the desired database
and click on [Backup]. Select the Backup directory, enter a name for
the backup file and click on [Start]. The backup is created. Afterwards,
copy the backup file to CD/DVD.

4 Save further files created by you in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

5 Close viva. Insert the installation CD and double-click on the setup.exe
file. Then select Repair/Update and click on [Next >].



10

Metrohm viva 2.0 Setup

Welcome to the InzstallShield Wizard For viva

The InstallShisld® Wizard will install viva on your
caorputer. Tao contitue, click Mest.

i

< Back [ Mext » ]l Cancel

6 Enter your update license code and click on [Next >].

Metrohm viva 2.0 Setup IEI
License code
Flease type in vour icense code. n MetrOhm

Licenze code [VATD |-

< Back ][ Mext » ]l Cancel

7 Complete the installation with [Finish].

An UpdateLog file with a list of all files that have been copied to your
computer during the program update and with a confirmation of a suc-
cessful installation is saved in the viva installation folder (default: C:\Pro-
gram Files\Metrohm\viva) under bin\InstallLog.

6 Program update with viva multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with the new
version of viva multi.
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H NOTE

The files in the database directory and the backup directory will be retained
when the program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

1 Make sure viva multi is closed on all clients.

E NOTE

In the bin subdirectory of the viva installation, you can find the Cli-
ents.exe application, with which all clients and their status can be dis-
played.

2 Open viva multi on the server and save the configuration database into
an external directory using the backup function of viva. In the Configu-
ration program part, select the File » Backup » Manually menu item.
Select the Backup directory, enter a name for the backup file and click

on [Start]. The backup is created. Afterwards, copy the backup file to CD/

DVD.

3 If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. In the
Method program part, select the File » Method manager... menu
item. Select the desired Method group, mark all methods to be expor-
ted and click on [Edit] » Export.... Select the desired export directory
and click on [OK]. The methods are exported into the desired directory.
Afterwards, copy the method files to CD/DVD.

4 Save all determination databases on the server into an external directory
using the backup function of viva. In the Database program part, select

the File » Database manager... menu item. Select the desired database

and click on [Backup]. Select the Backup directory, enter a name for
the backup file and click on [Start]. The backup is created. Afterwards,
copy the backup file to CD/DVD.

5 Save further files created by you in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

6 Updating the server

Close viva multi on the server and on all clients. Insert the installation CD

on the server and double-click on the setup.exe file. Then select
Repair/Update and click on [Next >].
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Metrohm viva 2.0 Setup

Welcome to the InzstallShield Wizard For viva

The InstallShisld® Wizard will install viva on your
caorputer. Tao contitue, click Mest.

< Back L Mext » Jl Cancel

7 Enter the update license code for viva multi and click on [Next >].

Metrohm viva 2.0 Setup

License code

Flease type in vour icense code.

55
L. Metrohm

Licenge code [VAT0

InstallShield

< Back ][ Mext » ]l Cancel

8 ﬂﬂ NOTE

The update of viva multi consists of the server license and three client
licenses. If an existing installation contains additional client licenses,

these will be deleted.

Click on [OK] in the corresponding message in order to continue the

installation.

9 Complete the installation with [Finish].

An UpdateLog file with a list of all files that have been copied to the
server during the program update and with a confirmation of a successful

8.103.8022EN / 2015-05-25



installation is saved in the server's viva installation folder (default: C:\Pro-
gram Files\Metrohm\viva) under bin\InstallLog.

10 In case additional licenses have been removed during the server update or
if further additional licenses are to be added, the Administrator can
enter them in viva (dialog: Configuration » Tools » Program admin-
istration... > Licenses > Add licenses).

11 Updating clients

For each client, insert the installation CD and double-click the setup.exe
file. Then select Repair/Update and click on [Next >]. Complete the
installation with [Finish].

n NOTE

In order to facilitate the updating of many clients, the installation can
be copied from the CD to a writeable medium and the file viva_init.ini
can be modified. There, user-defined parameters for the installation
(license code, installation path, server name, etc.) can be set in
advance, which allows you to only have to click through the installa-
tion.

An UpdateLog file with a list of all files that have been copied to the cli-
ent computer during the program update and with a confirmation for a
successful installation is saved in the client's viva installation folder
(default: C:\Program Files\Metrohm\viva) under bin\InstallLog.

7 Installation of drivers
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In normal cases, the installation routine of viva automatically installs all the
drivers necessary for controlling the supported devices.

If you are using a 64-bit operating system, it may be necessary to install drivers
manually in combination with a few devices. This is the case if the operating
system displays a message when connecting a device to the computer, as e.g.
Device driver software was not installed. No driver found. The message
should also show the name of the corresponding device. Write down this
name and proceed as follows to install the driver manually:

H NOTE

The following description applies for Windows 7 (64-bit version). It may
slightly vary for your system.

The drivers for the devices 889 IC Sample Center and Combustion Mod-
ule can both be found in the drivers/889 subfolder in the installation
folder.

13



1 Open the Windows Device Manager. The corresponding device can be
found under Other devices.

2 Right-click on the device. The context menu opens.

3 In the context menu, select Update driver software.... A dialog win-
dow opens.

4 Select Browse my computer for driver software. The file selection
dialog opens.

5 Navigate to the installation folder of viva (default: C:\Program Files\Met-
rohm\viva).

6 In the installation folder, open the drivers subfolder. It contains a sub-
folder for each of the corresponding devices in which the necessary driver
is stored.

7 In the drivers subfolder, open the subfolder of the corresponding device
and select the driver file (*.inf).

8 Apply the selection with [OK]. A Windows safety prompt is displayed. In
order to install the driver, click on [Install].

9 After successful installation, close the Device Manager.

8 Adding additional licenses with Windows Vista
or newer

General

Starting with Windows Vista, Microsoft has introduced the UAC (User Account
Control), which permits running tasks either as non-administrator or as admin-
istrator (without changes of user, switching off or similar).

http://technet.microsoft.com/en-us/library/cc709691%28WS. 10%29.aspx
http://technet. microsoft.com/en-us/magazine/2007.06.uac.aspx

This function can, however, cause difficulties with client/server installations of
viva.

Problem description

A user would like to add additional licenses for the program; the license code
for an additional five licenses, for example, is added (on the server) in the Con-
figuration program part in the Program administration dialog window
(accessible via the Tools » Program administration... menu item, Licenses
tab).
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8.103.8022EN / 2015-05-25

The file license.mlic, which contains the standard license code and the addi-
tional license codes, is stored in the bin directory of the program installation
(C:\Program Files\Metrohm\viva\bin).

If the user adds the five licenses and then looks at this license.mlic file, only
the standard license code will be listed (for three licenses).

If the user highlights the license.mlic file and clicks on Compatibility files in
the bar, then he or she will be taken to the C:\Users\'User'\AppData\Local
\VirtualStore\Program Files\Metrohm\viva\bin directory ('User’ being the
unique identifier (UID) of the user logged in on the operating system). The
license.mlic file with the license codes for the standard licenses and the five
newly added licenses can be found here, i.e., the additional licenses are stored
in the VirtualStore only for the Windows user who was logged in on the PC
at the time the additional licenses were added.

On the server, the program recognizes all of the licenses. The operating system
adds the license.mlic file from the C:\Users\'User"\AppData\Local\Virtual-
Store\Program Files\viva\bin directory to the detail list of the C:\Program
Files\Metrohm\viva\bin directory.

For the client/server functionality of the database server, however, the
license.mlic file in the C:\Program Files\Metrohm\viva\bin directory is rel-
evant, and here only the basic license is listed. Therefore, problems are to be
anticipated when adding additional clients (more than the three clients present
in the default settings).

Remedy

= For new installations

— To enter additional licenses, you must start the program as an admin-
istrator (right-click on the program icon and select Run as adminis-
trator there).

— If you then add the license code for additional licenses in the usual
way, then the license.mlic file in the C:\Program Files\Metrohm
\viva\bin directory will contain both license codes.

= For existing installations

— First of all, the license.mlic file in the C:\Users\'User"\AppData
\Local\VirtualStore\Program Files\Metrohm\viva\bin directory
must be deleted.

This file must not be present in the VirtualStore of any user — you
must check to make sure this is the case, and any such files which
may be found must be deleted.

— Afterwards, you must start the program as an administrator (right-
click on the program icon and select Run as administrator there).
If you then add the license code for additional licenses in the usual
way, then the license.mlic file in the C:\Program Files\Metrohm
\viva\bin directory will contain both license codes.
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9 User rights for viva

In order for the logged-in user to be able to access all functions with viva, the
Windows system administrator must ensure that the permissions are set for the

directories as listed below:

(64-bit version of Windows versions)

Directory Permission Group name or
user name

Database directory Modify SYSTEM

Directory where the databases will be saved (...\Data). User

Backup directory Modify User’

Directory where the backups will be stored (...\Backup).

%PROGRAMDATA%\Metrohm (Windows Vista and Modify User”

higher) **

Export directories Modify User

Directories where the exported files are to be saved.

PDF directories Modify User’

Directories where the PDF files are to be saved.

Desktop Modify User’

%PROGRAMFILES%\Metrohm\viva Read & execute | User’

(32-bit version of Windows versions)

%PROGRAMFILES(x86)%\Metrohm\viva Read & execute | User’

User = name of the user who is logged in

During installation of viva the permission Full Control is set for the following groups: SYSTEM,

Administrators, Users, Guests, Main users.

ﬂ NOTE

The BackupServer.exe process must be started for carrying out a backup
(backup of the configuration database and of the determination databases).
You can check this under "Windows Task Manager".

The user must be logged in during the whole backup process.
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