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Installation

1 Minimum system requirements

Operating system 32-bit version of:

￭ Windows XP Professional SP2
￭ Windows Vista Business/Enterprise/Ultimate
￭ Windows 7 Professional/Ultimate/Enterprise
￭ Windows 8 Professional/Enterprise
￭ Windows Server 2003
￭ Windows Server 2008
￭ Windows Server 2008 R2

64-bit version of:

￭ Windows 7 Professional/Ultimate/Enterprise
￭ Windows 8 Professional/Enterprise
￭ Windows Server 2008 R2
￭ Windows Server 2012

RAM 2 GB

Hard disk space Program: 1 GB

Data: 4 GB

USB ports For devices with USB interface (USB version 1.1 and
higher)

Screen Resolution 1,024 x 768

Network 10 Mbit/s, stable and permanent

Communication via TCP/IP

The Windows user must have administrator rights in order to be able to install
the viva software.

Caution

Data loss may occur if the PC changes to sleep mode during a determina-
tion. The sleep mode should therefore be deactivated in the energy set-
tings of the operating system.
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2 Single workplace installation

With the single workplace version viva full, you can install the client and the
database on your computer.

1 The installation process starts automatically when you insert the CD into
the drive. If this option is deactivated on your computer, double-click on
the file setup.exe.

If the minimum system requirements are not met (see above) an appropri-
ate message appears. Click on [Yes] if you would like to install the pro-
gram nonetheless.

Afterwards, click on [Next >].

 

2 During the installation process, the Welcome screen appears first. Click on
[Next >] to install the software.

 

3 After having read the license agreement for viva and accepted it with
[Yes], a window will appear where you can enter the license code.

 

4 Enter the license code for viva full and click on [Next >].
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5 Now confirm the target folder for the viva installation with [Next >] or
select a different target folder with [Browse…].

 

6 In the Additional installation information window you can define the
paths for the database and backup files:

Note

The default paths are different for the different Windows versions.

A path to a network drive is only permitted for the default backup
path.

You can change the ports viva uses to communicate with the database
server and the administration server with the button [Advanced…]. If
the ports are already used, an appropriate error message will appear. Ask
your system administrator for more information about this. Continue with
[Next >].
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7

This message points out again which ports viva uses. Write down these
ports and inform your system administrator in case viva is not able to
connect to the database. Confirm the message with [OK].

 

8 Once the copying procedure has been completed you can make further
workplace settings:

The option This client ID must exist in the current viva system is
only selectable if a database from a previous installation already exists on
your computer or if you want to connect to a database server which has
been installed on another computer.

If you activate this option, then viva checks whether the identifier you
have entered exists in the database. If this is true the identifier and all
associated settings will be adopted. With this option reinstalling a client is
much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.

 

9 At the end of the installation, the file info.txt will be created. This file
contains all relevant information concerning your current viva installation.
Save this file on your hard drive for future reference and print it (add to
IQ).
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Note

An InstallLog file can be found in the installation directory of viva
under …bin\InstallLog. It contains a listing of all files copied to your
computer during the installation and a confirmation that the installa-
tion has been successfully completed.

 

10 Complete the installation with [Finish].

3 Client/server installation

With the viva multi version (client/server version with three licenses) you can
select during the installation whether you want to install a client or the server
(incl. client) on your computer.

If you want to install only a client on your computer, a server to which the cli-
ent will be connected must have been previously installed on another com-
puter.

1 The installation process starts automatically when you insert the CD into
the drive. If this option is deactivated on your computer, double-click on
the file setup.exe.

If the minimum system requirements are not met (see above) an appropri-
ate message appears. Click on [Yes] if you would like to install the pro-
gram nonetheless.

Afterwards, click on [Next >].

 

2 During the installation process, the Welcome screen appears first. Click on
[Next >] to install the software.
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3 After having read the license agreement for viva and accepted it with
[Yes], a window will appear where you can enter the license code.

 

4 Enter the license code for viva multi and click on [Next >].

 

5 Now confirm the target folder for the viva installation with [Next >] or
select a different target folder with [Browse…].

 

6 The Additional installation information dialog appears. Here you can
select whether you want to install a client or the server:

The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.

With Client, only the client will be installed and you have to select the
database server (has to be installed in advance!) you would like to use

with . The network server name or the IP address is accepted as the
name.
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With the button [Advanced…] the ports viva uses to communicate with
the database and administration server can be changed. If the ports are
already used, an appropriate error message will appear. Ask your system
administrator for more information about this. Continue with [Next >].

 

7 All further installation steps correspond to those of the single workplace
installation from point 7 onwards.

4 Modifying/repairing/removing the installation
and upgrading the license

In order to carry out modifications on the current viva installation, start the file
setup.exe on the installation CD or click under:

￭ Windows XP - Control Panel ▶ Software
￭ Windows Vista / Windows 7 / Windows 8 - Control Panel ▶ Programs

and Features

on Metrohm viva. Then select Change/Remove:

Modify

With this option you can change the paths to the database and backup files
and set the ports which viva uses for communication. With the viva multi
version you can additionally change the path to the database server.

If the database path is changed, the existing databases are automatically cop-
ied to the new location.

Repair/Update

With this option you can repair an existing defective installation or update an
older installation.
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￭ Repairing the installation
In case of a defective viva installation because, for instance, a DLL file is
missing or a program file has been deleted by mistake, viva can be repaired
with this option.

￭ Updating the installation
In case an older version of viva is installed, it will be updated to the new
version of viva.

License upgrade

A direct upgrade of your current installation to a viva version with additional
features is possible with this option:

￭ viva full to viva multi

In order to do this, enter your new license code in the next dialog window.

Remove

This option removes your viva installation. Data which has been generated
after the installation (e.g. database entries, log files, exported data, etc.) will
not be deleted.

5 Program update with viva full

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically
updated for further use.

Note

The files in the database directory and the backup directory will be retained
when the program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

1 Save the configuration database into an external directory using the
backup function of viva. In the Configuration program part, select the
File ▶ Backup ▶ Manually menu item. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is cre-
ated. It is recommended to copy the backup file to CD/DVD afterwards.

 

2 If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. In the
Method program part, select the File ▶ Method manager... menu
item. Select the desired Method group, mark all methods to be
exported and click on [Edit] ▶ Export.... Select the desired export direc-
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tory and click on [OK]. The methods are exported into the desired direc-
tory. It is recommended to copy the method files to CD/DVD afterwards.

 

3 Save all determination databases created by you into an external directory
using the backup function of viva. In the Database program part, select
the File ▶ Database manager... menu item. Select the desired database
and click on [Backup]. Select the Backup directory, enter a name for
the backup file and click on [Start]. The backup is created. It is recom-
mended to copy the backup file to CD/DVD afterwards.

 

4 Save further files created by you in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

 

5 Close viva. Insert the installation CD and double-click on the file
setup.exe. Then select Repair/Update and click on [Next >].

 

6 Enter your update license code and click on [Next >].
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7 Complete the installation with [Finish].

An UpdateLog file with a list of all files that have been copied to your
computer during the program update and with a confirmation for a suc-
cessful installation is saved in the viva installation folder (default: C:\Pro-
gram Files\Metrohm\viva) under bin\InstallLog.

6 Program update with viva multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with the new
version of viva multi.

Note

The files in the database directory and the backup directory will be retained
when the program is updated.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Those files in these directories which are not updated
during the update will be deleted. The deleted files are listed in the Install-
Log.

1 Make sure viva multi is closed on all clients.

Note

In the bin subdirectory of the viva installation, you can find the Cli-
ents.exe application, with which all clients and their status can be dis-
played.

 

2 Open viva multi on the server and save the configuration database into
an external directory using the backup function of viva. In the Configu-
ration program part, select the File ▶ Backup ▶ Manually menu item.
Select the Backup directory, enter a name for the backup file and click
on [Start]. The backup is created. It is recommended to copy the backup
file to CD/DVD afterwards.

 

3 If desired, export the methods in addition to the automatic backup with
the configuration database (see above) into an external directory. In the
Method program part, select the File ▶ Method manager... menu
item. Select the desired Method group, mark all methods to be
exported and click on [Edit] ▶ Export.... Select the desired export direc-
tory and click on [OK]. The methods are exported into the desired direc-
tory. It is recommended to copy the method files to CD/DVD afterwards.
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4 Save all determination databases on the server into an external directory
using the backup function of viva. In the Database program part, select
the File ▶ Database manager... menu item. Select the desired database
and click on [Backup]. Select the Backup directory, enter a name for
the backup file and click on [Start]. The backup is created. It is recom-
mended to copy the backup file to CD/DVD afterwards.

 

5 Save further files created by you in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

 

6 Updating the server

Close viva multi on the server and on all clients. Insert the installation CD
on the server and double-click the file setup.exe. Then select Repair/
Update and click on [Next >].

 

7 Enter the update license code for viva multi and click on [Next >].
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8 Note

The update of viva multi consists of the server license and three client
licenses. If an existing installation contains additional client licenses,
these will be deleted.

Click on [OK] in the corresponding message in order to continue the
installation.

 

9 Complete the installation with [Finish].

An UpdateLog file with a list of all files that have been copied to the
server during the program update and with a confirmation for a success-
ful installation is saved in the server's viva installation folder (default: C:
\Program Files\Metrohm\viva) under bin\InstallLog.

 

10 In case additional licenses have been removed during the server update or
if further additional licenses are to be added, the Administrator can
enter them in viva (dialog: Configuration ▶ Tools ▶ Program admin-
istration... ▶ Licenses ▶ Add licenses).

 

11 Updating clients

For each client, insert the installation CD and double-click the file
setup.exe. Then select Repair/Update and click on [Next >]. Complete
the installation with [Finish].

Note

In order to facilitate the updating of many clients, the installation can
be copied from the CD to a writeable medium and the file viva_init.ini
can be modified. There, user-defined parameters for the installation
(license code, installation path, server name, etc.) can be set in
advance, which allows you to only have to click through the installa-
tion.

An UpdateLog file with a list of all files that have been copied to the cli-
ent computer during the program update and with a confirmation for a
successful installation is saved in the client's viva installation folder
(default: C:\Program Files\Metrohm\viva) under bin\InstallLog.
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7 Adding additional licenses with Windows Vista
or newer

General

Since Windows Vista, Microsoft has introduced the UAC (User Account Con-
trol), which permits running tasks either as non-administrator or as administra-
tor (without changes of user, switching off or similar).

http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx

http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx

This function can, however, cause difficulties with client-server installations of
viva.

Problem description

One would like to add additional licenses for the program; the license code for
an additional 5 licenses, for example, is added (on the server) in the program
part Configuration in the dialog window Program administration (accessi-
ble via menu item Tools ▶ Program administration..., tab Licenses).

The file license.mlic, which contains the standard license code and the addi-
tional license codes, is stored in the bin directory of the program installation
(C:\Program Files\Metrohm\viva\bin).

If one adds the 5 licenses and then looks at this file license.mlic, only the
standard license code will be listed (for 3 licenses).

If one highlights the file license.mlic and presses Compatibility files in the
bar, then one will arrive in the directory C:\Users\'User'\AppData\Local\Vir-
tualStore\Program Files\Metrohm\viva\bin ('User' being the abbreviation
(UID) for the user logged in on the operating system). The file license.mlic
with the license codes for the standard licenses and the 5 newly added licenses
is to be found here, i.e. the additional licenses are stored in the VirtualStore
only for the Windows user who was logged in on the PC at the time the addi-
tional licenses were added.

On the server, the program recognizes all of the licenses; the operating system
adds the file license.mlic from the directory C:\Users\'User'\AppData\Local
\VirtualStore\Program Files\viva\bin to the detail list of the directory C:
\Program Files\Metrohm\viva\bin.

For the client-server functionality of the database server, however, the file
license.mlic in the directory C:\Program Files\Metrohm\viva\bin is rele-
vant, and here only the basic license is listed. Therefore, problems are to be
anticipated when adding additional clients (more than the 3 clients present in
the default settings).

http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx
http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx
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Remedy

￭ For new installations
– To enter additional licenses, the program must be started as adminis-

trator (position the mouse on the Program icon and click the right
mouse button – select Run as administrator there).

– If one then adds the license code for additional licenses in the usual
way, then the file license.mlic in the directory C:\Program Files
\Metrohm\viva\bin will contain both license codes.

￭ For existing installations
– First of all, the file license.mlic in the directory C:\Users

\'User'\AppData\Local\VirtualStore\Program Files\Metrohm
\viva\bin must be deleted.
This file must not be present in the VirtualStore of any user – a
check must be made to make sure of this, and any such files which
may be found must be deleted.

– Afterwards, the program must be started as administrator (position
the mouse on the Program icon and click the right mouse button –
select Run as administrator).
If one then adds the license code for additional licenses in the usual
way, then the file license.mlic in the directory C:\Program Files
\Metrohm\viva\bin will contain both license codes.

8 User rights for viva

In order that the logged in user be able to access all functions with viva, the
windows system administrator must ensure that the permissions are set for the
directories as listed below:

Directory Permission Group name or
user name

Database directory

Directory where the databases will be saved (…\Data)

Modify SYSTEM

User*

Backup directory

Directory where the backups will be stored (…\Backup)

Modify User*

%ALLUSERSPROFILE%\Application Data\Metrohm
(Windows 2000, Windows XP)**

Modify User*

%PROGRAMDATA%\Metrohm (Windows Vista, Win-
dows 7) **

Modify User*

Export directories

Directories where the exported files are to be saved.

Modify User*

PDF directories

Directories where the PDF files are to be saved.

Modify User*

Desktop Modify User*

%PROGRAMFILES%\Metrohm\viva Read Execute User*
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* User = name of the user who is logged in

** During installation of viva the permission Full Control is set for the following groups: SYSTEM,
Administrators, User, Guests, Main users.
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