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Installation MagIC Net 2.x

1 Minimum system requirements
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Operating system

RAM

Storage capacity

Serial ports

USB ports

Screen

32 bit version of:

= Windows 2000 SP4

= Windows XP Professional SP2

= Windows Vista Business / Enterprise / Ultimate
=  Windows 7 Professional / Ultimate / Enterprise

64 bit version of:

= Windows 7 Professional / Ultimate / Enterprise
Windows 2000 / Windows XP: 1 GB

Windows Vista, Windows 7: 2 GB

Program: 1 GB

Data: 2 GB

for devices with RS-232 interface

for devices with USB interface

Resolution 1024 x 768

The windows user must have administrator rights in order to be able to install
the MagIC Net software.

Additional requirements for the MagIC Net server:

Operating system

32 bit version of:

=  Windows 2000 SP4

= Windows XP Professional SP2

=  Windows Vista Business / Enterprise / Ultimate
= Windows 7 Professional / Ultimate / Enterprise
= Windows 2000 Server

= Windows Server 2003

= Windows Server 2008

= Windows Server 2008 R2

64 bit version of:

= Windows 7 Professional / Ultimate / Enterprise
= Windows Server 2008 R2



Network 10 Mbit/s, stable and permanent

Caution

During a determination data loss may occur when the PC switches over to
the standby mode. In the energy settings of the operating system the
standby mode should therefore be deactivated.

Communication via TCP/IP

2 Single workplace installation

With the single workplace version MaglC Net Basic, MaglC Net Compact
or MagIC Net Professional the MagIC Net client as well as the server will be
installed on your computer.

1 Oninserting the CD into the drive of your computer the installation will
be started automatically. If this option is deactivated on your computer,
double click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nonetheless.

Afterwards, click on [Next >].

2 After having read the license agreement for MaglC Net and accepted it
with [Yes], a window will appear where you can enter the license code.

3 Enter the license code for MagIC Net Basic, MaglC Net Compact or
MagIC Net Professional and click on [Next >].

Metrohm MagIC Net 2.0 Setup al x|
License code
Flease type in your icenze code. n Mel’rohm

License code [IC20 - | - | |

InstallShield

< Back | Meut » I Cancel

8.102.8045EN



0™

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.

Metrohm MagIC Net 2.0 Setup =] |

Licenze code
Please type in pour licenze caode. n MetrOhm

Licensecode [IC20  -[ 0123 -[4567 -[go;o1  -[2345  -[&7&9

@ The licence code is valid only for a program update.
Flease enter the licence code of the previous full wersion.

License code [IC] | | - I |

ImtallShisld

< Back | Mext » I Cancel |

4 Now confirm the target folder for the MagIC Net installation with [Next
>] or select a different target folder with [Browse...].

5 In the dialog window Additional installation information you can
define the paths for the database and backup files:

Metrohm MagIC Net 2.0 Setup al x|
Additional installation information.
Flease enter the neceszany information n MetrOhm

for the operation.

@ Every uzer needs readAwrite rightz for the specified directories!

[atabaze path |C:'\F'rc-gram FileztMetrohmihaglC MethData I

Default backup path |C:'\F'rogram Filezitetrohm'kd aglC MethBackup |

Advanced... |
< Back | Meut » I Cancel |

InstallShield

i

The default paths are different for Windows 2000, Windows XP, Win-
dows Vista and Windows 7.
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With the button [Advanced...] the ports MagIC Net uses to communi-
cate with the database and administration server can be modified. If the
ports are already used, an appropriate error message will appear. Ask
your system administrator for more information about this. Continue with
[Next >].

Follow the instructions of the program until the following message
appears:

Metrohm MagIC Net 2.0 Setup =1

.i If wou use a firewall program please check its settings.
\‘) MagliC et uses the Following ports:
7001, 7002, 5745, 5746

This message points out which ports MaglC Net uses. Write down these
ports and inform your system administrator in case MagIC Net is not
able to connect to the database. Confirm the message with [OK].

As soon as the copying procedure has been finished you can set further
workplace settings:

Metrohm MagIC Net 2.0 Setup =] |
Workplace settings
Please set your client ID and your n MeI‘rOhm

preferred language.

Clignt 1D ||

= Thiz client 1DV must exist i e curent
Fdagllc et spstenm,

Language I Enalizh j

InstallZhield

< Back | Mext » I Cancel
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Metrohm StabNet 1.0 Setup

Workplace settings

Pleasze set your client 1D and wour n Me'l‘rOhm

preferned language.

X

Client ID EK

Language Englizh b

I et ][ Cancel ]

The option This client ID must exist in the current MagIC Net sys-
tem is only selectable if a database from a previous installation already
exists on your computer or if you want to connect to a database server
which has been installed on another computer.

If you activate this option, then MaglC Net checks whether the identifier
you have entered exists in the database. If this is true the identifier and all
associated settings will be adopted. With this option reinstalling a client is
much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.

At the end of the installation, the file info.txt will be created which con-
tains all relevant information concerning your current MaglC Net installa-
tion. Save this file on your hard disk in case of need in future and print it
(add to 1Q).

i

An InstallLog file can be found in the installation directory of

MagIC Net under ...bin\InstallLog. It contains a listing of all files cop-
ied to your computer during the installation and a confirmation that
the installation has been successfully completed.

9 Complete the installation with [Finish].



3 Client/server installation

With the MagIC Net Multi version (multiple workplace version with 3 licen-
ses) you can select during the installation whether you want to install a
MaglC Net client or the MagIC Net client plus server on your computer.

If you want to install a client only on your computer, a server, to which the
client will be connected, must have been previously installed on another com-
puter.

1 Oninserting the CD into the drive of your computer the installation will
be started automatically. If this option is deactivated on your computer,
double click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nonetheless.

Afterwards, click on [Next >].

2 After having read the license agreement for MaglC Net and accepted it
with [Yes], a window will appear where you can enter the license code.

3 Enter the license code for MaglC Net Multi and click on [Next >].

Metrohm MagIC Net 2.0 Setup =] |
Licenze code
Please type in vour icenze code. n Me'mhm

License code [IC20 - -| . | |

InstallShield

If you have entered the license code of an update license, then the
license code of the previous full version will additionally be requested.

< Back | Mext » I Cancel
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Metrohm MagIC Net 2.0 Setup =] |

License code

Flease type in vour icense code. n MetrOhm

License code IC20  -[ 0123 -[4567 -|go;m1  -[2345  -[67&9

@ The licence code is valid only for a program update,
Flease enter the licence code of the previous full werzsion.

License code |IC] | | -| | |

InstallShield

< Back | Mext » I Cancel |

4 Now confirm the target folder for the MagIC Net installation with [Next
>] or select a different target folder with [Browse...].

5 The dialog window Additional installation information appears
where you can select whether you want to install a client or the server:

Metrohm MagIC Net 2.0 Setup =] |
Additional installation information.
Flease enter the necessary information n MetrOhm

far the operation,

% Clignt/Server

@ Every user needs read/write rightz for the specified directories!

[atabaze path IC:'\F'rogram FilezhhetrohmibdaglC MethData |

Default backup path |C:\Pragram Files'Metrohm'tMaglC MetsB ackup |
= Client

Senver | I

advanced... |
< Back | Mext » I Cancel |

InstallShield

The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.

With Client, only the client will be installed and you have to select the
database server (has to be installed in advance!), to which you want to

connect, with |_J The network server name or the IP address are accep-
ted.

With the button [Advanced...] the ports MagIC Net uses to communi-
cate with the database and administration server can be modified. If the
ports are already used, an appropriate error message will appear. Ask
your system administrator for more information about this. Continue with
[Next >].
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6 All further installation steps correspond to those of the single workplace
installation on from point 6.

4 Modifying / repairing / removing the installation
and upgrading the license

Modify

Repair/Update

In order to carry out modifications on the current MagIC Net installation, start
the file setup.exe on the installation CD or click under:

= Windows XP and older - Control Panel » Software
=  Windows Vista / Windows 7 - Control Panel » Programs and Features

on Metrohm MagIC Net. Then select Change/Remove:

Metrohm MagIC Net 2.0 Setup 8 x|
Welcome
todify, repair, update, or remove the program. n Metmhm

Welcome to the MaglC Met Setup Maintenance program. This program lets you modify the
current installation. Click one of the options belaw.

i+ Modiy
ﬁ Select new program features to add or select currently installed features to
Temove.

" Repair/Update
ﬁ Reinztall all program features ingtalled by the previous setup.

" License upgrade

= Mew licenze
]
" Remove
Remove all installed features.
|matallShie

< Bach | Mext > I Canicel

With this option you can change the paths to the database and backup files
and set the ports which MaglC Net uses for communication. With the
MagIC Net Multi version you can additionally change the path to the data-
base server.

If the database path is changed, the existing databases are automatically cop-
ied to the new location.

With this option you can repair an existing defective installation or update an
older installation.

= Repairing the installation
In case of a defective MagIC Net installation because e.g. a DLL file is miss-
ing or a program file has been deleted by mistake, MagIC Net can be
repaired with this option.

» Updating the installation
In case an older version of MagIC Net is installed, it will be updated to the
new version of MagIC Net.

8.102.8045EN



License upgrade

Remove

Caution

During updating older MaglC Net versions the databases will be converted
to the new version. Depending on the size of the database, this can take
some time. For each database a progress bar is displayed which informs
about the status of the conversion.

The computer or Windows must not be restarted or shut down as long as
the conversion is running!

A direct upgrade of your current installation to a MagIC Net version with
additional features is possible:

» MagIC Net Compact to MagIC Net Professional or MagIC Net Multi
= MagIC Net Professional to MagIlC Net Multi

In order to do this, enter your new license code in the next dialog window.

This option removes your MaglC Net installation. Data which has been gener-
ated after the installation (e.g. database entries, log files, exported data etc.)
will remain on your hard disk.

5 Program update with MagIC Net Compact/Pro-

fessional
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During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically
updated for further use with the new version of MaglC Net Compact/Pro-
fessional.

ﬂ Note

The files in the database and backup directory will be retained when updat-
ing the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Files in these directories which have not been over-
written by the update will be deleted. The deleted files are listed in the
InstallLog.

1 Save the configuration database into an external directory using the
backup function of MagIC Net. In the program part Configuration,
select the menu item File » Save » Manually. Select the Backup direc-
tory, enter a name for the backup file and click on [Start]. The backup is



10

carried out automatically. It is recommended to copy the backup file to
CD/DVD.

If desired, export the methods in addition to the automatic backup of the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File » Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] » Export.... Select the desired export directory and click
on [OK]. The methods are exported into the desired directory. It is recom-
mended to copy the exported methods to CD/DVD.

Save all determination databases created by yourself into an external
directory using the backup function of MagIC Net. In the program part
Database, select the menu item File » Database manager.... Select
the desired database and click on [Backup]. Select the Backup direc-
tory, enter a name for the backup file and click on [Start]. The backup is
carried out automatically. It is recommended to copy the backup file to
CD/DVD.

Save further files created by yourself in the installation directory (e.g.
export files) into an external directory or to CD/DVD.

Close MagIC Net. Insert the installation CD and double-click the file
setup.exe. Then select Repair/Update and click on [Next].

Metrohm MagIC Net 2.0 Setup =] |
Welcome
Modify, repair. update, or remowe the program. n Mel’rohm

Welcome to the MaglC Met Setup Maintenance program. This program lets you maodify the
current inztallation. Click one of the options belaw.

= Modify

ﬁ Select hew progran features ta add or select currently installed features to
TEMovE.

{* Repair/lpdate
ﬁ Reinstall all program features inztalled by the previous setup.

" License upgrade
= Mew licenze
g

= Femove
Remove all installed features.

InstallZhiea

< Back | Mext » I Cancel |

6 Enter the update license code for MagIlC Net Compact or MagIC Net

Professional and click on [Next].

8.102.8045EN



Metrohm MagIC Net 2.0 Setup =] |

License code

Flease type in vour icense code. n Me"rohm

License code [IC20 - | . | |

InstallShield

< Back | Mext » I Cancel

7 Caution

During updating older MagIC Net versions to MaglC Net 2.x the data-
bases will be converted to the new version. Depending on the size of
the database, this can take some time. For each database a progress
bar is displayed which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion is running!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to your com-
puter and with a confirmation for a successful installation is saved in the
MagIC Net installation folder (default: C:\Program Files\Metrohm
\MaglC Net) under bin\InstallLog.

6 Program update with MagIC Net Multi
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During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with the new
version of MagIC Net Multi.

11
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i

The files in the database and backup directory will be retained when updat-
ing the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. Files in these directories which have not been over-
written by the update will be deleted. The deleted files are listed in the
InstallLog.

1 Make sure MaglC Net Multi is closed on all clients.

i

In the subdirectory bin of the MagIC Net installation there is the
application Clients.exe, with which all clients and their status can be
displayed.

2 Open MagIC Net Multi on the server and save the configuration data-
base into an external directory using the backup function of MagIC Net.
In the program part Configuration, select the menu item
File » Save » Manually. Select the Backup directory, enter a name
for the backup file and click on [Start]. The backup is carried out auto-
matically. It is recommended to copy the backup file to CD/DVD.

3 If desired, export the methods in addition to the automatic backup of the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File » Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] » Export.... Select the desired export directory and click
on [OK]. The methods are exported into the desired directory. It is recom-
mended to copy the exported methods to CD/DVD.

4 Save all determination databases on the server into an external directory
using the backup function of MagIC Net. In the program part Data-
base, select the menu item File » Database manager.... Select the
desired database and click on [Backup]. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is car-
ried out automatically. It is recommended to copy the backup file to CD/
DVD.

5 Save further files in the installation directory (e.g. export files) into an
external directory or to CD/DVD.

8.102.8045EN



6 Updating the server

Close MagIC Net Multi on the server and on all clients. Insert the instal-
lation CD on the server and double-click the file setup.exe. Then select
Repair/Update and click on [Next].

Metrohm MagIC Net 2.0 Setup =] |
Welcome
Modify, repair, update, or remaove the program. n MetrOhm

YWelcome to the MaglC Met Setup Maintenance program. This program lets you modify the
current inztallation. Click one of the options belaw.
= Modify

@ Select hew progran features to add or select currently installed features to
TEMovE.

{* Repair/lpdate
ﬁ Reinstall all program features inztalled by the previous zetup.

" License upgrade
= MHew licenze
T

= Femove

Remove all installed features.

InstallShiea

< Back | Mext » I Cancel |

7 Enter the update license code for MaglC Net Multi and click on [Next].

Metrohm MagIC Net 2.0 Setup =] |
License code
Please type in pour licenze caode. n MetrOhm

License code [IC20 - | - I |

ImstallShisld

< Back | Meut = I Cancel

N i

The update of MagIC Net Multi consists of the server license and
three client licenses. If an existing installation contains additional licen-
ses, these will be deleted.

Click on [OK] in the corresponding message in order to continue the
installation.
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9 @ Caution

During updating older MagIC Net versions to MagIC Net 2.x the data-
bases will be converted to the new version. Depending on the size of
the database, this can take some time. For each database a progress
bar is displayed which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion is running!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to the server
and with a confirmation of a successful installation is saved in the

MagIC Net server's installation folder (default: C:\Program Files\Metrohm
\MaglC Net) under bin\InstallLog.

10 In case additional licenses have been removed during the server update,
or if further additional licenses are to be added, the Administrator can
enter them in MagIC Net (dialog: Configuration » Tools » Program
administration » Licenses » Add licenses).

11 Updating clients
For each client, insert the installation CD and double-click the file
setup.exe. Then select Repair/Update and click on [Next]. Complete
the installation with [Finish].

In order to facilitate updating many clients, the installation can be cop-
ied from the CD to a writeable medium and the file magic_init.ini can
be modified. There, user-defined parameters (license code, installation
path, server name, ...) for the installation can be set in advance, which
allows you to only having to click through the installation.

An UpdateLog file with a list of all files having been copied to the client
computer and with a confirmation for a successful installation is saved in
the MagIC Net client's installation folder (default: C:\Program Files
\Metrohm\MaglC Net) under bin\InstallLog.

7 Installation of drivers

In normal cases, the installation routine of MagIC Net automatically installs all
the drivers necessary for controlling the supported devices.

If you are using a 64-bit operating system it may be necessary to install drivers
manually in combination with a few devices. This is the case if the operating
systems displays a message when connecting a device to the computer, e.g.
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Device driver software was not successfully installed. No driver
found. The message should also show the name of the corresponding device.
Note this name and proceed as follows to install the driver manually:

i

The following description applies for Windows 7 (64-bit version). It may
slightly vary for your system.

1 Open the Windows Device Manager. Under Other devices the corre-
sponding device can be found.

2 Click on the device with the right mouse button. The context menu
opens.

3 In the context menu, select Update Driver Software.... A dialog win-
dow opens.

4 Select Browse my computer for driver software. The file selection
dialog opens.

5 Navigate to the installation folder of MagIlC Net (default: C:\Program
Files\Metrohm\MagIC Net).

6 In the installation folder, open the subfolder drivers. This folder contains
the subfolder 889, in which you can find the driver for the 889 IC Sample
Center and the Combustion Module.

7 Apply the selection with [OK]. A safety prompt is displayed. In order to
install the driver, click on [Install].

8 After the successful installation, close the Device Manager.

8 Adding additional licenses with Windows Vista

or newer

8.102.8045EN

General

Since Windows Vista, Microsoft has introduced the UAC (User Account Con-
trol), which permits running tasks either as non-administrator or as administra-
tor (without changes of user, switching off or similar).

http.//technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx
http.//technet.microsoft.com/en-us/magazine/2007.06.uac.aspx

This function can, however, cause difficulties with client-server installations of
MagIC Net.

15


http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx
http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx

Problem description

One would like to add additional licenses for the program; the license code for
an additional 5 licenses, for example, is added (on the server) in the program
part Configuration in the dialog window Program administration (accessi-
ble via menu item &Tools » &Program administration..., tab Licenses).

The file license.mlic, which contains the standard license code and the addi-
tional license codes, is stored in the bin directory of the program installation
(C:\Program Files\Metrohm\MagIC Net\bin).

If one adds the 5 licenses and then looks at this file license.mlic, only the
standard license code will be listed (for 3 licenses).

If one highlights the file license.mlic and presses Compatibility files in the
bar, then one will arrive in the directory C:\Users\'User'\AppData\Local\Vir-
tualStore\Program Files\Metrohm\MagIC Net\bin (‘User’ being the
abbreviation (UID) for the user logged in on the operating system). The file
license.mlic with the license codes for the standard licenses and the 5 newly
added licenses is to be found here, i.e. the additional licenses are stored in the
VirtualStore only for the Windows user who was logged in on the PC at the
time the additional licenses were added.

On the server, the program recognizes all of the licenses; the operating system
adds the file license.mlic from the directory C:\Users\'User"\AppData\Local
\VirtualStore\Program Files\MagIC Net\bin to the detail list of the direc-
tory C:\Program Files\Metrohm\MagIC Net\bin.

For the client-server functionality of the database server, however, the file
license.mlic in the directory C:\Program Files\Metrohm\MagIC Net\bin is
relevant, and here only the basic license is listed. Therefore, problems are to be
anticipated when adding additional clients (more than the 3 clients present in
the default settings).

Remedy

= For new installations
— To enter additional licenses, the program must be started as adminis-
trator (position the mouse on the Program icon and click the right
mouse button — select Run as administrator there).
— If one then adds the license code for additional licenses in the usual
way, then the file license.mlic in the directory C:\Program Files
\Metrohm\MagIC Net\bin will contain both license codes.

8.102.8045EN



= For existing installations

— First of all, the file license.mlic in the directory C:\Users
\'User"\AppData\Local\VirtualStore\Program Files\Metrohm
\MagIC Net\bin must be deleted.
This file must not be present in the VirtualStore of any user —a
check must be made to make sure of this, and any such files which
may be found must be deleted.

— Afterwards, the program must be started as administrator (position
the mouse on the Program icon and click the right mouse button —
select Run as administrator).
If one then adds the license code for additional licenses in the usual
way, then the file license.mlic in the directory C:\Program Files
\Metrohm\MagIC Net\bin will contain both license codes.

9 User rights for MagIC Net

In order that the logged in user be able to access all functions with
MagIC Net, the windows system administrator must ensure that the permis-
sions are set for the directories as listed below:

Directory Permission Group name or
user name

Database directory Modify SYSTEM

Directory where the databases will be saved (...\Data) User”

Backup directory Modify User”

Directory where the backups will be stored (...\Backup)

%ALLUSERSPROFILE%\Application Data\Metrohm Modify User’

(Windows 2000, Windows XP)*

%PROGRAMDATA%\Metrohm (Windows Vista, Win- Modify User”

dows 7) ™

Export directories Modify User

Directories where the exported files are to be saved.

PDF directories Modify User”

Directories where the PDF files are to be saved.

Desktop Modify User’

%PROGRAMFILES%\Metrohm\MagIC Net Read Execute User

*

User = name of the user who is logged in

*%
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During installation of MagIC Net the permission Full Control is set for the following groups:
SYSTEM, Administrators, User, Guests, Main users.
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