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1 Introduction

1.1 Welcome to tiBase

Introduction

tiBase is a program for administering analysis data on the basis of PC/LIMS
reports. The reports of the corresponding Metrohm instruments can be
read into tiBase.

Overview of the main program features

￭ Easy-to-operate and easily configurable user interface
￭ Application
￭ Comprehensive online help
￭ Program versions
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1.2 Application

tiBase is a database program for administering data on the basis of PC/
LIMS reports.

The reports generated by Titrino plus, Coulometer, pH Meter/Conducto-
meter, PC Control, Touch Control, Ti-Touch and Compact Titrosampler
instruments can be read into tiBase.

1.3 Operation

Introduction

The modern user interface makes it easy for users to find their way
around tiBase. The bar on the left edge of the screen gives you access to
the two basic elements of tiBase:

Database Configura-
tion

Depending on the access permissions, these buttons are either visible or
hidden. The menu bar is in the upper part of the screen. It is also possible
for the individual commands to be hidden, depending on the access per-
missions.

In the center of the screen, you can find the information windows with
the determination overviews, curves, information or results. This view can
be set individually for each user with the aid of the new layout manager.
As a result, users see only those windows or buttons they actually need
for their work. This reduces the introductory period for routine users to a
minimum. Incorrect operation as a result of overcrowded screens is also a
thing of the past.
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1.4 Device integration

Introduction

PC/LIMS reports can be read into tiBase by:

￭ Titrino plus
848, 870, 877

￭ Touch Control
840 (5.840.0150), 900

￭ pH Meter/Conductometer
912, 913, 914

￭ Ti-Touch
915, 916

￭ PC Control
￭ 862 Compact Titrosampler
￭ 899 Coulometer

1.5 Database

Introduction

tiBase is based on an object-oriented database that has proven itself
in practice. All program settings, the user administration, methods and
templates are stored in the configuration database and the determina-
tion data is stored in the determination databases defined by the user.
These databases can be installed locally on the computer reserved for
measurements and make up a simple measurement system. tiBase is
however scalable and grows with operational requirements. As soon as
data security and central data management make it necessary, tiBase is
installed as a client/server configuration. The tiBase database is then
installed on a server. All measurement and office computers work as cli-
ents. All results are stored centrally in this network and can be accessed
and processed by all Client PCs. All clients also access the same pool of
methods.

The new database has all the major tools necessary for managing, search-
ing for and grouping results. Quick filters allow the user to browse
through thousands of determinations within seconds and to display the
result clearly. Chart plots give a fast overview of the sequence of results
based on time.

All options for reprocessing are available to the user.

Overview of functions

￭ Object-oriented client/server database (see Chapter 3.2.3.1, page
97).
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￭ Layout manager for the database view (see Chapter 4.1.7, page 123).
￭ Quick filters (see Chapter 4.5.2.4.3, page 220).
￭ Efficient search functions (see Chapter 4.5.2.3, page 217).
￭ Access permissions control for every database (see Chapter 4.3.5.3,

page 132).
￭ Automatic database backup (see Chapter 4.3.5.4, page 133).
￭ Control charts (see Chapter 4.5.2.16, page 258).
￭ Reprocess determinations (see Chapter 4.5.2.6, page 230).

1.6 Communication

Introduction

The decisive factor for acceptance is the possibility of easy and economical
integration in existing laboratory information systems, central databases
and long-term archiving systems.

tiBase is communicative. Data generated in tiBase can be exported in
XML and CSV format. Connection to LIMS systems on the market is thus
not difficult. Export to long-term archiving systems such as NuGenesis
SDMS or Scientific Software Cyberlab is also supported.

The new Report generator provides a simple and flexible solution for
creating analysis reports. The report generator allows you to freely define
the report templates. It is therefore possible at any time to display one or
more determinations in a choice of PDF format or as a printout.

Overview of functions

￭ Import of PC/LIMS reports (see Chapter 3.4.3, page 110).
￭ Various export formats, e.g. XML, CSV, SLK (see Chapter 4.4.4.2.1,

page 183).
￭ Report designer (see Chapter 4.4.1.4.1.1, page 140).
￭ E-mail functions for security settings (see Chapter 3.2.2.7, page 95).
￭ Send determinations by e-mail (see Chapter 4.5.2.7, page 253).
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1.7 Conformity

Introduction

tiBase also sets new standards with respect to the fulfilling of GMP and
GLP requirements. The latest quality standards and validation proce-
dures were implemented in developing and programming the software. A
centralized user administration defines the access permissions for program
functions and determinations, whereby any number of users with freely
definable access profiles are possible. The system administrator can conve-
niently access the user administration from any tiBase client. Access to the
software is password-protected and there is a choice of tiBase or Win-
dows login.

The use of digital signatures makes it possible to sign determinations.
There are two signatures available with differing properties. With the first
signature (Level 1, Review) the user confirms that he has programmed the
method correctly or carried out the analysis correctly. With the second sig-
nature (Level 2, Release) the method or result is shared and protected
against further modifications. It is thus possible to mirror customized
workflows in tiBase.

All data is version-controlled and protected against unauthorized
access, modification or deletion in the database. The database itself con-
trols access to the data in network operation and provides archiving and
restore functions.

Conformity-relevant properties of tiBase 1.1 Patch 1

￭ Conformity is priority in development and validation.
￭ Central user administration (see Chapter 3.2.1.1, page 79).
￭ Detailed access permissions (see Chapter 3.2.1.2.2, page 82).
￭ Password protection under tiBase or Windows (see Chapter 3.2.2.2,

page 88).
￭ Digital signature on two levels (see Chapter 2.3, page 15).
￭ One signature each for methods and results.
￭ Documentation of all determination modifications (see Chapter

4.5.2.13, page 257).
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1.8 Versions

Introduction

tiBase is available in the following sales versions which differ with regard
to scope and functions. An upgrade is possible at any time.

 tiBase 1.1 Patch
1 full

tiBase 1.1 Patch
1 multi

Product 6.6063.112 6.6063.113

User administration • •

Security settings • •

Client/server support  •

Number of licenses 1 3

Additional licenses as an
option

 •

XML data export to LIMS • •

Upgrade possible • •

1.9 Online help

Introduction

Calling up the help

tiBase has a very extensive and detailed online help that can be accessed
in two ways:

￭ General call The Help ▶ tiBase Help menu item or the symbol  is
used to open the online help with the topic Welcome to tiBase. From
there you can jump to the desired topic via Contents, Index, Search
or personal Favorites.

￭ Context-sensitive call With the [F1] function key on the keyboard
you can jump directly to the topic which will show information on the
active element in tiBase (dialog window, tab).

Symbols and conventions

The following symbols and formatting are used in this documentation:

Configuration Link to another help topic in which information is
shown for the marked term.
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Database Dialog text

Designation for names of parameters, menu items,
tabs and dialog windows in the software.

100 Designation for parameter values in input fields.

File ▶ New Menu or menu item; Path needed to reach a certain
point in the program.

[Next] Button

Formula editor

Formulae can be entered in fields with this symbol,
and the formula editor opens when you click on the
symbol (see Chapter 2.4, page 21).

Instruction step

Carry out these steps in the sequence shown.

Caution

This symbol draws attention to possible damage to
instruments or instrument parts.

Note

This symbol marks additional information and tips.

1.10 What is new in tiBase 1.1?

This chapter describes the changes that were made from tiBase 1.0 to
tiBase 1.1.

1.10.1 Improvements

Database program part

￭ PC/LIMS reports with extended character set (UTF-8) can be read in.
￭ The message 008-414 Not possible to import data now addition-

ally specifies the line and character in which the error has occurred.

Configuration program part

￭ A new feature is that the recommended settings in the Security set-
tings dialog window can be set using the Recommended settings
check box; this disables all of the fields that pertain to this setting.

￭ In a new import operation, this is started automatically if the corre-
sponding selection is made.
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￭ Importing (import operation under configuration) of a determination is
continued even if the determination is not readable. Determinations
that cannot be read in are moved to a folder named unreadable in
the source directory.

1.10.2 Fixed bugs and problems

Database program part

￭ PC/LIMS reports created with the 900 Touch Control were unable to be
read in.

￭ PC/LIMS reports cannot be imported on computers (PCs) with Chinese
Windows operating system.

￭ Recalculating did not work if the titer has been invalid.
￭ The formula editor did not open on double-clicking.
￭ The PC/LIMS report could not be read in if the user entry field con-

tained a number.
￭ Variables were not found if an additional command had been inserted.
￭ In the fixed report Results, the result names were not printed out.
￭ The assignment of calibration curves and raw data was wrong for

methods with more than one calibration command.
￭ The user name was not printed out correctly as short and long name.
￭ The PC/LIMS report could not be read in if the cylinder serial number

for the titrant is missing in a report.
￭ At recalculation, the ID (number) was shown in exponential syntax.
￭ Error when reading in the data if only numbers were in the text field

(e.g. sample identification, device name).
￭ Error when reading in the data if the Sample size field was empty.
￭ The titer was able to be set to invalid when being reprocessed for the

first time; an additional recalculation caused a crash.
￭ Error when reading in the data that contained method commands that

support the electrode check.
￭ Error when reading in the data if the ID designation was empty.
￭ Under the raw data, the variables EME, FP#.MEA, MI.MEA, MA.MEA,

BP#.MEA were output with two instead of four decimal places.
￭ Error when reading in the data if the titer field and/or titer unit field

was empty.
￭ In the measuring point list and on the axis of the curve, the label of the

drift was missing for MEAS Cond.
￭ The method version and change status of the method (Method saved

by) were read out incorrectly.
￭ If, in a report template, a line thickness was entered that is greater

than the allowed range (0.1 to 10.0 mm), the program crashed.
￭ The message 014-140 Limit value infringed with the note Press

[Continue] was misleading.
￭ The device serial number was displayed preceded by the field designa-

tion S.
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Configuration program part

￭ Error when automatically importing large PC/LIMS reports that are
saved via the network.

1.11 What is new in tiBase 1.1 Patch 1?

This chapter describes the changes that were made from tiBase 1.1 (Build
16) to tiBase 1.1 Patch 1 (Build 16-1).

1.11.1 Improvements

General

￭ tiBase runs on Windows 8 operating system. Windows 2000 is no lon-
ger supported. The installation manual has been revised.

1.11.2 Fixed bugs and problems

General

￭ In the online help, the wrong character was assigned to the value 044
in the ASCII table.

Database program part

￭ Reprocessing of determinations from 912 and 914 portable meter
instruments led to a software crash.

￭ If the message 008-401 File already exists in the database and
then 008-402 Delete or remove already existing file were both
rejected during importing of a PC/LIMS report into a database, then
the message 008-415 Import canceled by user did not appear.

￭ The curve overlay did not function correctly if there were several identi-
cal commands (e.g. MEAS commands) of different command types
(e.g. MEAS pH and MEAS Cond) in a determination.

Configuration program part

￭ If the check box Recommended settings was activated in the
Security settings dialog window and if the user then changed from
the option Password monitoring by tiBase to the option Pass-
word monitoring by Windows, then the message 005-001 No
password protection did not appear.

 

Herisau, November 26, 2014  
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2 General program functions

2.1 Program parts

2.1.1 Program parts
General program functions

tiBase has two different program parts which can be opened by clicking
on the corresponding symbol in the vertical bar on the left. The symbol for
the opened program part is shown in color, the symbol for the other pro-
gram part in black and white. The menus, symbol bars and content of the
main window depend on the program part currently opened.

Database program part

￭ Opening/closing databases
￭ Managing databases
￭ Reprocessing
￭ Creating report templates

Configuration program part

￭ Configuration of data import, login, backup, etc.
￭ Security settings
￭ User administration
￭ Program administration

NOTE

Access to a program part can be deactivated in the user administration.
The respective symbol is disabled in such cases.

2.1.2 Database - User interface
Program part: Database

Database symbol

Clicking on the database symbol in the vertical bar on the left opens the
Database program part, while at the same time the database symbol is
shown in color. The upper left corner of the symbol contains a black field
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displaying the number of databases currently opened (see Chapter 4.2.2,
page 127).

Elements

The user interface of the Database program part is comprised of the fol-
lowing elements:

￭ Database-specific menu bar.
￭ Database-specific toolbar.
￭ Main window in which up to 6 subwindows can be displayed.

2.1.3 Configuration - User interface
Program part: Configuration

Configuration symbol

Clicking on the configuration symbol in the vertical bar at the left opens
the Configuration program part, while at the same time the configura-
tion symbol is shown in color.

Elements

The user interface of the Configuration program part is comprised of the
following elements:

￭ Configuration-specific menu bar.
￭ Configuration-specific toolbar.
￭ Main window in which 2 subwindows are displayed.

2.2 Login/Password protection

2.2.1 General information on login / password protection
Program part: Configuration / Database

Login into tiBase

tiBase can be configured so that all users have to log in with their user
name and password, and this data is automatically checked. This
requires a User administration to be set up and the corresponding
Security settings to be made. This data is saved in the configuration
database. In the case of client/server systems, this is on the server and
applies globally for all clients (central user administration).



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 2 General program functions

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 13

Recommended settings

The [Set] button on the Login/Password protection tab in the Secur-
ity settings dialog window has to be pressed in order to make the set-
tings. The following conditions will then be complied with:

￭ A login with user name and password is required each time the
program is started.

￭ Depending on the setting, the password administration is carried
out in tiBase or in Windows.

￭ User names must be unique. Users cannot be deleted once they
have been entered.

￭ Passwords must be unique for each user. None of the expired pass-
words already used once by the user may be reused.

￭ Passwords must comprise a minimum number of characters.
￭ Passwords must be changed after a defined validity period.
￭ The number of login attempts is limited. If this number is exceeded,

the user will automatically be set to inactive status.

Actions

If the login is activated, the following actions can be performed:

￭ Logging in at program start
￭ Logging out manually
￭ Logging out automatically
￭ Changing password

2.2.2 Logging in
Program parts: Configuration / Database

If both the options Enforce login with user name and Enforce login
with password are activated in the Security settings, the Log in dia-
log window will appear every time the program is started and after each
time a user logs out.

User

Entry of the short name of the user.

Entry 24 characters

Password

Entry of the password.

Entry 24 characters
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NOTE

Users who log in for the first time or users whose status has been reset
from inactive or removed back to active must log in with the Start
password (see Chapter 3.2.1.3.1, page 85) specified by the adminis-
trator. Afterwards, the Change password window will automatically
open in which a new password must be entered.

[Change password]

Opens the Change password window, in which the new password must
be entered and confirmed.

[Cancel]

The login is canceled and the program is terminated.

2.2.3 Logging out manually
Menu item: Configuration / Database ▶ File ▶ Logout

A logged-in user can log out at any time with the File ▶ Logout menu
item. The logout options defined in the Security settings apply. After
the logout, the Log in window opens in which a new user can log in.

2.2.4 Logging out automatically
Program part: Configuration

If the automatic logout is activated in the Security settings, then the
user will be logged out automatically after the defined waiting time if no
operating functions have been performed in the meantime via keyboard
or mouse. The Log in window appears again afterwards, but only the
same user or members of the same user group can use it to log back in
again.

NOTE

Users with administrator rights can always log in.

2.2.5 Changing the password
Dialog window: Log in ▶ [Change password] ▶ Change password

NOTE

In tiBase, the password can only be changed if the Password moni-
toring by tiBase option is set in the security settings.
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[Change password]

This button in the Log in dialog window opens the Change password
window, in which the new password must be entered and confirmed.

NOTE

The password must always be changed before the Validity of the pass-
word expires. For users who are logging in for the first time or users
whose status has been reset from inactive or removed back to
active, this window opens automatically after login with the Start
password. Here you will also need to enter the Start password
assigned by the administrator in the Old password field.

Old password

Entry of the previous password.

Entry 24 characters

New password

Entry of the new password. The password options are defined in the
Security settings on the Login/Password protection tab.

Entry 24 characters

Confirm password

Confirmation of the new password.

Entry 24 characters

2.3 Electronic signatures

2.3.1 Rules for electronic signatures
Program part: Database

In tiBase, determinations can be electronically signed at two levels. The
following rules apply for this:

￭ Signature levels
Determinations can be signed at two levels (signature level 1 and sig-
nature level 2) by entering the user name and a password.

￭ Multiple signing
Determinations can be signed several times at each level.

￭ Signing at level 1
If level 2 has been signed, then no more signatures are possible at level
1.
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￭ Signing at level 2
Level 2 can not be signed unless there are already signatures on level
1.

￭ Different users
The same user may not sign on both level 1 and level 2.

￭ Reason and comment
Each signature must be accompanied by a reason selected from prede-
fined default reasons. An additional comment can also be entered.

￭ Saved data
Signature date, user name, full name, reason and comments are saved
for each signature.

￭ Deleting signatures 1
Signatures at level 1 are automatically deleted again when a new ver-
sion is created.

￭ Deleting signatures 2
Signatures at level 2 can only be deleted by users who have the respec-
tive permission.

￭ Signature options
The options for electronic signatures are set in the Signatures tab in
the Security settings dialog window.

2.3.2 Procedure for electronic signatures
Program part: Database

Determinations exhibit one of the following three statuses with respect to
signatures (see flow diagram):

￭ Not signed
Determinations that are not signed can be deleted and changed, with
a new version being created each time there is a change.

￭ Signed (1)
No new versions are generated when determinations are signed at
level 1. If determinations signed at level 1 are changed, then a new
version will be generated that no longer contains any signatures.
Determinations signed at level 1 can be deleted.

￭ Signed (2)
No new versions are generated when determinations are signed at
level 2. Determinations signed at level 2 can neither be changed nor
deleted. It is, however, possible to delete the signatures (2), although
the signatures (1) will be retained.
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Modify

Modify

Not signed

Sign (1)

Signed 1

Sign (2)

Signed 2

Delete signatures 2

DeleteCreate

Delete

Modify

Delete

2.3.3 Signature Level 1
Dialog window: Database ▶ Determinations ▶ Sign ▶ Signature
1… ▶ Signature level 1

Determinations can be signed at level 1 in the Signature level 1 win-
dow.

NOTE

Determinations that have been signed at level 1 can be modified and
deleted. If the modified method or determination is saved as a new ver-
sion, however, then all existing signatures will be deleted automatically,
i.e. the method or determination must be signed once again.

Info

Display of information for signing and deleting signatures. The following
messages are possible:

Selection Signature possible | Signature 1 not possible
(signature 2 exists) | Signature not possible
(accessed by other client) | Signature not pos-
sible for multiple determinations

Signature possible
The selected determination can be signed.

Signature 1 not possible (signature 2 exists)
The selected determination can no longer be signed at level 1 as it has
already been signed at level 2.



2.3 Electronic signatures ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

18 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

Signature not possible (accessed by other client)
The selected determination cannot be signed as it is already marked to
be signed on a different client.

Signature not possible for multiple determinations
Several determinations have been selected; they may, however, only be
signed individually.

User

Entry of the user name (short name).

Entry 24 characters

Password

Entry of the password.

Entry 24 characters

Reason

Selection from the Default reasons defined for the Signature level 1
category in the Security settings dialog window.

Selection Selection from the default reasons

Comment

Entry of a comment on the signature.

Entry 1,000 characters

[Sign]

Sign the determination. The window remains open.

NOTE

Determinations can only be signed at level 1 if the user belongs to a
user group with the respective permission.

2.3.4 Signature level 2
Dialog window: Database ▶ Determinations ▶ Sign ▶ Signature
2… ▶ Signature level 2

Determinations can be signed at level 2 in the Signature level 2 win-
dow.
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NOTE

Determinations signed at level 2 are locked, i.e. they can be neither
modified nor deleted. In order to be able to edit such determinations
again, the signatures on level 2 must first be deleted.

Info

Information for signing and deleting signatures is displayed in this box.
The following messages are possible:

Selection Signature possible | Signature 2 not possible
(signature 1 missing) | Signature not possible
(accessed by other client)

Signature possible
The selected determination can be signed.

Signature 2 not possible (signature 1 missing)
The selected determination cannot be signed at level 2 as it has not yet
been signed at level 1.

Signature not possible (accessed by other client)
The selected determination cannot be signed as it is already marked to
be signed on a different client.

User

Entry of the user name (short name).

Entry 24 characters

Password

Entry of the password.

Entry 24 characters

Reason

Selection from the Default reasons defined for the Signature level 2
category in the Security settings dialog window.

Selection Selection from the default reasons

Comment

Entry of a comment on the signature.

Entry 1,000 characters

[Sign]

Sign the determination. The window remains open.
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NOTE

Determinations can only be signed at level 2 if the user belongs to a
user group with the respective permission.

2.3.5 Deleting signatures Level 2
Dialog window: Database ▶ Determinations ▶ Sign ▶ Delete Sig-
natures 2… ▶ Delete Signatures Level 2

The Delete Signatures Level 2 window allows you to delete all of the
signatures on level 2 for the selected method or determination.

User

Entry of the user name (short name).

Entry 24 characters

Password

Entry of the password.

Entry 24 characters

Reason

Selection from the Default reasons defined for the Signature level 2
category in the Security settings dialog window.

Selection Selection from the default reasons

Comment

Entry of a comment on the signature.

Entry 1,000 characters

[Delete]

Delete signatures 2.

NOTE

Signatures 2 can only be deleted if the user belongs to a user group
with the respective permission.
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2.4 Formula editor

Dialog window: Formula editor

The formula editor serves as a support when entering formulas for result
calculation. It has an automatic syntax check, which is activated when
the formula is applied. The general rules of priority apply for the calcula-
tion operations.

The Formula editor dialog window contains the following elements:

￭ Input field
Entry of the calculation formula (see Chapter 2.4.1, page 21).

￭ Buttons
Buttons for the quick entry of operators, parentheses and brackets (see
Chapter 2.4.1, page 21).

￭ Operators/functions
Selection of the operators and functions available for the calculation
formula (see Chapter 2.4.4.1, page 38).

￭ Description
Description of the selected variables, operators or functions.

2.4.1 Input field
Dialog window: Formula editor

The calculation formula is entered in the input field of the formula editor.
The following options are available for the entry:

Entry via keyboard

￭ Numbers
Numbers as well as mathematical functions can be entered directly via
the keyboard.

￭ Text
Text must be enclosed in quotation marks " (e.g. "my text").

￭ Variables
Variables must be entered and ended with an apostrophe ' (e.g.
'MV.my variable').

￭ Time
Time indications must always be made with the aid of the Time( )
function.

Entry using the buttons

Mathematical operators and parentheses or brackets can simply be
inserted in the formula using the corresponding buttons. A space is auto-
matically inserted before and after the character.
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Addition Equal to Logical AND

Subtraction Greater than Logical OR

Multiplication Less than
 

Round parentheses

Division Not equal to
 

 

Potentiation Less than or equal to Molar mass calculator

  Greater than or equal to Undo last action

    Redo last action

Entry via selection

The element selected in the Variables or Operators fields can be added
to the formula by double-clicking or with [Insert].

2.4.2 Calculation algorithms
Dialog window: Formula editor

Numerical format

The standard IEEE 754 (1985) for binary floating-point arithmetic is imple-
mented in "double precision" (64 bit) in the software.

Rounding-off process

Measured values and results are rounded off symmetrically (commercial
rounding). I.e., 1, 2, 3, 4 are always rounded down whereas 5, 6, 7, 8,
9 are always rounded up.

Examples

2.33 yields 2.3

2.35 yields 2.4

2.47 yields 2.5

–2.38 yields –2.4

–2.45 yields –2.5

Statistics

The mean value as well as the absolute and relative standard deviation of
results R are calculated using the following formulas:
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Mean value

Absolute standard
deviation

Relative standard devi-
ation (in %)

The calculation of the mean value and the standard deviation requires a
multitude of calculation operations, which are carried out with full accu-
racy. The input data (results) and the output data (mean value, standard
deviation), however, are then rounded off to the accuracy specified by the
user.

It is not the number of decimal places which is decisive for the accuracy of
the calculations, but rather the number of significant digits of the decimal
numbers displayed. As a result of the binary 64-bit numerical format
implemented on the basis of the IEEE 754 standard, the resulting decimal
numbers have 15 reliable significant decimal places.

You can influence the number of significant digits by selecting the unit
and the number of decimal places. As the result unit to be set sometimes
contains the prefix "milli" as well as the actual physical unit, the number of
significant places changes accordingly by three places during such a con-
version.

Example

The displayed result of 1,234.56789158763 mg/L has 15 reliable digits.
It should be rounded off to three decimal places according to the above
rounding-off process:

1,234.568 mg/L (7 significant places, 3 of them decimal places)

The unit "g/L" means that the same result 1.23456789158763 g/L is
also rounded off to three decimal places:

1.235 g/L (4 significant places, 3 of them decimal places)

The number of significant digits has now been reduced by three to four
digits by omitting the prefix "milli".
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NOTE

The above losses with respect to accuracy caused by rounding off in the
range of the maximum reliable places are only theoretically relevant.
Most of the time they are lower by several orders of magnitude than,
for example, the uncertainties resulting from sample size.

2.4.3 Variables

2.4.3.1 Variables - Overview 
Dialog window: Formula editor

Variables are automatically generated by the program during or at the end
of the determination. You can use the formula editor to access these and
either use the values for further calculations or output them in reports as a
result.

Variable types

The following types of variables are differentiated:

Name Syntax Description

Method vari-
ables 

'MV.Variable
name'

Method variables include the varia-
bles FCT and DIV

Sample data
variables 

'MV.Variable
name'

Sample data variables include the
variables Sample size, Unit, Sam-
ple position, ID1 and ID2.

Command
variables 

'Command
name.Variable
name'

Command variables are variables
which are generated by the individ-
ual commands in the method run.
The command variables are dis-
played in the order determined by
the commands executed in the
method run.

Result varia-
bles 

'RS.Result
name.Variable
identification'

Result variables are special com-
mand variables which are gener-
ated by CALC commands and
which are available under a desig-
nation of their own.

Determina-
tion varia-
bles 

'DV.Variable
identification'

Determination variables are general
variables and cannot be assigned to
individual commands.
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Name Syntax Description

System vari-
ables 

'SV.Variable
identification'

System variables are general varia-
bles which are adopted in the
determination at the start of the
determination.

Common
variables 

'CV.Name' Common variables are global varia-
bles. Depending on the device, the
names are set or can be defined by
the user.

Enter variables

Variables must always be entered and ended with an apostrophe ' (e.g.
'MV.myVariable').

NOTE

When using variables, always observe their data type (Number, Text
or Date/Time).

2.4.3.2 Method variables
Tab: Database ▶ Determinations ▶ Reprocessing ▶ Variables

Method variables include the variables FCT (factor) and DIV (divisor).

Syntax

'MV.Variable name'

Examples: 'MV.FCT' and 'MV.DIV'

Occurence

These two variables occur in the formula saved in the 870 KF Titrino plus.
By modifying these variables the result can be indicated as different con-
centration units (mg/mL, ppm etc.).

Method variables

Variable
name

Description Data type

FCT Conversion factor for the calculation for-
mula

Number

DIV Divisor for the calculation formula Number
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Conversion table of the formula for KF titration

Result unit Sample size
in...

Factor Divisor

% g 0.1 1

% mg 100 1

% mL 0.1 Density of the
sample in g/
mL

ppm g 1000 1

ppm mL 1000 Density of the
sample in g/
mL

ppm µ L 1 Density of the
sample in g/
mL

mg/mL g Density of the
sample in g/
mL

1

mg/mL mL 1 1

mg 1 1 1

mL 1 1 Density of H

2O in g/mL

mg/piece Pieces 1 1

2.4.3.3 Sample data variables
Dialog window: Formula editor ▶ Sample data variables

Sample data variables include the variables Sample size, Unit, Sample
position, ID1 and ID2.

In the field Variables of the formula editor all sample data variables
are listed.

Syntax

'MV.Variable name'

Examples: 'MV.Sample Size' , 'MV.Sample Unit' , 'MV.ID1'

You can select the sample data variables directly in the formula editor
under Variables ▶ Sample data variables in order to avoid syntax
errors.
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Sample data variables

Variable
name

(PC-Con-
trol)

Variable name

( tiBase 1.1
Patch 1)

Description Data
type

CI1 ID1 Sample identification
1

Number

CI2 ID2 Sample identification
2

Number

C00 Sample Size Sample size Number

 Sample Unit Sample unit Text

NOTE

If the PC/LIMS report contains a negative value for the sample size
(from reweighing), it will be converted during the import into tiBase 1.1
Patch 1. The variable COO becomes Abs MV.Sample.Size in tiBase
1.1 Patch 1

2.4.3.4 Command variables
Dialog window: Formula Editor ▶ Variables

The command variables are method-specific. They depend on which com-
mands are used in the method. Included among the command variables
are also solution and sensor variables, which are applied automatically
from the corresponding tables in the Configuration for the device-
dependent commands at the time the determination is started and which
are allocated to the individual commands. The Variables field of the For-
mula editor lists all Command variables which are available for the cur-
rent method.

Syntax

'Command name.Variable identification'

Examples: 'DET U 3.SME' , 'Liquid Handling 4.CONC'

You can select the command variables directly in the formula editor under
Variables ▶ Command Variables in order to avoid syntax errors.

If a method run before the calculation contains more than one data gen-
erating command (titrations, measurements, calibrations, monitored dos-
ing, evaluations, calculations), then there is a command identification
before the variable.
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M. for titration mode, measuring mode and monitored dosing

<E. for EVAL

C. for CALC

Command variables

Unless marked otherwise, all of the variables listed here in alphabetical
order are of the Number type.

NOTE

In the case of variables with Index {x}, the desired number 1…9 must
be entered for x (e.g. .EP{3}.ERC for the third endpoint).

If no index is specified, then the last index will be used automatically
(e.g. .EP.ERC for the last endpoint).

Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Command

.BM# .BP{x}.MEA Measured value for the break
point x (1…9) in the unit of the
measured value

DET, MET, MEAS (without
T/Flow)

.BT# .BP{x}.TEM Temperature for the break point
x (1…9) in °C

DET, MET, MEAS (without
T/Flow)

.BD# .BP{x}.TIM Time for the break point x (1…9)
in s

DET, MET, MEAS (without
T/Flow)

.BP# .BP{x}.VOL Volume for the break point x
(1…9) in mL

DE, MET

.CONC .CONC Concentration of the solution
used for the command (number)

DET, MET, SET, KFT, STAT,
STDADD, ADD, DOS, LQH

.MCD .DBL Duration command (total dura-
tion for the processing of the
command) in s

DET, MET, SET, KFT, KFC,
STAT, MEAS, CAL MEAS,
STDADD, DOS

.MDC .DRI Current and/or last drift for drift
correction in mL/min

SET, KFT, KFC

.MSD .DSC Duration start conditions (time
for processing all start condi-
tions) in s

DET, MET, SET, KFT, STAT

.DDC .DTI Time for drift correction (time
from the start of the titration to
the end of the command) in s

SET, KFT, KFC
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Command

.MCM .EME End measured value (measured
value after processing of the
command) in the unit of the
measured value

DET, MET, SET, KFT, KFC,
STAT, MEAS, CAL MEAS,
STDADD, DOS

.MEN .ENP Electrode zero point for the sen-
sor used for the command
(dimensionless for pH sensor or
in mV for the ISE sensor, num-
ber) and/or electrode zero point
calculated from the calibration
(for STDADD and CAL LOOP)

DET pH, DET U, MET pH,
MET U, SET pH, SET U,
STAT, MEAS pH, MEAS U,
MEAS T, MEAS Conc, CAL
LOOP, DOS, STDADD

 .EP{x}.DME Measured value differential for
the endpoint x (1…9)

MET

.EF# .EP{x}.ERC ERC for the endpoint x (1…9) DET

.EM# .EP{x}.MEA Measured value for the endpoint
x (1…9) in the unit of the mea-
sured value

DET, MET, SET, KFT, KFC

.ESI# .EP{x}.MEP Marking for the endpoint x
(1...9); 1 = 1 endpoint, 2 = 2 or
more endpoints

DET, MET, SET, KFT

.EP# .EP.QTY Measured value (water) for the
endpoint in mg

KFC

.ET# .EP{x}.TEM Temperature for the endpoint x
(1...9) in °C

DET, MET, SET, KFT

.ED# .EP{x}.TIM Time for the endpoint x (1...9) in
s

DET, MET, SET, KFT, KFC

.EP# .EP{x}.VOL Volume for the endpoint x (1…
9) in mL

DET, MET, SET, KFT

.MCT .ETE End temperature (temperature
following processing of the com-
mand) in °C

DET, MET, SET, KFT, KFC,
STAT, MEAS (without T/
Flow), CAL MEAS,
STDADD, DOS

.MCV .EVT End volume (total dosed volume
at the end of the command) in
mL

DET, MET, SET, KFT, STAT,
DOS

.FM# .FP{x}.MEA Measured value for the fixed
endpoint x (1…9) in the unit of
the measured value

DET, MET, SET, KFT, STAT

 .FP{x}.QTY Measured value (water) for the
fixed endpoint x (1...9) in mg

KFC
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Command

.FT# .FP{x}.TEM Temperature for the fixed end-
point x (1…9) in °C

DET, MET, SET, KFT, STAT,
MEAS (without T/Flow)

.FD# .FP{x}.TIM Time for fixed endpoint x (1…9)
in s

DET, MET, SET, KFT, KFC,
STAT, MEAS (without T/
Flow)

.FP# .FP{x}.[VOL] Volume for the fixed endpoint x
(1...9) in mL

DET, MET, SET, KFT, STAT

.HM# .HP{x}.MEA Measured value for HNP x (1...9)
in mV 1)

DET, MET

.HT# .HP{x}.TEM Temperature for HNP x (1...9) in
°C

DET, MET

.HD# .HP{x}.TIM Time for HNP x (1...9) in s DET, MET

.HP# .HP{x}.[VOL] Volume for HNP (half neutraliza-
tion potential) x (1...9) in mL

DET, MET

#M.MIM .IME Initial measured value (measured
value before start conditions are
processed) in the unit of the
measured value (number)

DET, MET, SET, KFT, STAT,
MEAS, CAL MEAS,
STDADD, DOS

.MIT .ITE Initial temperature (temperature
before start conditions are pro-
cessed) in °C

DET, MET, SET, KFT, STAT,
MEAS (without T/Flow),
CAL MEAS, STDADD, DOS

.XAM .MA.MEA Maximum measured value in the
unit of the measured value

DET, MET, SET, KFT, STAT,
MEAS

.XAT .MA.TEM Temperature for the maximum
measured value in °C

DET, MET, SET, KFT, STAT,
MEAS

.XAD .MA.TIM Time for the maximum measured
value in s

DET, MET, SET, KFT, STAT,
MEAS

.XAP .MA.[VOL] Volume with maximum mea-
sured value in mL

DET, MET, SET, KFT, STAT

 .MI.GFL Minimum gas flow rate in
mL/min

MEAS T/Flow

.XIM .MI.MEA Minimum measured value in the
unit of the measured value

DET, MET, SET, KFT, STAT,
MEAS

.XIT .MI.TEM Temperature for minimum mea-
sured value in °C

DET, MET, SET, KFT, STAT,
MEAS

.XID .MI.TIM Time for the minimum measured
value in s

DET, MET, SET, KFT, STAT,
MEAS
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Command

.XIP .MI.[VOL] Volume for minimum measured
value in mL

DET, MET, SET, KFT, STAT

.RMC .MR.MRC Correlation coefficient for mean
dosing rate for the whole range

STAT, DOS

.RMS .MR.MRS Standard deviation for mean
dosing rate for the whole range
in mL/min

STAT, DOS

.RM .MR.MRT Mean dosing rate for the whole
range in mL/min

STAT, DOS

.MTM .MTE Temperature measurement with
sensor; 1 = on, 0 = off)

DET, MET, SET, KFT, STAT,
MEAS (without T/Flow),
CAL MEAS, STDADD, DOS

.MMP .NMP Number of measuring points
(number of measuring points in
the measuring point list)

DET, MET, SET, KFT, KFC,
STAT, MEAS, CAL MEAS,
DOS

.RDC# .RE{x}.DRC Correlation coefficient for mean
dosing rate in window x (1…9)

STAT

.RDS# .RE{x}.DRS Standard deviation for mean
dosing rate in window x (1…9)
in mL/min

STAT

.RD# .RE{x}.[DRT] Mean dosing rate in window x
(1…9) in mL/min

STAT

.MCM .RES Result calculated from the stan-
dard addition curve (concentra-
tion of the selected unit)

STDADD

.MSL .SLO Electrode slope of the sensor
used for the command (in % for
pH sensor or mV for ISE sensor,
number) or electrode slope cal-
culated from the calibration (for
CAL LOOP)

DET pH, DET U, MET pH,
MET U, SET pH, SET U,
STAT, MEAS pH, MEAS U,
MEAS T, MEAS Conc, CAL
LOOP, DOS, STDADD

.MSM .SME Start measured value (measured
value after processing the start
conditions) in the unit of the
measured value

DET, MET, SET, KFT, KFC,
STAT

.MST .STE Start temperature (temperature
after processing of the start con-
ditions) in °C

DET, MET, SET, KFT, KFC,
STAT
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Command

.MTS .STY Type of stop with which the
command was stopped: 1 = nor-
mal; 0 = manual or after error

DET, MET, SET, KFT, STAT,
MEAS, CAL MEAS,
STDADD, DOS

.MSA .SVA Start volume absolute (volume
that was added according to the
start condition "start volume") in
mL

DET, MET, SET, KFT, STAT

.MSP .SVM Start volume measured value
(volume which was added
according to the start measured
value given in the start condi-
tions) in mL

DET, MET

.MSS .SVS Start volume measured value
(volume that was added accord-
ing to the start condition "start
slope") in mL

DET, MET

.MSV .SVT Total start volume (volume that
was added in dependence on all
three start conditions) in mL

DET, MET, SET, KFT, STAT

.TITER .TITER Titer value of the solution used
for the command (number)

DET, MET, SET, KFT, STAT,
STDADD dos, STDADD
auto, ADD, DOS, LQH

.MVA .VAR Variance of the result calculated
from the standard addition curve

STDADD

.MCV .VOL Dosed volume STDADD, ADD, LQH

1) HNP = Half neutralization potential

2.4.3.5 Result variables
Dialog window: Formula Editor ▶ Variables

Result variables are method-specific and are defined in the CALC com-
mand of the method. The Variables field of the Formula editor lists all
Result variables which are available for the current method.

Syntax

'RS.Result name.Variable identification'

Examples: 'RS.RS01.VAL' (='RS.RS01'), 'RS.testTime.UNI'

You can select the method variables directly in the formula editor under
Variables ▶ Result Variables in order to avoid syntax errors.
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Result variables

Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Command

.R1 to .R9 [.VAL] Result value ( .VAL optional;
number)

CALC

SSA# .ASD Absolute standard deviation for
the result (number)

CALC

SMN# .MNV Mean value of the result (num-
ber)

CALC

SNR .NSR Statistics actual counter for the
result (number)

CALC

SSD .NST Statistics setpoint counter for the
result (number)

CALC

SSR# .RSD Relative standard deviation for
the result (number)

CALC

SNT .STS Statistics status for the result
(number 1 = Statistics on, 0 =
Statistics off)

CALC

#C.R# unit .UNI Result unit (Text) CALC

2.4.3.6 Determination variables
Dialog window: Formula Editor ▶ Variables

Determination variables are general variables that are generated in the
method run. They are not assigned to individual commands. The Varia-
bles field of the Formula editor lists the determination variables which
are available for the current method, sorted according to name.

Syntax

'DV.Variable name'

Examples: 'DV.DUR', 'DV.STT'

You can select the determination variables directly in the formula editor
under Variables/Determination variables in order to avoid syntax
errors.
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Available determination variables

Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Data
type

DD DUR Duration of the determination in
s

Number

 STT Time point at which the determi-
nation was started

Date/
Time

2.4.3.7 System variables
Dialog window: Formula Editor ▶ Variables

System variables are general variables which are adopted in the determi-
nation at the start of the determination. They are assigned neither to indi-
vidual commands nor to determinations. The Variables field of the For-
mula editor lists all System variables which are available for the current
method.

Syntax

'SV.Variable name'

Examples: 'SV.SIN', 'SV.SLI'

You can select the system variables directly in the formula editor under
Variables/System variables in order to avoid syntax errors.

Available system variables

Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Data type

%AC .ACC Autostart actual counter. Number

%AD .ACE Autostart setpoint counter. Number

%RN .RUN Sample number. Number

%SE .SEN Indication whether the end of
the sample table has been
reached (1 = yes, 0 = no).

Number

%AS .SIN Indication whether the determi-
nation has been started as a sin-
gle determination or within a
series (1 = single determina-
tion, 0 = series determina-
tion).

Number

%SL SLI Sample table actual line. Number
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Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Data type

SNT .STA Indication whether the statistics
is activated (1 = yes, 0 = no.

Number

%SC .STC Start counter Number

%SS  Sample table status

1 = Sample table on

0 = Sample table off

Number

2.4.3.8 Common variables
Dialog window: Formula Editor ▶ Variables

Common variables are global variables, which are adopted from the corre-
sponding table of the program part Configuration, where the common
variables can be defined, at the start of the determination and assigned to
the determination. The Variables field of the Formula editor lists all Com-
mon Variables which are available for the current method, sorted
according to name.

Syntax

'CV.Variable name.Variable name'

Examples: 'CV.TestDate', 'CV.TestTime.VAL', 'CV.Average-
Temp.UNI'

You can select the common variables directly in the formula editor under
Variables/Common Variables in order to avoid syntax errors.

Available Common Variables

Variable
name

(PC-Control)

Variable
name

( tiBase 1.1
Patch 1)

Description Data type

CV01...CV25 [.VAL] Value of common variables
(number).

Text, number or date/time

Usage

870 KF Titrino Plus

With this instrument the two common variables, CV01 and CV02, are
defined for blind values.

877 Titrino Plus, 848 Titrino Plus, 862 Titrosampler
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With these instruments there can be defined up to five method-independ-
ent common variables, CV01 to CV05. Common variables are e.g useful
for the following applications:

￭ Determination of a blank value which will be taken into account during
the content determination of the sample.

￭ Determination of the content of a standard solution, which will be
taken into account during the content determination of the sample.

2.4.3.9 Alphabetical command overview

￭ BRC
Coulometric bromine number determination

￭ CAL Cond
Determination of cell constants of conductivity sensors with the aid of
a known standard solution.

￭ CAL MEAS Conc
Measuring of calibration buffers for the calibration of ion-selective
electrodes.

￭ CAL MEAS pH
Measuring of calibration buffers for the calibration of pH sensors.

￭ DET pH
Potentiometric pH measurement with pH electrodes (measured quan-
tity pH).

￭ DET U
Potentiometric voltage measurement with metal electrodes (measured
quantity voltage U).

￭ DET Ipol
Voltametric measurement with selectable polarization current (mea-
sured quantity voltage U).

￭ DET Upol
Amperometric measurement with selectable polarization voltage (mea-
sured value current I).

￭ DOS pH
Dosing of a specified volume with a solution (measured quantity pH)

￭ DOS U
Dosing of a specified volume with a solution (measured quantity volt-
age U).

￭ KFC
Coulometric Karl Fischer titration with voltametric measurement.

￭ KFT Ipol
Volumetric Karl Fischer titration with voltametric measurement (selecta-
ble polarization current).

￭ KFT Upol
Volumetric Karl Fischer titration with amperometric measurement
(selectable polarization current).

￭ MEAS Conc
Concentration measurement (direct measurement).
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￭ MEAS Cond
Conductivity measurement.

￭ MEAS Ipol
Voltametric measurement with selectable polarization current

￭ MEAS pH
Potentiometric pH measurement with pH electrodes.

￭ MEAS T
Temperature measurement.

￭ MEAS U
Potentiometric voltage measurement.

￭ MEAS Upol
Amperometric measuremen with selectable polarization current.

￭ MET Ipol
Monotonic equivalence point titration with voltametric measurement
(selectable polarization current).

￭ MET pH
Monotonic equivalence point titration with potentiometric pH mea-
surement.

￭ MET U
Monotonic equivalence point titration with potentiometric voltage
measurement.

￭ MET Upol
Monotonic equivalence point titration with amperometric measure-
ment (selectable polarization voltage).

￭ SET pH
Endpoint titration with potentiometric pH measurement.

￭ SET U
Endpoint titration with potentiometric voltage measurement.

￭ SET Ipol
Endpoint titration with voltametric measurement (selectable polariza-
tion current).

￭ SET Upol
Endpoint titration with amperometric measurement (selectable polari-
zation voltage).

￭ STAT pH
STAT titration by keeping the measured value pH constant.

￭ STAT U
STAT titration by keeping the measured value U constant.
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2.4.4 Operators/functions

2.4.4.1 Operators/functions - Overview
Dialog window: Formula editor ▶ Operators/functions

Overview of the operators and functions

Operators Functions

Arithmetic:

￭ Addition (+)
￭ Subtraction (-)
￭ Multiplication (*)
￭ Division (/)
￭ Potentiation (^)

Arithmetic:

￭ Exponential function (Exp)
￭ Natural logarithm (Ln)
￭ Common logarithm (Log)
￭ Square root (Sqrt)
￭ Absolute value (Abs)
￭ Fraction (Frac)
￭ Integer (Int)
￭ Round integer (Round)
￭ Sign (Sign)
￭ Quantiles of the Student's t-distribution (Tinv)

Logic:

￭ AND
￭ OR

Date/Time:

￭ Time()
￭ Time(Date)
￭ Time(Date+Time)

Comparison:

￭ Equal to (=)
￭ Greater than (>)
￭ Greater than or equal to (>=)
￭ Less than (<)
￭ Less than or equal to (<=)
￭ Not equal to (<>)

Type conversion:

￭ NumberToText
￭ NumberToTime
￭ TextToNumber
￭ TextToTime
￭ TimeToNumber
￭ TimeToText

Text:

￭ TextPosition
￭ SubText
￭ Trim

 Miscellaneous:

￭ Error
￭ Case

Priority rules of the operators

The operators are evaluated in the order in which they are listed in the
table below. In order to attain the required order, it may be necessary to
place operands in parentheses.
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 Operators

Arithmetic ^

*, /

+, -

Comparison <, <=, >, >=

Logic AND, OR

2.4.4.2 Arithmetical operators

2.4.4.2.1 Addition
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 + Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.

Examples

Operand1 Operand2 Result Example Remark

both operands of the same type:

Number Number Number 1.2 + 3 = 4.2 -

Text Text Text "Metrohm" + "AG" =
"Metrohm AG"

If the maximum permissible length
(65 536 characters) of the charac-
ter string is exceeded by addition
of the operands, the surplus char-
acters will be removed from the
second operand.

Time Time Number Time(1998;04;06) +
Time(1964;02;03) = 59300.875 (for
UTC+1)

Result: Number of days calculated
from December 1899, dependent
on the system time

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 1.2 + "Metrohm" = "1.2Metrohm" -

Text Number Text "Metrohm" + 1.2 = "Metrohm1.2" -

Number Time Number 2.0 + Time(1999;11;7) = 36472.96
(for UTC+1)

Result: Number of days calculated
from December 1899, dependent
on the system time

Time Number Number Time(1999;10;7) + 2.0 = 36441.92
(for UTC+2)

Result: Number of days calculated
from December 1899, dependent
on the system time
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Operand1 Operand2 Result Example Remark

Text Time Text "Metrohm" + Time(1999;10;7) =
"Metrohm1999-10-07 00:00:00
UTC+2"

Before the operation, the operand
of the type Date/Time is con-
verted to Text.

Time Text Text Time(1999;01;7) + "Metrohm" =
"1999-01-07 00:00:00 UTC
+1Metrohm"

The same rules apply here as for
the previous operation.

2.4.4.2.2 Subtraction
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 - Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.

Examples

Operand1 Operand2 Result Example Remark

both operands of the same type:

Number Number Number 1.2 - 3 = -1.8 -

Text Text Text "Metrohm" - "AG" = invalid This operation is not allowed.

Time Time Number Time(1998;01;06) -
Time(1964;12;03) = 12'087.00 (for
UTC+1)

Result: Number of days calculated
from December 1899, dependent
on the system time

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 1.2 - "Metrohm" = invalid This operation is not allowed.

Text Number Text "Metrohm" - 1.2 = not valid This operation is not allowed.

Number Time Number 2.0 - Time(1999;10;7) =
-36'437.917 (for UTC+2)

Result: Number of days calculated
from December 1899, dependent
on the system time

Time Number Number Time(1999;10;7) - 2.5 =
36'437.917 (for UTC+2)

Result: Number of days calculated
from December 1899, dependent
on the system time

Text Time Text "Metrohm" - Time(1999;10;7) =
invalid

This operation is not allowed.

Time Text Text Time(1999;10;7) - "Metrohm" =
invalid

This operation is not allowed.
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2.4.4.2.3 Multiplication 
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 * Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.

Examples

Operand1 Operand2 Result Example Remark

Operands of the same type:

Number Number Number 1.2 * 3 = 3.6 -

Text Text Text "Metrohm" * "AG" = invalid This operation is not allowed.

Time Time Number Time(1998;05;06) *
Time(1902;02;03) = 27'478'004.545
(for UTC+1 or +2 for summer time)

Result: Number of days calcu-
lated from December 1899,
dependent on the system time

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 2 * "Metrohm" = "MetrohmMe-
trohm"

-

Text Number Text "Metrohm" * 2 = "MetrohmMe-
trohm"

-

Number Time Number 2.0 * Time(1999;10;7) = 72'879.833
(for UTC+2)

Result: Number of days calcu-
lated from December 1899,
dependent on the system time

Time Number Number Time(1999;10;7) * 2.0 = 72'879.833
(for UTC+2)

Result: Number of days calcu-
lated from December 1899,
dependent on the system time

Text Time Text "Metrohm" * Time(1999;10;7) =
invalid

This operation is not allowed.

Time Text Text Time(1999;10;7) * "Metrohm" =
invalid

This operation is not allowed.

2.4.4.2.4 Division
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 / Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.
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Examples

Operand1 Operand2 Result Example Remark

Operands of the same type:

Number Number Number 1.2 / 3 = 0.4 Operand2 must not be zero!

Text Text Text "Metrohm" / "AG" = invalid This operation is not allowed.

Time Time Number Time(1998;04;06) /
Time(1964;02;03) = 1.533 (for UTC
+1 or +2 for summer time)

Result: Number of days calculated
from December 1899, dependent
on the system time

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 1.2 / "Metrohm" = invalid This operation is not allowed.

Text Number Text "Metrohm" / 1.2 = invalid This operation is not allowed.

Number Time Number 10'000 / Time(1999;10;7) = 274 (for
UTC+2)

Result: Number of days calculated
from December 1899, dependent
on the system time

Time Number Number Time(1999;02;17) / 10'000 = 3.621
(for UTC+1)

Result: Number of days calculated
from December 1899, dependent
on the system time

Text Time Text "Metrohm" / Time(1999;10;7) =
invalid

This operation is not allowed.

Time Text Text Time(1999;10;7) / "Metrohm" =
invalid

This operation is not allowed.

2.4.4.2.5 Potentiation
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 ^ Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time.

Examples

Operand1 Operand2 Result Example Remark

Operands of the same type:

Number Number Number 1.2 ^ 3 = 1.728 Complex results (which com-
prise +bi, i.e. a real and an
imaginary component) are dis-
played as an error.

Text Text Text "Metrohm" ^ "AG" = invalid This operation is not allowed.
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Operand1 Operand2 Result Example Remark

Time Time Number Time(1900;01;05) ^
Time(1900;01;02) = 196.371 (for UTC
+1)

Result: Number of days calcu-
lated from December 1899,
dependent on the system time

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Text 1.2 ^ "Metrohm" = invalid This operation is not allowed.

Text Number Text "Metrohm" ^ 1.2 = invalid This operation is not allowed.

Number Time Number 1.2 ^ Time(1900;02;03) = 586.198
(for UTC+1)

-

Time Number Number Time(1999;10;7) ^ 2.5 =
253479847878.04 (for UTC+2)

-

Text Time Text "Metrohm" ^ Time(1999;10;7) =
invalid

This operation is not allowed.

Time Text Text Time(1999;10;7) ^ "Metrohm" =
invalid

This operation is not allowed.

2.4.4.3 Logical operators

2.4.4.3.1 AND
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 AND Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a num-
ber (1 = true, 0 = false). The following cases are possible:

Operand1 Operand2 Result

1 1 1

0 1 0

1 0 0

0 0 0

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 AND 4 --> 1

4 AND 0 --> 0

Numbers greater than 0 are interpreted as
1 (true).
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Oper-
and1

Oper-
and2

Result Example Remark

Text Text Number "Metrohm" AND "AG" --> 1

"" AND "AG" --> 0

An empty character string ("") is interpre-
ted as 0 (false), everything else as 1 (true).
The first operation therefore corresponds
to 1 AND 1 --> 1.

Time Time Number Time(1999;10;07) AND
Time(1999;10;07) --> 1

Time(): see Time(Date)

Operands of a different type:

Number Text Number 1.2 AND "1.2" --> 1

0 AND "1" --> 1

0 AND "0" --> 1

0 AND "" --> 0

Before the operation, the operand of the
type Number is converted to the type
Text, as a conversion from Text to Num-
ber is not advisable. During the second
operation, the 0 is therefore converted to
"0", which corresponds to the logical
value 1 (true), as every character string
that is not empty is interpreted as 1.

Text Number Number "Metrohm" AND 1.2 --> 1 The same rules apply here as for the previ-
ous operation.

Number Time Number 2.0 AND Time(1999;10;7) -->
1

0 AND Time(1999;10;07) --> 0

Before the operation, the operand of the
type Date/Time is converted to Number
and all data from December 30, 1899 are
interpreted as 1 (true).

Time Number Number Time(1999;10;7) AND 2.5 -->
1

The same rules apply here as for the previ-
ous operation.

Text Time Number "Metrohm" AND
Time(1999;10;7) --> 1

"" AND Time(1999;10;07) -->
0

Before execution of the operation, the
operand of the type Date/Time is con-
verted to the type Text and every charac-
ter string that is not empty is interpreted
as 1 (true).

Time Text Number Time(1999;10;7) AND
"Metrohm" --> 1

The same rules apply here as for the previ-
ous operation.

2.4.4.3.2 OR
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 OR Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a num-
ber (1 = true, 0 = false). The following cases are possible:

Operand1 Operand2 Result

1 1 1

0 1 1
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Operand1 Operand2 Result

1 0 1

0 0 0

Examples

Operand1 Operand2 Result Example Remark

Operands of the same type:

Number Number Number 5 OR 4 --> 1

4 OR 0 --> 1

Numbers greater than 1 are automati-
cally interpreted as 1 (true)

Text Text Number "Metrohm" OR "AG" --> 1

"" OR "Metrohm" --> 1

"" OR "" --> 0

An empty character string ("") is inter-
preted as 0 (false), everything else as 1
(true). The first operation therefore cor-
responds to 1 OR 1 --> 1

Time Time Number Time(1999;10;07) OR
Time(1964;02;03) --> 1

Time(): see Time(Date)

Operand of different type: The operand which does not correspond to the result type is converted to the relevant
result type before the operation.

Number Text Number 1.2 OR "1.2" --> 1

0 OR "" --> 1

Before the operation, the operand of
the type Number is converted to the
type Text, as a conversion from Text to
Number is not advisable. During the
second operation, the 0 is therefore
converted to "0", which corresponds to
the logical value 1 (true), as every char-
acter string that is not empty is interpre-
ted as 1.

Text Number Number "Metrohm" OR 1.2 --> 1 The same rules apply here as for the pre-
vious operation.

Number Time Number 2.0 OR Time(1999;10;7) --> 1

0 OR Time(1964;02;03) --> 1

Before the operation, the operand of
the type Date/Time is converted to
Number and all data from December
30, 1899 are interpreted as 1 (true).

Time Number Number Time(1999;10;7) OR 2.5 --> 1 The same rules apply here as for the pre-
vious operation.

Text Time Number "Metrohm" OR
Time(1999;10;7) --> 1

Before execution of the operation, the
operand of the type Date/Time is con-
verted to the type Text and every char-
acter string that is not empty is interpre-
ted as 1 (true).

Time Text Number Time(1999;10;7) OR
"Metrohm" --> 1

The same rules apply here as for the pre-
vious operation.
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2.4.4.4 Relational operators

2.4.4.4.1 Equal to
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 = Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a num-
ber (1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 = 5 --> 1

4 = 5 --> 0

-

Text Text Number "Metrohm" = "AG" --> 0

"aG" = "AG" --> 0

When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 70). Attention: Uppercase
and lowercase letters have different values!

Time Time Number Time(1998;04;06) =
Time(1964;02;03) --> 0

(see Chapter 2.4.4.6.2, page 58)

Operands of a different type:

Number Text Number 1.2 = "1.2" --> 11.2 =
"Metrohm" --> 0

Before the relational operation, the Number
is converted to Text, afterwards the texts
are compared according to ASCII value (see
Chapter 2.4.4.10, page 70).

Text Number Number "Metrohm" = 1.2 --> 0 The same rules apply here as for the previous
operation.

Number Time Number 2.0 = Time(1999;10;07) -->
0

Before the operation, the operand of the
type Date/Timeis converted to Number.
During execution of the operation, the exact
value is always used after this conversion,
even if maximum 5 places after the comma
can be displayed (see Chapter 2.4.4.7.5,
page 63).

Time Number Number Time(1999;10;7) = 2.0 --> 0 The same rules apply here as for the previous
operation.
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Oper-
and1

Oper-
and2

Result Example Remark

Text Time Number "Metrohm" =
Time(1999;10;07) --> 0

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999-10-07 00:00:00 UTC
+2"), afterwards the texts are compared
according to ASCII value (see Chapter
2.4.4.10, page 70).

Time Text Number Time(1999;10;07) =
"Metrohm" --> 0

The same rules apply here as for the previous
operation.

2.4.4.4.2 Greater than
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 > Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a num-
ber (1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 > 4 --> 1

4 > 5 --> 0

-

Text Text Number "Metrohm" > "AG" --> 1

"Aarau" > "Zug" --> 0

When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 70). Attention: Upper-
case and lowercase letters have different
values!

Time Time Number Time(1998;04;06) >
Time(1964;02;03) --> 1

(see Chapter 2.4.4.6.2, page 58)

Operands of a different type:

Number Text Number 1.2 > "Metrohm" --> 01.23 >
"1.2" --> 1

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 70).

Text Number Number "Metrohm" > 1.2 --> 1 The same rules apply here as for the previ-
ous operation.

Number Time Number 2.0 > Time(1999;10;07) --> 0 Before the comparison, the operand is
converted from the type Date/Time to a
Number.
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Oper-
and1

Oper-
and2

Result Example Remark

Time Number Number Time(1999;10;07) > 2.0 --> 1 The same rules apply here as for the previ-
ous operation.

Text Time Number "Metrohm" >
Time(1999;10;07) --> 1

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999-10-07 00:00:00 UTC
+2"), afterwards the texts are compared
according to ASCII value (see Chapter
2.4.4.10, page 70).

Time Text Number Time(1999;10;7) >
"Metrohm" --> 0

The same rules apply here as for the previ-
ous operation.

2.4.4.4.3 Greater than or equal to
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 >= Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a num-
ber (1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 >= 4 --> 1

4 >= 5 --> 0

-

Text Text Number "Metrohm" >= "AG" --> 1 When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 70). Attention: Upper-
case and lowercase letters have different
values!

Time Time Number Time(1998;04;06) >=
Time(1964;02;03) --> 1

(see Chapter 2.4.4.6.2, page 58)

Operands of a different type:

Number Text Number 1.2 >= "1.2" --> 11.2 >=
"Metrohm" --> 0

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 70).

Text Number Number "Metrohm" >= 1.2 --> 1 The same rules apply here as for the previ-
ous operation.
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Oper-
and1

Oper-
and2

Result Example Remark

Number Time Number 2.0 >= Time(1999;10;07) -->
0

Before the comparison, the operand is con-
verted from the type Date/Time to a
Number.

Time Number Number Time(1999;10;07) >= 2.0 -->
1

The same rules apply here as for the previ-
ous operation.

Text Time Number "Metrohm" >=
Time(1999;10;07) --> 1

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999-10-07 00:00:00 UTC
+2"), afterwards the texts are compared
according to ASCII value (see Chapter
2.4.4.10, page 70).

Time Text Number Time(1999;10;7) >=
"Metrohm" --> 0

The same rules apply here as for the previ-
ous operation.

2.4.4.4.4 Less than 
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 < Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a num-
ber (1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 < 4 --> 0

4 < 5 --> 1

-

Text Text Number "Metrohm" < "AG" --> 0 When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 70). Attention: Upper-
case and lowercase letters have different
values!

Time Time Number Time(1998;04;06) <
Time(1964;02;03) --> 0

(see Chapter 2.4.4.6.2, page 58)

Operands of a different type:

Number Text Number 1.2 < "Metrohm" --> 11.2 <
"1" --> 0

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 70).



2.4 Formula editor ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

50 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

Oper-
and1

Oper-
and2

Result Example Remark

Text Number Number "Metrohm" < 1.2 --> 0 The same rules apply here as for the previ-
ous operation.

Number Time Number 2.0 < Time(1999;10;07) -->
1

Before the comparison, the operand is con-
verted from the type Date/Time to a
Number.

Time Number Number Time(1999;10;07) < 2.0 -->
0

The same rules apply here as for the previ-
ous operation.

Text Time Number "Metrohm" <
Time(1999;10;07) --> 0

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999-10-07 00:00:00 UTC
+2"), afterwards the texts are compared
according to ASCII value (see Chapter
2.4.4.10, page 70).

Time Text Number Time(1999;10;7) <
"Metrohm" --> 1

The same rules apply here as for the previ-
ous operation.

2.4.4.4.5 Less than or equal to 
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 <= Operand2

The operands can be entered either directly or as variables and can be of
the type Text, Number or Date/Time. The result type is always a num-
ber (1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 <= 4 --> 0

4 <= 5 --> 1

-

Text Text Number "Metrohm" <= "AG" --> 0 When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 70). Attention: Upper-
case and lowercase letters have different
values!

Time Time Number Time(1998;04;06) <=
Time(1964;02;03) --> 0

(see Chapter 2.4.4.6.2, page 58)

Operands of a different type:



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 2 General program functions

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 51

Oper-
and1

Oper-
and2

Result Example Remark

Number Text Number 2 <= "1.2" --> 01.2 <=
"Metrohm" --> 1

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 70).

Text Number Number "Metrohm" <= 1.2 --> 0 The same rules apply here as for the previ-
ous operation.

Number Time Number 2.0 <= Time(1999;10;07) --
> 1

Before the comparison, the operand is con-
verted from the type Date/Time to a Num-
ber.

Time Number Number Time(1999;10;07) <= 2.0 --
> 0

The same rules apply here as for the previ-
ous operation.

Text Time Number "Metrohm" <=
Time(1999;10;07) --> 0

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999.10.07"), afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 70).

Time Text Number Time(1999;10;7) <=
"Metrohm" --> 1

The same rules apply here as for the previ-
ous operation.

2.4.4.4.6 Not equal to 
Dialog window: Formula editor ▶ Operators/Functions

Syntax

Operand1 <> Operand2

The operands can be entered either directly or as a variable and can be of
the type Text, Number or Date/Time. The result type is always a num-
ber (1 = true, 0 = false).

Examples

Oper-
and1

Oper-
and2

Result Example Remark

Operands of the same type:

Number Number Number 5 <> 4 --> 1

5 <> 5 --> 0

-

Text Text Number "Metrohm" <> "AG" --> 1 When making a comparison between two
texts the ASCII value of the character
sequence is compared (see Chapter
2.4.4.10, page 70). Attention: Upper-
case and lowercase letters have different
values!

Time Time Number Time(1998;04;06) <>
Time(1964;02;03) --> 1

(see Chapter 2.4.4.6.2, page 58)
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Oper-
and1

Oper-
and2

Result Example Remark

Operands of a different type:

Number Text Number 1.2 <> "1.2" --> 01.2 <>
"Metrohm" --> 1

Before the relational operation, the Num-
ber is converted to Text, afterwards the
texts are compared according to ASCII
value (see Chapter 2.4.4.10, page 70).

Text Number Number "Metrohm" <> 1.2 --> 1 The same rules apply here as for the previ-
ous operation.

Number Time Number 2.0 <> Time(1999;10;07) -->
1

Before the comparison, the operand is con-
verted from the type Date/Time to a
Number.

Time Number Number Time(1999;10;07) <> 2.5 -->
1

The same rules apply here as for the previ-
ous operation.

Text Time Number "Metrohm" <>
Time(1999;10;07) --> 1

Before the operation, the operand is con-
verted from the type Date/Time to Text
(here thus: "1999-10-07 00:00:00 UTC
+2"), afterwards the texts are compared
according to ASCII value (see Chapter
2.4.4.10, page 70).

Time Text Number Time(1999;10;7) <>
"Metrohm" --> 1

The same rules apply here as for the previ-
ous operation.

2.4.4.5 Arithmetical functions

2.4.4.5.1 Exponential function
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Exp(number)

Calculates e ^ number. Other notation for y = e(number), whereby e is the
Euler number (e = 2.71828…).

Parameters

Number 　 Exponent

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

Examples

Exp(1.5) = 4.48169

Exp('CV.AverageTemp') = Power of the exponent (common variable
CV.AverageTemp) for base e
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2.4.4.5.2 Natural logarithm 
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Ln(number)

Gives the logarithm of the entered number for base e. Alternative nota-
tion for y = loge(number), whereby e is the Euler number (e = 2.71828…).

Parameters

Number 　 > 0

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

Examples

Ln(3) = 1.09861

Ln('CV.AverageTemp') = Natural logarithm of the value of the common
variable CV.AverageTemp for base e

2.4.4.5.3 Common logarithm
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Log(number)

Gives the logarithm of the entered number for base 10. Alternative nota-
tion for y = log10(number).

Parameters

Number　 > 0

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

Examples

Log(10) = 1

Log('CV.AverageTemp') = Common logarithm of the value of the com-
mon variable CV.AverageTemp
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2.4.4.5.4 Square root 
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Sqrt(number)

Gives the square root of the entered number. Alternative notation for y =
√ number or y = 2√ number.

Parameters

Number　 ≥ 0

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

Examples

Sqrt(33) = 5.745

Sqrt('CV.AverageTemp') = Square root of the value of the common
variable CV.AverageTemp

2.4.4.5.5 Absolute value
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Abs(number)

Gives the absolute value of the entered number, i.e. the value of the num-
ber irrespective of its sign.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

Examples

Abs(-55.3) = 55.3

Abs('CV.AverageTemp') = Value of the common variables CV.Avera-
geTemp without signs
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2.4.4.5.6 Fraction
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Frac(number)

Gives the fraction of the entered number.

NOTE

In the results properties, the number Decimal places of the result
must always be given, as otherwise the fraction cannot be displayed.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

Examples

Frac(-55.325) =0.325

Frac('CV.AverageTemp') = Value of the common variable CV.Avera-
geTemp without sign

2.4.4.5.7 Integer
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Int(number)

Gives the integer of the entered number.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

Examples

Int(-55.325) = -55

Int('CV.AverageTemp') = Integer of the value of the common variable
CV.AverageTemp
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2.4.4.5.8 Rounding integer 
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Round(number)

Gives the rounded value of the entered number as a whole number.

NOTE

If the first decimal place is 5 or greater, the number is rounded up to
the next whole number (commercial rounding).

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

Examples

Round(-55.5259) = -56

Round('CV.AverageTemp') = Rounded value of the common variable
CV.AverageTemp

2.4.4.5.9 Sign
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Sign(number)

Gives the sign of the entered number: 1 for a positive number, -1 for a
negative number.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

Examples

Sign(-55.3) = -1

Sign(26.115) = 1
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Sign('CV.AverageTemp') = Sign of the value of the common variable
CV.AverageTemp

2.4.4.5.10 Quantiles of the Student's t-distribution
Dialog window: Formula editor ▶ Operators/Functions

Syntax

ts = Tinv(Probability; Degrees of freedom)

Calculates the quantiles of the Student's t-distribution for two-sided inter-
vals.

The result describes the half interval length as a multiple of the standard
deviation of a sampling totality with given degrees of freedom within
which, with the indicated probability, the mean value of the distribution
lies, when the interval is centered on the mean value of the sampling
totality.

Parameters

Probability

Type number, value range: 0 ... 1. Direct entry as number or as formula
providing a number. If the type of value is non-permitted, then the result
will become invalid. This is to indicate the probability with which the
unknown mean value of the t-distributed result is expected to lie within
the two-sided interval.

Degrees of freedom

Type number, value range: 1 ... n. Direct entry as number or as formula
providing a number. If the type of value is non-permitted, then the result
will become invalid. The number of independent samplings for calculat-
ing the standard deviation, reduced by the number of adjusted parame-
ters for the model to which the standard deviation refers, must be speci-
fied as degrees of freedom (Degrees of freedom = Number of samplings −
Number of parameters).

Examples

Tinv(0.95; 9) = 2.26 : With a 10-fold determination (e.g. of a titer) half
the interval length corresponds to 2.26 times the standard deviation.

Calculation of the confidence interval for a mean value of sam-
pling: A variance-homogenous sampling with a range n for a normally
distributed quantity with an expected value µ has the mean value xm, the
standard deviation s and the freedom degrees v = n − 1. Half the interval
length ts ⋅  s/√ n then indicates how high the absolute difference between
the mean value xm and the expected value µ maximally is within the given
probability. The confidence interval is the full interval length, centered
to the mean value: µ = xm ± ts ⋅ s/√ n.
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Titer determination: 0.991, 1.021, 0.995, 1.003, 1.007, 0.993, 0.998,
1.015, 1.003, 0.985

Mean value = 1.001

Standard deviation = 0.0111

Student's t-quantiles for a probability of 95% = 2.26

Confidence interval of the titer = 1.001 ± 0.008

2.4.4.6 Date/time functions

2.4.4.6.1 Time()
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Time()

Gives the current date and the current time.

Parameters

none

Return value

Current date and current time in the format yyyy-mm-dd hh:mm:ss
UTC ±xx

NOTE

UTC = Universal Time , from which the times in the various time zones
of the earth are derived. CET (Central European Time) is equal to UTC
plus 1 hour, in the summer time UTC plus 2 hours.

2.4.4.6.2 Time(Date) 
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Time(year; month; day)

Gives the entered figures in the format Date/Time.

Parameters

year 00…99 or 1000…9999

month 1…12

day 1…31

A parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
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expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

NOTE

Only the integral part is used for all parameters.

A variable of the type Date/Time cannot be transferred as a parameter
here.

Both for the automatic and explicit conversion of a Time to the type
Number, the number of days are counted since December 30, 1899
at 01 hours.

Attention: December 30, 1899 01 hour = 0.00000 days, this number
is rounded off to 5 decimal places, but a relational operation for exam-
ple is carried out with the exact value!

Return value

Date/Time in the format yyyy-mm-dd hh:mm:ss UTC ±xx

NOTE

UTC = Universal Time , from which the times in the various time zones
of the earth are derived. CET (Central European Time) is equal to UTC
plus 1 hour, in the summer time UTC plus 2 hours.

Examples

Time(2004;02;02) = 2004-02-02 00:00:00 UTC +1 (dependent on
the system time)

Time('CV.Test year';'CV.Test month';'CV.Test day') = Date com-
prised of the common variables

2.4.4.6.3 Time(Date + Time)
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Time(year; month; day; hour; minute; second)

Gives the entered numbers in the format Date/Time.

Parameters

year 00…99 or 1000…9999

month 1…12

day 1…31
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hour 0…23

minute 0…59

second 0…59

A parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. If this is not possi-
ble, the result of this operation is given as invalid.

NOTE

Only the integral part is used for all parameters.

A variable of the type Date/Time cannot be transferred as a parameter
here.

Both for the automatic and explicit conversion of a Time to the type
Number, the number of days are counted since December 30, 1899
at 01 hours.

Attention: December 30, 1899 01 hour = 0.00000 days, this number
is rounded off to 5 decimal places, but a relational operation for exam-
ple is carried out with the exact value!

Return value

Date/Time in the format yyyy-mm-dd hh:mm:ss UTC ±xx

NOTE

UTC = Universal Time , from which the times in the various time zones
of the earth are derived. CET (Central European Time) is equal to UTC
plus 1 hour, in the summer time UTC plus 2 hours.

Examples

Time(2004;06;02;10;30;25) = 2004-06-02 10:30:25 UTC +2
(dependent on the system time)

Time('CV.TestYear';'CV.TestMonth';'CV.TestDay';'CV.Tes-
tHour';'CV.TestMin';'CV.TestSek') = Date comprised of the common
variables



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 2 General program functions

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 61

2.4.4.7 Type Conversion functions

2.4.4.7.1 NumberToText
Dialogfenster: Formula editor ▶ Operators/Functions

Syntax

y = NumberToText(number)

Returns the entered number as Text.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number.

Examples

NumberToText(-55.3) = -55.3

NumberToText('CV.AverageTemp') = Vale of the common variable
(AverageTemp) as Text

2.4.4.7.2 NumberToTime
Dialogfenster: Formula editor ▶ Operators/Functions

Syntax

y = NumberToTime(number)

Returns the entered number as Date/Time, whereby the number is inter-
preted as the number of days since December 30, 1899 at 01 hours.

Parameters

Number

The parameter can be indicated either directly as a number or as a variable
of the type Number.

Examples

NumberToTime(35545.526) = 1997-05-25 14:37:26 UTC+2
(dependent on the system time)

NumberToTime(35780.55) = 1997-12-16 14:12:00 UTC+1 (depen-
dent on the system time)

NumberToTime('CV.TestDate') = Value of the common variable (Test-
Date) as Date/Time
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2.4.4.7.3 TextToNumber
Dialogfenster: Formula editor ▶ Operators/Functions

Syntax

y = TextToNumber(Text)

Returns the entered text as a number.

Parameters

Text

The parameter may only contain numerical characters or variables of
the type Text, as otherwise a type conversion is not possible. The result of
this conversion or the calculation would then be invalid. In addition, text
must be marked by inverted commas.

Examples

TextToNumber("-55.3") = -55.3

TextToNumber('CV.AverageTemp') = Value of the variables (Average-
Temp) as Number

TextToNumber('MV.ID1') = entered text of ID 1 as Number

2.4.4.7.4 TextToTime
Dialogfenster: Formula editor ▶ Operators/Functions

Syntax

y = TextToTime(Text;Format)

Returns the entered text as a Date/Time.

Parameters

Text

The parameter may only contain numerical characters or variables of
the type Text, as otherwise a type conversion is not possible (Result =
invalid). As separator between Year, Month etc. you can use the follow-
ing characters: slash (/), full stop (.), minus (-), semi-colon (;), colon (:),
space and comma. You can determine the order of the individual data
yourself, but must indicate this in the Format parameter.

Format

Indicates in which format or order the text has been entered. This para-
meter must be marked by inverted commas and can comprise the fol-
lowing code characters:

Characters Significance

y Year
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Characters Significance

M Month

d Day

H Hour 0…23

h Hour AM/PM

m Minute

s Second

a AM/PM marking

NOTE

If you indicate the time in the format AM/PM, it is necessary in addi-
tion to the formatting character h to use the AM/PM marking a (see
first example below).

Examples

TextToTime("2004-12-3 5:22:01 PM";"yMdhmsa") = 2004-12-03
17:22:01 UTC+1 (dependent on the system time)

TextToTime("12-15-01 2001:3:5";"HmsyMd") = 2001-03-05
12:15:01 UTC+1 (dependent on the system time)

TextToTime('CV.TestDate';'CV.TestFormat') = Values of the com-
mon variables in the time format indicated

TextToTime('MV.ID1';'CV.TestFormat') = entered text of ID1 in the
time format indicated

2.4.4.7.5 TimeToNumber
Dialogfenster: Formula editor ▶ Operators/Functions

Syntax

y = TimeToNumber(Time)

Returns the entered time as a Number.
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NOTE

Both for the automatic and explicit conversion of a Time to the type
Number, the number of days are counted since December 30, 1899
at 01 hours.

Attention: December 30, 1899 01 hours = 0.00000 days, this number
is rounded off to 5 decimal places, but a relational operation for exam-
ple is carried out with the exact value.

Parameters

Time

This parameter can be indicated either in the form of a time function or as
a variable of the type Time.

Examples

TimeToNumber(Time()) = current date and current time represented as
Number (in days since December 1899)

TimeToNumber(Time(1999;12;31;23;59;59)) = 36525.95832

TimeToNumber(Time('TestYear';'TestMonth';'TestDay')) = Value of
the common variables as number of days as a Number

2.4.4.7.6 TimeToText
Dialogfenster: Formula editor ▶ Operators/Functions

Syntax

y = TimeToText(Time)

Returns the time entered as Text.

y = TimeToText(Time;Format)

Gives the time entered as Text in the required format.

Parameters

Time

This parameter can be indicated either in the form of a time function or as
a variable of the type Date/Time.

Format

Indicates in which format or order the time is to be output as text. This
parameter can comprise the following code characters and must be
marked by inverted commas:
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Characters Significance Example

y two-digit year number 03

yyyy four-digit year number 1999

M one or two-digit month number 4, 12

MM two-digit month number 04, 12

MMM Month name short form Jul, Aug

MMMM Month name July, August

d one or two-digit day number 2, 25

dd two-digit day number 02, 25

h one-digit or two-digit hour number
(1…12 AM/PM)

5, 11

hh two-digit hour number (1…12 AM/
PM)

05, 11

H one-digit or two-digit hour number
(0…23)

8, 17

HH two-digit hour number (0…23) 08, 17

m one or two-digit minute number 2, 25

mm two-digit minute number 02, 25

s one or two-digit second number 3, 55

ss two-digit second number 03, 55

E Weekday short form Mon, Tue, Wed

EEEE Weekday Monday, Tuesday

D one, two or three-digit number of
the day in the year

2, 35, 142

DD two or three-digit number of the day
in the year

02, 35, 142

DDD three-digit number of the day in the
year

002, 035, 142

F one-digit number of the weekday in
the month, e.g. the 2nd Monday in
May

2

w one or two-digit number of the
week in the year

5, 25

ww two-digit number of the week in the
year

05, 25

W one-digit number of the week in the
month

3

a Format AM/PM AM, PM
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Characters Significance Example

' Inverted commas used for entering
any text

 

'' Entry of ' '

NOTE

If you wish to indicate the time in the format AM/PM, it is necessary in
addition to the formatting character h to use the AM/PM marking a
(see last example below).

Examples

TimeToText(Time()) = current date and current time (system) as Text

TimeToText(Time(2004;05;04)) = 2004-05-04 00:00:00 UTC+2
(dependent on the system time)

TimeToText('CV.TestTime') = Value of the common variable (type
Time) as Text

TimeToText(Time(2000;12;31);"EEEE', 'dd'.'MMMM' 'yyyy") =
Sunday, December 31, 2000

TimeToText(Time(1997;05;22);"M'/'d'/'yyyy', 'ha") = 5/22/1997,
12PM

2.4.4.8 Text functions

2.4.4.8.1 TextPosition
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = TextPosition(Text ; sample text)

Gives the Index which indicates at which point the sample text appears
for the first time in the Text. The numbering of the index begins at 1!

Parameters

Text

The parameter can be indicated either directly or as a variable of the type
Text, Number or Date/Time.

Sample text

The parameter can be indicated either directly or as a variable of the type
Text, Number or Date/Time. If the types of the two parameters do not
coincide, the type is converted from Sample text to the type Text. If the
Sample text is not included in the Text, the status invalid is given.
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NOTE

Entries of the type Number are always provided with a decimal place.

Example: TexPosition("12345";3) = invalid, as the 3 is converted to
3.0 before the operation in 3.0 and this is not included in the text.

Examples

TextPosition("Citric acid";"acid") = 9, the word "acid" occurs in the
text from index number 9 onwards

TextPosition("Citric acid";"Acid") = invalid, the word "Acid" (capital-
ized) does not occur in the text

TextPosition("Citirc acid";"salt") = invalid, the word "salt" does not
occur in the text

TextPosition(Time(2004;05;05);"5") = 7

TextPosition(3362.14;"6") = 3

TextPosition('MV.ID2';"Carbonate") = Index in which the word part
"Carbonate" begins for the first time in the ID2

2.4.4.8.2 SubText
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = SubText(Text ; Position ; Length)

Gives that part of the text from Text which begins at the index Position
and which has the length Length.

Parameters

Text

The parameter can be indicated either directly as text or as a variable of
the type Text. If the parameter does not correspond to the expected
type, it will automatically be converted to this. If this type conversion is
not possible, the result of this operation is given as invalid.

Position

The numbering of the Position begins at 1. The parameter can be indica-
ted either directly as a number or as a variable of the type Number. If
the parameter does not correspond to the expected type, it will automati-
cally be converted to this. If a type conversion is not possible or the posi-
tion does not exist, the result of this operation is given as invalid.

Length
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The parameter can be indicated either directly as a number or as a variable
of the type Number. If the parameter does not correspond to the
expected type, it will automatically be converted to this. It a type conver-
sion is not possible or the length indicated here is greater than the length
of the subtext, invalid is given

Examples

SubText("Citric acid";9;5) = acid

SubText("Citric acid";9;6) = invalid, only five characters exist from
position 9 onwards

SubText('MV.ID2';1;3) = the first three chracters of the identification 2

2.4.4.8.3 Trim
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Trim(Text)

Gives the Text without spaces before and after.

y = Trim(Text ; sample text)

Gives the Text without Sample text.

Parameters

Text

The parameter can be indicated either directly or as a variable of the type
Text, Number or Date/Time.

Sample text

The parameter can be indicated either directly or as a variable of the type
Text, Number or Date/Time. If the types of the two parameters do not
coincide, the type is converted from Sample text to the type Text.

NOTE

Entries of the type Number are always provided with a decimal place.

Example: Trim("12345";3) = 12345, as the 3 is converted to 3.0
before the operation and this is not included in the text.

Examples

Trim(" Citric acid ") = "Citric acid"

Trim("Citric acid";"acid") = Lemons

Trim("Citric acid";"salt") = Citric acid
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2.4.4.9 Miscellaneous functions

2.4.4.9.1 Case
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Case(Condition ; value_true ; value_false)

y = Case(Condition ; value_true ; value_false ; value_error)

Gives value_true if the condition is true. Otherwise value_false is given.
If an error occurs in the condition (result invalid), value_error is given.

Parameters

Condition　Number

Any variable (type Number) can be entered here, or a relational or logic
operation can be performed whose operators can be transferred either
directly or as a variable. These can be of the type Text, Number or Date/
Time.

Value_true

If condition <> 0, this parameter is saved as a result of the function. This
parameter can be transferred either directly or as a variable and can be of
the type Text, Number or Date/Time. Entire operations can also be
transferred here.

Value_false

If condition = 0, this parameter is saved as a result of the function. This
parameter can be transferred either directly or as a variable and can be of
the type Text, Number or Date/Time. Entire operations can also be
transferred here.

Value_error

If condition = invalid, this parameter is saved as a result of the function.
This parameter can be transferred either directly or as a variable and can
be of the type Text, Number or Date/Time. Entire operations can also
be transferred here.

Examples

Case('MV.ID1' = "";"ID1 empty";"ID1 not empty") = if no entry has
been made for ID1 in the run window, the text ID1 empty, otherwise
ID1 not emptywill be saved in the result.

Case('RS.IntermediateRes' > 5.5;"Intermediate result too
high";'RS.IntermediateRes' * 26.5;"Error occurred") = If the result
"IntermediateRes" is greater than 5.5, the text "Intermediate result
too high" will be written into the result, otherwise the intermediate result
will be multiplied by 26.5. If an error occurs during the comparison
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('RS.IntermediateRes' > 5.5), "Error occurred" will be saved as a
result of this operation.

2.4.4.9.2 Error
Dialog window: Formula editor ▶ Operators/Functions

Syntax

y = Error(value)

Gives +1 if the value is invalid (error) or 0 if the valie is valid. This
function can be used e.g. to check variables for their existence or validity.

Parameters

Value

The variable to be tested.

Examples

Error('RS.IntermediateRes') = 0: the intermediate result was able to be
calculated.

Error('RS.ZwischenRes') = 1: the intermediate result is invalid.

2.4.4.10 ASCII table
Dialog window: Formula editor

To generate the ASCII code, press and hold the [ALT] key and enter the
three-digit code for the required symbol using the numeric keypad.

Only printable characters are listed in the table below:

ASCII value

(dec)

Character ASCII value

(dec)

Character ASCII value

(dec)

Character

32 Space 64 At sign (@) 96 Grave accent (`)

33 Exclamation
mark (!)

65 A 97 a

34 Quotation mark
(")

66 B 98 b

35 Hash mark (#) 67 C 99 c

36 Dollar ($) 68 D 100 d

37 Percent (%) 69 E 101 e

38 Ampersand (&) 70 F 102 f

39 Apostrophe (') 71 G 103 g

40 Opening paren-
theses (()

72 H 104 h
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ASCII value

(dec)

Character ASCII value

(dec)

Character ASCII value

(dec)

Character

41 Closing paren-
theses ())

73 I 105 i

42 Multiplication
sign (*)

74 J 106 j

43 Addition sign (+) 75 K 107 k

44 Comma (,) 76 L 108 l

45 Minus sign (-) 77 M 109 m

46 Period (.) 78 N 110 n

47 Slash mark (/) 79 O 111 o

48 0 80 P 112 p

49 1 81 Q 113 q

50 2 82 R 114 r

51 3 83 S 115 s

52 4 84 T 116 t

53 5 85 U 117 u

54 6 86 V 118 v

55 7 87 W 119 w

56 8 88 X 120 x

57 9 89 Y 121 y

58 Colon (:) 90 Z 122 z

59 Semicolon (;) 91 Square bracket
([)

123 Curly bracket ({)

60 Less than (<) 92 Backslash (\) 124 Vertical stroke (¦)

61 Equals (=) 93 Square bracket
(])

125 Curly bracket (})

62 Greater than (>) 94 Circumflex (^) 126 Tilde (~)

63 Question mark
(?)

95 Underscore (_)   

2.4.5 Molar mass calculator
Dialog window: Molar mass calculator

The dialog window molar mass calculator is used for the simple entry
of molar masses into the formula editor and is opened with the button

.
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Mode of operation

The molecular formula of any chemical compound can be entered in the
Molecular formula field, after which pressing [OK] will cause the molar
mass of the compound to be calculated and entered directly into the for-
mula editor.

The molecular formula can be entered either directly or by clicking on the
symbols of the periodic system.

Examples

Molecular
formula

Molar mass

H2SO4 98.0734

Ca(OH)2 74.09268

AlCl3*6H2O 238.43174

2.5 Editing

2.5.1 Select date
Dialog window: Select date

The dialog window Select date serves for entering a date in a field and is

opened with the button .

Selects the month
Selects the year

Selects the day

Selected date
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2.5.2 Text editor
Dialog window: Text editor

The text editor serves for entering formatted text in text fields and is

opened with the button .

The toolbar of the text editor includes the following functions:

Cut selected text and copy it to the clipboard.

Copy selected text to the clipboard.

Insert text from the clipboard.

Open editor for entering a hyperlink (see Chapter 2.5.3, page 74).

Open formula editor for entering calculation formulas .(see Chapter 2.4,
page 21)

NOTE

In order for results of formulas of the type Date to be output correctly,
for text windows they must be converted to Text using the function
TimeToText (see Chapter 2.4.4.7.6, page 64).

Font size in pt.

Select font color.

Bold.

Italic.

Underlined.
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Left-justified.

Centered.

Right-justified.

2.5.3 Hyperlink
Dialog window: Hyperlink

The dialog window Hyperlink serves for entering a hyperlink in a field

and is opened with the button .

Displayed text

Designation of the hyperlink that is displayed.

Link target

Address of the link target to which the hyperlink refers (Web site, E-mail
address, file,...).

The button opens a selection dialog for linking a file as a link target.
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3 Configuration

3.1 Configuration - General

3.1.1 Configuration - Definition
Program part: Configuration

Definition

In tiBase, configuration is to be understood as settings for data import,
security settings, user administration, program administration and tem-
plates.

Organization

All configuration data is saved in the configuration database. In the
local server systems (tiBase full) these are stored in the program directory
of the computer on which the program has been installed. In client/server
systems (tiBase multi) the configuration database is stored centrally on
the server and saves and contains all the configuration data of all comput-
ers (clients) that are connected to this server.

3.1.2 Configuration - User interface
Program part: Configuration

Configuration symbol

Clicking on the configuration symbol in the vertical bar at the left opens
the Configuration program part while, at the same time, the configura-
tion symbol is shown in color.

Elements

The user interface of the Configuration program part comprises the fol-
lowing elements:

￭ Configuration-specific menu bar.
￭ Configuration-specific toolbar.
￭ Main window in which 2 subwindows are displayed.
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3.1.3 Configuration - Menu bar

3.1.3.1 Configuration - Main menus
Program part: Configuration

The menu bar in the Configuration program part includes the following
main menu items:

￭ File
Export, import, back up, restore configuration data.

￭ View
Activate/deactivate the toolbar.

￭ Tools
User administration, Security settings, Program administration, Options.

￭ Help
Open program help, display program information.

3.1.3.2 Configuration - File menu
Program part: Configuration

Export… Export configuration data (see Chapter 3.3.1.1, page 102).

Import… Import configuration data (see Chapter 3.3.1.2, page 103).

Backup ▶

Automatic Back up configuration data automatically (see Chapter 3.3.2.1, page 104).

Manual Back up configuration data manually (see Chapter 3.3.2.2, page 105).

Print (PDF)... ▶

User administra-

tion Output user administration data as PDF file (see Chapter 3.2.1.1, page 79).

Security settings Output security settings as PDF file (see Chapter 3.2.2.1, page 87).

Logout... Log out user (see Chapter 2.2.3, page 14)

Exit Exit the program.

3.1.3.3 Configuration - View menu
Program part: Configuration

Toolbar Activate/deactivate the toolbar display.
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3.1.3.4 Configuration - Tools menu
Program part: Configuration

User administra-

tion…
Manage users and groups of users with access permissions, signature permis-
sions and options (see Chapter 3.2.1.1, page 79).

Security settings… Options for login, password protection and electronic signature (see Chapter
3.2.2.1, page 87).

Program administra-

tion...
General settings for local server and client/server settings (see Chapter 3.2.3.1,
page 97).

Options… Set program options (see Chapter 3.3.3.1, page 106).

3.1.3.5 Help Menu
Program part: Configuration / Database

tiBase Help Open tiBase help.

About Displays information about the program and the installation.

3.1.4 Configuration - Toolbar
Program part: Configuration

User administra-

tion…
Manage users and groups of users with access permissions, signature permis-
sions and options (see Chapter 3.2.1.1, page 79).

Security settings… Options for login, password protection, Audit Trail and electronic signature (see
Chapter 3.2.2.1, page 87).

Logout... Log out user (see Chapter 2.2.3, page 14).

tiBase Help Open tiBase Help.

3.1.5 Configuration - Subwindows 
Program part: Configuration

Selection

The following subwindows are displayed in the main window:

￭ Import processes
Shows the details for reading-in PC/LIMS reports of different analysis
instruments in tabular form.
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￭ Import protocol
Shows the log entries since the last program start.

Presentation

The subwindows can be enlarged or made smaller to suit by dragging the
separating bar between the windows.

By clicking on the button  above at the right, the subwindows can be
maximized so that only one subwindow is displayed in the main window.
The original view of all subwindows is restored when the  button in the
maximized subwindow is clicked on again.

3.1.6 Configuration - Functions
Program part: Configuration

The following functions can be carried out in the Configuration program
part:

Views

￭ Toolbar

User administration

￭ Manage user groups
￭ Access permissions
￭ Signatures
￭ Options
￭ Users

Security settings

￭ Login/password protection
￭ Electronic signature
￭ Default reasons

Program administration

￭ Backup directories
￭ Clients
￭ Licenses

Export/import of configuration data

￭ Export configuration data
￭ Import configuration data

Back up/restore configuration data

￭ Back up configuration data automatically
￭ Back up configuration data manually
￭ Restore configuration data
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Options

￭ General program properties

3.1.7 View

3.1.7.1 Views - General
Program part: Configuration

Definition

The term View is used to designate the contents and design of the main
window in the Configuration and Database program parts. In contrast
to the Database program part, the Configuration program part has
only one view.

Function

￭ Toolbar
Activate/deactivate the toolbar.

Load automatically

At the program start the view with the following subwindows is opened:

Import processes, Import protocols

Export/import

Views can also be exported and imported. In this way these views can be
exchanged between different client/server systems.

3.1.7.2 Toolbar
Menu item: Configuration ▶ View ▶ Toolbar

The toolbar can be enabled or disabled with the Configura-
tion ▶ View ▶ Toolbar menu item.

3.2 Administration

3.2.1 User administration

3.2.1.1 User administration
Dialog window: Configuration ▶ Tools ▶ User administration

Overview

User groups and their users can be managed in the User administration
dialog window. Access rights for menu items and functions, signature per-
missions and default views can be defined for the individual program parts
for each user group. In the case of client/server systems, the user adminis-
tration is globally valid for all connected clients (central user administra-
tion).
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During installation, the three user groups Administrators (with the user
Admin1), Users and Removed users (each without any users) are auto-
matically created. All groups can be renamed; the Administrators group
is the only group that cannot be deleted.

The user administration data can be exported and imported. In this way
this data can be exchanged between different client/server systems.

The user administration data can be output as PDF file with the
File ▶ Print (PDF) ▶ User administration menu item.

Structure

The User administration dialog window is divided into two parts, the
size of which can be modified with the mouse. The user groups with their
assigned users are listed in a tree in the left-hand part; the right-hand side
shows details of the selected items.

Each user group, with the exception of the Removed users group, con-
tains the following items:

￭ Access permissions
Assignment of access permissions to the four program parts and their
menu bars.

￭ Signatures
Assignment of signature permissions for methods and determinations.

￭ Options
Definition of the view for the individual program parts.

￭ Users
Details regarding the user.

Functions

The following functions can be carried out in the User administration
dialog window:

￭ Add user groups
￭ Copy user groups
￭ Rename user groups
￭ Delete user groups
￭ Define access permissions for user groups
￭ Define signature permissions for user groups
￭ Define options for user groups
￭ Add users
￭ Set start password for new user
￭ Deactivate users
￭ Activate users
￭ Remove users
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3.2.1.2 User groups

3.2.1.2.1 User groups - Details
Dialog window: Configuration ▶ Tools ▶ User administration

If a user group is selected in the left-hand side of the User administra-
tion dialog window, then details of this user group will be shown on the
right-hand side together with a table containing all of its members.

Group data

Group name

Display of the name of the user group.

Description

Description of the user group.

Entry 256 characters

[Rename group]

Rename the selected user group.

[Delete group]

Delete the selected user group.

[Copy group]

Copy the selected user group.

[Add group]

Add a new user group.

Group members

The table showing the group members contains information about all
members of the selected user group. The table can neither be edited nor
sorted.

User

Short name of the user.

Full name

Full name of the user.

Status

Current user status.

Selection enabled | disabled

enabled
The user can log in as usual.
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disabled
The user can no longer log in. The administrator must first assign him
or her the status enabled and provide him or her with a new start
password.

[Add user]

Add a new user to the user group.

3.2.1.2.2 User administration - Access permissions
Dialog window: Configuration ▶ Tools ▶ User administration

If the Access permissions item is highlighted for a user group in the left-
hand part of the User administration dialog window, then the access
permissions of this group for program parts, menu items and functions
will be shown as a tree in the right-hand side of the window and can be
modified there. If one item is deactivated, then all the subitems belonging
to it will also be automatically deactivated. If a subitem, e.g. the Tools
menu, is deactivated in the configuration, then the box for the configura-
tion is colored gray. Blocked functions are deactivated for the particular
users, i.e. shown in gray.

Meaning of the symbols:

Expand view P Program part

Collapse view M Menu item

Full access to function(s) F Function

Limited access to function(s)   

No access to function(s)   

NOTE

All access permissions are switched on by default in the Administra-
tors group and cannot be modified.

3.2.1.2.3 User administration - Signatures
Dialog window: Configuration ▶ Tools ▶ User administration

If the Signatures item is highlighted for a user group in the left-hand part
of the User administration dialog window, then the permissions of this
group will be shown in the right-hand part and can be modified there.

Permissions for determinations

Signature Level 1

If this check box is activated, then users in this user group can sign deter-
minations electronically at level 1.
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Selection off | on
Default value off

Signature Level 2 (Lock)

If this check box is activated, then users in this user group can sign deter-
minations electronically at level 2 and at the same time lock them against
further modifications.

Selection off | on
Default value off

Delete signatures Level 2

If this check box is activated, then users in this user group can delete all
signatures at level 2. This enables the determination to be edited again.

Selection off | on
Default value off

3.2.1.2.4 User administration - Options
Dialog window: Configuration ▶ Tools ▶ User administration

If the Options item is highlighted for a user group in the left-hand part of
the User administration dialog window, then options for this group will
be shown in the right-hand part and can be modified there.

Default database view

Selection of the view that will open in the Database program part as the
default setting when the user logs in.

Selection Selection of the defined database views

Default configuration view

Selection of the view that will open in the Configuration program part
as default setting when the user logs in.

Selection Selection of the defined configuration views

3.2.1.2.5 Adding a user group
Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Add group] ▶ Add
group

In order to add a new user group with default settings, an existing group
must be selected and either the context-sensitive Add group menu item
or the [Add group] button must be pressed. The Add group dialog win-
dow then opens afterwards.

Group name

Name of the new group.
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Entry 24 characters

A new group with default settings is created under this name with [OK]; it
does not contain any users. The Description field and the table of group
members are empty.

3.2.1.2.6 Copying a user group
Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Copy
group] ▶ Copy group

Dialog window:

In order to copy a user group and save it under a new name, an existing
group must be selected and either the context-sensitive Copy group
menu item or the [Copy group] button must be pressed. This opens the
Copy group dialog window.

Group name

Name of the new group.

Entry 24 characters

Pressing [OK] creates a new group under this name that has the same
properties (access permissions, signature permissions, etc.) as the selected
group; it does not contain any users. The Description field and the table
of group members are empty.

3.2.1.2.7 Renaming a user group
Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Rename
group] ▶ Rename group

In order to rename a selected user group, either the context-sensitive
Rename group menu item or the [Rename group] button must be
pressed. This opens the Rename group dialog window.

Group name

Entry of the new group name.

Entry 24 characters

3.2.1.2.8 Deleting a user group
Function: Configuration ▶ Tools ▶ User administration ▶ [Delete group]

In order to delete a selected user group, either the context-sensitive
Delete group menu item or the [Delete group] button must be
pressed. The group is then deleted.
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NOTE

Deleting user groups is only possible if the group no longer contains
any users.

3.2.1.3 User

3.2.1.3.1 User - Details
Dialog window: Configuration ▶ Tools ▶ User administration

If a user group is selected in the left-hand side of the User administra-
tion dialog window, then the details of this user will be shown on the
right-hand side.

User

Display of the short name of the user that must be entered in the User
field at the time of log in. This name is defined when a new user is created
and cannot be subsequently modified.

Entry 24 characters

Full name

Full name of the user.

Entry 256 characters

Status

Display of the current status of the user. Only users of the Administra-
tors group can modify the status.

Selection enabled | disabled | removed

enabled
Users with enabled status can log in as usual. An exception is the first
login after the change of status from disabled or removed to
enabled. If this is the case, then a start password must be assigned
with which the user can log in again.

disabled
Users with disabled status can no longer log in. They will be automati-
cally set to this status as soon as the number of login attempts defined
in the Security settings has been exceeded.
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removed
Users with the removed status can no longer log in. If the set status
of a user is changed from enabled or disabled to removed, then the
user will automatically be moved to the group Removed users. If the
status of a removed user is changed back to enabled or disabled,
then a dialog window will appear for selecting the group to which the
user is to be assigned.

Start password

The invisible start password is shown with 6 * characters and must be
entered by a new user the first time that the new user logs in or after a
change in status from disabled or removed to enabled. The administra-
tor must assign a new start password when adding a new user or when
there is a change in status to enabled. If the user has logged in with the
start password and then entered a new password afterwards, then the
start password will be deleted once again.

Entry 50 characters

[Set start password]

Opens the Start password dialog window. This button is enabled only
for users with enabled status. If a user has forgotten his or her password,
then the administrator can assign a new start password.

User group

Current user group. The administrator can modify the group assignment
of the user. The user is automatically moved to the new group. A user can
also be moved to a new group with Drag&Drop.

Selection Selection of the defined user groups

Remarks

Possibility of entering additional information for the user (e.g. function,
address).

Entry 1000 characters

3.2.1.3.2 Adding a user
Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Add user] ▶ Add
user

There are two possible ways to add a new user:

￭ Select a user group and then the context-sensitive Add user menu
item.

￭ Select a user group and press the [Add user] button.

The Add user dialog window is then opened in both cases.
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User

Short name of the new user that must be used to log in at program start.
After the name has been entered, a Start password must be issued with
which the user is entered in the list of users.

Entry 24 characters

3.2.1.3.3 Setting a start password
Dialog window: Configuration ▶ Tools ▶ User administration ▶ [Set start pass-
word] ▶ Set start password

A start password can be assigned for the selected user with the [Set start
password] button in the User administration dialog window. It is
active only for newly added users or for those who once again have had
their status set to enabled. The Start password dialog window opens.

Start password

Entry of a new start password. Password options are not used for the start
password.

Entry 50 characters

Confirm password

Confirmation of the start password.

Entry 50 characters

3.2.2 Security settings

3.2.2.1 Security settings
Dialog window: Configuration ▶ &Tools ▶ Security settings

Overview

Parameters for login, password protection and electronic signatures can
be configured in the Security settings dialog window.

With client/server systems, the security settings are globally valid for all
connected clients.

Security settings can be exported and imported. This means that these set-
tings can be exchanged between different client/server systems.

The security settings can be output as a PDF file with the &File ▶ &Print
(PDF)... ▶ Security settings menu item.
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Recommended settings

Recommended settings

on | off (Default value: off)

If this check box is activated, then the recommended default settings will
be activated on all tabs.

Tabs

The security settings are configured on the following tabs:

￭ Login/password protection
Settings for login and password protection

￭ Modifications
Activation/deactivation of comments when determinations are modi-
fied

￭ Signatures
Options for electronic signatures

￭ Default reasons
Definition of reasons for signing and modifying methods, determina-
tions and sample data.

3.2.2.2 Login/password protection
Tab: Configuration ▶ &Tools ▶ Security settings ▶ Login/Password protection

Definition is made on the Login/Password protection tab as to
whether the user must log in with name only or with name and password
and how the password must be monitored and constructed.

Login policies

Enforce login with user name

If this check box is activated, then each time the program starts the login
window will appear in which the user must enter his or her user name. If
this check box is deactivated, no login is necessary and the user logged
in under Windows will be adopted as user name. If this is the case, then
all subsequent parameters are deactivated.

Selection on | off
Default value off

Recommended setting: on (can no longer be
edited)

Enforce login with password

If this check box is activated, then each time the program starts the login
window will appear in which the user must enter not only his or her user
name but also a password. If this option is switched off, then all of the
subsequent parameters will be deactivated.
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Selection on | off
Default value off

Recommended setting: on (can no longer be
edited)

Password monitoring by tiBase

If this option is switched on, then the password will be monitored by
tiBase in accordance with the subsequent parameters.

Selection on | off
Default value on

Recommended setting: on (can no longer be
edited)

Password monitoring by Windows

If this option is switched on, then the password will be monitored in
accordance with the parameters defined in Windows. The parameters for
password protection are in this case deactivated.

Selection on | off
Default value off

Recommended setting: off (can no longer be
edited)

CAUTION

In order to prevent an unwanted login by means of the Guest user cat-
egory that is defined by default in Windows when performing password
monitoring with Windows, it is imperative that this also be assigned a
password or (even better) be deactivated.

CAUTION

If this option is switched on, then the user names in Windows and
tiBase must necessarily match, because otherwise the user will no lon-
ger be able to log in to tiBase. In order to ensure this, once this selec-
tion has been made, the Test login dialog window (see Chapter
3.2.2.3, page 92) appears in which the logged-in user must log in
with his or her Windows password. If this test login fails, then the
Security settings dialog window will remain open.
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NOTE

For Windows 2000, proceed as follows for password monitoring by
Windows:

1. Start/execute "secpol.msc".
2. Under "Local Policies/User Rights Assignment", activate the "Act as

part of the operating system" policy for all desired user groups.
3. Restart the computer.

Maximum number of login attempts

If this check box is activated, then a user will be set to the disabled sta-
tus as soon as the number of login attempts defined here has been
exceeded. A user with the disabled status can no longer log in. The
counter for the login attempts is reset for the respective user once he or
she has logged in successfully.

Selection on | off
Default value off

Recommended setting: on (can no longer be
edited)

Input range 2 - 5 
Default value 3 

Recommended setting: 3

Message by e-mail

If this check box is activated, then an e-mail will be sent to the address
defined under [E-mail...] as soon as the defined number of login
attempts has been exceeded.

If no definition of the e-mail parameters has been entered, the [E-mail...]
dialog will be opened when the check box is activated.

Selection on | off
Default value off

Recommended setting: off

[E-mail...]

This button opens the Send e-mail window (see Chapter 3.2.2.7, page
95) for defining the e-mail parameters.

Logout policies

New login only for same user

If this check box is activated, then only the same user can log in again
after a logout. Users with administrator rights can always log in.
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Selection on | off
Default value off

Recommended setting: off

Automatic logout after

If this check box is activated, then the user will be logged out automati-
cally when no operating functions have been carried out with the key-
board or the mouse within this time. After this automatic logout, only a
member of the same user group as the one to which the previously log-
ged-off user belongs or a user with administrator rights can log in again.

Selection on | off
Default value off

Recommended setting: off

Input range 1 - 60 min
Default value 10 min

Recommended setting: 10

Password policies

NOTE

If the Password monitoring by Windows option is switched on,
then the parameters for password protection are deactivated. Compli-
ance with the recommended settings must then be ensured by the
administrator in Windows.

Enforce unique password

Activating this check box ensures that a user can use a given password
only once.

Selection on | off
Default value off

Recommended setting: on (can no longer be
edited)

Enforce use of special characters

Activating this check box ensures that the password must contain at
least one special character (@, #, ~ , etc.).

Selection on | off
Default value off

Recommended setting: off
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Minimum password length

Activating this check box ensures that the password must contain at
least the indicated number of characters.

Selection on | off
Default value off

Recommended setting: on (can no longer be
edited)

Input range 1 - 10 characters
Default value 6 characters

Recommended setting: 6

Passwords expire every

Activating this check box ensures that the user must enter a new pass-
word before the validity period expires. When a user logs in whose pass-
word will expire within the next 10 days, a corresponding message will
appear. If the validity period has expired, the user can only log in if he or
she changes the password.

Selection on | off
Default value off

Recommended setting: on (can no longer be
edited)

Input range 1 - 999 days
Default value 365 days

Recommended setting: 365

3.2.2.3 Test login for password monitoring by Windows
Tab: Configuration ▶ &Tools ▶ Security settings ▶ Login/Password protec-
tion ▶ Test login

If the Password monitoring by Windows option (see Chapter 3.2.2.2,
page 88) is activated, then the Windows password of the user must be
entered in this dialog window. The test login is used to check whether the
user name matches the Windows user name.
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User

Display of the current user name.

Password

Entry of the Windows password.

It is only when the test login is successful that the Password monitoring
by Windows can be used.

3.2.2.4 Changes
Tab: Configuration ▶ &Tools ▶ Security settings ▶ Modifications

Definition can also be set up on the Modifications tab as to whether or
not, in the event of changes to determinations, a reason for the change
and a change comment are required.

Comment on modification of determinations

If this check box is activated, then each time that a determination is
modified a modification reason and a modification comment must be
entered that will then be saved in the determination and displayed in the
database in the Information subwindow on the Determination tab.

Selection on | off
Default value off

Recommended setting: on (can no longer be
edited)

3.2.2.5 Signatures
Tab: Configuration ▶ &Tools ▶ Security settings ▶ Signatures

The parameters for the electronic signature can be configured on the Sig-
natures tab.

Inactivity delay

If this check box is activated, then the dialog window for signing will be
automatically closed when the entered time limit has expired.

Selection on | off
Default value off

Recommended setting: off

Input range 1 - 60 min
Default value 10 min

Recommended setting: 10
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Remove password after signature

If this check box is activated, then the password must be entered again
after each signature.

Selection on | off
Default value off

Recommended setting: on (can no longer be
edited)

Sign each determination separately

If this check box is activated, then each determination selected in the
determination overview must be signed individually.

Selection on | off
Default value off

Recommended setting: on (can no longer be
edited)

3.2.2.6 Default reasons
Tab: Configuration ▶ &Tools ▶ Security settings ▶ Default reasons

The reasons which must be entered when signing determinations or
changing determinations are defined on the Default reasons tab.

Category

Selection of the category for which the reasons are to be defined.

Selection Signature level 1 | Signature level 2 | Modifi-
cation of determinations

Default value Signature level 1

Reasons

Display of the reasons defined for the selected category.

Entry 64 characters

Move text upward (modifies sequence).

Move text downward (modifies sequence).

[New]

Add a new reason.

[Edit]

Edit the selected reason.
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[Delete]

Delete the selected reason.

Preset reasons

Signature Level 1

Selection Review | Approval | Authorship | Responsibil-
ity | Release | Determination modified | Results
checked

Signature Level 2

Selection Review | Approval | Authorship | Responsibil-
ity | Release | Determination modified | Results
checked | Signature 2 deleted

Modifying determinations

Selection Variable modified | Calculation modified | Sta-
tistics modified | Curve evaluation modified

3.2.2.7 Sending e-mail
Dialog window: Configuration ▶ &Tools ▶ Security settings ▶ Login/Password pro-
tection ▶ [E-mail...]

Mail to

E-mail address of the recipient.

Entry 200 characters

Subject

Title for describing the message.

Entry 200 characters

Message

The message defined here is sent as an e-mail when the maximum permit-
ted number of login attempts has been exceeded.

The text editor for entering or changing the message is opened with 
or by double-clicking on the text field.

Selection Text (unlimited)

Sender

Mail from

E-mail address of the sender.
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Entry 200 characters

SMTP Server

Address of the SMTP mail server.

Entry 200 characters

Port

Port number of the SMTP mail server.

Input range 1 - 65536 
Default value 25 

Authentication

on | off (Default value: off)

Check box for activating the authentication of the sender when sending
the e-mail and for selecting the authentication method.

Selection SMTP | SMTP after POP
Default value SMTP

POP server

Address of the POP mail server.

Entry 200 characters

Port

Port number of the POP mail server.

Input range 1 - 65536 
Default value 110 

User

Name of the user for access to mail server. The name need not match the
Windows user name.

Entry 200 characters

Password

Password for accessing the mail server. This password need not match the
Windows password.

Entry 200 characters
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3.2.3 Program administration

3.2.3.1 Program administration
Dialog window: Configuration ▶ &Tools ▶ Program administration

Overview

Backup directories and licenses can be managed in the Program admin-
istration dialog window.

Tabs

The parameters for program administration are defined on the following
tabs:

￭ Backup directories
List of the defined backup directories.

￭ Clients
List of computers on which tiBase is installed.

￭ Licenses
List of installed licenses with number of clients. This tab is only shown
on the server of a client/server installation.

3.2.3.2 Backup directories

3.2.3.2.1 Backup directories
Tab: Configuration ▶ &Tools ▶ &User administration... ▶ Backup directories

Table with the defined backup directories. With a click on the column title
the table can be sorted according to the selected column in either increas-
ing or decreasing sequence. The directory Default backup directory is
created during installation.

NOTE

The following buttons are only active when tiBase is running on the
server, they are inactive for the individual clients.

[New]

Add a new backup directory (see Chapter 3.2.3.2.2, page 98).

[Edit]

Edit the selected backup directory (see Chapter 3.2.3.2.3, page 98).

[Delete]

Delete the selected backup directory.
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NOTE

The Default backup directory cannot be deleted.

3.2.3.2.2 Creating a new backup directory
Dialog window: Configuration ▶ &Tools ▶ &User administration... ▶ Backup direc-
tories ▶ [New] ▶ New backup directory

Name

Name for the backup directory.

Entry 50 characters

Directory

Entry or selection (with  ) of the path for the backup directory.

Entry 1000 characters

NOTE

If the backup directory is on a network drive the saving date should be
added manually to the Backup name because the saving date infor-
mation is not available when the directory is restored.

NOTE

Make sure that you have read and write permission on the selected
directory.

3.2.3.2.3 Editing a backup directory
Dialog window: Configuration ▶ &Tools ▶ &User administration... ▶ Backup direc-
tories ▶ [Edit] ▶ Edit backup directory

Name

Name for the backup directory.

Entry 50 characters
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NOTE

The Default backup directory created during installation cannot be
renamed.

Directory

Entry or selection (with ) of the path for the backup directory.

Entry 1000 characters

NOTE

If the backup directory is on a network drive the saving date should be
added manually to the Backup name because the saving date infor-
mation is not available when the directory is restored.

NOTE

Make sure that you have read and write permission on the selected
directory.

3.2.3.3 Clients
Tab: Configuration ▶ &Tools ▶ Program administration ▶ Clients

Table with information about the computers on which tiBase is installed.
The table cannot be edited. With a click on the column title the table can
be sorted according to the selected column in either increasing or
decreasing sequence.

Client ID

Display of the ID for the client that has been entered for the client/server
installation.

Computer name

Display of the name of the computer on which the client has been
installed.

Status

Display as to whether tiBase has been started on the client (active) or
not (inactive).
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NOTE

The content of the tab Clients can also be displayed via the shortcut

 in the directory ..\Metrohm\tiBase\bin (available only on the
server) if tiBase is not running.

3.2.3.4 Licenses
Tab: Configuration ▶ &Tools ▶ Program administration ▶ Licenses

Table with the licenses that are installed on the server (for tiBase multi)
or on the local server (for tiBase full). The table cannot be edited.

NOTE

In client/server systems, this tab is visible only on the server and only for
members of the Administrators user group.

License code

Display of the entered license code.

Number of clients

Display of the number of clients to have been enabled with the license
code.

[Add licenses]

Add new, additional licenses (see Chapter 3.2.3.5, page 101).
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NOTE

Starting with Windows Vista, Microsoft has introduced the UAC (User
Account Control), which permits running tasks either as a non-adminis-
trator or as an administrator (without changes of user, deactivation or
similar). This function can, however, cause difficulties with client/server
installations of tiBase on computers with Windows Vista or Windows
7. Therefore, to add additional licenses, proceed as follows:

￭ For new installations
To enter additional licenses, the program must be started as admin-
istrator (position the mouse on the Program icon and click the right
mouse button – select Run as administrator there). If one then
adds the license code for additional licenses in the usual way, then
the license.mlic file in the C:\Program Files\Metrohm\'Program
name'\bin directory will contain both license codes.

￭ For existing installations
First of all, the license.mlic file in the C:\Users\'User'\AppData
\Local\VirtualStore\Program Files\Metrohm\'Program
name'\bin directory must be deleted. This file must not be present
in the VirtualStore of any user – a check must be made to make
sure of this, and any such files which may be found must be deleted.
Afterwards, the program must be started as administrator (position
the mouse on the Program icon and click the right mouse button –
select Run as administrator there). If one then adds the license
code for additional licenses in the usual way, then the license.mlic
file in the C:\Program Files\Metrohm\'Program name'\bin
directory will contain both license codes.

Additional information on this topic can be found in the installation
manual, which is saved in the C:\Program Files\Metrohm\tiBase
\doc directory.

3.2.3.5 Adding licenses
Dialog window: Configuration ▶ &Tools ▶ Program administration ▶ Licen-
ses ▶ [Add licenses] ▶ Add licenses

The menu &Tools ▶ Program administration ▶ Licenses ▶ [Add
licenses] in the program part Configuration opens the dialog window
Add licenses in which the new license code can be entered.

License code

Entry of the license code.
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3.3 Configuration data

3.3.1 Export/import

3.3.1.1 Exporting configuration data
Dialog window: Configuration ▶ File ▶ Export… ▶ Export configuration data

File ▶ Export... opens the Export configuration data dialog window
in which the following parts of the configuration database can be selected
for export:

 

Configuration views

on | off (Default value: on)

Export saved configuration views (see Chapter 4.1.7, page 123).

Database views

on | off (Default value: on)

Export saved database views (see Chapter 4.1.7, page 123).

 

Control chart templates

on | off (Default value: on)

Export saved control chart templates (see Chapter 4.4.3.1, page 178).

Curve overlay templates

on | off (Default value: on)

Export saved curve overlay templates (see Chapter 4.4.2.1, page 173).

Export template

on | off (Default value: on)

Export the saved export template.

 

Security settings

on | off (Default value: on)

Export security settings (see Chapter 3.2.2.1, page 87).

User administration

on | off (Default value: on)

Export user administration (see Chapter 3.2.1.1, page 79).
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[OK]

The Save dialog window for saving data, in which the name and directory
for the export file must be entered, opens. The selected configuration
data is then saved in a file with the extension .mcfg.

3.3.1.2 Importing configuration data
Dialog window: Configuration ▶ File ▶ Import… ▶ Import configuration data

With File ▶ Import... and after selection of the *.tcfg file to be impor-
ted, the Import configuration data dialog window opens in which the
following parts of the configuration database can be selected for import:

NOTE

Data that is not present in the export file cannot be selected.

 

Configuration views

on | off (Default value: on)

Import saved configuration views (see Chapter 4.1.7, page 123).

Database views

on | off (Default value: on)

Import saved database views (see Chapter 4.1.7, page 123).

 

Control chart templates

on | off (Default value: on)

Import saved control chart templates (see Chapter 4.4.3.1, page 178).

Curve overlay templates

on | off (Default value: on)

Import saved curve overlay templates (see Chapter 4.4.2.1, page 173).

Export template

on | off (Default value: on)

Export the saved export template.
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Security settings

on | off (Default value: on)

Import security settings (see Chapter 3.2.2.1, page 87).

User administration

on | off (Default value: on)

Import user administration (see Chapter 3.2.1.1, page 79).

 

[OK]

The selected data is imported.

3.3.2 Back up/restore

3.3.2.1 Backing up configuration data automatically
Dialog window: Configuration ▶ File ▶ Save ▶ Automatically ▶ Backup configura-
tion data automatically

Automatic backup

on | off (Default value: off)

If this check box is activated, then the configuration database is saved
automatically to the defined backup directory at the desired time interval.
The entire configuration database is saved at this time.

If this check box is deactivated, then the following parameters cannot be
edited.

Last backup

Display of date and time of the last configuration data backup.

Next backup

Date and time at which the next backup is to be carried out.  opens
the Next backup window to select the date (see Chapter 2.5.1, page
72).

Default value　　　Last backup + 1 month

Interval

Entry of the time interval after which an automatic backup will take place.
With each automatic or manual backup, the interval entered here will be
added to the date of the Last backup and shown in the Next backup
field.

Input range 1 - 999 
Default value 1 
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Selection Day(s) | Week(s) | Month(s) | Year(s)
Default value Month(s)

Backup directory

Selection of a predefined backup directory (see Chapter 3.2.3.2.1, page
97).

NOTE

Make sure that you have read and write permission for the selected
directory.

3.3.2.2 Backing up configuration data manually
Dialog window: Configuration ▶ File ▶ Save ▶ Manually ▶ Backup configuration
data manually

Backup target

Backup directory

Selection of a predefined backup directory (see Chapter 3.2.3.2.1, page
97).

NOTE

Make sure that you have read and write permission for the selected
directory.

Backup name

Selection of an already existing name or entry of a new name for the
backup file. If an existing backup file is selected, it will be overwritten.

Entry 50 characters
Selection Backup names

NOTE

If the backup directory is located on a network drive, then the backup
date should be added to the Backup name, because the backup date
information is not available when the directory is restored.

[Start]

Start the manual backup of the complete configuration database.
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3.3.2.3 Restoring configuration data
Dialog window: Restore configuration data

"Restore configuration data" dialog window

Backup directory

Selection of a directory predefined in the program administration that
contains the backed-up configuration database.

Selection Backup directories

Backup name

Selection of a backup file.

Selection Backup files

Backup date

Display of the time at which the configuration database was backed up. If
the backup file is located on a network drive, this information is not avail-
able.

Database name

Display of the name of the configuration database. This information is not
available if the backup file is located on a network drive.

Size

Display of the size of the configuration database in KB.

Save As

Display of the name under which the configuration database will be
restored.

[Start]

Start restoration of the configuration database. After the start, a progress
bar appears in the window. The dialog window closes automatically when
the backup has been completed.

3.3.3 Options

3.3.3.1 Options - Overview
Dialog window: Configuration ▶ Tools ▶ Options ▶ Options

Under Tools ▶ Options, general program properties can be set on the
following tabs:

￭ General
Selects dialog language.
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￭ Save
Saves settings on exiting the program.

￭ PDF
Settings for PDF files.

3.3.3.2 Options - General
Tab: Configuration ▶ Tools ▶ Options ▶ Options ▶ General

Dialog language

Dialog language

Selection of the dialog language.

Selection German | English | additional languages
(dependent on installed language patches)

Default value English

NOTE

For the altered setting to become effective the program must be restar-
ted.

3.3.3.3 Options - Save
Tab: Configuration ▶ Tools ▶ Options ▶ Options ▶ Save

Save on exiting

Here you can define the settings to be saved when the program is exited.
If the corresponding check box is activated, the current view with its set-
tings will be saved automatically when the program is exited. If the corre-
sponding check box is deactivated, then any modifications that may
have been made to the view will not be saved and at the next program
start the original, manually saved view will be loaded.

Configuration settings

on | off (Default value: off)

Switches Save configuration view on/off when exiting the program.

Database settings

on | off (Default value: off)

Switches Save database view on/off when exiting the program.
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3.3.3.4 Options - PDF
Tab: Configuration ▶ Tools ▶ Options ▶ Options ▶ PDF

Security permissions for PDF files

Content copying or extraction allowed

on | off (Default value: on)

If this option is switched off none of the PDF file contents can be copied
or extracted.

Printing allowed

on | off (Default value: on)

If this option is switched off the PDF file cannot be printed out.

Adding or changing comments allowed

on | off (Default value: on)

If this option is switched off comments and form fields can neither be
added nor altered.

Modifying the document allowed

on | off (Default value: on)

If this option is switched off no changes can be made to the PDF file.

3.4 Subwindow Import processes

3.4.1 Import processes - General
Subwindow: Configuration ▶ Import processes

The subwindow Import processes shows the details for reading-in PC/
LIMS reports of different analysis instruments in tabular form. It is always
shown in the program part Configuration, and cannot be removed from
the Configuration view.

The subwindow can be enlarged or made smaller to suit by dragging the
separating bar between the windows.

By clicking on the button  above at the right, the subwindow can be
maximized so that only one subwindow is displayed in the main window.
The original view of two subwindows is restored when the  button is
pressed in the maximized subwindow again.
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3.4.2 Import processes - Table
Subwindow: Configuration ▶ Import processes

Table view

The table cannot be edited directly. With a click on the column title the
table can be sorted according to the selected column in either increasing
or decreasing sequence. The table view can be adapted with the left-hand
mouse button as follows:

￭ Drag the margin between column titles:
Sets the column width

￭ Double-click on the margin between column titles:
Sets the optimal column width

￭ Drag the column title:
Moves the column to the required location

If the contents of a field is larger than the column width then the whole
contents will be shown as a Tooltip if the mouse cursor is kept on the
field.

Contents

The table shows the following information about reading-in PC/LIMS
reports as standard:

Name

Name for the data import process (e.g. user group, user, devices, meth-
ods, etc.)

Data source

Source directory with PC/LIMS reports to be read-in automatically from
this directory into a database. With the symbol  the dialog window
Search opens, in which the source directory is selected and then can be
entered into the field Directory.

Database

Name of the tiBase 1.1 Patch 1 database, in which the read-in reports are
saved.

Comment

Optional comment.

Status

Status of the import process.

Selection started | stopped | inactive
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started
The import process has been started manually or automatically. The
status is displayed in green lettering.

stopped
The import process has been stopped manually or automatically by an
error. The status is displayed in red lettering. Additionally the back-
ground of the line number is also shown in red.

inactive
The option Start automatically is disabled for this import process.
The import process has to be started manually. The status as well as all
line entries are displayed in gray lettering.

Functions

The menu Edit beneath the table contains the following menu items:

Start import Start import for selected data source.

Stop import Stop import for selected data source.

New… Define new import process.

Delete Delete selected import process.

Properties… Edit selected import process.

3.4.3 Import processes - Properties
Dialog window: Configuration ▶ Import processes ▶ [Edit] ▶ New / Proper-
ties... ▶ Properties Import process

In this dialog window the details for the import of PC/LIMS reports are
defined.

Name

Name for the data import process (e.g. user group, user, devices, meth-
ods, etc.)

Data source

Source directory with PC/LIMS reports to be read-in automatically from
this directory into a database. With the symbol  the dialog window
Search opens, in which the source directory is selected and then can be
entered into the field Directory.

Database

Name of the tiBase 1.1 Patch 1 database, in which the read-in reports are
saved.
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Comment

Optional comment.

Start automatically

on | off (Default value: on)

If this check box is activated, the data import is started automatically at
the start of the program.

File options

Delete file

If this option is enabled, the reports are deleted after the data import.

Move file

If this option is enabled, the reports are saved in a selected directory after
the data import.

Directory

Directory, in which the PC/LIMS reports are saved after having been
imported to the database. With the symbol  the dialog window Search
opens, in which the directory is selected and then can be entered into the
field Directory.

3.5 Subwindow Import protocol

3.5.1 Import protocol - General
Subwindow: Configuration ▶ Import protocol

The subwindow Import protocol shows information about the data
import, error messages and warnings recorded since the last program
start. It is always shown in the program part Configuration, and cannot
be removed from the Configuration view.

The subwindow can be enlarged or made smaller to suit by dragging the
separating bar between the windows.

By clicking on the button  above at the right, the subwindow can be
maximized so that only one subwindow is displayed in the main window.
The original view of two subwindows is restored when the  button is
pressed in the maximized subwindow again.



3.5 Subwindow Import protocol ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

112 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

3.5.2 Import protocol - Table
Subwindow: Configuration ▶ Import protocol

Table view

The table cannot be edited directly. With a click on the column title the
table can be sorted according to the selected column in either increasing
or decreasing sequence. The table view can be adapted with the left-hand
mouse button as follows:

￭ Drag the margin between column titles:
Sets the column width

￭ Double-click on the margin between column titles:
Sets the optimal column width

￭ Drag the column title:
Moves the column to the required location

If the contents of a field is larger than the column width then the whole
contents will be shown as a Tooltip if the mouse cursor is kept on the
field.

Contents

The table shows the following information about reading-in PC/LIMS
reports as standard:

Type

 information

 warning

 error

Date

Date of the log entry

Import process

Name of the corresponding import process

Data source

Directory, from which the PC/LIMS report data has been read-in.

Database

Name of the tiBase 1.1 Patch 1 database, in which the read-in reports are
saved.

Action
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Selection OK | Import | Delete | Move

OK
The PC/LIMS report has successfully been imported, moved or deleted.

Import
tiBase cannot import the selected PC/LIMS reports.

Delete
tiBase cannot delete the selected PC/LIMS reports.

Move
tiBase cannot move the selected PC/LIMS reports.

Details

Detailed information on the log entry.

Functions

The menu Edit beneath the table contains the following menu items:

Delete all messages Delete all messages in the window Import protocol.

Options... Open the dialog window Properties Import protocol.

3.5.3 Import protocol - Properties
Dialog window: Configuration ▶ Import protocol ▶ [Edit] ▶ Options...

Filter options

Show information

on | off (Default value: off)

If this check box is activated, information on the import process is shown
in the table.

Show warnings

on | off (Default value: off)

If this check box is activated, warnings are shown in the table.

Show errors

on | off (Default value: off)

If this check box is activated, errors during the import are shown in the
table.

Maximum number of log entries

In this field the maximum number of log entries to be listed in the table
Import protocol is entered.



3.5 Subwindow Import protocol ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

114 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

If the number of entries exceeds the value entered, rolling recording takes
place. This means, that the oldest entry is deleted when a new log saying
is incoming.

Input range 20 - 1000 
Default value 100 

NOTE

If during a rolling recording an error or warning not remedied yet has
been deleted, the warning or error will be newly logged as soon as the
corresponding import process is started again.
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4 Database

4.1 Database - General

4.1.1 Database - Definition
Program part: Database

Definition

The term Database is used in tiBase to refer to the program part in
which the determinations saved in the databases can be displayed, man-
aged, evaluated, reprocessed and printed out. The determination data-
bases are also referred to as databases; they can, in contrast to the
configuration database, be generated by the user and contain the
determination data. Included among such determination data are the
method data used for the determination, the measuring data generated
during the determination and the results calculated from it.

Organization

In the case of local server systems (tiBase 1.1 Patch 1 full), the data-
bases are stored on the drives managed by the computer and are only
available to those users registered on that computer who have the appro-
priate access rights.

In client/server systems (tiBase 1.1 Patch 1 multi) the databases are
stored on drives managed centrally by the server and are globally available
throughout the entire client/server system, i.e. all users with the appropri-
ate access rights can use these databases.

4.1.2 Database - User interface
Program part: Database

Database symbol

Clicking on the database symbol in the vertical bar on the left opens the
Database program part, while at the same time the database symbol is
shown in color. The upper left corner of the symbol contains a black field
displaying the number of databases currently opened (see Chapter 4.2.2,
page 127).
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Elements

The user interface of the Database program part is comprised of the fol-
lowing elements:

￭ Database-specific menu bar.
￭ Database-specific toolbar.
￭ Main window in which up to 6 subwindows can be displayed.

4.1.3 Database - Menu bar

4.1.3.1 Database - Main menus
Program part: Database

The menu bar in the Database program part includes the following main
menu items:

￭ File
Open and close databases, database manager, print.

￭ Edit
Copy selected lines in the determination overview to the clipboard,
mark all lines.

￭ View
Change the layout, load a view, save the view, modify the subwindow
properties.

￭ Determinations
Search, filter, sign, delete determinations; overlay curves, calibration
curves, reprocessing, etc.

￭ Tools
Report templates, further templates.

￭ Help
Open program help, display program information.

4.1.3.2 Database - File menu
Program part: Database

Open… Opens a database (see Chapter 4.2.1, page 126).

Close all Closes all open databases (see Chapter 4.2.6, page 128).

Close Closes the database (see Chapter 4.2.6, page 128).

Database manager… Management of the determination databases (see Chapter 4.3.1, page 129).

Print ▶

Determination

overview…
PDF file output of the determination overview (see Chapter 4.5.2.11, page
255).
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Report… PDF file output of the report (see Chapter 4.5.2.12, page 255).

Logout… Logs out user (see Chapter 2.2.3, page 14).

Exit Exits the program.

4.1.3.3 Database - Edit menu
Program part: Database

Copy Copies the selected lines in the determination overview to the clipboard.

Select all Selects all lines in the current set of determinations in the determination over-
view.

4.1.3.4 Database - View menu
Program part: Database

Update Updates the determination overview.

Change layout… Modifies the layout of the loaded database view (see Chapter 4.1.7.2, page
124).

Load view… Loads a saved database view (see Chapter 4.1.7.3, page 125).

Save view… Saves the loaded database view (see Chapter 4.1.7.4, page 125).

Split vertically Splits the database window vertically and displays two databases side by side
(see Chapter 4.2.4, page 128).

Split horizontally Splits the database window horizontally and displays two databases, one above
the other (see Chapter 4.2.5, page 128).

Unsplit Undoes the splitting of the database window (see Chapter 4.2.3, page 128).

Properties ▶

Column display Sets the column display for the Determination overview subwindow (see
Chapter 4.5.1.3, page 212).

Properties

Results Set properties for the subwindow Results (see Chapter 4.7, page 270).

Toolbar Activates/deactivates the toolbar display.
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4.1.3.5 Database - Determinations menu
Program part: Database

Comment… Enter a comment on the selected determination (see Chapter 4.5.2.2, page
217).

Search Opens the Search window for searching for determinations (see Chapter
4.5.2.3, page 217).

Filter ▶

Last filter Applies the most recently used quick or special filter (see Chapter 4.5.2.4.2,
page 220).

Quick filter Quick filtering of the database with the content of the selected table cell (see
Chapter 4.5.2.4.3, page 220).

Special filter… Opens the Special filter window for the definition of user-specific filters (see
Chapter 4.5.2.4.4, page 221).

All statistical

records
Displays all related statistical records of the focused determination (see Chapter
4.5.2.4.5, page 222).

Remove filter Removes the current filter (see Chapter 4.5.2.4.6, page 222).

Sign ▶

Signature 1… Sign the selected determinations on level 1 (see Chapter 2.3.3, page 17).

Signature 2… Sign the selected determinations on level 2 (see Chapter 2.3.4, page 18).

Show signa-

tures…
Shows all signatures for the focused determination (see Chapter 4.5.2.5.4, page
229).

Delete signa-

tures 2…
Deletes all signatures at level 2 of the focused determination (see Chapter 2.3.5,
page 20).

Send to… Sends the selected determinations per e-mail (see Chapter 4.5.2.7, page 253).

Export… Exports the selected determinations (see Chapter 4.5.2.8, page 253).

Import… Imports the selected determinations (see Chapter 4.5.2.9, page 254).

Show history Shows all versions of the focused determination in the determination table (see
Chapter 4.5.2.13, page 257).
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Make current Makes the old version selected in the history view the current version once again
(see Chapter 4.5.2.14, page 257).

Control chart… Displays control chart and statistical evaluation of the selected determination
(see Chapter 4.5.2.16, page 258).

Overlay curves… Overlays the curves of the selected determinations (see Chapter 4.5.2.17, page
259).

Reprocess… Reprocesses the selected determinations (see Chapter 4.5.2.6, page 230).

Delete Deletes the selected determinations (see Chapter 4.5.2.10, page 254).

4.1.3.6 Database - Tools menu
Program part: Database

Report templates ▶

New ▶

Form report Opens the Report template window with an empty form report (see Chapter
4.4.1.3, page 139). This menu item is disabled as long as the database is
empty.

Open… Opens a report template for editing (see Chapter 4.4.1.3, page 139). This menu
item is disabled as long as the database is empty.

Manager… Manage report templates (see Chapter 4.4.1.1.1, page 137).

Templates ▶

Control chart

templates… Manage templates for control charts (see Chapter 4.4.3, page 178).

Curve overlay

templates… Manage curve overlay templates (see Chapter 4.4.2.1, page 173).

Export tem-

plates… Manage export templates (see Chapter 4.4.4.1, page 182).

4.1.3.7 Help Menu
Program part: Configuration / Database

tiBase Help Open tiBase help.

About Displays information about the program and the installation.



4.1 Database - General ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

120 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

4.1.4 Database - Toolbar
Program part: Database

Open… Opens a database (see Chapter 4.2.1, page 126).

Close Closes the database (see Chapter 4.3.1, page 129).

Database manager… Management of the determination databases (see Chapter 4.3.1, page 129).

Logout… Logs out user (see Chapter 2.2.3, page 14).

Copy Copies the selected lines in the determination overview to the clipboard.

Update Updates the determination overview.

Change layout… Modifies the layout of the loaded database view (see Chapter 4.1.7.2, page
124).

Load view… Loads a saved database view (see Chapter 4.1.7.3, page 125).

Save view… Saves the loaded database view (see Chapter 4.1.7.4, page 125).

Split vertically Splits the database window vertically and displays two databases side by side
(see Chapter 4.2.4, page 128).

Split horizontally Splits the database window horizontally and displays two databases, one above
the other (see Chapter 4.2.5, page 128).

Unsplit Undoes the splitting of the database window (see Chapter 4.2.3, page 128).

Comment Enter a comment on the selected determination (see Chapter 4.5.2.2, page
217).

Search Opens the Search window for searching for determinations (see Chapter
4.5.2.3, page 217).

Filter/Last filter Applies the most recently used quick or special filter (see Chapter 4.5.2.4.2,
page 220).

Filter/Quick filter Quick filtering of the database with the content of the selected table cell (see
Chapter 4.5.2.4.3, page 220).
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Filter/Special filter… Opens the Special filter window for the definition of user-specific filters (see
Chapter 4.5.2.4.4, page 221).

Filter/Remove filter Removes the current filter (see Chapter 4.5.2.4.6, page 222).

Import… Imports selected determinations (*.txt or *.tdet).

Sign/Signature 1…

Sign the selected determinations on level 1 (see Chapter 2.3.3, page 17).

Sign/Signature 2… Sign the selected determinations on level 2 (see Chapter 2.3.4, page 18).

Show history Shows all versions of the focused determination in the determination table (see
Chapter 4.5.2.13, page 257).

Make current Makes the old version selected in the history view the current version once again
(see Chapter 4.5.2.14, page 257).

Control chart… Displays control chart and statistical evaluation of the selected determination
(see Chapter 4.5.2.16, page 258).

Overlay curves… Overlays the curves of the selected determinations (see Chapter 4.5.2.17, page
259).

Reprocess… Reprocesses the selected determinations (see Chapter 4.5.2.6, page 230).

Delete Deletes the selected determinations (see Chapter 4.5.2.10, page 254).

Report templates/

Open… Opens a report template for editing (see Chapter 4.4.1.3, page 139).

tiBase Help Opens tiBase Help.

4.1.5 Database - Subwindow
Program part: Database

Selection

The following subwindows can be displayed in the main window:

￭ Determination overview
Overview of the determinations saved in the database. This subwindow
is permanently on display.

￭ Information
Display of information for the focused determination.
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￭ Results
Display of the results of the focused determination.

￭ Curves 1 - 5
Display of curves for the focused determination.

Display

The subwindows can be enlarged or made smaller to suit by dragging the
separating bar between the windows.

By clicking on the  button above at the right, the subwindows can be
maximized so that only one subwindow is displayed in the main window.
The original view of all subwindows is restored by clicking on the  but-
ton in the maximized subwindow once again.

If you change the view of the subwindows, these changes will remain in
effect when the database is closed and reopened.

4.1.6 Database - Functions
Program part: Database

The following functions can be carried out in the Database program part:

Views

￭ Modifying the layout of the database view
￭ Loading a database view
￭ Saving a database view
￭ Renaming a database view
￭ Deleting a database view

Database manager

￭ Creating a new database
￭ Renaming a database
￭ Editing database properties
￭ Backing up a database
￭ Restoring a database
￭ Deleting a database

Determinations

￭ Overview of functions

Templates

￭ Editing report templates
￭ Editing templates for control charts
￭ Editing curve overlay templates
￭ Editing export templates
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4.1.7 Views

4.1.7.1 Views - General
Program part: Database

Definition

The term View defines the content and design of the main window in the
Database program part (the Configuration program part has only one
view). The following elements belong to a view:

￭ Number, arrangement, sequence and size of the subwindows.
￭ Representation within the individual subwindows, i.e. column

sequence, column width, sorting and filter.

Functions

The following functions are possible for views:

￭ Changing the layout
Define the number, arrangement and sequence of the subwindows for
the current view.

￭ Saving a view
Save current view.

￭ Loading a view
Load a saved view.

￭ Renaming a view
Rename a saved view.

￭ Deleting a view
Delete a saved view.

￭ Toolbar
Enable or disable the toolbar.

Save automatically

The current view will be saved automatically when the program is closed if
the corresponding Save on closing item is activated under
Tools ▶ Options on the Save tab in the Configuration program part.

Load automatically

The standard procedure is that the view saved when the program is termi-
nated will be loaded automatically the next time that the program is
opened. As an alternative, a default view that is loaded automatically the
first time that the program part is opened can be defined for each user
group.

The standard procedure is that views are opened with the following sub-
windows with the very first program start:

￭ Configuration
Import processes, Import protocols
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￭ Database
Determination overview, Curve #, Information, Results

Export/import

Views can also be exported and imported. In this way these views can be
exchanged between different client/server systems.

4.1.7.2 Changing the layout
Dialog window: Database ▶ View ▶ Change layout… ▶ Change layout

The Change layout dialog window is opened with the  symbol or the
View ▶ Change Layout… menu item.

Select layout

Selection of a graphical symbol for the number, arrangement and
sequence of the subwindows.

Selection Selection of the possible combinations

Available subwindows

Display of the subwindows that are still available for displaying the view.

Selection Selection of the subwindows

Displayed subwindows

Display of the subwindows that are shown in the view.

Selection Subwindows

Add the selected subwindow to the view.

Remove the selected subwindow from the view.

Move the selected subwindow upward (modifies sequence).

Move the selected subwindow downward (modifies sequence).
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4.1.7.3 Loading a view
Dialog window: Database ▶ View ▶ Load view… ▶ Load view

The Load view dialog window is opened with the  symbol or the
View ▶ Load view… menu item.

Name

Name of the view to be loaded.

[Rename]

Rename the selected view.

[Delete]

Delete the selected view.

[Load]

Load the selected view.

4.1.7.4 Saving a view
Dialog window: Database ▶ View ▶ Save view… ▶ Save view

The Save view dialog window is opened with the  symbol or the
View ▶ Save view... menu item.

Name

Name under which the view is to be saved.

[Rename]

Rename the selected view.

[Delete]

Delete the selected view.

[Save]

Save the view under the given name. The saved views are globally valid
and available for client/server systems.

4.1.7.5 Renaming a view
Dialog window: Database ▶ View ▶ Rename view… ▶ Rename view

To be able to rename a view, open either the Load View or the Save
View dialog window and press the [Rename] button. The Rename
View window is then opened.

Rename view to

Entry of a new name for the view.

Entry 50 characters
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4.1.7.6 Deleting a view
Function: Database ▶ View ▶ Load/Save view… ▶ [Delete]

To be able to delete a view, open either the Load view or Save view
dialog window and press the [Delete] button. The delete procedure must
then be confirmed.

4.2 Database display

4.2.1 Opening a database
Dialog window: Database ▶ File ▶ Open… ▶ Open database

The  symbol or the File ▶ Open… menu item opens the Open data-
base window, in which one of the databases to be opened available on
the server (or on the local server) can be selected.

Database table

The database table contains information concerning all determination
databases. The table cannot be edited. The table can be sorted according
to the selected column (Name, Number of records, Size, Last
backup, Next backup, Comment) in ascending or descending order by
clicking on the column title.

Name

Name of the database.

Number of records

Shows the number of records in the database.

Size

Shows the size of the database in KB.

Editable

Shows whether or not the database can be edited by the user currently
logged in.

Comment

Shows comments about the database.

Opening a database

Database name

Name of the database to be opened. If a database is selected from the
table, the name of the database will be entered automatically in this field.
It can, however, also be entered manually.
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Entry 50 characters

[Open]

Opens the selected database and shows its data records in the determina-
tion overview. The database name is displayed in the title bar of the pro-
gram, the number of currently opened databases is displayed in the left
upper corner of the database symbol.

NOTE

A maximum of 4 databases can be opened, but only 2 can be displayed
at the same time. Databases that are open at the time the program is
exited will be opened automatically the next time the program is
started.

4.2.2 Selecting a database
Program part: Database

The number of currently opened databases is displayed in the upper left
corner of the database symbol. If 2 or more databases are opened, then
these databases, which can be displayed either next to one another or
one above the other in the main window, can be selected with the aid of
the database symbol.

No database is opened. No database loaded is dis-
played in the main window.

A database is opened and is displayed in the main win-
dow.

Two databases are opened. Normally only one database
is displayed in the main window, but the option exists of
displaying two databases at once, either next to one
another or one above the other.
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A menu with the names of all the currently
opened databases is displayed by clicking
on the database symbol with either the left
or right mouse button. The databases dis-
played in the main window are then marked
with a checkmark. Clicking on the desired
database displays it in the main window in
the place of the previously selected one.

4.2.3 Displaying a single database
Menu item: Database ▶ View ▶ Unsplit

In the default settings, the most recently opened database is displayed by
itself in the main window. If the display of two databases is enabled, then

the  symbol or the View ▶ Unsplit menu item can be used to switch
back to the display of just one single database.

4.2.4 Displaying databases next to one another
Menu item: Database ▶ View ▶ Split vertically

Two databases are displayed next to one another in the main window

with the  symbol or the View ▶ Split vertically menu item.

4.2.5 Displaying databases one above the other
Menu item: Database ▶ View ▶ Split horizontally

Two databases can be displayed one below the other in the main window

with the  symbol or the View ▶ Split horizontally menu item.

4.2.6 Closing a database
Menu items: Database ▶ File ▶ Close / Close all

Closing a single database

The  symbol or the File ▶ Close menu item can be used to close the
focused database.

Closing all databases

All the opened databases are closed with the File ▶ Close all menu item.
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4.3 Managing databases

4.3.1 Managing databases
Dialog window: Database ▶ File ▶ Database manager… ▶ Database manager

The  symbol or the File ▶ Database manager… menu item is used to
open the Database manager window, in which a user with correspond-
ing access permission can administer databases.

Database table

The database table contains information concerning all determination
databases. The table cannot be edited. The table can be sorted according
to the selected column (Name, Number of records, Size, Last
backup, Next backup, Comment) in ascending or descending order by
clicking on the column title.

Name

Name of the database.

Number of records

Shows the number of records in the database.

Size

Shows the size of the database in KB.

Last backup

Shows the date and time of the last database backup.

Next backup

Shows the date and the time at which the next backup is to be carried
out.

Comment

Shows comments about the database.

Window menus and functions

The [Edit] menu beneath the database table contains the following menu
items:

New… Creates a new database (see Chapter 5.3.4, page 317).

Delete Deletes the selected database (see Chapter 4.3.4, page 131).

Rename… Rename the selected database (see Chapter 4.3.3, page 130).
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[Properties]

Opens the Database manager window for editing the database selected
in the table (see Chapter 4.3.5.1, page 131).

[Backup]

Opens the Back up database window for backing up the database
selected in the table (see Chapter 4.3.6, page 134).

[Restore]

Opens the Restore databases window for restoring backed-up data-
bases (see Chapter 4.3.7, page 135).

[Close]

Closes the Database manager window.

4.3.2 Creating a new database
Dialog window: Database ▶ File ▶ Database manager… ▶ Database man-
ager ▶ [Edit] ▶ New... ▶ New database

The [Edit] ▶ New... menu item can be used to open the New database
window, in which a name for the new database must be entered.

Name

Name of the new database.

Entry 50 characters
Default value New database #

NOTE

The database name must be unique in the entire client/server system.

Clicking on [OK] opens the Database properties window for editing the
database properties.

4.3.3 Renaming a database
Dialog window: Database ▶ File ▶ Database manager… ▶ Database man-
ager ▶ [Edit] ▶ Rename... ▶ Rename database

The [Edit] ▶ Rename... menu item is used to open the Rename data-
base window for renaming the selected database.

Rename database 'Name' to

Entry of the new database name.

Entry 50 characters
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NOTE

The database name must be unique in the entire client/server system.

4.3.4 Deleting a database
Menu item: Database ▶ File ▶ Database manager… ▶ Database man-
ager ▶ [Edit] ▶ Delete

The [Edit] ▶ Delete menu item is used to delete the selected database.

NOTE

Databases that are open cannot be deleted.

4.3.5 Database properties

4.3.5.1 Database properties - Overview
Dialog window: Database ▶ File ▶ Database manager… ▶ Database man-
ager ▶ [Properties] ▶ Properties - Database - 'Database name'

The properties for a database are set on the following tabs:

￭ General
General information about the database.

￭ Access permissions
Database access permissions for user groups.

￭ Backup
Definition of backup monitoring and automatic backups.

￭ Monitoring
Definition of database monitoring.

4.3.5.2 Database properties - General
Tab: Database ▶ File ▶ Database manager… ▶ Database manager ▶ [Proper-
ties] ▶ Properties - Database - 'Database name' ▶ General

General information about the database.

Comment

Freely definable comments about the database.

Entry 250 characters

Number of records

Shows the number of records in the database.

Size

Shows the size of the database in KB.
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Created

Shows the date and time of the creation of the database.

Created by

Shows the user (short name) who created the database.

Modified

Shows date and time of the last modification of the database properties.

Modified by

Shows the name of the user (short name) who carried out the modifica-
tions.

4.3.5.3 Database properties - Access rights
Tab: Database ▶ File ▶ Database manager… ▶ Database manager ▶ [Proper-
ties] ▶ Properties - Database - 'Database name' ▶ Access rights

Database access permissions for user groups.

User group

Shows the user groups defined in the user administration.

Read

on | off (Default value: on)

Activates/deactivates the permission to open the database. The database
can only be displayed, but not modified (records cannot be deleted or
reprocessed).

Edit

on | off (Default value: off)

Activates/deactivates the permission to edit the database. Records can be
modified or deleted.

NOTE

If access for editing is activated, then access rights for reading will also
automatically be activated. If access for reading is deactivated, then
access rights for editing will also automatically be deactivated.
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4.3.5.4 Database properties - Backup
Tab: Database ▶ File ▶ Database manager… ▶ Database manager ▶ [Proper-
ties] ▶ Properties - Database - 'Database name' ▶ Backup

Definition of backup monitoring and automatic backups.

Backup monitoring

on | off (Default value: off)

Activates/deactivates the backup monitoring for the selected database. If
the Backup monitoring check box is enabled, then the Next backup
field in the database table will be highlighted in red when the interval
time elapses.

Last backup

Shows the date and time of the last database backup.

Next backup

Date on which the next backup must take place. The date can be selected

by pressing  in the Select date dialog window.

Entry Date selection
Default value Last backup + 1 month

Interval

Entry of the interval for the backup monitoring. After each automatically
or manually triggered backup, the interval entered here will be added
automatically to the Last backup and the Next backup field will be
automatically adjusted accordingly.

Input range 1 - 999 
Default value 1 
Selection Days | Weeks | Months | Years
Default value Months

Starting backup automatically

on | off (Default value: off)

Automatic start of the backup for the database in the defined Backup
directory.

Backup directory

Selection of a directory predefined in the Program administration for
the automatic backup.

Selection Selection of the backup directory | Default
backup directory

Default value Default backup directory
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NOTE

Make sure that you have read and write permission for the selected
directory.

4.3.5.5 Database properties - Monitoring
Tab: Database ▶ File ▶ Database manager… ▶ Database manager ▶ [Proper-
ties] ▶ Properties - Database - 'Database name' ▶ Monitoring

Definition of database monitoring.

Monitoring size

on | off (Default value: off)

Activates/deactivates size monitoring for the selected database. If this
check box is activated, then the Size field in the database table will be
shown in red when the limit value has been exceeded. At the same time,
a corresponding message appears when the database is opened.

Maximum size

Maximum permitted database size in MB.

Input range 1 - 2147483647 MB
Default value 500 MB

Monitoring number of records

on | off (Default value: off)

Activates/deactivates the monitoring of the number of records for the
selected database. If this check box is activated then the Number field in
the database table will be shown in red when the limit value has been
exceeded. At the same time, a corresponding message also appears when
the database is opened.

Maximum number

Maximum permitted number of records for database.

Input range 1 - 2147483647 
Default value 1,000 

4.3.6 Backing up database manually
Dialog window: Database ▶ File ▶ Database manager… ▶ Database man-
ager ▶ [Backup] ▶ Database backup

[Backup] is used to open the Backup database dialog window:
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Backup target

Backup directory

Selection of a directory predefined in the Program administration for
the backup.

Selection Selection of the backup directory | Default
backup directory

Default value Default backup directory

NOTE

Make sure that you have read and write permission for the selected
directory.

Backup name

Selection of an already existing name or entry of a new name for the
backup file. If an existing backup file is selected, it will be overwritten.

Entry 50 characters
Default value Backup-##

NOTE

If the backup directory is on a network drive, the backup date should
be added manually to the Backup name because the backup date
information is not available when the data is restored.

[Start]

Starts manual database backup.

4.3.7 Restoring the database
Dialog window: Database ▶ File ▶ Database manager… ▶ Database man-
ager ▶ [Restore] ▶ Restoring databases

[Restore] is used to open the dialog window Restore databases:

Backup directory

Selection of a directory that is predefined in the Program administra-
tion and in which the backed-up databases are located.

Selection Selection of the backup directory | Default
backup directory

Default value Default backup directory
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Backup name

Selection of a backup file.

Selection Selection of backup files

Backup date

Shows the time at which the database was backed up. This information is
not available if the backup file is located on a network drive.

Database name

Shows the name of the database. This information is not available if the
backup file is located on a network drive.

Number of records

Shows the number of records in the database. This information is not
available if the backup file is located on a network drive.

Size

Shows the size of the database in KB.

Save As

Name under which the database is to be restored.

Entry 50 characters
Default value New database ##

[Start]

Starts database restoring. After the start, a progress bar appears in the
window. The dialog window closes automatically once the backup has
been completed.

NOTE

Existing databases cannot be overwritten, i.e. they must first be deleted
so that the database can be restored under its old name.
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4.4 Templates

4.4.1 Report templates

4.4.1.1 Manage report templates

4.4.1.1.1 Report template manager
Dialog window: Database ▶ Tools ▶ Report templates ▶ Manager… ▶ Report tem-
plate manager

The menu item Tools ▶ Report templates ▶ Manager… is used to
open the window Report template manager.

List of report templates

The list of report templates contains information about all the saved
report templates. The table cannot be edited. With a click on the column
title (Column Name, Saved, Saved by, Comment) the table can be
sorted according to the selected column in increasing or decreasing
sequence.

Name

Name of report template.

Saved

Date and time when the report template was saved.

Saved by

Short name of the user who saved the report template.

Comment

Comment on the report template.

Window menus

The menu [Edit] below the list of report templates contains the following
menu items:

Rename… Rename the selected report template (see Chapter 4.4.1.1.2, page 138).

Copy Copy the selected report template(s) (see Chapter 4.4.1.1.3, page 138).

Delete… Delete the selected report template(s) (see Chapter 4.4.1.1.4, page 138).

Export… Export the selected report template(s) (see Chapter 4.4.1.1.5, page 138).

Import… Import report templates (see Chapter 4.4.1.1.6, page 138).
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4.4.1.1.2 Rename report templates
Dialog window: Database ▶ Tools ▶ Report templates ▶ Manager… ▶ Report tem-
plate manager ▶ [Edit] ▶ Rename… ▶ Rename report template

With the menu item Edit ▶ Rename... in the window Report template
manager, the window Rename report template opens for renaming
the selected report template.

Rename report template 'Name' to

Entry of  the new name for the report template.

Entry 50 characters

NOTE

The name of the report template must be unambigous in the whole Cli-
ent/Server system.

4.4.1.1.3 Copy report template
Menu item: Database ▶ Tools ▶ Report templates ▶ Manager... ▶ Report template
manager ▶ [Edit] ▶ Copy

With the menu item Edit ▶ Copy in the window Report template
manager the selected report templates are copied under the name Copy
of 'Report template name'.

4.4.1.1.4 Delete report templates
Menu item: Database ▶ Tools ▶ Report templates ▶ Manager... ▶ Report template
manager ▶ [Edit] ▶ Delete...

With the menu item Edit ▶ Delete... in the window Report template
manager the selected report templates are deleted.

4.4.1.1.5 Export report templates
Dialog window: Database ▶ Tools ▶ Report templates ▶ Manager… ▶ Report tem-
plate manager ▶ [Edit] ▶ Export… ▶ Select directory for export

With the menu item Edit ▶ Export... in the window Report template
manager the selected report templates are each exported in a file with
the name 'Name'.mrep. The window Select directory for export
opens in which the directory for export must be selected.

4.4.1.1.6 Import report templates
Dialog window: Database ▶ Tools ▶ Report templates ▶ Manager… ▶ Report tem-
plate manager ▶ [Edit] ▶ Import… ▶ Select files for import

With the menu item Edit ▶ Import... in the window Report template
manager the dialog window Select files for import opens in which the
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report templates to be imported must be selected. The report templates
are then imported.

4.4.1.2 Create new report template
Menu item: Database ▶ Tools ▶ Report templates ▶ New

New form report

With the menu item Tools ▶ Report templates ▶ New ▶ Form report
the program window Report template - New form report opens with
an empty report template, which can then be edited.

4.4.1.3 Open report template
Dialog window: Database ▶ Tools ▶ Report templates ▶ Open… ▶ Open report
template

With the symbol  or the menu item Tools ▶ Report tem-
plates ▶ Open... the window Open report template opens in which
one of the globally available report templates can be selected and
opened.

List of report templates

The list of report templates contains information about all the saved
report templates. The table cannot be edited. With a click on the column
title (Column Name, Saved, Saved by, Comment) the table can be
sorted according to the selected column in increasing or decreasing
sequence.

Name

Name of report template.

Saved

Date and time when the report template was saved.

Saved by

Short name of the user who saved the report template.

Comment

Comment on the report template.

Open report template

Name

Name of the report template to be opened. If a report template is selected
from the table, the name will be entered automatically in this field. It can
however also be entered manually.

Entry 50 characters
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[Open]

Opens the program window Report template, in which the selected
report template is shown and can be edited.

4.4.1.4 Edit report template

4.4.1.4.1 Report template - General

4.4.1.4.1.1 Report template - Overview
Program window: Database ▶ Report template

Which determination data and which other items (e.g. text fields, images,
graphics elements) are to be produced in a report are defined in report
templates. The templates can be created or edited in their own program
window and then saved globally under a unique name. They are used for
the automatic production of reports in determinations or for manual
report production from the database.

There are two basically different types of report template:

￭ Form report
In the Form report the report section always includes the whole area
between the header and the footer. This means that for each determi-
nation at least one page will always be produced.

￭ Tabular report
In the Tabular report the report section can be set with the mouse. For
each data set one such report section will be filled with data and
placed on the page row by row. In this way tabular reports can be cre-
ated from several determinations.

4.4.1.4.1.2 Report template - Desktop
Program window: Database ▶ Report template

Elements

The desktop of the program window Report template has the following
elements:

￭ Menu bar
￭ General toolbar
￭ Module-specific toolbar
￭ Module bar
￭ Main window
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4.4.1.4.1.3 Report template - Menu bar

4.4.1.4.1.3.1 Report template - Main menu 
Program window: Database ▶ Report template

The menu bar in the program window Report template has the follow-
ing main menu items:

￭ File
Save report template, page setup, page preview, close window.

￭ Edit
Undo, redo, cut, copy, paste, delete, enter comment.

￭ View
Update view, page navigation.

￭ Insert
Insert pages.

￭ Tools
Options.

￭ Help
Open Program Help.

4.4.1.4.1.3.2 Report template - Menu File
Program window: Database ▶ Report template

Save Save an opened report template (see Chapter 4.4.1.4.2.11, page 153).

Save as Save an opened report template under a new name (see Chapter 4.4.1.4.2.11,
page 153).

Page setup... Set up the layout for the report template (see Chapter 4.4.1.4.2.2, page 145).

Page preview Set up the layout for the report template (see Chapter 4.4.1.4.2.8, page 151).

Exit Close the program window Report template.

4.4.1.4.1.3.3 Report template - Menu Edit
Program window: Database ▶ Report template

Undo: Undo the last action.

Restore: Restore the undone action.

Cut Cut selected items and copy them to the clipboard (see Chapter 4.4.1.4.2.6,
page 149).

Copy Copy the selected items to the clipboard (see Chapter 4.4.1.4.2.6, page 149).
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Insert Insert marked items from the clipboard (see Chapter 4.4.1.4.2.6, page 149).

Delete Delete the marked items (see Chapter 4.4.1.4.2.6, page 149).

Comment Enter comments on the report template (see Chapter 4.4.1.4.2.9, page 152).

4.4.1.4.1.3.4 Report template - Menu View
Program window: Database ▶ Report template

Update Update the view.

First page Show the first page of the report template (see Chapter 4.4.1.4.2.4, page 148).

Previous page Show the previous page of the report template (see Chapter 4.4.1.4.2.4, page
148).

Next page Show the next page of the report template (see Chapter 4.4.1.4.2.4, page
148).

Last page Shows the last page of the report template (see Chapter 4.4.1.4.2.4, page
148).

4.4.1.4.1.3.5 Report template - Menu Insert
Program window: Database ▶ Report template

Page before Insert a new page in front of the shown page (see Chapter 4.4.1.4.2.4, page
148).

Page after Inserts a new page after the shown page (see Chapter 4.4.1.4.2.4, page 148).

4.4.1.4.1.3.6 Report template - Menu Tools
Program window: Database ▶ Report template

Options... Set options for the report template (see Chapter 4.4.1.4.2.10, page 152).

4.4.1.4.1.3.7 Report template - Menu Help
Program window: Database ▶ Report template

tiBase Help Open tiBase help.
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4.4.1.4.1.4 Report template - General toolbar 
Program window: Database ▶ Report template

Save Save an opened report template (see Chapter 4.4.1.4.2.11, page 153).

Page preview Set up the layout for the report template (see Chapter 4.4.1.4.2.8, page 151).

Print (PDF)… Show the report template with the data of the selected determination as a PDF-
file.

Undo: Undo the last action.

Restore: Restore the undone action.

Cut Cut selected items and copy them to the clipboard (see Chapter 4.4.1.4.2.6,
page 149).

Copy Copy the selected items to the clipboard (see Chapter 4.4.1.4.2.6, page 149).

Insert Insert marked items from the clipboard (see Chapter 4.4.1.4.2.6, page 149).

Delete Delete the marked items (see Chapter 4.4.1.4.2.6, page 149).

Select zoom level (see Chapter 4.4.1.4.2.7, page 150).

Grid Switch the grid display on and off (see Chapter 4.4.1.4.2.10, page 152).

Snap to grid Switch snap at grid on and off (see Chapter 4.4.1.4.2.10, page 152).

4.4.1.4.1.5 Report template - Module-specific toolbar 
Program window: Database ▶ Report template

Depending on the module selected in the report template, other symbols
and input fields are shown below the general toolbar, with which the
properties of these modules can be directly edited (see Chapter
4.4.1.4.1.6, page 143).

4.4.1.4.1.6 Report template - Module bar 
Program window: Database ▶ Report template

Select modules If this option is enabled then modules in the report template can be selected,
reduced/enlarged and moved (see Chapter 4.4.1.4.2.6, page 149).
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Text field If this option is enabled then text fields can be inserted in the report template
(see Chapter 4.4.1.4.3.1, page 154).

Data field If this option is enabled then data fields can be inserted in the report template
(see Chapter 4.4.1.4.3.2, page 156).

Date field If this option is enabled then date fields can be inserted in the report template
in which the actual date is entered (see Chapter 4.4.1.4.3.3, page 158).

Time field If this option is enabled then time fields can be inserted in the report template
in which the actual time is entered (see Chapter 4.4.1.4.3.4, page 159).

Page number If this option is enabled then fields can be inserted in the report template in
which the page number is entered (see Chapter 4.4.1.4.3.5, page 161).

Number of pages If this option is enabled then fields can be inserted in the report template in
which the number of pages is entered (see Chapter 4.4.1.4.3.6, page 163).

Fixed report If this option is enabled then fixed reports can be inserted in the report tem-
plate (see Chapter 4.4.1.4.3.7, page 164).

Group field If this option is enabled then group fields can be inserted in the report tem-
plate (see Chapter 4.4.1.4.3.8, page 166).

Image If this option is enabled then images can be inserted in the report template (see
Chapter 4.4.1.4.3.9, page 167).

Line If this option is enabled then lines can be inserted in the report template (see
Chapter 4.4.1.4.3.10, page 168).

Rectangle If this option is enabled then rectangles can be inserted in the report template
(see Chapter 4.4.1.4.3.11, page 169).

Curve If this option is enabled then curves can be inserted in the report template (see
Chapter 4.4.1.4.3.12, page 170).

Calibration curve If this option is enabled then calibration curves can be inserted in the report
template (see Chapter 4.4.1.4.3.13, page 172).
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4.4.1.4.2 Report template - Functions

4.4.1.4.2.1 Report template - Function overview
Program window: Database ▶ Report template

In the program window Report template the following functions can be
executed:

￭ Page setup
￭ Define sections in main window
￭ Insert report pages
￭ Insert modules
￭ Edit modules
￭ Zooming
￭ Show page preview
￭ Enter comment on report template
￭ Define options for report template
￭ Save report template

4.4.1.4.2.2 Report template - Page setup 
Dialog window: Report template ▶ File ▶ Page setup… ▶ Page setup

With the menu item File ▶ Page setup... in the window Report tem-
plate the dialog window Page setup opens in which the report format
settings can be made.

General

only for form report

Settings

Selection Apply to current page | Apply to all pages
Default value Apply to current page

Apply to current page
The page settings are only applied for the currently selected report
page.

Apply to all pages
The page settings are applied for all report pages.

Page format

Page format

Selection of the page format. The width and height of the paper can be
defined with User-defined.

Selection A4 | Letter | Legal | User-defined
Default value A4
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Width

Width of the page format. This parameter can only be edited for Page
format= User-defined

Input range 0.0 - 499.0 mm
Default value 210.0 mm

Height

Height of the page format. This parameter can only be edited for Page
format= User-defined

Input range 0.0 - 499.0 mm
Default value 297.0 mm

Orientation

Selection of the page format.

Selection Portrait | Landscape
Default value Portrait

Page margins

Top

Upper page margin.

Input range 0.0 - 499.0 mm
Default value 15.0 mm

Bottom

Lower page margin.

Input range 0.0 - 499.0 mm
Default value 15.0 mm

Left

Left-hand page margin.

Input range 0.0 - 499.0 mm
Default value 20.0 mm

Right

Right-hand page margin.

Input range 0.0 - 499.0 mm
Default value 20.0 mm
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Layout

Header

Height of header.

Input range 0.0 - 499.0 mm
Default value 15.0 mm

Footer

Height of footer.

Input range 0.0 - 499.0 mm
Default value 15.0 mm

Determination height

Height of the section for a single determination on a tabular report.

only for tabular report
Input range 0.0 - 499.0 mm
Default value 25.0 mm

4.4.1.4.2.3 Report template - Define sections 
Program window: Database ▶ Report template

Define sections for form report

The header, footer and report sections can be enlarged and reduced with
the left mouse button.

Defining sections for tabular report

The header, footer and report sections can be enlarged and reduced with
the left mouse button.
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4.4.1.4.2.4 Report template - Insert pages 
Menu item: Report template ▶ Insert ▶ Page before / Page after

NOTE

It is not possible to insert pages in templates for tabular reports.

Inserting page before

With the menu item Insert ▶ Page before in the program window
Report template a new empty report report page is inserted before the
report page shown.

Insert page after

With the menu item Insert ▶ Page after in the program window
Report template a new empty report report page is inserted after the
report page shown.

Navigating

In report templates with several pages the navigation bar can be used to
switch to the required page.

Jumps to first page.

Jumps to previous page.

Jumps to next page.

Jumps to last page.
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4.4.1.4.2.5 Report template - Insert modules 
Program window: Database ▶ Report template

In order to insert a module in a report template the corresponding symbol
must be selected on the module bar and then placed on the report tem-
plate by creating a field with the left mouse button. The Properties win-
dow of the corresponding module then opens automatically.

Form report

The following modules can be inserted in a form report:

￭ Header
Text field, Data field, Date field, Time field, Page number, Number of
pages, Image, Line, Rectangle, Curve, Calibration curve

￭ Report section
Text field, Data field, Date field, Time field, Fixed report, Group field,
Image, Line, Rectangle, Curve, Calibration curve

￭ Footer
Text field, Data field, Date field, Time field, Page number, Number of
pages, Image, Line, Rectangle, Curve, Calibration curve

Tabular report

The following modules can be inserted in a tabular report:

￭ Header
Text field, Date field, Time field, Page number, Number of pages,
Image, Line, Rectangle

￭ Report section
Text field, Data field, Date field, Time field, Group field, Image, Line,
Rectangle,

￭ Footer
Text field, Date field, Time field, Page number, Number of pages,
Image, Line, Rectangle

4.4.1.4.2.6 Report template - Edit modules 
Program window: Database ▶ Report template

Enable selection

This symbol in the Module bar must be switched on in order to be able to
select modules in a report template for editing.

Select a single module

Single modules are selected with a click of the left mouse button. This
automatically shows the corresponding properties of the module below
the toolbar.
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Select several modules

Several modules are selected by drawing a frame around the required
modules with the left mouse button.

Moving, reducing, enlarging modules

When this cursor symbol appears then the selected modules can be
moved about on the report template with the left mouse button pressed
down.

  
When one of these cursor symbols appears then the selected modules can
be reduced and enlarged respectively on the report template with the left
mouse button pressed down.

Cutting, copying, pasting, deleting modules

Cut the selected modules and copy them to the clipboard.

Copy the selected modules to the clipboard.

Paste modules from the clipboard.

Delete the selected module.

Edit module properties

Open the properties window for the selected module. Alternatively the
properties can also be edited directly below the toolbar.

4.4.1.4.2.7 Report template - Zoom
Program window: Database ▶ Report template

With this list box on the toolbar the required zoom step for showing the
report template can be selected in steps of 25% from 25% to 400%.
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4.4.1.4.2.8 Report template - Page preview 
Preview window: Report template ▶ File ▶ Page preview ▶ Report preview

With the symbol  or the menu item File ▶ Page preview in the pro-
gram window Report template the window Report preview opens in
which a page preview of the report template is shown with the data of
the determinations selected in the determination overview.

Functions

Produces displayed report as PDF-file.

Selects the required zoom step for displaying the report preview, range
25% to 400% in steps of 25%.

Select report page

In report templates with several pages the navigation bar Page can be
used to switch to the required page.

Jumps to first page.

Jumps to previous page.

Jumps to next page.

Jumps to last page.

Selecting determination

If several determinations have been selected for the report display then
the navigation bar Determination can be used to switch to the required
determination.

Jumps to first determination.

Jumps to previous determination.

Jumps to next determination.
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Jumps to last determination. 

4.4.1.4.2.9 Report template - Comment
Dialog window: Report template ▶ Edit ▶ Comment ▶ Comment

With the symbol  or the menu item Edit ▶ Comment in the program
window Report template the window Comment on report template
opens in which comments on the opened report template can be entered.

Comment

Enter comment on the report template that is shown in the List of report
templates.

Entry 1000 characters

4.4.1.4.2.10 Report template - Options 
Dialog window: Report template ▶ Tools ▶ Options...

With the menu item Tools, Options in the program window Report
template the window Options for report templates opens in which
various settings for the report template can be defined.

Unit

Unit

Select the size unit for the report template.

Selection mm | cm | inch
Default value mm

Grid

X distance

Grid distance in X-direction.

Input range 1.0 - 100.0 mm
Default value 5.0 mm

Y distance

Grid distance in Y-direction.

Input range 1.0 - 100.0 mm
Default value 5.0 mm

Display grid

on | off (Default value: off)

Enable/Disable the grid display on the report template.
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Snap at grid

on | off (Default value: off)

Enable/Disable snapping at grid on the report template.

Default font

Font

Select the default font for the report templates.

Selection Arial | Windows fonts
Default value Arial

4.4.1.4.2.11 Report template - Save
Dialog window: Report template ▶ File ▶ Save/Save as ▶ Save report template

With the symbol  or the menu item File ▶ Save an existing opened
report template will be saved again under its own name without opening
the window Save report template.

When saving a newly created report template with the menu item
File ▶ Save or when saving an existing report template with the menu
item File ▶ Save as the window Save report template opens in which
a name for the report template can be entered or selected.

List of report templates

The list of report templates contains information about all the saved
report templates. The table cannot be edited. With a click on the column
title (Column Name, Saved, Saved by, Comment) the table can be
sorted according to the selected column in increasing or decreasing
sequence.

Name

Name of report template.

Saved

Date and time when the report template was saved.

Saved by

Short name of the user who saved the report template.

Comment

Comment on the report template.
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Save report template

Name

Name under which the report template is to be saved.

Entry 50 characters

NOTE

The name of the report template must be unambigous in the whole Cli-
ent/Server system.

[Save]

Save the report template under the required name.

4.4.1.4.3 Report template - Modules

4.4.1.4.3.1 Report template - Text field 
Program window: Database ▶ Report template

Text fields are used for showing any texts in the report.

Insert

In order to insert a text field into a report template the corresponding
symbol must be selected on the Module bar and placed on the report
template by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of image field.

Input range 0.0000 - (max. page width) mm
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Height

Height of image field.

Input range 0.0000 - (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.

Bold.

Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Switches line break on/off for multi-line text fields.

Fills the field with dots.

Text

Entry of text for the text field.
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4.4.1.4.3.2 Report template - Data field 
Program window: Database ▶ Report template

Data fields are used for showing determination data in a report.

Insert

In order to insert a data field into a report template the corresponding
symbol must be selected on the Module bar and placed on the report
template by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of data field.

Input range 0.0000 - (max. page width) mm

Height

Height of data field.

Input range 0.0000 - (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.

Bold.
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Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Switches line break on/off for multi-line data fields.

Fills the field with dots.

Prefix

Text placed in front of the data field contents.

Entry 50 characters

Data field

Shows path and name of selected data field (the field cannot be edited

directly). With  a window opens for selecting the data field in which all
the available fields for the determination overview are shown in a tree
structure. With a double-click on the required field the path and name of
the data field are entered.

Suffix

Text placed after the data field contents.

Entry 50 characters

Preview

Shows a formatted example of text.
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4.4.1.4.3.3 Report template - Date field 
Program window: Database ▶ Report template

Date fields are used for showing the current date in a report.

Insert

In order to insert a date field into a report template the corresponding
symbol must be selected on the Module bar and placed on the report
template by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of date field.

Input range 0.0000 - (max. page width) mm

Height

Height of date field.

Input range 0.0000 - (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.

Bold.
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Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Fills the field with dots.

Prefix

Text placed in front of the date field contents.

Entry 50 characters

Suffix

Text placed after the date field contents.

Entry 50 characters

Sample

Shows the formatted date.

4.4.1.4.3.4 Report template - Time field 
Program window: Database ▶ Report template

Time fields are used for showing the actual time in the report.

Insert

In order to insert a time field in a report template the corresponding sym-
bol must be selected on the Module bar and then placed on the report
template by creating a field with the left-hand mouse key.
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Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of time field.

Input range 0.0000 - (max. page width) mm

Height

Height of time field.

Input range 0.0000 - (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.

Bold.

Italic.

Underlined.

Left-justified.

Centered.
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Right-justified.

Fills the field with dots.

Prefix

Text placed in front of the contents of the time field.

Entry 50 characters

Suffix

Text to be placed after the contents of the time field.

Entry 50 characters

Preview

Shows the formatted time.

4.4.1.4.3.5 Report template - Page number 
Program window: Database ▶ Report template

The actual page number in the report is produced in a page number field.

Insert

In order to insert page number field into a report template the corre-
sponding symbol must be selected on the Module bar and then placed in
the header or footer of the report template by creating a field with the
left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of the page number field.

Input range 0.0000 - (max. page width) mm
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Height

Height of the page number field.

Input range 0.0000 - (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.

Bold.

Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Fills the field with dots.

Prefix

Text placed in front of the page number field.

Entry 50 characters

Suffix

Text placed after the page number field.

Entry 50 characters
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Preview

Shows the formatted page number.

4.4.1.4.3.6 Report template - Number of pages 
Program window: Database ▶ Report template

This field shows the total number of pages in the report.

Insert

In order to insert a number of pages field into a report template, the cor-
responding symbol must be selected on the Module bar and then placed
in the header or footer of the report template by creating a field with the
left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of the field.

Input range 0.0000 - (max. page width) mm

Height

Height of the field.

Input range 0.0000 - (max. page height) mm

Selection of the available Windows fonts.

Font size in pt.

Color selection.
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Bold.

Italic.

Underlined.

Left-justified.

Centered.

Right-justified.

Fills the field with dots.

Prefix

Text placed in front of the field contents.

Entry 50 characters

Suffix

Text placed after the field contents.

Entry 50 characters

Preview

Shows the formatted number of pages.

4.4.1.4.3.7 Report template - Fixed report 
Program window: Database ▶ Report template

Fixed reports are used for producing predefined part-reports of the deter-
mination in the report.

Insert

In order to insert a fixed report in a report template the corresponding
symbol must be selected on the Module bar and then placed on the
report template by creating a field with the left mouse button.
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Properties

X pos.

Shows the predefined x-position for the fixed report.

Y pos.

Y position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Shows the predefined width of the fixed report.

Height

Height of fixed report.

Input range 0.0000 - (max. page height) mm

Fixed report

Selection of a predefined fixed report.

Selection Calculations | Calibration data | Curves | Mes-
sages | List of meas. points | Result list | Raw
data (endpoints) | Standard addition | Statis-
tics data (brief) | Statistics data (full) | Signa-
ture list Determination | Signature list
Method | Variables | Devices used | Common
variables used | Solutions used | Sensors used

Default value Calculations

Command name

Name of the command for which a curve, a calibration curve or a measur-
ing point list is to be produced. With not defined, the lists for all curves
present in the determination will be produced as default.

This parameter appears only as editable field when Fixed report =
Curve, Calibration curve or Measuring point list.

Entry 50 characters
Selection not defined
Default value not defined
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4.4.1.4.3.8 Report template - Group field
Program window: Database ▶ Report template

A group field is for the purpose of grouping together a variety of fields in
the report template. All of the fields gathered together in a group field
can be moved together as a group. The group field prevents a page break
inside the group field.

The group field always extends across the entire width of a page; only the
upper edge (Y value) and the height of the field can be configured.

NOTE

The following fields, which do not permit page break controls, cannot
be inserted into a group field.

￭ Fixed report
￭ Curve
￭ Calibration curve

Insert

In order to insert group field into a report template the corresponding
symbol must be selected on the Module bar and placed on the report
template by creating a field with the left-hand mouse key.

Properties

X pos.

Shows the predefined x-position for the field.

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Shows the predefined width of the fixed report.

Height

Height of the field

Input range 0.0000 - (max. page height) mm
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4.4.1.4.3.9 Report template - Image 
Program window: Database ▶ Report template

An image field is used for including any external graphics on the report
template. The file formats *.jpg and *.gif are supported.

Insert

In order to insert an image into a report template the corresponding sym-
bol must be selected on the Module bar and placed on the report tem-
plate by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of image field.

Input range 0.0000 - (max. page width) mm

Height

Height of image field.

Input range 0.0000 - (max. page height) mm

Graphics file

Shows path and name of the selected graphics file (the field cannot be

edited directly). With  a window opens for selecting the graphics file.
The path and name of the graphics file are then entered.

Size

Entry how the image is to be displayed.

Selection original | proportional | non-proportional
Default value original

original
Original size.
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proportional
Proportional enlargement or diminishment.

non-proportional
Non-proportional enlargement or diminishment.

4.4.1.4.3.10 Report template - Line 
Program window: Database ▶ Report template

Any line can be inserted in the report template.

Insert

In order to insert a line in a report template the corresponding symbol
must be selected on the Module bar and then placed on the report tem-
plate by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Length

Length of the line.

Input range 0.0 - (max. page width) mm

Angle

Angle of the line.

Input range 0 - 360.000 °

Thickness

Thickness of the line.

Input range 0.1 - 10.0 mm
Default value 0.5 mm

Selection of the line color.
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Selection of the type of line.

4.4.1.4.3.11 Report template - Rectangle 
Program window: Database ▶ Report template

Any rectangle can be inserted in the report template.

Insert

In order to insert a rectangle into a report template the corresponding
symbol must be selected on the Module bar and placed on the report
template by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of the rectangle.

Input range 0.0000 - (max. page width) mm

Height

Height of the rectangle.

Input range 0.0000 - (max. page height) mm

Thickness

Thickness of the line for the rectangle.

Input range 0.1 - 10.0 mm
Default value 0.5 mm

Selection of the line color.
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Selection of the type of line for the rectangle.

Switches the fill color on and off.

Selection of the fill color.

4.4.1.4.3.12 Report template - Curve field 
Program window: Database ▶ Report template

Curve fields are used for showing determination curves in the report.

Insert

In order to insert a curve in a report template the corresponding symbol
must be selected on the Module bar and then placed on the report tem-
plate by creating a field with the left mouse button.

Properties

NOTE

The properties are saved individually for each curve field. This means
that it is possible, e.g., to show several different curves for the same
measuring command beside one another in several curve fields.

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of curve field.

Input range 0.0000 - (max. page width) mm

Height

Height of curve field.
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Input range 0.0000 - (max. page height) mm

Command type

Shows the command type for which a curve is to be produced.

Selection DET | MET | SET | MEAS | KFT | KFC | BRC |
 STAT | DOS

Default value DET

Command name

Name of the command for which the curve is to be produced. With not
defined all curves present in the determination with the selected Com-
mand type will be produced as default.

NOTE

In the command name, the index in the format .# must be specified
additionally (e.g. Chloride.1).

Selection not defined | 50 characters
Default value not defined

Autoscaling

on | off (Default value: on)

If this check box is activated, all axes in the curve window are scaled auto-
matically. In this case the fields Start value and End value cannot be
edited.

Tabs

Additional properties for the curve field can be set on the following 4
tabs:

￭ x axis
Parameters for the graphical display of the curve on the x axis.

￭ y1 axis
Parameters for the graphical display of the curve on the y1 axis (left-
hand y axis).

￭ y2 axis
Parameters for the graphical display of the curve on the y2 axis (right-
hand y axis).

￭ Options
Options for graphical display of curves.
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4.4.1.4.3.13 Report template - Calibration curve field
Program window: Database ▶ Report template

Calibration curve fields are used for showing calibration or standard addi-
tion curves in the report.

Insert

In order to insert calibration curve field into a report template the corre-
sponding symbol must be selected on the Module bar and placed on the
report template by creating a field with the left-hand mouse key.

Properties

X pos.

x-position within the permitted section.

Input range 0.0000 - (max. page width) mm

Y pos.

y-position within the permitted section.

Input range 0.0000 - (max. page height) mm

Width

Width of calibration curve field.

Input range 0.0000 - (max. page width) mm

Height

Height of calibration curve field.

Input range 0.0000 - (max. page height) mm

Command name

Entry of the name of the command for which the calibration curve is to be
produced. With not defined the first calibration curve present in the
determination with the selected Command type will be produced as
default.

Selection not defined | 50 characters
Default value not defined
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4.4.2 Curve overlay templates

4.4.2.1 Manage curve overlay templates
Menu item: Database ▶ Tools ▶ Templates ▶ Curve overlay templates

With the menu item Tools, Templates, Curve overlay templates the
dialog window Curve overlay templates opens in which the globally
available templates for curve overlay can be managed.

Template table

The table with the defined templates cannot be edited, although it can be
sorted according to the selected column in increasing or decreasing
sequence by clicking on the column title

Template name

Shows the name of the template.

Command type

Shows the command type for which the template can be used.

Comment

Shows the comments about the template.

Functions

[New]

Generates a new template. The dialog window Properties - Overlay
curves opens in which the properties for the new template can be
defined.

[Properties]

Open the dialog window Properties - Overlay curves in which the
properties of the template selected in the table can be edited.

[Delete]

Delete the template selected in the table.

[Copy]

Copy the template selected in the table and save it under the name Copy
of....
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4.4.2.2 Edit curve overlay templates

4.4.2.2.1 Curve overlay - Properties
Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay tem-
plates... ▶ Curve overlay templates ▶ [Properties] ▶ Properties - Overlay curves -
'Name'

Template name

Name for the curve overlay template which is saved in the configuration
database per client.

Entry 50 characters

Command type

Selection of the command type from which curves are to be overlaid.

Selection DET pH | DET U | DET Ipol | DET Upol | MET
pH | MET U | MET Ipol | MET Upol | SET pH |
 SET U | SET Ipol | SET Upol | STAT pH | STAT
U | DOS pH | DOS U | KFT Ipol | KFT Upol |
 KFC | BRC | MEAS pH | MEAS U | MEAS Ipol |
 MEAS Upol | MEAS T | MEAS Conc | MEAS
Cond | CAL MEAS pH | CAL MEAS Conc | CAL
Cond

Default value DET pH

Autoscaling

on | off (Default value: on)

If this check box is activated, then the. In this case the fields Start value
and End value cannot be edited.

Tabs

Further properties of a template for the overlaying of curves can be set on
the following 4 tabs:

￭ x axis
Parameters for the graphical display of the overlaid curves on the x
axis.

￭ y axis
Parameters for the graphical display of the overlaid curves on the y
axis.

￭ Options
Options for the graphical display of the overlaid curves.

￭ Comment
Enter comment on the template.
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4.4.2.2.2 Curve overlay - x axis
Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay tem-
plates... ▶ Curve overlay templates ▶ [Properties] ▶ Properties - Overlay curves -
'Name'

Parameters for the graphical display of the overlaid curves on the x axis.

x axis

Size

Selection of the quantity to be shown on the x axis.

Selection Command-dependent selection

Label

Freely definable axis label for the x axis. With auto the designation from
the field Size will be used.

Entry 25 characters
Default value auto

Scaling

Start value

Initial value for scaling the x axis.

Input range -1.0 E12 - 1.0 E12 
Default value 0.0 

End value

End value for scaling the x axis.

Input range -1.0 E12 - 1.0 E12 
Default value 1000.0 

4.4.2.2.3 Curve overlay - y axis
Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay tem-
plates... ▶ Curve overlay templates ▶ [Properties] ▶ Properties - Overlay curves -
'Name'

Parameters for the graphical display of the overlaid curves on the y axis.

y axis

Size

Selection of the quantiy to be shown on the y axis.

Selection Command-dependent selection
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Label

Freely definable axis label for the y axis. With auto the designation from
the field Size will be used.

Entry 25 characters
Default value auto

Display measuring points

on | off (Default value: on)

If this check box is activated then the individual measuring points will be
shown on the curve.

NOTE

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols
again.

Scaling

Start value

Initial value for scaling the y-axis.

Input range -1.0 E12 - 1.0 E12 
Default value 0.0 

End value

End value for scaling the y-axis.

Input range -1.0 E12 - 1.0 E12 
Default value 1000.0 

4.4.2.2.4 Curve overlay - Options
Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay tem-
plates... ▶ Curve overlay templates ▶ [Properties] ▶ Properties - Overlay curves -
'Name'

Options for the graphical display of the overlaid curves.

Display grid

on | off (Default value: off)

If this check box is actjvated then a grid will be shown against the back-
ground.
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Grid type

Selection of the type of grid line.

Selection Select line type

Grid color

Selection of the grid line color.

Selection Color selection | gray
Default value gray

Show endpoints

on | off (Default value: off)

If this check box is activated then the endpoints found will be indicated on
the curve by the symbol ♦ and labeled with EP# (potentiometric end-
points), BP# (break point) or FP# (fixed endpoint).

Automatic EPs

Selection of the color for automatically set endpoints.

Selection Color selection | black
Default value black

Manual EPs

Selects the color for manually set endpoints.

Selection Color selection | pink
Default value pink

Background

Background color

Selection of the color for the curve background.

Selection Color selection | white
Default value white

Legend

Display of the data field, which is shown in the legend to identify the
curves.

Open the dialog window Legend - Field selection for selecting the data
field.
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Multiple curves of the same command

Setting, which curves are displayed when the command has been run sev-
eral times, e.g. because of a LOOP command or a multiple call of a
Track.

Selection Show only last curve | Show all curves
Default value Show only last curve

Show only last curve
Only the curve generated during the last run of the command is dis-
played.

Show all curves
The curves of all runs of the command are displayed.

4.4.2.2.5 Curve overlay - Comment
Dialog window: Database ▶ Tools ▶ Templates ▶ Curve overlay tem-
plates... ▶ Curve overlay templates ▶ [Properties] ▶ Properties - Overlay curves -
'Name'

Entry of comment on the curve overlay template.

Comment

Comment on control chart.

Entry 1000 characters

4.4.3 Templates for control chart

4.4.3.1 Managing control chart templates
Menu item: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Control
chart templates

With the menu item Tools ▶ Templates ▶ Control chart templates...,
the dialog window Control chart templates opens in which the globally
available templates for control charts can be managed.

Template table

The table with the defined templates cannot be edited, although it can be
sorted according to the selected column in increasing or decreasing
sequence by clicking on the column title

Template name

Shows the name of the template.

Comment

Shows the comments about the template.
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Functions

[New]

Create new template. The dialog window Properties - Control chart
template opens in which the properties for the new template can be
defined.

[Properties]

The dialog window Properties - Control chart template opens, in
which the properties of the template selected in the table can be edited.

[Delete]

Delete template.

[Copy]

Copies the template and saves it under the name Copy of....

4.4.3.2 Editing control chart templates

4.4.3.2.1 Control chart template - Properties
Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Con-
trol chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Template name

Name for the control chart template which is saved in the configuration
database per client.

Entry 50 characters

Tabs

The properties of a control chart template can be set on the following 4
tabs:

￭ Graphical parameters
Parameters for the graphical display of the control chart.

￭ Limits
Definition of warning and intervention limits for the control chart.

￭ Statistics
Display of statistics data on the control chart.

￭ Comment
Enter comment on the template.

4.4.3.2.2 Control chart template - Graphical parameters
Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Con-
trol chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Parameters for the graphical display of the control chart.
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y axis

Result

Selection of the result column whose value is to be shown on the y axis.

Selection RS01 | RS02 | RS03 | RS04 | RS05 | RS06 |
 RS07 | RS08 | RS09 | RS10 | RS11 | RS12 |
 RS13 | RS14 | RS15 | RS16 | RS17 | RS18 |
 RS19 | RS20 | RS21 | RS22 | RS23 | RS24 | RS25

Default value RS01

Label

Freely definable axis label for the y axis.

Entry 25 characters
Default value Result

Background

Background color

Selection of the background color for the control chart.

Selection Color selection | white
Default value white

Measured values

Shape

Selection of the symbol for the display of the measured values.

Selection Symbol selection | •
Default value •

Color

Selection of the color for the measuring point symbol.

Selection Color selection | blue
Default value blue

Link measured values

on | off (Default value: off)

If this check box is activated, then the measured value points will be
joined by a line.
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4.4.3.2.3 Control chart template - Limit values
Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Con-
trol chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Definition of warning and intervention limits to be shown on the control
chart.

Warning limits

Warning limits are always in orange on the control chart.

Lower limit

Lower warning limit.

Entry 10 digits
Input range -1.0E8 - 1.0E8 (max. 10 digits) 

Upper limit

Upper warning limit.

Entry 10 digits
Input range -1.0E8 - 1.0E8 (max. 10 digits) 

Intervention limits

Intervention limits are displayed in red on the control chart.

Lower limit

Lower intervention limit.

Entry 10 digits
Input range -1.0E8 - 1.0E8 (max. 10 digits) 

Upper limit

Upper intervention limit.

Entry 10 digits
Input range -1.0E8 - 1.0E8 (max. 10 digits) 

4.4.3.2.4 Control chart template - Statistics
Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Con-
trol chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Definition of the display of statistics data on the control chart.

Show the statistics data

on | off (Default value: on)

If this check box is activated, then below the graph the statistics data for
Mean value, Standard deviation, Number of measuring points and
Minimum and maximum values will be shown.
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Draw in mean value

on | off (Default value: on)

If this check box activated, then the Mean value will be shown on the
control chart as a continuous line in the color of the measured value.

Draw in standard deviation

on | off (Default value: on)

If this check box is activated, then the two values Mean value + Abso-
lute standard deviation and Mean value - Absolute standard devi-
ation will be shown on the control chart as dotted lines in the color of
the measured value.

4.4.3.2.5 Control chart template - Comment
Dialog window: Database ▶ Tools ▶ Templates ▶ Control chart templates... ▶ Con-
trol chart templates ▶ [Properties] ▶ Properties - Control chart - 'Name'

Entry of comment on the control chart template.

Comment

Comment on control chart.

Entry 1000 characters

4.4.4 Export templates

4.4.4.1 Export templates manager
Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export
templates

With the menu item Tools ▶ Templates ▶ Export templates, the dia-
log window Export templates opens in which the globally available
templates for manual or automatic export of determination data can be
managed.

Template table

The table with the defined templates cannot be edited, although it can be
sorted according to the selected column in increasing or decreasing
sequence by clicking on the column title

Name

Shows the name of the export template.

File type

Shows the file format of the export template for data export.
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Comment

Shows the comment on the export template.

Functions

[New]

Creates a new export template. The dialog window Export template
opens in which the properties for the new template can be defined.

[Properties]

The dialog window Export template opens, in which the properties of
the template selected in the table can be edited.

[Delete]

Delete the selected export template.

[Copy]

Copies the selected export template and saves under the name Copy
of….

4.4.4.2 Edit export templates

4.4.4.2.1 Export template - Properties
Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export
templates ▶ [Properties] ▶ Export template 'Name'

[Properties] is used to open the dialog window Export template
'Name' in which the properties of the selected export template can be
edited.

Name

Name of export template.

Entry 50 characters

Comment

Freely definable comment on the export template.

Entry 250 characters

Target directory

Entry or selection (with ) of the path for the folder in which the export
file is to be saved.

Entry 1000 characters

File type

Selection of the file format for data export:
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Selection *.tdet (tiBase format) | *.csv (comma-separa-
ted) | *.slk (SLK format) | *.xml (XML format) |
 *.csv (measuring point list)

Default value *.tdet (tiBase format)

*.tdet (tiBase format)
Program-specific data exchange format that can only be imported into
other tiBase 1.1 Patch 1 databases.

*.csv (comma-separated)
Data exchange format with unformatted text that can be imported into
other PC programs (e.g. Excel, Access).

*.slk (SLK format)
Data exchange format with formatted text that can be imported into
other PC programs (e.g. Excel).

*.xml (XML format)
Data exchange format with XML code that can be imported into corre-
sponding PC programs.

*.csv (measuring point list)
Data exchange format for the measuring point list with unformatted
text, which can be imported into corresponding PC programs. The text
file contains a document header with date/time of the determination
and the determination ID, then the measuring point lists of the sepa-
rate commands are listed one after the other. The command name is
listed first for each measuring point list, followed by a header with the
designations and the units of the measured values of the command.
This is followed by the list of the measuring points, each measuring
point is listed in a separate line and consists of a time indication and all
measured values generated by the command.

[Select fields]

Opens the dialog window Select fields in which the required fields for
export can be selected, arranged in the required sequence and renamed.

NOTE

Field selection is only possible for the file types *.csv and *.slk. With
*.tdet and *.xml all fields will always be exported.

[Options]

Opens the dialog window Options, in which the separators can be
defined.
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NOTE

The options can only be set for the data types *.csv (comma separa-
ted) and *.csv (measuring point list).

File name

One of the following options can be selected for the definition of the
name of the export file:

Selection Determination ID | Sample identification |
 Request on each export | Fixed file name
(append data)

Default value Determination ID

Determination ID
If this option is selected then the name of the export file will be formed
from the unambiguous Determination ID, the Computer name, the
date stamp -YYYYMMDD-HHMMSS and the suffix for the format.

Sample identification
If this option is selected then the name of the export file will be formed
from the selected sample identification ID1 or ID2, the Computer
name, the date stamp -YYYYMMDD-HHMMSS and the suffix for
the format. If the generated name already exists in the folder then a
version number will additionally be appended to the date.

Request on each export
If this option is selected then the name of the export file will be reques-
ted at each export. In addition to the entered name the Computer
name and the date stamp -YYYYMMDD-HHMMSS will be added
automatically.

Fixed file name (append data)
If this option is selected then the name of the export file will be formed
from the name entered here and the suffix for the format. If the file is
already present in the folder then the data will be appended to this file.

NOTE

The option Fixed file name can only be selected for the file type *.csv
(comma separated) or *.slk (SLK format).
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4.4.4.2.2 Export template - Select fields
Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export
templates ▶ [Properties] ▶ Export templates ▶ [Select fields] ▶ Select fields

With [Select fields] in the Properties window for export templates the
dialog window Select fields opens in which the fields for data export for
the file types *.csv and *.slk can be selected.

Available fields

Shows all the fields that can be exported.

Selected fields

Shows all the fields that will be exported.

Default name

Non-editable name of the field to be exported.

Displayed name

Field name that can be edited by the user for the exported field. The
Default name is entered as default. If the field name is deleted then the
Default name appears again.

Add selected field.

Remove selected field.

Modifies the sequence of the exported fields by moving the selected field
up.

Modifies the sequence of the exported fields by moving the selected field
down.

4.4.4.2.3 Export template - Options for CSV format
Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export
templates ▶ [Properties] ▶ Export template ▶ [Options] ▶ Options for CSV for-
mat

With [Options] in the Properties window for export templates the dialog
window Options for CSV format opens in which the separators can be
defined.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 4 Database

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 187

Field separator

Selection of the field separator.

Selection ; | , | Tab
Default value ;

Record separator

Selection of the data set separator (CR = Carriage return, LF = Line feed).

Selection CR/LF | CR | LF
Default value CR/LF

Header

on | off (Default value: on)

If this check box is activated, the column headers are exported at the
beginning of the export file.

4.4.4.2.4 Export template - Options for measurement point list
Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export
templates ▶ [Properties] ▶ Export template ▶ [Options] ▶ Options for measuring
point list

With [Options] in the Properties window for export templates the dialog
window Options for measurement point list opens in which the sepa-
rators can be defined.

Field separator

Selection of the field separator.

Selection ; | , | Tab
Default value ;

4.4.4.2.5 Export template - Request at file export
Dialog window: Database ▶ Tools ▶ Templates ▶ Export templates... ▶ Export
templates ▶ [Properties] ▶ Export template

If in the properties of the export template under File name the option
Request on each export has been selected (see Chapter 4.4.4.2.1,
page 183), then before the export of a determination the dialog File
export is displayed.

Target directory

Shows the target directory for the export file, which has been defined in
the properties of the export templates (see Chapter 4.4.4.2.1, page 183)
used.
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File name

Name under which the export file is to be saved în the Target directory.
During creating the file the user name as well as the current time stamp
are automatically attached to the name entered.

[OK]

The export of the corresponding determination is carried out to the indica-
ted file.

[Cancel]

The export of the corresponding determination is canceled. If several
determinations have been selected to be exported, then the dialog File
export will be displayed for the next determination.

[Cancel all]

The export of all selected determinations is canceled.

4.4.4.3 XML export
XML export

General

An XML export file with all determination data can be created when an
XML report template is used at the export of the determinations.

Structure

An XML export file is constructed as follows:

<?xml version="1.0" encod-
ing="ISO-8859-1" ?>

 

–<DeterminationReport> Determination report

<xmlCreator val=""/> Program name

<xmlCreatorVersion val=""/> Program version

<xmlCreatorBuildNo val=""/> Build number

<subtype val=""/>  



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 4 Database

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 189

+ <Determination> Determination data

+ <Method> Method data

+ <Sample> Sample data

+ <Results dynamic=""> Results overview

+ <ResultaSingle=""> Single results

+ <Command Data dynamic=""> Command variables

+ <Comvars dynamic=""> Common variables

+ <usedDevices dynamic=""> Device data

+ <usedSensors dynamic=""> Sensor data

+ <Statistics> Statistical data

–<System> System data

<userName val="" /> User name (abbreviation)

<userNameFull val="" /> User name (full name)

<clientName val="" /> Client name

<progVersion val="" /> Program version - Build number

<licenseRoot val="" /> License code

</Sytem>  

</DeterminationReport>  

NOTE

dynamic= means that the following nodes can appear more than
once.

The actual data is situated between " ".

4.4.4.3.1 XML export - Determination data
XML export

– <Determination> Determination data

– <Identification> Information about the identification of the determina-
tion.

<statisticLinkID val=""/> Statistics ID:

Unambiguous and unmistakable identification for the
statistically linked determinations.
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<determinationID val=""/> Determination ID:

Unambiguous and unmistakable identification for the
determination.

<serverName val=""/> Name of the server to which the client was connected
when the determination was recorded.

<clientName val=""/> Name of the client with which the determination was
recorded.

<detCounter val=""/> Sample number which was entered in the run window.

<startCounter val=""/> Start counter

</Identification>

– <Acquisition> Information about recording the determination.

<determinationStart val=""/> Date and time at start of determination.

<determinationDuration val=""/> Duration of the determination from its start to its end or
termination in s.

<determinationEndState val=""/
>

Determination run (way in which the determination was
ended):

regular without errors

The determination was finished automatically after the
method was processed normally and without any errors.

manual stop

The determination has been ended with the [Stop] fixed
key.

error

The determination has been ended because an error
occured.

<userName val=""/> Short name of user logged in at start of determination.

<userNameFull val=""/> Full name of user logged in at start of determination.

<determinationNote val=""/> Remark on determination

<progVersion val=""/> Program version and build number of the program at
recording the determination.

<licenseRoot val=""/> License start number of the program at recording the
determination.
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</Acquisition>  

– <Version> Information about the determination version.

<signOffState val=""/> Signature status

no

Determination not signed.

Level 1

Determination signed on level 1.

Level 2

Determination signed on level 2.

<version val=""/> Version of the determination.

<status val="original"/> Determination status:

original

Determination data unaltered.

modified

Determination data modified.

<recalcDate val=""/> Date and time when the reprocessed determination ver-
sion was saved.

<recalcedBy val=""/> Short name of user logged in when determination was
reprocessed.

<recalcedByuserFull val=""/> Full name of user logged in when determination was
reprocessed.

<recalcReason val=""/> Reason for the determination modification.

<changeComment val=""/> User comment on the determination modification.

</Version>  

– <Miscellaneous> Different determination data.

<deterComment val=""/> Comment, which has been entered on the determina-
tion.

– <runMessages dynamic=""> Messages

– <data> Message

<subtype val=""/>  
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<msgSource val=""/> Message source:

Shows from where the message comes:

Program

Message that cannot be assigned to a particular com-
mand.

Track 'Track name' - Command 'Command name'

Message produced by a command during the run.

<msgText val=""/> Message text.

<msgTime val=""/> Time at which the message was created in the run (date,
time, UTC in the format JJJJ-MM-TT hh:mm:ss UTC....

<msgTitle val=""/> Message title and number.

</data>  

</runMessages>  

– <DetermVars dynamic=""> Determination variables

– <data> Determination variable

<vt val=""/> Variable type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val=""/> Variable identification

<vr val=""/> Variable value.

</data>  

</DetermVars>  

– <SystemVars dynamic=""> System variables

– <data> System variable

<vt val=""/> Variable type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val=""/> Variable identification
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<vr val=""/> Variable value.

</data>  

</SystemVars>  

</Miscellaneous>  

– <signOff dynamic=""> Signatures

– <data> Signature

<subtype val=""/>  

– <signature>  

<vr val=""/> Shows at which level the determination has been signed
(Level 1 or Level 2).

</signature>  

– <signDate>...</signDate> Date and time at which the determination was signed.

– <userName>...</userName> Short name of the user who signed the determination.

– <userNameFull>...</userName-
Full>

Full name of the user who signed the determination.

– <reason>...</reason> Reason for signature.

– <comment>...</comment> Comment on the signature.

</data>  

</signOff>  

</Determination>  

4.4.4.3.2 XML export - Method data
XML export

– <Method> Method data

– <Identification> Information about the identification of the method.

<methodName val=""/> Name of the method.

<methodID val=""/>> Method ID:

Unambiguous and unmistakable identification for the
method.

<methodComment val=""/> Method comment (Command comment on START
command).



4.4 Templates ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

194 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

</Identification>

– <Version> Information about method version.

<signOffState val=""/> Signature status

no

Method not signed.

Level 1

Method signed at level 1.

Level 2

Method signed at level 2.

<version val=""/> Version of the method.

<status val="original"/> Method status:

new

The method has been newly created and not yet saved.

modified

The method has been reprocessed but not saved.

saved

The method has been saved.

reviewed

The method has been signed at stage 1.

released

The method has been signed at stage 2.

<savingTime val=""/> Date and time when the modified method version was
saved.

<savingUser val=""/> Short name of user logged in when modified method
was saved.

<savingUserFull val=""/> Full name of user logged in when modified method was
saved.

<changeReason val=""/> Reason for the method modification.

<changeComment val=""/> User comment on the method modification.

</Version>  

– <signOff dynamic=""> Signatures

– <data> Signature

<subtype val=""/>  
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– <signature>  

<vr val=""/> Shows at which level the method has been signed (Level
1 or Level 2).

<</signature>>  

– <signDate>...</signDate> Date and time at which the method was signed.

– <userName>...</userName> Short name of the user who signed the method.

– <userNameFull>...</userName-
Full>

Full name of the user who signed the method.

– <reason>...</reason> Reason for signature.

– <comment>...</comment> Comment on the signature.

</data>  

</signOff>  

</Method>  

4.4.4.3.3 XML export - Sample data
XML export

– <Sample> Sample data

– <Smpl.Data> Sample data

– <SmplSize> Sample size.

– <data>...</data> see above

</SmplSize>  

– <SmplUnit> Sample size unit.

– <data>...</data> see above

</SmplUnit>  

</SmplData>  

– <Identification> Sample identifications.

– <ID__01> Sample identification ID1.

– <data>...</data> see above

</ID__01>  

– <ID__02> see above

</Identification>  

</Sample>  
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4.4.4.3.4 XML export - Results overview
XML export

– <Results dynamic=""> Results overview

– <data>  

<subtype val="" />  

<vr val="" /> Result value with the number of decimal places defined
in the CALC command.

<vf val="" /> Result value with full precision.

<vs val=""/> Result status:

OK = The value is ok and has not been monitored.

OKL = The value is ok and has been monitored.

LE = The value exceeded the limit and has not been
monitored.

LEL = The value exceeded the limit and has been moni-
tored..

NV = The value is invalid and has not been monitored.

NVL = The value is invalid and has been monitored.

<vt val=""/> Result type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val=""/> Result name.

 Name of the CALC command the result has been gener-
ated with.

<un val=""/> Unit of the result.

<fo val=""/> Formula used for the calculation of the result.

– <fv dynamic=""> Variables used for the calculation of the result.

– <data>  

<vr val="" /> Variable value.

<vs val=""/> Variable status (see above).

<vt val=""/> Variable type (see above).

<vn val=""/> Variable name.
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</data>  

</fv>  

– <sme> Mean value of the result.

– <data>  

<vr val="" /> Mean value with the number of decimal places defined
in the CALC command.

<vf val="" /> Mean value with full precision.

<vs val=""/> Variable status (see above).

</data>  

<sme>  

– <abs> Absolute standard deviation of the result.

– <data>  

<vr val="" /> Absolute standard deviation with the number of decimal
places defined in the CALC command.

<vf val="" /> Absolute standard deviation with full precision.

<vs val=""/> Variable status (see above).

</data>  

<abs>  

– <rel> Relative standard deviation of the result.

– <data>  

<vr val="" /> Absolute standard deviation with the number of decimal
places defined in the CALC command.

<vf val="" /> Relative standard deviation with full precision.

<vs val=""/> Variable status (see above).

</data>  



4.4 Templates ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

198 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

<rel>  

-<max>  

– <data>  

<vr val="" />  

<vf val="" />  

<vs val=""/>  

</data>  

</max>  

-<min>  

– <data>  

<vr val="" />  

<vf val="" />  

<vs val=""/>  

</data>  

</min>  

<n val="" /> Number of the result among the statistically evaluated
results.

<nmax val="" /> Maximum number of statistically evaluated results.

</data>  

</Results>  

4.4.4.3.5 XML export - Single results
XML export

– <ResultsSingle> Single results

– <RS01> 1. single result

– <data>  

<vr val="" /> Result value with the number of decimal places defined
in the CALC command.

<vf val="" /> Result value with full precision.
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<vs val=""/> Result status:

OK = The value is ok and has not been monitored.

OKL = The value is ok and has been monitored.

LE = The value exceeded the limit and has not been
monitored.

LEL = The value exceeded the limit and has been moni-
tored..

NV = The value is invalid and has not been monitored.

NVL = The value is invalid and has been monitored.

<vt val=""/> Result type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val=""/> Result name.

<un val=""/> Unit of the result.

<fo val=""/> Formula used for the calculation of the result.

– <fv dynamic=""> Variables used for the calculation of the result.

– <data>  

<vr val="" />  

<vs val="" />  

<vt val=""/>  

<vn val=""/>  

</data>  

– <sme> Mean value of the result.

– <data>  

<vr val="" /> Mean value with the number of decimal places defined
in the CALC command.

<vf val="" /> Mean value with full precision.

<vs val=""/> Variable status (see above).

</data>  



4.4 Templates ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

200 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

<sme>  

– <abs> Absolute standard deviation of the result.

– <data>  

<vr val="" /> Absolute standard deviation with the number of decimal
places defined in the CALC command.

<vf val="" /> Absolute standard deviation with full precision.

<vs val=""/> Variable status (see above).

</data>  

<abs>  

– <rel> Relative standard deviation of the result.

– <data>  

<vr val="" /> Absolute standard deviation with the number of decimal
places defined in the CALC command.

<vf val="" /> Relative standard deviation with full precision.

<vs val=""/> Variable status (see above).

</data>  

<rel>  

– <max>  

– <data>  

<vr val="" />  

<vf val="" />  

<vs val=""/>  

</data>  

</max>  

– <min>  

– <data>  

<vr val="" />  

<vf val="" />  

</data>  

</min>  

<n val="" /> Number of the result among the statistically evaluated
results.

<nmax val="" /> Maximum number of statistically evaluated results.
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</data>  

<RS01>  

<RS02> … <RS25> Further single results (see above)

</ResultsSingle>  

4.4.4.3.6 XML export - Command data
XML export

– <CommandData dynamic=""> Command data

– <Command> Data on command

<subtype val="" />  

<data val="" /> Command name.Index

<commandType val="" /> Command type.

– <CommandVars dynamic=""> Command variables

– <data>  

<vt val="" /> Variable type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val="" /> Variable identification

<vr val="" /> Variable value.

</data>  

</CommandVars>  

– <Sensor> Data on sensor.

<subtype val="" /> Type of sensor:

XML_SENSOR_OTHER = Other sensor

XML_SENSOR_PH = pH sensor

XML_SENSOR_ION = ISE sensor

XML_SENSOR_METAL = Metal sensor

XML_SENSOR_TEMP = Temperature sensor

XML_SENSOR_COND = Conductivity sensor

– <sensorData> Data on sensor.

<sensorName val="" /> Sensor name.
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<sensorType val="" /> Sensor type.

<sensorOrderNo val="" /> Order number of sensor.

<sensorSerialNo val="" /> Serial number of sensor.

<sensorInitDate val="" /> Date on which the sensor was used for the first time.

<sensorCellConst val="" /> Cell constant of the conductivity sensor.

<sensorSlope val="" /> Slope of the sensor.

<sensorPh0 val="" /> Electrode zero point of the pH sensor.

<sensorIonVa val="" /> Ion (valency) of the ISE sensor.

<sensorE0 val="" /> Electrode zero point of the sensor.

<sensorC val="" /> Blank value of the ISE sensor.

<sensorCalTemp val="" /> Calibration temperature.

<sensorCalDate val="" /> Calibration date.

<sensorCalMethod val="" /> Calibration method.

</sensorData>  

</Sensor>  

</Device>  

– <CalibData> Calibration data

<sensorName val="" /> Sensor name.

<sensorType val="" /> Sensor type.

<sensorSlope val="" /> Slope of the sensor.

<sensorPh0 val="" /> Electrode zero point of the pH sensor.

<sensorIonVa val="" /> Ion (valency) of the ISE sensor.

<sensorE0 val="" /> Electrode zero point of the sensor.

<sensorC val="" /> Blank value of the ISE sensor.

<resultUnit val="" /> Concentration unit of calibration.

<variance val="" /> Variance of calibration.

<sensorCalTemp val="" /> Calibration temperature.

<sensorCalTempType val="" /> Calibration mode.

<sensorCalDate val="" /> Calibration date.

<sensorCalMethod val="" /> Calibration method.

– <CalibrationTable> Calibration solutions.

– <header> Column headers.
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<<RowDesc val="" /> Column header for buffers/standards.

<NominalVal val="" /> Column header for nominal value.

<MeasVal val="" /> Column header for measured value.

<CalTemp val="" /> Column header for calibration temperature.

<CalDur val="" /> Column header for duration of measurement.

<header>  

– <body dynamic="">  

– <data>  

<RowDesc> ... </RowDesc> Buffer/Standard.

<NominalVal> ... </NominalVal> Nominal value.

<MeasVal> ... </MeasVal> Measured value.

<CalTemp> ... </CalTemp> Calibration temperature.

<CalDur> ... </CalDur> Duration of measurement in s.

</data>  

</body>  

</CalibrationTable>  

</CalibData>  

– <StdAddData> Standard addition data

<slope val="" /> Calculated slope of the standard addition curve.

<e0 val="" /> Calculated axis intercept of the standard addition curve.

<ion val="" /> Ion (Valency).

<conc val="" /> Calculated valency.

<concUnit val="" /> Concentration unit.

<variance val="" /> Variance.

– <StdAddTable> Standard addition solutions.

– <header> Column headers.

<RowDesc val="" /> Column header for measuring solution.

<dV val="" /> Column header for addition volume.

<MeasVal val="" /> Column header for measured value.

<dU val="" /> Column header for measured value differential.

<Dur val="" /> Column header for duration of measurement.

</header>  
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– <body dynamic="">  

– <data>  

<RowDesc> ... </RowDesc> Measuring solution.

<dV> ... </dV> Addition volume in mL.

<MeasVal> ... </MeasVal> Measured value in mV.

<dU> ... </dU> Measured value differential in mV.

<Dur> ... </Dur> Duration of measurement in s.

</data>  

</body>  

</StdAddTable>  

</StdAddData>  

– <MeasPoints content-
Type="table">

Measuring points

– <tableHeader> Column headers.

– <th>  

<vr val="" /> Column header.

</th>  

</tableHeader>  

– <tableBody> Measuring points.

– <td>  

<vr val="" />  

<vf val="" />  

</td>  

</tableBody>  

</MeasPoints>  

– <EndPoints dynamic=""> Endpoints

– <data>  

<ept val="" /> Designation of the endpoint.

<epvx val="12.1835" /> X value of the endpoint.

<epux val="mL" /> Unit of the x value of the endpoint.

<epvy val="518.5" /> Y value of the endpoint.

<epuy val="mV" /> Unit of the y value of the endpoint.
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</data>  

</EndPoints>  

</Command>  

</CommandData>  

4.4.4.3.7 XML export - Common Variables
XML export

– <Comvars dynamic> Common variables

– <data>  

<subtype val="" />  

<vr val="" /> Variable value.

<vs val="" /> Variable status:

OK = The value is ok and has not been monitored.

OKL = The value is ok and has been monitored.

LE = The value exceeded the limit and has not been
monitored.

LEL = The value exceeded the limit and has been moni-
tored..

NV = The value is invalid and has not been monitored.

NVL = The value is invalid and has been monitored.

<vt val="" /> Variable type:

TX = Text

NR = Number

DT = Date/Time

NA = Unknown

<vn val="" /> Variable name.

<un val="" /> Unit of the variable.

<am val="" /> Assignment method.

<at val="" /> Assignment date.

</data>  

</Comvars dynamic>  



4.4 Templates ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

206 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

4.4.4.3.8 XML export - Device data
XML export

– <usedDevices dynamic=""> Device data

– <Device> Data on device.

<subtype val="" />  

– <deviceType> Device type.

<vn val="" /> Parameter name.

<vr val="" /> Parameter value.

</deviceType>  

– <deviceName> ... </device-
Name>

Device name.

– <instrNo> ... </instrNo> Device serial number.

– <deviceProgNo> ... </device-
ProgNo>

Device program number.

– <rackName> ... </rackName> Rack name.

– <rackCode> ... </rackCode> Rack code.

– <towerNoOne> ... </tower-
NoOne>

Tower number.

– <swingHeadOneType> ... </
swingHeadOneType>

Type of Swing Head on tower 1.

– <swingHeadOneSerial> ... </
swingHeadOneSerial>

Serial number of the Swing Head on tower 1.

– <towerNoTwo> ... </tower-
NoTwo>

Tower number.

– <swingHeadTwoType> ... </
swingHeadTwoType>

Type of Swing Head on tower 2.

– <swingHeadTwoSerial> ... </
swingHeadTwoSerial>

Serial number of the Swing Head on tower 2.

– <devicePorts dynamic=""> Data on the peripheral devices connected.

– <Port>  

<subtype val="" /> Type of the device connected to the port:

XML_PORT_DEVICE_DOS = Dosing/Exchange unit

XML_PORT_DEVICE_REMOTE = Remote Box

XML_PORT_DEVICE_STIR = Stirrer
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– <dosPortName> ... </dosPort-
Name>

Number of the MSB connector the dosing device was
connected to.

– <dosType> ... </dosType> Dosing device type.

– <dosSerial> ... </dosSerial> Dosing device serial number.

– <exchDosUnit> Data on exchange/dosing unit.

– <exdosTitle> ... </exdosTitle> Designation of the exchange/dosing unit.

– <exdosName> ... </exdos-
Name>

Name of the exchange/dosing unit.

– <exdosType> ... </exdosType> Type of exchange/dosing unit.

– <exdosOrder> ... </exdosOr-
der>

Order number of exchange/dosing unit.

– <exdosSerial> ... </exdosSe-
rial>

Serial number of exchange/dosing unit.

– <cylVol> ... </cylVol> Cylinder volume of exchange/dosing unit.

– <cylSerial> ... </cylSerial> Cylinder serial number of exchange/dosing unit.

– <Solution> Data on solution.

– <solTitle> ... </solTitle> Solution title.

– <solutionName> ... </solution-
Name>

Solution name.

– <conc> ... </conc> Concentration.

– <concUnit> ... </concUnit> Concentration unit.

– <solCreationTime> ... </sol-
CreationTime>

Production date.

– <titer> ... </titer> Titer value.

– <titerUnit> ... </titerUnit> Titer unit.

– <titerCreationTime> ... </titer-
CreationTime>

Date and time of the last titer determination.

– <titerMethod> ... </titerMe-
thod>

Name of the method with which the last titer determina-
tion was carried out.

</Solution>  

</exchDosUnit>  

– <stirrerPortName> ... </stirrer-
PortName>

Number of the MSB connector the stirrer was connected
to.

– <stirrerType> ... </stirrerType> Type of stirrer.
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– <serialStirrer> ... </serialStir-
rer>

Serial number.

– <remotePortName> ... </remo-
tePortName>

Number of the MSB connector the Remote Box was con-
nected to.

– <remoteType> ... </remote-
Type>

Type of Remote Box.

</Port>  

</devicePorts>  

</Device>  

</usedDevices>  

4.4.4.3.9 XML export - Sensor data
XML export

– <usedSensors dynamic=""> Sensor data

– <Sensor> Data on sensor.

<subtype val="" /> Type of sensor:

XML_SENSOR_OTHER = Other sensor

XML_SENSOR_PH = pH sensor

XML_SENSOR_ION = ISE sensor

XML_SENSOR_METAL = Metal sensor

XML_SENSOR_TEMP = Temperature sensor

XML_SENSOR_COND = Conductivity sensor

– <sensorData> Data on sensor.

<sensorName val="" /> Sensor name.

<sensorType val="" /> Sensor type.

<sensorOrderNo val="" /> Order number of sensor.

<sensorSerialNo val="" /> Serial number of sensor.

<sensorInitDate val="" /> Date on which the sensor was used for the first time.

<sensorSlope val="" /> Slope of the sensor.

<sensorPh0 val="" /> Electrode zero point of the pH sensor.

<sensorIonVa val="" /> Ion (valency) of the ISE sensor.

<sensorE0 val="" /> Electrode zero point of the sensor.

<sensorC val="" /> Blank value of the ISE sensor.
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<sensorCalTemp val="" /> Calibration temperature.

<sensorCalDate val="" /> Calibration date.

<sensorCalMethod val="" /> Calibration method.

<sensorCalUser val="" /> User

<sensorCalMeasInput val="" /> Measuring input at calibration.

</sensorData>  

</Sensor>  

</usedSensors>  

4.4.4.3.10 XML export - Statistical data
XML export

– <Statistics> Statistical data

<subtype val="" />  

<nMax val="" /> Maximum number of statistically evaluated results.

– <StatisticsShort dynamic=""> Statistical data on the separate results.

– <data>  

<subtype val="" />  

– <resName>  

<vr val="" /> Result name.

<vf val="" />  

</resName>  

– <n> ... </n> Number of the result among the statistically evaluated
results.

– <sme> ... </sme> Mean value of the result.

– <un> ... </un> Result unit.

– <abs> ... </abs> Absolute standard deviation of the result.

– <rel> ... </rel> ... Relative standard deviation of the result.

– <min> ... </min> ... Minimum value of the result.

– <max> ... </max> ... Maximum value of the result.

</data>  
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</StatisticsShort>  

– <StatisticsOverview content-
Type="table">

Statistical data overview

<subtype val="" />  

– <tableHeader> Column headers (dynamic).

– <th>  

<vr val="" /> Column header.

</th>  

</tableHeader>  

– <tableBody> Table content (dynamic).

– <td>  

<vr val="" /> Field content.

</td>  

</tableBody>  

</StatisticsOverview>  

</Statistics>  

4.5 Determination overview

4.5.1 Determination overview - General

4.5.1.1 Determination overview - Overview
Subwindow: Database ▶ Determination overview

General

The Determination overview subwindow shows selected data in tabu-
lar form for the determinations contained in the open database. It is
always displayed in the Database program part, i.e. it cannot be removed
from the database view. The subwindow can be enlarged and reduced as
required; it can also be maximized.

Elements

The Determination overview subwindow includes the following tools:

￭ Determination table
￭ Filter selection
￭ Navigation bar
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4.5.1.2 Determination overview - Table
Subwindow: Database ▶ Determination overview

Data display

The information defined in the Column display regarding the determina-
tions is displayed in the determination table. If the content of a field is
larger than the column width, then the entire content will be shown as a
tooltip if the mouse cursor is kept on the field.

If a result value is monitored and lies within the limits defined, then it will
be shown in green text color. If it is outside these limits then the value
will be shown in red text color.

NOTE

Lines that contain red entries will also show the line number highlighted
with a red background.

Updating

As long as the Database program part remains open, changes in the
determination table that are caused by ongoing determinations or by
other users (adding, changing or deleting records) are not displayed auto-
matically. The table must either be updated with View ▶ Update or
newly sorted or filtered. The determination table is automatically updated
every time a switch is made from an other program part to the Database
program part.

Table view

Click on the column title to sort the table according to the selected col-
umn in either ascending or descending order. The table view can be adap-
ted with the left mouse button as follows:

￭ Drag the margin between column titles
Sets the column width.

￭ Double-click on the margin between column titles
Sets the optimal column width.

￭ Drag the column title
Moves the column to the required location.

Data record selection and table navigation

The determinations selected in the table are displayed in turquoise; the
focused determination, the data of which is displayed in the other sub-
windows, is marked with an arrow before the line number. There are vari-
ous opportunities for record selection in the table.
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In the determination table it is not possible to show more than 200 deter-
minations at once. If more than 200 records are present in the database,
then the Navigation bar must be used to switch to further sets of determi-
nations.

4.5.1.3 Determination overview - Column display
Dialog window: Database ▶ View ▶ Properties ▶ Column display… ▶ Column dis-
play

View ▶ Properties ▶ Column display… opens the Column display
dialog window. Here the columns that are to be shown in the determina-
tion table can be defined.

Available columns

Display of all the fields that can be shown as columns in the determination
table.

Displayed columns

Display of all the fields that will be shown as columns in the determination
table.

Default name

Non-editable name of the field that is displayed as a column.

Displayed name

Editable name (by double-click) of the column displayed in the determina-
tion overview.

Adds the selected column to the table.

Removes the selected column from the table.

Moves selected column upwards.

Moves selected column downwards.
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4.5.1.4 Determination overview - Filter selection
Subwindow: Database ▶ Determination overview

Filter

Selection of the filter with which the determination table is to be filtered:

Selection All determinations | All statistical records |
 Quick filter | Temporary filter | Filter name

Default value All determinations

All determinations
The table is shown unfiltered.

All statistical records
The table is filtered so that all determinations are shown that are statis-
tically linked with the selected determination.

Quick filter
The table is filtered according to the last defined quick filter.

Temporary filter
The table is filtered according to the last defined, not saved special fil-
ter.

Filter name
The table is filtered according to the selected and saved special filter.

Statistics

With the statistics filter selected here the determinations shown in the
determination table can be additionally filtered according to the statistical
data generated by the method independently of any other filters that may
have been used.

Selection All | Last

All
All determinations are shown for all statistics series.

Last
Only the last determination is shown for each statistics series.

4.5.1.5 Determination overview - Navigation bar
Subwindow: Database ▶ Determination overview

The navigation bar shown below the determination table is used for navi-
gation in extensive tables in which all the determinations can no longer be
displayed simultaneously. It contains the following elements:

Jump to the first set of determinations in the table.
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Jump back to the previous set of determinations in the table.

Display of the selected set #### - #### of determinations in the table. If
the table is not filtered, then the total number of all determinations will
also be shown. If the table is filtered, then the total number of filtered
determinations will appear with the additional information (filtered).

Jump further to the next set of determinations in the table.

Jump to the last set of determinations in the table.

4.5.1.6 Determination overview - Table navigation
Subwindow: Database ▶ Determination overview

The vertical and the horizontal scroll bars can be used to navigate in the
determination table with the mouse. In addition the following options are
available with the keyboard:

[↑]

Moves the line cursor up by one field.

[↓]

Moves the line cursor down by one field.

[Ctrl] [End]

Jumps to the last determination in the current set.

[Ctrl] [Home]

Jumps to the first determination in the current set.

[Page Up]

Scrolls backward within the current set.

[Page Down]

Scrolls forward within the current set.

[Alt] [End]

Jumps to last determination (of all).

[Alt] [Home]

Jumps to first determination (of all).
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[Alt] [↑]

Jumps to first record of previous set.

[Alt] [↓]

Jumps to first record of next set.

In the determination table it is not possible to show more than 200 deter-
minations at once. If more than 200 determinations are present in the
database then the navigation bar must be used to switch to further sets of
determinations.

4.5.1.7 Determination overview - Data record selection
Subwindow: Database ▶ Determination overview

The determinations selected in the table are displayed in turquoise; the
focused determination, the data of which is displayed in the other sub-
windows, is marked with an arrow before the line number. The first deter-
mination is always selected and focused when a database is opened.

The following possibilities are available for the selection of determinations
in the determination table:

￭ Single determinations
Single determinations are selected by clicking on them with the mouse
within the line (including line number). This determination, whose data
is shown in the other opened subwindows, is now focused and
marked with an arrow in front of the line number.

￭ Several determinations in sequence
In order to select several determinations in sequence, the required
range can be selected with the left mouse button pressed down. It is
also possible to select a range with a click on the first determination
and [Shift] & click on the last determination. The last determination
to be selected receives the focus.

￭ Several determinations not in sequence
In order to select several determinations not in sequence, the individual
determinations must be selected by left-clicking on them while holding
down the Ctrl key. The last determination to be selected receives the
focus.

￭ All determinations
With [Ctrl] [A] or by clicking on the uppermost left-hand table cell, all
the filtered determinations within the current set of determinations are
selected. The focus is retained.
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4.5.1.8 Determination overview - Functions
Subwindow: Database ▶ Determination overview

The following functions can be carried out with the determinations
selected in the determination table:

Editing determinations

￭ Updating the determination overview
￭ Entering a determination comment
￭ Signing determinations
￭ Exporting determinations
￭ Importing determinations
￭ Sending determinations to
￭ Reprocessing determinations
￭ Deleting determinations

Searching and filtering determinations

￭ Search determinations
￭ Filter determinations

Other functions

￭ Determination overview - Print
￭ Printing a report
￭ Displaying determination history
￭ Determinations - Control chart
￭ Determinations - Overlay curves
￭ Printing overlaid curves
￭ Printing a control chart

4.5.2 Determination overview - Functions

4.5.2.1 Update determination overview
Menu item: Database ▶ View ▶ Update

The menu item View ▶ Update or the symbol    is used to update the
determination table.

NOTE

The determination table is updated automatically when the database is
opened and when a change is made from another program part to the
program part Database, but afterwards only when the table is newly
sorted or filtered.
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4.5.2.2 Determination comment
Dialog window: Database ▶ Determinations ▶ Comment… ▶ Determination com-
ment

With the menu item Determinations ▶ Comment… or the symbol 
the dialog window Determination comment opens in which new com-
ments on the selected determination can be entered an existing comment
can be edited.

Comments entered this way appear automatically as a Tooltip text when
the cursor line is kept on the number field of a line in the determination
table for more than 1 second. In addition, it is also displayed in the sub-
window Information.

4.5.2.3 Searching for determinations
Dialog window: Database ▶ Determinations ▶ Search… ▶ Search - Database

The Determinations ▶ Search... menu item or the  symbol opens the
Search - Database dialog window for the search for determinations.

Search in

Selection of the data field in which the search is to be carried out.

Selection All fields | 'Field name'

All fields
A search is made in all fields of the database.

'Field name'
A search is made only in the selected field. The 10 most recently
selected fields are always available for selection.

[Other…]

Open the Search - Field selection dialog window. All fields are listed in
tree form. A field can be included in the search by highlighting it and clos-
ing the dialog window with [OK].

Details

Depending on the data field, further list boxes are dynamically created
under Details in order to be able to select the desired property.

Search options

Type

Selection of the type of format for fields in which several types are possi-
ble. Only this type will be shown for fields with a fixed type.

Selection Text | Date | Number
Default value Text
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Operator

Selection of the comparison operator for the search criterion.

for fields of the type = text
Selection = | <> | empty | not empty
Default value =

for fields of the type = date
Selection = | <> | < | <= | > | >= | empty | not empty | inva-

lid | out of limits | Today
Default value =

invalid
Values with the entry invalid are searched for.

out of limits
Values that are outside of the defined limit values for the selected fields
will be searched for (values shown in red).

Today
A search is made for the current date. A range in days can also be
defined in the Search term field, according to which the search
should be carried out, starting from the current date.

for fields of the type = number
Selection = | <> | < | <= | > | >= | empty | not empty | inva-

lid | out of limits
Default value =

invalid
Values with the entry invalid are searched for.

out of limits
Values that are outside of the defined limit values for the selected fields
will be searched for (values shown in red).

Search term

Entry of the search term for the search in the selected data field. For fields
where Type = Date, the date can be selected by pressing on […] in the
Select date dialog window.

for fields of the type = text
Entry 256 characters

Definition of a text expression as a search term. The
last 10 search terms are saved and can be selected.
The following wildcards can be used in the search
term:

Selection ^? | ^# | ^$ | ^*
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^?
Wildcard for any character.

^#
Wildcard for any digit.

^$
Wildcard for any letter of the alphabet.

^*
Wildcard for any character string.

for fields of the type = date
Entry all possible date values

Definition of a date as search term. The last 10
search terms are saved and can be selected.

for fields of the type = date and operator = today
Input range -9,999 - 9,999 
Default value 0 

Definition of a numerical value as a range in days in
which, starting from the current date, the search is
to be carried out. The last 10 search terms are saved
and can be selected.

for fields of the type = number
Entry all possible numerical values

Definition of a numerical value as search term. The
last 10 search terms are saved and can be selected.

Search direction

Selection of the search direction.

Selection All | Down | Up
Default value All

All
A search is made down to the end of the database and then again
from above down to the selected record.

Down
A search is made to the end of the database.

Up
A search will be made to the beginning of the database.

Match case

on | off (Default value: off)

If this check box is activated, then the search in fields of the Text type is
case-sensitive.
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Search for whole word only

on | off (Default value: off)

If this check box is activated, then the field contents must be identical
with the search term during searches in Text fields (no part-search).

[Find next]

Search next occurrence of the search term.

4.5.2.4 Filtering determinations

4.5.2.4.1 Filtering determinations - Overview
Subwindow: Database ▶ Determination overview

The following possibilities exist for filtering determinations in the determi-
nation table:

￭ Filter selection in the filter bar
￭ Quick filter
￭ Special filter
￭ Last filter
￭ Remove filter

4.5.2.4.2 Determinations - Last filter
Menu item: Database ▶ Determinations ▶ Filter ▶ Last filter

The most recently used filter is reactivated with the Determina-

tions ▶ Filter ▶ Last filter menu item or the  symbol.

4.5.2.4.3 Determinations - Quick filter
Menu item: Database ▶ Determinations ▶ Filter ▶ Quick filter

The Determinations ▶ Filter ▶ Quick filter menu item or the  sym-
bol can be used to carry out a quick filtering for the content of the
selected tabular field. After this function has been selected, the field in the
determination table in which the cursor is located will have a colored
background during navigation. At the same time, the following special fil-
ter symbol appears:

By double-clicking with the left mouse button you can set the content of
the selected field as filter criterion and apply it directly to the table.

NOTE

The quick filter can be applied again within the filtered table, so that
the number of entries can be limited step by step.
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4.5.2.4.4 Determinations - Special filter
Dialog window: Database ▶ Determinations ▶ Filter ▶ Special filter… ▶ Special fil-
ter - Database "Database name"

The Determinations ▶ Filter ▶ Special filter... menu item or the 
symbol is used to open the Special filter - Database dialog window for
defining user-specific filters.

Filter

Selection of the filter to be loaded for editing.

Selection 'Filter name' | New filter
Default value New filter

'Filter name'
The saved filter is loaded.

New filter
An empty table with the name New filter is loaded.

[Save filter]

Opens the Save filter dialog window in which the filter criteria entered in
the table can be saved as a special filter under the required name.

[Delete filter]

The currently loaded special filter is deleted.

Table view

The overview table shows all the defined filter criteria and cannot be
directly edited. The filter criteria will be numbered automatically in
sequence. The table view can be adapted with the left mouse button as
follows:

￭ Drag the margin between column titles
Sets the column width

￭ Double-click on the margin between column titles
Sets the optimal column width

If the content of a field is larger than the column width, then the entire
content will be shown as a tooltip if the mouse cursor is kept on the
field.

For the meaning of the columns, see Edit filter criterion.

Functions

The [Edit] menu beneath the filter table contains the following menu
items:
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Edit line Opens the Edit filter criterion dialog window in which the filter criterion of
the line selected in the table can be edited.

Insert new line Inserts a new empty line above the line selected in the table. The Edit filter cri-
terion dialog window opens automatically.

Cut lines Transfers the selected lines to the clipboard.

Copy lines Copies the selected lines to the clipboard.

Insert lines Pastes lines from the clipboard above the selected line.

Delete lines Deletes the selected lines.

[Apply filter]

Applies filter criteria to the determination table.

4.5.2.4.5 Determinations - All statistical records
Menu item: Database ▶ Determinations ▶ Filter ▶ All statistical records

With the Determinations ▶ Filter ▶ All statistical records menu item

or the  symbol all determinations statistically linked with the selected
determination are displayed.

4.5.2.4.6 Determinations - Deleting a filter
Menu item: Database ▶ Determinations ▶ Filter ▶ Delete filter

With the Determinations ▶ Filter ▶ Delete filter menu item or the 
symbol the most recently used filter will be deleted and all determinations
will be displayed.

4.5.2.4.7 Determinations - Saving a filter
Dialog window: Database ▶ Determinations ▶ Filter ▶ Special filter… ▶ Special fil-
ter - Database "Database name" ▶ [Save filter] ▶ Save filter

The [Save filter] button in the Special filter - Database "Database
name" dialog window opens the Save filter dialog window for saving a
special filter.

All the saved special filters are shown in the upper field.

Filter name

Name under which the special filter is to be saved.

Entry 50 characters

[Save]

Saves the filter under the given name.
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NOTE

The filters are saved globally in the configuration database and are
therefore available for all clients.

4.5.2.4.8 Determinations - Editing the filter criterion
Dialog window: Database ▶ Determinations ▶ Filter ▶ Special filter ▶ Special filter
- Database "Database name" ▶ [Edit] ▶ Edit line ▶ Edit filter criterion 'Filter
name'

The Edit ▶ Edit line command in the Special filter - Database "Data-
base name" dialog window opens the Edit filter criterion # dialog
window, in which the filter criterion selected in the filter table can be
edited.

Link

Selection of the type of link (logical operator) with the preceding filter cri-
terion.

Selection AND | OR
Default value AND

AND
Logical "AND" link.

OR
Logical "OR" link.

Field

Selection of the data field for which a criterion is to be formulated.

Selection 'Field name'
Filtering is carried out only for the selected field. The
10 most recently selected fields are always available
for selection.

[Other…]

Open the Filter - Field selection dialog window. Herein all fields that
can be used for filtering are listed in tree form. A field can be included by
highlighting it and closing the dialog window with [OK].

Details

Depending on the data field, further list boxes are dynamically created
under Details in order to be able to select the desired property.
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Condition

Type

Selection of the type of format for fields in which several types are possi-
ble. Only this type will be shown for fields with a fixed type.

Selection Text | Number | Date
Default value Text

Operator

Selection of the comparison operator for the filter criterion.

For fields of the type = text
Selection = | <>
Default value =

For fields of the type = date
Selection = | <> | < | <= | > | >= | Today
Default value =

Today
A search is made for the current date. In the Comparative value
field, a range in days can also be defined, according to which filtration
should be carried out, starting from the current date.

For fields of the type = number
Selection = | <> | < | <= | > | >= | empty | not empty | inva-

lid | out of limits
Default value =

invalid
Values with the entry invalid are filtered for.

out of limits
Values that are outside of the defined limit values for the selected fields
are filtered for (values shown in red).

Comparative value

Selection or entry of the comparative value for the filter criterion. For fields
where Type = Date, the date can be selected by pressing on […] in the
Select date dialog window.

For fields of the type = text
Entry 256 characters

Definition of a text expression as comparative value.
* can be used as a wildcard for any string of charac-
ters if the option Use asterisk (*) as wildcard is
enabled.
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For fields of the type = date
Entry all possible date values

Definition of a date as comparative value.

For fields of the type = date and operator = today
Input range -9,999 - 9,999 
Default value 0 

Definition of a numerical value as a range in days in
which, starting from the current date, the filtering is
to be carried out.

For fields of the type = number
Entry all possible numerical values

Definition of a numerical value as comparative
value.

Match case

on | off (Default value: off)

If this check box is activated, then the filtering of fields of the Text type is
case-sensitive.

Use asterisk (*) as wildcard

on | off (Default value: off)

If this check box is activated then the asterisk * can be used as a wildcard
for any character strings when filtering Text-type fields.

4.5.2.5 Signing determinations

4.5.2.5.1 Rules for electronic signatures
Program part: Database

In tiBase, determinations can be electronically signed at two levels. The
following rules apply for this:

￭ Signature levels
Determinations can be signed at two levels (signature level 1 and sig-
nature level 2) by entering the user name and a password.

￭ Multiple signing
Determinations can be signed several times at each level.

￭ Signing at level 1
If level 2 has been signed, then no more signatures are possible at level
1.

￭ Signing at level 2
Level 2 cannot be signed unless there are already signatures on level 1.

￭ Different users
The same user may not sign on both level 1 and level 2.
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￭ Reason and comment
Each signature must be accompanied by a reason selected from prede-
fined default reasons. An additional comment can also be entered.

￭ Saved data
Signature date, user name, full name, reason and comment are saved
for each signature.

￭ Deleting signatures 1
Signatures at level 1 are automatically deleted when a new version is
created.

￭ Deleting signatures 2
Signatures at level 2 can be deleted by users who have the respective
permission.

￭ Signature options
The options for electronic signatures are set in the Signatures tab in
the Security settings dialog window.

4.5.2.5.2 Signature level 1

Dialog window: Database ▶ Determinations ▶ Sign ▶ Signature
1… ▶ Signature level 1

Determinations can be signed at level 1 in the Signature level 1 win-
dow.

NOTE

Determinations that have been signed at level 1 can be modified and
deleted. If the modified method or determination is saved as a new ver-
sion, however, then all existing signatures will be deleted automatically,
i.e. the method or determination must be signed once again.

Info

Display of information for signing and deleting signatures. The following
messages are possible:

Selection Signature possible | Signature 1 not possible
(signature 2 exists) | Signature not possible
(access by other client) | Signature not possi-
ble for multiple determinations

Signature possible
The selected determination can be signed.

Signature 1 not possible (signature 2 exists)
The selected determination can no longer be signed at level 1 as it has
already been signed at level 2.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 4 Database

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 227

Signature not possible (access by other client)
The selected determination cannot be signed as it is already marked to
be signed on a different client.

Signature not possible for multiple determinations
Several determinations have been selected; they may, however, only be
signed individually.

User

Entry of the user name (short name).

Entry 24 characters

Password

Entry of the password.

Entry 24 characters

Reason

Selection from the Default reasons defined for the Signature level 1
category in the Security settings dialog window.

Selection Selection from the default reasons

Comment

Entry of a comment on the signature.

Entry 1,000 characters

[Sign]

Sign the determination. The window remains open.

NOTE

Determinations can only be signed at level 1 if the user belongs to a
user group with the respective permission.

4.5.2.5.3 Signature level 2

Dialog window: Database ▶ Determinations ▶ Sign ▶ Signature
2… ▶ Signature level 2

Determinations can be signed at level 2 in the Signature level 2 win-
dow.
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NOTE

Determinations signed at level 2 are locked, i.e. they can be neither
modified nor deleted. In order to be able to edit such determinations
again, the signatures on level 2 must first be deleted.

Info

Information for signing and deleting signatures is displayed in this box.
The following messages are possible:

Selection Signature possible | Signature 2 not possible
(signature 1 missing) | Signature not possible
(access by other client)

Signature possible
The selected determination can be signed.

Signature 2 not possible (signature 1 missing)
The selected determination cannot be signed at level 2, as it has not
yet been signed at level 1.

Signature not possible (access by other client)
The selected determination cannot be signed as it is already marked to
be signed on a different client.

User

Entry of the user name (short name).

Entry 24 characters

Password

Entry of the password.

Entry 24 characters

Reason

Selection from the Default reasons defined for the Signature level 2
category in the Security settings dialog window.

Selection Selection from the default reasons

Comment

Entry of a comment on the signature.

Entry 1,000 characters

[Sign]

Sign the determination. The window remains open.
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NOTE

Determinations can only be signed at level 2 if the user belongs to a
user group with the respective permission.

4.5.2.5.4 Displaying determination signatures
Dialog window: Database ▶ Determinations ▶ Sign ▶ Display signatures… ▶ Sig-
natures - Determination 'Determination ID'

The Determinations ▶ Sign ▶ Show signatures… menu item opens
the Signatures - Determination 'Determination ID' window with a
table in which the information for all of the signatures for the selected
determinations is displayed.

Signature

Shows at which level the determination has been signed (level 1 or level
2).

Signature date

Date and time at which the determination was signed.

User

Short name of the user who signed the determination.

Full name

Full name of the user who signed the determination.

Reason

Reason for signature.

Signature comment

Comment on the signature.

4.5.2.5.5 Deleting signatures Level 2

Dialog window: Database ▶ Determinations ▶ Sign ▶ Delete sig-
natures 2… ▶ Delete Signatures Level 2

The Delete Signatures Level 2 window allows you to delete all of the
signatures on level 2 for the selected method or determination.

User

Entry of the user name (short name).

Entry 24 characters
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Password

Entry of the password.

Entry 24 characters

Reason

Selection from the Default reasons defined for the Signature level 2
category in the Security settings dialog window.

Selection Selection from the default reasons

Comment

Entry of a comment on the signature.

Entry 1,000 characters

[Delete]

Delete signatures 2.

NOTE

Signatures 2 can only be deleted if the user belongs to a user group
with the respective permission.

4.5.2.6 Determinations - Reprocessing

4.5.2.6.1 Reprocessing - General
Dialog window: Reprocessing

Reprocessing determinations

The determinations saved in the database can be reprocessed at any time.
The variables, methods, statistics and curve evaluation can be modified
and the results recalculated. The reprocessed determination can then be
saved in the database as a new version.

NOTE

Determinations signed at level 2 can no longer be reprocessed.

Opening the reprocessing window

The reprocessing of determinations that have been selected in the Deter-
mination overview subwindow takes place in the independent Repro-
cessing dialog window, which is opened with Determina-

tions ▶ Reprocess... or the  symbol. When the window is opened,
the first of the selected determinations is always shown by default.
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Closing the reprocessing window

The Reprocessing dialog window is closed with [OK], [Cancel] or with
the Windows button for closing.

NOTE

The reprocessing window cannot be closed while the recalculation pro-
cess is still running.

4.5.2.6.2 Reprocessing - Window
Dialog window: Reprocessing

Subwindows

The Reprocessing dialog window contains the following two subwind-
ows that can be enlarged and reduced by dragging the separating bar
between them:

￭ Modifications
Modification of variables, method, statistics, curve evaluation

￭ Result view
Shows the current results

Functions

If determinations have been modified in the Modifications subwindow,
then the following functions can be triggered:

[Recalculate]

Recalculates the selected determination(s) with the modifications on varia-
bles, method, statistics or curve evaluation made in the Modifications
subwindow.

A progress bar is shown during recalculation. Recalculation can be abor-

ted by clicking on  next to the progress bar. The results of this recalcula-
tion are entered automatically in the Result view subwindow.

This button is disabled as long as no modifications have been made. After
the recalculation further data can be modified and then recalculation trig-
gered again.

[Reset]

Reset all modifications that were made but not yet saved during repro-
cessing to the original data and results.

This button is disabled for as long as no modifications have been made or
when the recalculation has not yet been triggered.
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[OK]

Close the Reprocessing dialog window. Each determination that has
been modified by reprocessing will be saved as a new version with a ver-
sion number increased by +1.

This button is disabled for as long as reprocessing has not yet been trig-
gered and if not all of the selected determinations were able to have been
recalculated.

[Cancel] or 

Close the Reprocessing dialog window. The result of the reprocessing
made since the last saving will not be saved.

NOTE

If the Comment on modification of determinations option is
enabled under Configuration ▶ Tools ▶ Security settings ▶ Audit
Trail/Modifications, the Modification comment determination
dialog window is displayed before saving.

4.5.2.6.3 Recalculation rules
Dialog window: Reprocessing

The following rule applies for recalculating the selected and modified
determinations:

With measuring commands (DET, MET, SET, KFT, KFC, BRC, MEAS, CAL
MEAS) only the evaluations with existing data will be recalculated. All
other parameters will be ignored.

4.5.2.6.4 Modifications

4.5.2.6.4.1 Modifications - Overview
Subwindow: Database ▶ Determination overview ▶ Determinations ▶ Repro-
cess... ▶ Reprocessing ▶ Modifications

In the subwindow Modifications of the dialog window Reprocessing
modifications can be made on the following 4 tabs:

￭ Variables
Modification of the variables used in the selected determination.

￭ Calculations
Selected determinations will be recalculated.

￭ Statistics
Modification of statistics data.
The tab Statistics will only be shown when the last determination
(and only this one) is selected from a set of determinations which,
because of the statistics defined in the method, belong together.
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￭ Curve evaluation
Manual modification of the curve evaluation.
The tab Curve evaluation is only shown when a single determination
is selected that contains curves that can be evaluated.

4.5.2.6.4.2 Modifications - Variables
Tab: Database ▶ Determination overview ▶ Determinations ▶ Repro-
cess... ▶ Reprocessing ▶ Modifications ▶ Variables

On the tab Variables the variables used in the determination can be
modified.

Variable table

The variable table shows those variables used that are present in all the
selected determinations and cannot be edited directly. With a click on the
column title (columns Variable, Value) the table can be sorted according
to the selected column in increasing or decreasing order.

Variable

Shows the name of the variable. Only the those variables are displayed
which are available in all the selected determinations and can be edited.
These include: the method variables FCT (factor) and DIV (divisor), the
sample data variables C00 (sample size), ID1 and ID2 (sample identifica-
tion, the common variables CV01 to CV25 as well as the following com-
mand variables:

￭ 1M.TITER
Titer value of the solution used in the command.

￭ 1M.CONC
Concentration of the solution used in the command.

Value

Display of the variable value. If a fixed value is defined for a variable, the
value will be presented in italics.

[Modify]

Open the dialog window Modify variable to modify the value of an
existing variable.
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NOTE

If a variable is modified, then with [Recalculate] all the selected deter-
minations will be recalculated with the new value. If one variable is not
modified then when several determinations are recalculated the original
value of the variable will be used (i.e. variables with the same name but
different values will not be overwritten until they are deliberately modi-
fied).

4.5.2.6.4.3 Modifications - Calculations
Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Modifica-
tions ▶ Calculations

Table with calculations

The table contains details on the calculations.

Result variable

Variable, which is automically generated by the program during the evalu-
ation or by the results defined by the user.

Result name

Name of the result. This name will be shown in the result view as well as
in the report. The result name can be used in further calculations as varia-
ble RS.Result name.VAL.

Formula

Calculation formula which can be generated after pressing  in the for-
mula editor.

Formula lines can be deleted according to normal rules ([Delete]), copied
([Ctrl+C]), cut ([Ctrl+x]) and be pasted ([Ctrl+v])

Entry 1000 characters
Default value empty

Unit

Unit of the result for the output (text only). The unit can be used in further
calculations as variable 'RS.Result name.UNI'.

Entry 16 characters
Default value empty

Decimal places

Number of decimal places for the output of the calculated result. This
parameter is ignored for results of the type text or date/time.
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Input range 0 - 5 
Default value 2 

Assignment

Assign a result to a defined result column RS01 … RS25. This order
specifies in which of the 25 available result columns in the determination
overview the result is being added to. Per calculation the result columns
RS01 ... RS25 are available. Only the columns still free are made avail-
able. With none the result will not be assigned to any column.

Input range RS01 - RS25 
Default value none 

Statistics

on | off (Default value: on)

If this check box is activated, the mean value and the absolute and relative
standard deviation are calculated for the result. This field is only active
when the statistics is enabled in the method of the imported determina-
tion (i.e. the statistics can only then be disabled and enabled again, if it
has already been enabled in the method).

Description

Freely selectable description of the result.

Entry 1000 characters
Default value empty

Functions

[New]

Opens the dialog window Result 'Resultname' - RS# (see Chapter
4.5.2.6.4.7, page 248). A maximum of 81 result calculations can be gen-
erated. Afterwards, the button [New] will be disabled.

[Delete]

Deletes the selected calculations from the table.

[Properties]

Opens the dialog window Result 'Result name' - RS# in order to edit
calculations selected in the table (see Chapter 4.5.2.6.4.7, page 248).

4.5.2.6.4.4 Modifications - Statistics
Tab: Database ▶ Determination overview ▶ Determinations ▶ Repro-
cess... ▶ Reprocessing ▶ Modifications ▶ Statistics

On the tab Statistics the single results for the statistics calculation can
subsequently be switched on and off.
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Results with statistics

Result name

Selection of the statistically evaluated result by using the result name for
which the single results of all determinations are shown.

Selection Result name

Table of single results

For the result selected above the following data for the individual determi-
nations is shown:

Determination start

Shows the date and time at which the determination was started.

Version

Shows the version number of the determination.

Sample size

Shows the sample size.

Result value

Shows the result value. The statistics data (mean value, standard devia-
tions, etc.) for the selected determination are listed in the subwindow
Result view .

[Determination on/off]

All single results of the selected determination for statistical calculations
can be switched off or on. If the determination is switched off then an
asterisk (*) appears behind all result values in the table and the line is
shown as inactive (gray); if it is switched on again then the asterisks will
disappear. However, updating the statistics data always only takes place
with [Recalculate].

[Result on/off]

Switch the selected single result for the statistical calculations off or on. If
the result is switched off, an asterisk (*) appears behind the result value, is
it switched on again, the asterisk disappears. However, updating the sta-
tistics data always only takes place with [Recalculate].



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 4 Database

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 237

NOTE

If the results of a determination are switched off, the statistics for these
results will be switched off when this determination is recalculated, i.e.
no data for the mean value and standard deviations will be shown.
However, the determinations remain statistically linked to each other so
that the results can also be switched on again.

4.5.2.6.4.5 Modify variable
Dialog window: Reprocessing ▶ Modifications ▶ Variables ▶ [Modify] ▶ Modifiy
variable

In the dialog window Modify variable the value of the selected variable
is modified.

Variable

Shows the name of the variable.

Value

Value of the variables. With variables of the type Date the date must be
entered in the dialog window (see Chapter 2.5.1, page 72).

Input range -1.0 E+99 - 1.0 E+99 (max. 15 digits) 
(for Type = Number)

Entry 100 characters
(for Type = Text)

Selection 'Date'
(for Type = Date/Time)

4.5.2.6.4.6 Curve evaluation

4.5.2.6.4.6.1 Modifications - Curve evaluation
Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Modifica-
tions ▶ Curve evaluation

On the tab Curve evaluation the curves that can be manually evaluated
are displayed.

Command name

Selection of the measuring command (command name.index - com-
mand type) for which the curve is to be shown for reprocessing.

Selection Command name
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[Edit]

The dialog window Curve evaluation opens for manually reprocessing
the curve evaluation.

4.5.2.6.4.6.2 Edit curve evaluation
Dialog window: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Mod-
ifications ▶ Curve evaluation ▶ [Edit] ▶ Curve evaluation

In the dialog window Curve evaluation the evaluation of the selected
curve can be reprocessed manually.

In the curve those EP's are indicated, which have values for the dimen-
sions of the x and y axis, i.e. manually set EP's are possibly not indicated.

Command name

Selection Command name

Command name
Selection of the measuring command for which the curve is to be
shown for reprocessing.

Toolbar

The toolbar above the curve contains symbols for the following functions
for re-evaluation of the curve:

Set EP manually

By moving the mouse a point on the curve is selected. The current
X and Y values are shown graphically with a blue cross hair and
numerically above the curve in the fields X and Y. A new endpoint
can be set by clicking with the left mouse button. This function is
activated as standard when the window Curve evaluation is
opened.

Set EP with intersection lines

By moving the mouse a point on the curve is selected to which
the tangent is automatically applied. The first tangent is set by
clicking the left mouse button. The mouse is then used to select a
second point to which the second tangent is to be applied. The
second tangent is set with clicking the left mouse button and at
the same time a new endpoint is set at the point where both tan-
gents intersect.
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Set EP with parallel tangents

By moving the mouse a point on the curve is selected to which
the tangent is automatically applied. At the same time a tangent
parallel to it is applied to the other leg of the curve. The two tan-
gents are set with a click of the left mouse button and at the
same time a new endpoint is set at the intersection of the middle
line of the two tangents with the curve.

NOTE

If new endpoints are set manually or by intersection or tangent evalua-
tion or if existing endpoints are deleted then the endpoints will always
be renumbered from left to right. During recalculation the automatic
evaluations will generally no longer be used for curves, i.e. the end-
points defined in the curve evaluation are retained.

Set horizontal auxiliary lines

By moving the mouse a horizontal auxiliary line is drawn in the
graph; this can be set by clicking the left mouse button. This func-
tion is only active when under Curve evaluation ▶ Proper-
ties ▶ Properties - Curves 1 ▶ Options the option Show
evaluation lines is enabled.

Set vertical auxiliary lines

By moving the mouse a vertical auxiliary line is drawn in the
graph; this can be set by clicking the left mouse button. This func-
tion is only active when under Curve evaluation ▶ Proper-
ties ▶ Properties - Curves 1 ▶ Options the option Show
evaluation lines is enabled.

Delete endpoints and auxiliary lines

With the context-sensitive menu item Delete EP# the selected
endpoint can be deleted, with Delete ###.### the selected aux-
iliary line can be deleted.

Zooming

By drawing out a rectangle with the left mouse button the
selected area can be zoomed.

Reset zoom

The graph will be reset to zoom level 100%.

Copy to clipboard

The content of the curve window is copied to the clipboard.
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Define properties for the graph display

The dialog window Properties - Curves # is opened for graph
display. The curve properties defined for each command type are
saved for the reprocessing window per client.

Show EP list

The dialog window Endpoints is opened in which all endpoints
of the selected curve are displayed in a table. If an endpoint is
added to or deleted from the curve then the table will be updated
automatically.

Show coordinates

The current coordinates of the cursor are shown in the coordinate display:

X:

X-coordinate.

Y:

Y-coordinate.

4.5.2.6.4.6.3 Curve evaluation - Endpoint list
Dialog window: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Mod-
ifications ▶ Curve evaluation ▶ [Edit] ▶ Curve evaluation ▶ Show EP list ▶ End-
points

The dialog window Endpoints opened with the icon  shows all auto-
matically found and manually set endpoints of the selected curve in tabu-
lar form. The endpoints are sorted according to ascending volume, if an
endpoint is deleted from or added to the curve then the table will be
updated automatically.

Endpoint

Designation of the endpoint with number. The following names are possi-
ble:

Selection EP#

EP#
Endpoint that has been determined automatically by potentiometric
evaluation or set manually by using the intersection or tangent
method.

Selection BP#

BP#
Endpoint that has been determined by automatic break point evalua-
tion.

Selection FP#
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FP#
Endpoint that has been determined by automatic fixed point evalua-
tion.

Volume

Volume value in mL for endpoint.

Measured value

Measured value (pH) for endpoint.

ERC

ERC value for the endpoint.

Time

Time for the endpoint.

Temperature

Temperature for the endpoint.

NOTE

Manually set endpoints only have two measured quantities, for the
other measured quantities invalid is entered.

[Delete]

Delete selected endpoint.

[Exit]

Close dialog window.

4.5.2.6.4.6.4 Curve evaluation - Properties

4.5.2.6.4.6.4.1 Properties curve evaluation - Overview
Dialog window: Database ▶ Determinations ▶ Reprocess... ▶ Reprocess-
ing ▶ Curve evaluation ▶ [Edit] ▶ Curve evaluation ▶ Icon 'Properties and Graphi-
cal display' ▶ Properties - 'Curve #'

The properties of the curve display in the dialog window Properties -
'Curve #' can be set on the following 4 tabs:

￭ x axis
Parameters for the graphical display of the curves on the x axis.

￭ y axis
Parameters for the graphical display of the curves on the left y axis.

￭ y2 axis
Parameters for the graphical display of the curves on the right y axis.
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￭ Options
Options for graphical display of curves.

4.5.2.6.4.6.4.2 Properties curve evaluation - x axis
Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Curve evalua-
tion ▶ [Edit] ▶ Curve evaluation ▶ Properties ▶ x axis

On the tab x axis the parameters for the graphical display of the curves
on the x axis can be set.

Command type

Shows the type of command for which the curve properties can be
defined. The curve properties defined for each command type for the
reprocessing window are saved per client.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be
scaled automatically. In this case the fields Start value and End value
cannot be edited.

Size

Selection Command-dependent selection

Command-dependent selection
Selection of the quantity to be shown on the x axis.

Label

Freely definable axis label for the x axis.

Selection 50 characters | auto
Default value auto

auto
The designation from the field Size will be used.

Scaling

Fixed scaling of the x axis between the start value and the end value.

Start value

Initial value for scaling the x axis.

Only editable when the option Autoscaling is disabled.
Input range -1.0E12 - 1.0E12 
Default value 0 

End value

End value for scaling the x axis.
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Only editable when the option Autoscaling is disabled.
Input range -1.0E12 - 1.0E12 
Default value 1000 

4.5.2.6.4.6.4.3 Properties curve evaluation - y axis
Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Curve evalua-
tion ▶ [Edit] ▶ Curve evaluation ▶ Properties ▶ y axis

On the tab y axis the parameters for the graphical display of the curves
on the y axis (left y axis) can be set.

Command type

Shows the type of command for which the curve properties can be
defined. The curve properties defined for each command type for the
reprocessing window are saved per client.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be
scaled automatically. In this case the fields Start value and End value
cannot be edited.

Size

Selection Command-dependent selection

Command-dependent selection
Selection of the quantiy to be shown on the y axis.

Label

Freely definable axis label for the y axis.

Selection 50 characters | auto
Default value auto

auto
The designation from the field Size will be used.

Scaling

Fixed scaling of the y axis between the start value and the end value.

Start value

Initial value for scaling the y-axis.

Only editable when the option Autoscaling is disabled.
Input range -1.0E12 - 1.0E12 
Default value 0 
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End value

End value for scaling the y-axis.

Only editable when the option Autoscaling is disabled.
Input range -1.0E12 - 1.0E12 
Default value 1000 

Curve

Curve color

Selection of the color for the curve line.

Selection 13 colors | blue
Default value blue

Symbol

Selection of the symbol for the display of the individual measuring points.

Selection 5 symbols | No symbol
Default value No symbol

No symbol
Measuring points are not shown.

NOTE

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols
again.

Symbol color

Selection of the color for the measuring point symbol.

Selection 13 colors | blue
Default value blue

Smoothing

Smoothing

on | off (Default value: on)

Switches smoothing on/off for the curve.

Smoothing factor x axis

Factor for smoothing on the x axis.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 4 Database

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 245

Input range 0.01 - 1000 
Default value 0.01 

Smoothing factor y-axis

Factor for smoothing on the y axis.

Input range 0.01 - 1000 
Default value 0.01 

Show with original curve

on | off (Default value: off)

If this check box is activated, then the original curve (solid line, same
color) will be shown in addition to the smoothed curve (dotted line).

4.5.2.6.4.6.4.4 Properties curve evaluation - y2 axis
Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Curve evalua-
tion ▶ [Edit] ▶ Curve evaluation ▶ Properties ▶ y2 axis

On the tab y2 axis the parameters for the graphical display of the curves
on the y2 axis (right y axis) can be set.

Command type

Shows the type of command for which the curve properties can be
defined. The curve properties defined for each command type for the
reprocessing window are saved per client.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be
scaled automatically. In this case the fields Start value and End value
cannot be edited.

Size

Selection Command-dependent selection | off
Default value off

Command-dependent selection
Selection of the quantity to be shown on the y2 axis.

Label

Freely definable axis label for the y2 axis.

Selection 50 characters | auto
Default value auto

auto
The designation from the field Size will be used.
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Curve

Curve color

Selection of the color for the curve line.

Selection 13 colors | red
Default value red

Symbol

Selection of the symbol for the display of the individual measuring points.

Selection 5 symbols | No symbol
Default value No symbol

No symbol
Measuring points are not shown.

NOTE

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols
again.

Symbol color

Selection of the color for the measuring point symbol.

Selection 13 colors | red
Default value red

Smoothing

Smoothing

on | off (Default value: on)

Switches smoothing on/off for the curve.

Smoothing factor x axis

Factor for smoothing on the x axis.

Input range 0.01 - 1000 
Default value 0.01 

Smoothing factor y-axis

Factor for smoothing on the y axis.
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Input range 0.01 - 1000 
Default value 0.01 

4.5.2.6.4.6.4.5 Properties curve evaluation - Options
Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Curve evalua-
tion ▶ [Edit] ▶ Curve evaluation ▶ Properties ▶ Options

On the tab Options the parameters for the graphical display of the curves
can be set.

Command type

Shows the type of command for which the curve properties can be
defined. The curve properties defined for each command type for the
reprocessing window are saved per client.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be
scaled automatically. In this case the fields Start value and End value
cannot be edited.

Display grid

Display grid

on | off (Default value: off)

If this check box is actjvated then a grid will be shown against the back-
ground.

Grid type

Selection of the type of grid line.

Selection 5 line types

Grid color

Selection of the grid line color.

Selection 13 colors | gray
Default value gray

Background

Background color

Selection of the color for the curve background.

Selection 13 colors | white
Default value white
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Show endpoints

Show endpoints

on | off (Default value: on)

If this check box is activated then the endpoints found will be shown on
the curve by the symbol ♦ and labeled with EP# (potentiometric end-
point), BP# (break point), FP# (fixed endpoint), HP (HNP), MI (minimum
value) or MA (maximum value).

Automatic EPs

Selection of the color for automatically set endpoints.

Selection 13 colors | black
Default value black

Manual EPs

Selects the color for manually set endpoints.

Selection 13 colors | pink
Default value pink

Show evaluation lines

Show evaluation lines

on | off (Default value: off)

If this check box is activated the evaluation lines (tangents, auxiliary lines)
will be shown.

Tangents

Selection of the color for the tangents and auxiliary lines.

Selection 13 colors | light green
Default value light green

Auxiliary lines

Selection of the color for the auxiliary lines.

Selection 13 colors | blue
Default value blue

4.5.2.6.4.7 Result Result name
Dialog window: Database ▶ Determination ▶ Reprocessing ▶ Modifications ▶ Cal-
culations ▶ [New]/[Properties] ▶ Result 'Result name' - RS##

In the dialog window Result Result name - RS## results and their prop-
erties can be edited.

The dialog window consists of the following two tabs:
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4.5.2.6.4.7.1 Definition
Tab: Database ▶ Determinations ▶ Reprocessing ▶ Modifications ▶ Calcula-
tions ▶ [New]/[Properties] ▶ Result 'Result name' - RS## ▶ Definition

Result variable

Variable, which is automically generated by the program during the evalu-
ation or by the results defined by the user.

Result name

Name of the result. This name will be shown in the result view as well as
in the report. The result name can be used in further calculations as varia-
ble RS.Result name.VAL.

Entry 50 characters
Default value empty

Formula

Calculation formula which can be generated after pressing  in the for-
mula editor.

Formula lines can be deleted according to normal rules ([Delete]), copied
([Ctrl+C]), cut ([Ctrl+x]) and be pasted ([Ctrl+v])

Entry 1000 characters
Default value empty

Unit

Unit of the result for the output (text only). The unit can be used in further
calculations as variable 'RS.Result name.UNI'.

Entry 16 characters
Default value empty

Decimal places

Number of decimal places for the output of the calculated result. This
parameter is ignored for results of the type text or date/time.

Input range 0 - 5 
Default value 2 

Assignment

Assign a result to a defined result column RS01 … RS25. This order
specifies in which of the 25 available result columns in the determination
overview the result is being added to. Per calculation the result columns
RS01 ... RS25 are available. Only the columns still free are made avail-
able. With none the result will not be assigned to any column.
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Input range RS01 - RS25 
Default value none 

Statistics

on | off (Default value: on)

If this check box is activated, the mean value and the absolute and relative
standard deviation are calculated for the result. This field is only active
when the statistics is enabled in the method of the imported determina-
tion (i.e. the statistics can only then be disabled and enabled again, if it
has already been enabled in the method).

Description

Freely selectable description of the result.

Entry 1000 characters
Default value empty

4.5.2.6.4.7.2 Monitoring
Tab: Database ▶ Determinations ▶ Reprocessing ▶ Modifications ▶ Calcula-
tions ▶ [New]/[Properties] ▶ Result 'Result name' - RS## ▶ Monitoring

Result monitoring

If this check box is activated, then the limit values for the result of the cal-
culation formula are being monitored.

Lower limit

Lower limit for the result. This parameter is only editable when the result
monitoring is enabled.

Entry 10 digits
Default value 0

Upper limit

Upper limit for the result. This parameter is only editable when the result
monitoring is enabled.

Entry 10 digits
Default value 99999.99999

Message

Only editable when the check box Monitoring result is activated.

Selection Display message | Record message

Display message
If this option is selected, the message "The limit value for the result 're-
sult name' has been exceeded." appears. At the same time the mes-
sage is documented, i.e. it is saved in the determination.
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Record message
If this option is selected, the message "The limit value for the result 're-
sult name' has been exceeded." is saved in the determination.

4.5.2.6.5 Result view
Subwindow: Database ▶ Determinations ▶ Reprocess… ▶ Reprocessing ▶ Result
view

In the Result view subwindow of the Reprocessing dialog window,
results and raw data are displayed on the following two tabs:

4.5.2.6.5.1 Result view - Results overview
Tab: Database ▶ Determinations ▶ Reprocess... ▶ Reprocessing ▶ Result
view ▶ Result overview

On the Result view tab of the Result display subwindow the results
calculated in the calculating commands and the variables used for this are
displayed and updated with each recalculation.

The following elements are displayed:

Title

Name of the calculation command (1C - 9C).

Result

Result name, result value with defined number of decimal places, result
unit.

Statistical evaluations

Results of the statistical evaluation (mean value, absolute and relative stan-
dard deviations, number of measured values used for the statistics).

Navigation

If several determinations are selected for reprocessing, the navigation but-
tons can be used to switch between the result view of the individual
determinations:

Jump to the first determination.

Jump to the previous determination.

Jump to the next determination.

Jump to the last determination.
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4.5.2.6.5.2 Result view - Raw data
Tab: Database ▶ Determinations ▶ Reprocess… ▶ Reprocessing ▶ Result dis-
play ▶ Raw data

On the Raw data tab of the Result view subwindow the raw data gen-
erated in commands with evaluations will be shown and updated at each
recalculation.

If several determinations are selected for reprocessing then the navigation
buttons can be used to switch between the result view of the individual
determinations:

Jump to the first determination.

Jump to the previous determination.

Jump to the next determination.

Jump to the last determination.

4.5.2.6.6 Modification comment for determinations
Dialog window: Database ▶ Determinations ▶ Delete/Reprocess...

If the option Comment on modification of determinations is switched
on in the security settings then before the modified sample data is
accepted the window Modification comment determination first
appears in which a Reason must be selected and a Comment on the
modification must be entered.

Reason

Selection from the default reasons defined for the category Modifica-
tions of determinations in the Security settings dialog window.

Selection Selection from default reasons

Comment

Entry of a comment on the modification of the determinations.

Entry 1000 characters
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4.5.2.7 Sending determinations to
Dialog window: Database ▶ Determinations ▶ Send to...

The menu item Determinations ▶ Send to...  opens the dialog window
Send determinations per E-mail.

Selection Determination ID | Sample identification | File
name

Default value Determination ID

Determination ID
With this option, the name of the export file is formed out of an unam-
biguous determination ID, the computer name, the date stamp -
YYYYMMDD-HHMMSS and the suffix for the format.

Sample identification
With this option the sample identification is selected. The name of the
export file is formed out of this ID, the computer name, the date stamp
YYYYMMDD-HHMMSS and the suffix for the format. If the created
name exists already in the directory, a version number will be appen-
ded additionally to the date.

File name
With this option the name under which the export file of a determina-
tion is saved as an attachment to the E-mail message is entered. If
more than one determination is selected, then a sequential number will
be added to this name for each determination.

After each confirmation of the file name with [OK] every determination is
exported to a separate *.tdet file. The standard Windows E-mail Client
will open with an empty message and the export files will automatically be
added as an attachment.

4.5.2.8 Exporting determinations
Dialog window: Database ▶ Determinations ▶ Export… ▶ Export determinations

Click on the Determinations ▶ Export… menu item to open the
Export determinations dialog window for exporting the selected deter-
minations.

Selection

Selection of determinations for the export.

Selection All selected data records | All filtered data
records

Default value All selected data records

All selected data records
All those determinations are exported that have been selected (high-
lighted) in the determination table.
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All filtered data records
All the determinations from the determination table as a whole that
correspond to the set filter are exported.

Export template

Selection of the export template for the data export.

Selection 'Export template'

4.5.2.9 Importing determinations
Dialog window: Database ▶ Determinations ▶ Import… ▶ Import determinations

The Determinations ▶ Import… menu item opens the Import deter-
minations dialog window, in which the determinations to be imported
must be selected. These determinations are then imported into the open
database.

NOTE

Supported file formats:

￭ *.txt (PC/LIMS report)
￭ *.tdet (tiBase format)
￭ *.utf8 (Unicode)

4.5.2.10 Deleting determinations
Menu item: Database ▶ Determinations ▶ Delete

The selected determinations are deleted after the confirmation request

with the  symbol or the Determinations ▶ Delete menu item.

NOTE

If a database is opened simultaneously on several clients and if determi-
nations are deleted on a client, then these will continue to be shown on
the other clients in the determination table until the table is updated.
All the fields of these determinations will then have the entry deleted.

NOTE

If the Comment on modification of determinations check box in
the Security settings is activated, then the Modification comment
determination window will appear before the modification is saved.
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4.5.2.11 Determination overview - Print
Dialog window: Database ▶ File ▶ Print ▶ Determination overview… ▶ Print deter-
mination overview (PDF)

The Menu item File ▶ Print ▶ Determination overview... opens the
dialog window Print determination overview (PDF).

Selection

Selection Selected determinations | All filtered determi-
nations

Default value Selected determinations

Selected determinations
If this option is selected, then a list with all determinations that are
selected (marked) in the determination table will be produced.

All filtered determinations
If this option is selected, then a list with all the determinations in the
determination table that meet the filter criterion will be produced.

Orientation

Selection Portrait | Landscape
Default value Portrait

Portrait
If this option is selected then the determination table will be produced
in portrait format.

Landscape
If this option is selected then the determination table will be produced
in landscape format.

[OK]

The determination table is produced in the required format as a PDF file
and opened directly with Acrobat Reader; it can then be printed out and/
or saved.

4.5.2.12 Determinations - Print report
Dialog window: Database ▶ File ▶ Print ▶ Report... ▶ Report output

The menu item File ▶ Print ▶ Report... opens the dialog window
Report output.

Selection

Selection Selected determinations | All filtered determi-
nations

Default value Selected determinations

Selected determinations
If this option is selected, then the reports will be produced for all deter-
minations that are selected (marked) in the determination table.
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All filtered determinations
If this option is selected, then the reports will be produced for all the
determinations in the determination table that meet the filter criterion.

Report type

Selection Original report(s) | Report template
Default value Original report(s)

Original report(s)
If this option is selected then the reports produced during the determi-
nation will appear at the Output target defined below.

Report template
If this option is selected then reports according to the selected Report
template will be produced at the Output target defined below.

NOTE

Original report is used to refer to a report, which has been automati-
cally generated at the creation of the determination version. If a
determination is being reprocessed, a new determination version and
therefore also a new original report is created.

In order to print the report of the non-reprocessed determination the
determination 1 must be selected.

Output target

Printer

on | off (Default value: on)

If this check box is activated, the reports are printed on the selected
printer.

PDF file

on | off (Default value: off)

If this check box is activated the reports are put out as PDF files under the
entered file name.

NOTE

If several reports are produced simultaneously as a PDF file then an
index will be automatically appended to the file name.
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4.5.2.13 Determinations - Displaying history
Menu item: Database ▶ Determinations ▶ Show history

Switch history view on/off

With the menu item Determinations ▶ Display history... or the symbol

 only the currently focused determination in the Determination table as
well as all the previous versions of this determination will be shown.

If the History view with the menu item Determinations ▶ Display his-

tory... or the symbol  is disabled again, then the original selection of
determinations in the Determination table will appear again.

4.5.2.14 Determinations - Make current
Menu item: Database ▶ Determinations ▶ Make current

Make old version current

With the menu item Determinations ▶ Make current... or the symbol

 the determination version selected in the determination table will again
be made the current determination version. This creates a new determina-
tion whose version number is increased by +1 compared with the last ver-
sion to have been saved.

4.5.2.15 Determinations - Show calibration curve
Dialog window: Database ▶ Determinations ▶ Show calibration curve… ▶ Calibra-
tion curve

With the Determinations, Show calibration curve… menu item or

the  symbol the calibration or standard addition curve is shown for the
determination selected in the Calibration curve dialog window.

Calibration curve for CAL LOOP pH

In the Calibration curve dialog window a tab marked with the com-
mand name showing the calibration curve and calibration data will be dis-
played for each CAL LOOP pH command . The command type is shown
above the calibration curve. The curve display shows the measured values
and the curve calculated from these measured values. Listed below are the
individual measured values and the results for Slope, E(0) and Variance.

Calibration curve for CAL LOOP Conc

In the Calibration curve dialog window a tab marked with the com-
mand name showing the calibration curve and calibration data will be dis-
played for each CAL LOOP Conc command . above the calibration curve.
The curve display shows the measured values and the curve calculated
from these measured values. Listed below are the individual measured val-
ues and the results for Slope, E(0), c(blank) and Variance. Calibration
curve for CAL LOOP Conc
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Standard addition curve for STDADD

In the Calibration curve dialog window a tab marked with the com-
mand name showing the standard addition curve and evaluation data will
be displayed for each STDADD command. The command type is shown
above the calibration curve. The curve display shows the measured values
and the curve calculated from these measured values. Listed below are the
individual measured values and the results for Determination, Show
calibration curve…, E(0) and Variance.

NOTE

Calibration curves cannot be printed out directly from the Calibration
curve dialog window. Instead, you should use a report with a report
template which contains the fixed report .

4.5.2.16 Determinations - Control chart
Dialog window: Database ▶ Determinations ▶ Control chart… ▶ Control chart

With the Determinations, Control chart... menu item or the  symbol
the Control chart - 'Template name' dialog window opens, in which a
control chart containing statistical evaluation (mean value, number of
determinations, absolute and relative standard deviation) is shown for the
selected determinations according to the loaded template.

Template

Selection Default | 'Template name'
Default value Default

Default
Selection of the saved templates for control charts (see Chapter
4.4.3.2.1, page 179). When the dialog window is opened, the last
template to have been loaded will be loaded. If a new template is
selected, then the display will be updated automatically.

[Templates]

Open the Templates for control charts dialog window .

Graph display

Shows the measured values together with warning and intervention limits
and statistical values according to the settings on the selected control
chart. If the cursor is moved to a point then the number, date and value
appear as a tooltip. The sorting and, for the first and last point, the date
and time are shown as the legend.
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[Print (PDF)]

Opens the Print control chart (PDF) (see Chapter 4.5.2.19, page 260)
dialog window. The content of the control chart can be shown as a PDF
file in the required format.

4.5.2.17 Determinations - Overlay curves
Menu item: Database ▶ Determinations ▶ Overlay curves… ▶ Overlay curves

The Determinations, Overlay curves… menu item or the  symbol
opens the Overlay curves dialog window, in which overlaid curves of the
selected determinations are shown according to the loaded template.

Template

Selection of a saved template for showing overlaying curves.

Selection Standard | "Template" | Last saved template
Default value Last saved template

If a new template is selected then the display will be
updated automatically.

NOTE

The Command type for which the overlaying of curves is possible is
defined in the template. Curves from the selected determinations can
only be overlaid when the determination method contains a command
with this Command type (e.g. DET).

Command name

Selection of the command whose curves are to be displayed with the
selected template.

Selection "Command"
This selection is only necessary if the method con-
tains several commands of the same Command
type.

[Templates]

Opens the Curve overlay templates dialog window.

Graph display

Shows the curves according to the settings of the selected template. The
command type (e.g. DET pH) is shown centrally above the graph. At the
right of the curve the legend is shown with the line number in the deter-
mination table belonging to the determination.
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The legend consists of the content of a data field which can be defined in
the options of the template and of a counter identifying the curves if the
same command has been executed several times during a determination.

[Print (PDF)]

Opens the Print curves (PDF) (see Chapter 4.5.2.18, page 260) dialog
window. The content of the curve overlay with legend can be shown as a
PDF file in the required format.

4.5.2.18 Printing overlaid curves
Dialog window: Database ▶ Determinations ▶ Overlay curves… ▶ Overlay
curves ▶ [Print (PDF)] ▶ Print curves (PDF)

With [Print (PDF)] in the Overlay curves dialog window, the Print
curves (PDF) dialog window is opened.

Orientation

Selection Portrait format | Landscape format
Default value Landscape format

Portrait format
Produces the control chart in portrait format.

Landscape format
Produces the control chart in landscape format.

Comment

Possibility of entering comments on the control chart which will be pro-
duced together with the control chart.

Entry 1,000 characters

[OK]

Close the dialog window. The control chart is produced in the required
format as a PDF file and opened directly with the Acrobat Reader. It can
then be printed out and/or saved.

4.5.2.19 Print control chart

In the dialog window Print control chart (PDF) the format for the print-
out of the control chart is indicated.

Orientation

Selection Portrait | Landscape
Default value Landscape

Portrait
Produces control chart in portrait format.

Landscape
Produces control chart in landscape format.
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Comment

Possibility of entering comments on the control chart which will be pro-
duced together with the control chart.

Entry 1000 characters

[OK]

The control chart is shown in the required format as a PDF file and opened
directly with the Acrobat Reader; it can then be printed out and/or saved.

4.6 Subwindow Information

4.6.1 Information - Overview 
Subwindow: Database ▶ Information

General

In the subwindow Information general information about the focused
determination in the determination table is shown. The subwindow can
be switched on in the program part Database during the definition of
the layout and thus made visible. It can be enlarged and reduced as
required; it can also be maximized.

Tabs

Information about the determination is shown on the following tabs:

￭ Determination
Display of general information about determination.

￭ Method
Shows general information about the method used.

￭ Sample
Shows general information about the sample used.

￭ Configuration
Shows general information about the devices, sensors and common
variables used.

￭ Messages
Shows messages about the determination.

￭ Determination comment
Shows the comment on the determination.

4.6.2 Information - Determination 
Tab: Database ▶ Information ▶ Determination

Display of general information about determination.

Identification

Information about the identification of the determination.
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Determination ID:

Unambiguous and unmistakable identification for the determination.

Sample number:

Shows the Sample number entered in the run window.

Start counter:

Shows the start counter which is increased by +1 at the start of each
determination. The start counter is saved for each client and cannot be
reset.

Recording

Information about recording the determination.

Determination start:

Date and time at start of determination.

Determination duration:

Duration of the determination from its start to its end or termination in s.

Determination run:

Way in which the determination was ended:

Selection Regular without errors | Manual stop |  error

Regular without errors
The determination was finished automatically after the method was
processed normally and without any errors.

Manual stop
The determination has been ended with the [Stop] fixed key.

error
The determination has been ended because an error occured.

User (short name):

Short name of the user.

Program version

Display of program version and build number of tiBase with which the
PC_LIMS report was imported and edited.

Status/Version

Information about the determination version.

Determination status:

Selection original | modified
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original
Determination data unaltered.

modified
Determination data modified.

Determination version:

Version of the determination. The unaltered original determination has the
version number 1, reprocessed determinations have a version number >1.

Reprocessing date:

Date and time when the reprocessed determination version was saved.

Reprocessed by (short name):

Short name of user logged in when determination was reprocessed. If a
new version was generated automatically by reprocessing statistically
linked determinations without modification of determination data, tiBase
1.1 Patch 1 will be displayed here.

Reprocessed by (full name):

Full name of user logged in when determination was reprocessed. If a
new version was generated automatically by reprocessing statistically
linked determinations without modification of determination data, New
generated version for statistics will be displayed here.

Modification reason determination:

Reason for the determination modification.

Modification comment determination:

User comment on the determination modification.

Signature Level #

Information about the signatures at Level 1 or Level 2 in chronological
order.

Signature date:

Date and time at which the determination was signed.

Signed by (short name):

Short name of user who signed the determination.

Signed by (full name):

Full name of user who signed the determination.

Signature reason:

Reason for signature selected by user.
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Signature comment:

User comments on signing the determination.

4.6.3 Information - Method 
Tab: Database ▶ Information ▶ Method

Shows general information about the method used.

Identification

Information about the identification of the method.

Method name:

Name of the method.

Method ID:

Unambiguous identification for the method.

Method comment:

Method comment (Command comment on START command).

Status/Version

Information about method version.

Method status:

Selection new | modified | saved | reviewed | released

new
The method has been newly created and not yet saved.

modified
The method has been reprocessed but not saved.

saved
The method has been saved.

reviewed
The method has been signed at stage 1.

released
The method has been signed at stage 2.

Method version:

Version of the method the determination was created with.

Method saving date:

Date and time when the modified method version was saved.

Method saved by (short name):

Short name of user logged in when modified method was saved.
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Modification reason method:

Reason for the method modification.

Modification comment method:

User comment on the method modification.

Signature Level #

Information about the signatures at Level 1 or Level 2 in chronological
order.

Signature date:

Date and time at which the method was signed.

Signed by (short name):

Short name of the user who signed the method.

Signature reason:

Reason for signature selected by user.

Signature comment:

User comments on signing the method.

4.6.4 Information - Sample
Tab: Database ▶ Information ▶ Sample

Shows general information about the sample used.

Sample data

Information about the sample. The only sample data shown is that for
which a value is available.

Sample size:

Value for the sample size.

Sample size unit:

Unit of sample size.

Identification

Information about the sample identifications.

ID1

Shows the sample identification saved under ID1. The identifications will
only be shown when a value is present.
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ID2

Shows the sample identification saved under ID2. The identifications will
only be shown when a value is present.

4.6.5 Information - Configuration 
Tab: Database ▶ Information ▶ Configuration

Shows general information about the devices, sensors and common varia-
bles used.

Device 'Software name'

Information about the device used (only the existing device information
will be shown).

Device type:

Name of the software.

Program version:

Version of the software.

Device serial number:

Serial number of the software.

Device 'Device name'

Information about the device used (only the existing device information
will be shown).

Device type:

Type of device.

Program version:

Device program version.

Device serial number:

Serial number of the instrument.

　 

Rack name:

Name of the rack on the sample changer.

Rack code:

Rack code of the rack on the sample changer.
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Tower:

Number of the tower on which a Swing Head is used.

Swing Head type:

Type of Swing Head attached to tower.

Swing Head serial number:

Serial number of Swing Head attached to tower.

　 

Measuring input:

Number of the measuring input (+ designation iConnect for intelligent
sensors).

ADC type:

Type of analog/digital converter.

ADC serial number:

Serial number of measuring input.

Temperature sensor:

Type of connected temperature sensor.

　 

Stirrer:

Stirrer connection at device.

Stirrer type:

Type of stirrer.

Stirrer serial number:

Serial number of stirrer.

　 

Dosing device:

Dosing connection at device.

Dosing device type:

Dosing device type.

Dosing device serial number:

Serial number of dosing device.
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Exchange/Dosing unit:

Type of exchange or dosing unit.

Remote Box:

Connection to device.

Buret serial number

Serial number of the buret.

Solution 'Solution name'

Solution name:

Name of the solution.

Concentration:

Concentration value and unit of the solution.

Titer:

Titer value and units of the solution.

Date titer det.:

Date of the titer determination.

Titer method:

Method with which the titer was determined.

Sensor 'Sensor name'

Information about the sensor used.

Sensor type:

Type of sensor (+ designation IS for intelligent sensors).

Sensor serial number:

Serial number of sensor.

Order number:

Order number of sensor.

Slope:

Electrode slope of the sensor used (in % for pH sensor or in mV for ISE).

pH (0):

Electrode zero point of the sensor used (dimensionless for pH sensor).
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Calibration temperature:

Temperature during the calibration.

Calibration method:

Shows the method with which the calibration was carried out.

User:

Shows the user logged in during the calibration or who entered the cali-
bration data manually.

E (0):

Electrode zero point of the sensor used (in mV only for ISE).

c (blank):

Blank value of the ISE sensor used.

Cell constant:

Cell constant of the conductivity sensor used.

Common variable 'Name'

Information about the common variable used.

Value:

Value and unit of the common variables at the start of the determination.

4.6.6 Information - Messages 
Tab: Database ▶ Information ▶ Messages

Shows messages generated during the determination run.

'Time'

Shows the time at which the message was generated in the run (date,
time, UTC in the format YYYY-MM-DD hh:mm:ss UTC.....).

Message title:

Shows the message title and number.

Message source:

Shows from where the message comes:



4.7 Results subwindow ￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭

270 ￭￭￭￭￭￭￭￭ tiBase 1.1 Patch 1

4.6.7 Information - Determination comment 
Tab: Database ▶ Information ▶ Determination comment

Shows the comment on the determination.

Determination comment:

Shows the comment entered for the determination.

4.7 Results subwindow

4.7.1 Results - General
Subwindow: Database ▶ Results

In the subwindow Results in the program part Database the results cal-
culated in the calculation commands and the variables used for are
shown. It shows the results overview, the raw data of the commands with
evaluations as well as the results calculated in the calculation commands,
statistical evaluations, formulas and all variables used for for the determi-
nation selected in the determination overview.

When navigating in the determination overview this data will be updated
automatically (with a certain delay).

The subwindow Results can be switched on and made visible in the defi-
nition of the layout in the program part Database. It can be enlarged and
reduced as required; it can also be maximized.

Tabs

The results of the determination are shown on the following tabs:

￭ Results overview
Shows the results overview for all calculation commands.

￭ Raw data
Display of evaluation raw data for commands with evaluations.

￭ "Command name"
Show the results for a single calculation command. A tab with the cor-
responding command name is provided for each calculation command.

4.7.2 Results - Results overview
Tab: Database ▶ Result ▶ Results overview

On the tab Results overview the results for all calculation commands
and (if existent and desired) the corresponding statistical evaluations are
displayed. The display of the statistical evaluations can be selected in the
dialog window Properties result window
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Command "Command name"

For each CALC command a results overview is shown according to the
following pattern:

"Command name"

Name of the CALC command.

NOTE

Only the last results having been calculated will be shown. For example,
if there are several commands that generate a result with the same
name, then the corresponding result data will be shown only for that
command that was the last to calculate the result. Nothing will be
shown for the other commands.

"Result"

Shows the result name and result value with the defined number of deci-
mal places and units.

NOTE

If a result value is monitored and lies within the limit value defined in
the CALC command then the text will be shown in green, if it lies out-
side the limits it will be shown in red text color.

Mean value:

Shows the mean value for statistically evaluated results.

s(abs):

Shows the absolute standard deviation for statistically evaluated results.

s(rel):

Shows the relative standard deviation for statistically evaluated results.

Minimum:

Shows the minimum value for statistically evaluated results.

Maximum:

Shows the maximum value for statistically evaluated results.

n:

Shows the number of measurements for statistically evaluated results.
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4.7.3 Results - Raw data
Tab: Database ▶ Results ▶ Raw data

On the Raw data tab the evaluation results of commands with evalua-
tions are shown.

"Command name"

For each CALC command the raw data is displayed in six columns.

Column 1

Display of the command type.

Column 2

Shows the variable designation for the raw data.

Columns 3 - 6

Display of the raw data.

The following tables show the raw data displayed depending on the com-
mand type. For each variable the Variable name, Unit and Number of
decimal places is indicated.

Table 1 Command DET pH

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,pH, 3 EP#.TIM, s, 1 EP#.TEM, °C, 1

FP# FP#.VOL, mL, 4 FP#.MEA, pH, 3 FP#.TIM, s, 1 FP#.TEM, °C, 1

HP# HP#.VOL, mL, 4 HP#.MEA, pH, 3 HP#.TIM, s, 1 HP#.TEM, °C, 1

MI MI.VOL, mL, 4 MI.MEA, pH, 3 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, pH, 3 MA.TIM, s, 1 MA.TEM, °C, 1

BP# BP#.VOL, mL, 4 BP#.MEA, pH, 3 BP#.TIM, s, 1 BP#.TEM,°C, 1

Table 2 Command DET U

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,mV, 1 EP#.TIM, s, 1 EP#.TEM, °C, 1

FP# FP#.VOL, mL, 4 FP#.MEA, mV, 1 FP#.TIM, s, 1 FP#.TEM, °C, 1

HP# HP#.VOL, mL, 4 HP#.MEA, mV, 1 HP#.TIM, s, 1 HP#.TEM, °C, 1

MI MI.VOL, mL, 4 MI.MEA, mV, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, mV, 1 MA.TIM, s, 1 MA.TEM, °C, 1

BP# BP#.VOL, mL, 4 BP#.MEA, mV, 1 BP#.TIM, s, 1 BP#.TEM,°C, 1
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Table 3 Command DET Ipol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,mV, 1 EP#.TIM, s, 1 EP#.TEM, °C, 1

FP# FP#.VOL, mL, 4 FP#.MEA, mV, 1 FP#.TIM, s, 1 FP#.TEM, °C, 1

HP# HP#.VOL, mL, 4 HP#.MEA, mV, 1 HP#.TIM, s, 1 HP#.TEM, °C, 1

MI MI.VOL, mL, 4 MI.MEA, mV, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, mV, 1 MA.TIM, s, 1 MA.TEM, °C, 1

BP# BP#.VOL, mL, 4 BP#.MEA, mV, 1 BP#.TIM, s, 1 BP#.TEM,°C, 1

Table 4 Command DET Upol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,µA, 1 EP#.TIM, s, 1 EP#.TEM, °C, 1

FP# FP#.VOL, mL, 4 FP#.MEA, µA, 1 FP#.TIM, s, 1 FP#.TEM, °C, 1

HP# HP#.VOL, mL, 4 HP#.MEA, µA, 1 HP#.TIM, s, 1 HP#.TEM, °C, 1

MI MI.VOL, mL, 4 MI.MEA, µA, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, µA, 1 MA.TIM, s, 1 MA.TEM, °C, 1

BP# BP#.VOL, mL, 4 BP#.MEA, µA, 1 BP#.TIM, s, 1 BP#.TEM,°C, 1

Table 5 Command MET pH

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,pH, 3 EP#.TIM, s, 1 EP#.TEM, °C, 1

FP# FP#.VOL, mL, 4 FP#.MEA, pH, 3 FP#.TIM, s, 1 FP#.TEM, °C, 1

HP# HP#.VOL, mL, 4 HP#.MEA, pH, 3 HP#.TIM, s, 1 HP#.TEM, °C, 1

MI MI.VOL, mL, 4 MI.MEA, pH, 3 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, pH, 3 MA.TIM, s, 1 MA.TEM, °C, 1

BP# BP#.VOL, mL, 4 BP#.MEA, pH, 3 BP#.TIM, s, 1 BP#.TEM,°C, 1

Table 6 Command MET U

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,mV, 1 EP#.TIM, s, 1 EP#.TEM, °C, 1

FP# FP#.VOL, mL, 4 FP#.MEA, mV, 1 FP#.TIM, s, 1 FP#.TEM, °C, 1

HP# HP#.VOL, mL, 4 HP#.MEA, mV, 1 HP#.TIM, s, 1 HP#.TEM, °C, 1

MI MI.VOL, mL, 4 MI.MEA, mV, 1 MI.TIM, s, 1 MI.TEM, °C, 1
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Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

MA MA.VOL, mL, 4 MA.MEA, mV, 1 MA.TIM, s, 1 MA.TEM, °C, 1

BP# BP#.VOL, mL, 4 BP#.MEA, mV, 1 BP#.TIM, s, 1 BP#.TEM,°C, 1

Table 7 Command MET Ipol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,mV, 1 EP#.TIM, s, 1 EP#.TEM, °C, 1

FP# FP#.VOL, mL, 4 FP#.MEA, mV, 1 FP#.TIM, s, 1 FP#.TEM, °C, 1

HP# HP#.VOL, mL, 4 HP#.MEA, mV, 1 HP#.TIM, s, 1 HP#.TEM, °C, 1

MI MI.VOL, mL, 4 MI.MEA, mV, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, mV, 1 MA.TIM, s, 1 MA.TEM, °C, 1

BP# BP#.VOL, mL, 4 BP#.MEA, mV, 1 BP#.TIM, s, 1 BP#.TEM,°C, 1

Table 8 Command MET Upol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,µA, 1 EP#.TIM, s, 1 EP#.TEM, °C, 1

FP# FP#.VOL, mL, 4 FP#.MEA, µA, 1 FP#.TIM, s, 1 FP#.TEM, °C, 1

HP# HP#.VOL, mL, 4 HP#.MEA, µA, 1 HP#.TIM, s, 1 HP#.TEM, °C, 1

MI MI.VOL, mL, 4 MI.MEA, µA, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, µA, 1 MA.TIM, s, 1 MA.TEM, °C, 1

BP# BP#.VOL, mL, 4 BP#.MEA, µA, 1 BP#.TIM, s, 1 BP#.TEM,°C, 1

Table 9 Command SET pH

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,pH, 3 EP#.TIM, s, 1 EP#.TEM, °C, 1

DRI DRI, µL/min, 1    

DTI DTI, s, 1    

FP# FP#.VOL, mL, 4 FP#.MEA, pH, 3 FP#.TIM, s, 1 FP#.TEM,°C, 1

MI MI.VOL, mL, 4 MI.MEA, pH, 3 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, pH, 3 MA.TIM, s, 1 MA.TEM, °C, 1
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Table 10 Command SET U

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,mV, 1 EP#.TIM, s, 1 EP#.TEM, °C, 1

DRI DRI, µL/min, 1    

DTI DTI, s, 1    

FP# FP#.VOL, mL, 4 FP#.MEA, mV, 1 FP#.TIM, s, 1 FP#.TEM,°C, 1

MI MI.VOL, mL, 4 MI.MEA, mV, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, mV, 1 MA.TIM, s, 1 MA.TEM, °C, 1

Table 11 Command SET Ipol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,mV, 1 EP#.TIM, s, 1 EP#.TEM, °C, 1

DRI DRI, µL/min, 1    

DTI DTI, s, 1    

FP# FP#.VOL, mL, 4 FP#.MEA, mV, 1 FP#.TIM, s, 1 FP#.TEM,°C, 1

MI MI.VOL, mL, 4 MI.MEA, mV, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, mV, 1 MA.TIM, s, 1 MA.TEM, °C, 1

Table 12 Command SET Upol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP# EP#.VOL, mL, 4 EP#.MEA,µA, 1 EP#.TIM, s, 1 EP#.TEM, °C, 1

DRI DRI, µL/min, 1    

DTI DTI, s, 1    

FP# FP#.VOL, mL, 4 FP#.MEA, µA, 1 FP#.TIM, s, 1 FP#.TEM,°C, 1

MI MI.VOL, mL, 4 MI.MEA, µA, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, µA, 1 MA.TIM, s, 1 MA.TEM, °C, 1

Table 13 Command KFT Ipol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP EP.VOL, mL, 4 EP.MEA,mV, 1 EP.TIM, s, 1 EP.TEM, °C, 1

DRI DRI, µL/min, 1    

DTI DTI, s, 1    

FP# FP#.VOL, mL, 4 FP#.MEA, mV, 1 FP#.TIM, s, 1 FP#.TEM,°C, 1
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Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

MI MI.VOL, mL, 4 MI.MEA, mV, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, mV, 1 MA.TIM, s, 1 MA.TEM, °C, 1

Table 14 Command KFT Upol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP EP.VOL, mL, 4 EP.MEA,µA, 1 EP.TIM, s, 1 EP.TEM, °C, 1

DRI DRI, µL/min, 1    

DTI DTI, s, 1    

FP# FP#.VOL, mL, 4 FP#.MEA, µA, 1 FP#.TIM, s, 1 FP#.TEM,°C, 1

MI MI.VOL, mL, 4 MI.MEA, µA, 1 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, µA, 1 MA.TIM, s, 1 MA.TEM, °C, 1

Table 15 Command KFC

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP EP.MEA, mV, 1 EP.QTY,µg, 1 EP.TIM, s, 1 EP.TEM, °C, 1

DRI DRI, µg/min, 1    

DTI DTI, s, 1    

FP# FP#.MEA, mV, 1 FP#.QTY, µg, 1 FP#.TIM, s, 1 FP#.TEM,°C, 1

Table 16 Command BRC

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EP EP.MEA, mV, 1 EP.QTY,µg, 1 EP.TIM, s, 1 EP.TEM, °C, 1

DRI DRI, µg/min, 1    

DTI DTI, s, 1    

FP# FP#.MEA, mV, 1 FP#.QTY, µg, 1 FP#.TIM, s, 1 FP#.TEM,°C, 1

Table 17 Command STAT pH

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

MR MR.MRT, mL/min,
4

MR.MRS, mL/min,
4

MR.MRC, "empty",
3

 

RE# RE#.DRT, mL/min,
4

RE#.DRS, mL/min,
4

RE#.DRC, "empty",
3

 

FP# FP#.VOL, mL, 4 FP#.MEA, pH, 3 FP#.TIM, s,1 FP#.TEM,°C, 1
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Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

MI MI.VOL, mL, 4 MI.MEA, pH, 3 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, pH, 3 MA.TIM, s, 1 MA.TEM, °C, 1

Table 18 Command STAT U

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

MR MR.MRT, mL/min,
4

MR.MRS, mL/min,
4

MR.MRC, "empty",
3

 

RE# RE#.DRT, mL/min,
4

RE#.DRS, mL/min,
4

RE#.DRC, "empty",
3

 

FP# FP#.VOL, mL, 4 FP#.MEA, mV, 3 FP#.TIM, s,1 FP#.TEM,°C, 1

MI MI.VOL, mL, 4 MI.MEA, mV, 3 MI.TIM, s, 1 MI.TEM, °C, 1

MA MA.VOL, mL, 4 MA.MEA, mV, 3 MA.TIM, s, 1 MA.TEM, °C, 1

Table 19 Command MEAS pH

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EME EME, pH, 3    

ETE ETE, °C, 1    

FP# FP#.MEA, pH, 3 FP#.TIM, s,1 FP#.TEM,°C, 1  

MI MI.MEA, pH, 3 MI.TIM, s, 1 MI.TEM, °C, 1  

MA MA.MEA, pH, 3 MA.TIM, s, 1 MA.TEM, °C, 1  

BP# BP#.MEA, pH, 3 BP#.TIM, s, 1 BP#.TEM, °C, 1  

Table 20 Command MEAS U

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EME EME, mV, 1    

ETE ETE, °C, 1    

FP# FP#.MEA, mV, 1 FP#.TIM, s,1 FP#.TEM,°C, 1  

MI MI.MEA, mV, 1 MI.TIM, s, 1 MI.TEM, °C, 1  

MA MA.MEA, mV, 1 MA.TIM, s, 1 MA.TEM, °C, 1  

BP# BP#.MEA, mV, 1 BP#.TIM, s, 1 BP#.TEM, °C, 1  
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Table 21 Command MEAS Ipol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EME EME, mV, 1    

ETE ETE, °C, 1    

FP# FP#.MEA, mV, 1 FP#.TIM, s,1 FP#.TEM,°C, 1  

MI MI.MEA, mV, 1 MI.TIM, s, 1 MI.TEM, °C, 1  

MA MA.MEA, mV, 1 MA.TIM, s, 1 MA.TEM, °C, 1  

BP# BP#.MEA, mV, 1 BP#.TIM, s, 1 BP#.TEM, °C, 1  

Table 22 Command MEAS Upol

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EME EME, µA, 1    

ETE ETE, °C, 1    

FP# FP#.MEA, µA, 1 FP#.TIM, s,1 FP#.TEM,°C, 1  

MI MI.MEA, µA, 1 MI.TIM, s, 1 MI.TEM, °C, 1  

MA MA.MEA, µA, 1 MA.TIM, s, 1 MA.TEM, °C, 1  

BP# BP#.MEA, µA, 1 BP#.TIM, s, 1 BP#.TEM, °C, 1  

Table 23 Command MEAS T

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EME EME, °C, 1    

FP# FP#.MEA, °C, 3 FP#.TIM, s,1   

MI MI.MEA, °C, 1 MI.TIM, s, 1   

MA MA.MEA, °C, 1 MA.TIM, s, 1   

BP# BP#.MEA, °C, 1 BP#.TIM, s, 1   

Table 24 Command MEAS T/Flow

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EME EME, °C, 1    

MI MI.MEA, °C, 1 MI.GFL, mL/min, 1 MI.TIM, s, 1  

MA MA.MEA, °C, 3 MA.GFL, mL/min,
1

MA.TIM, s, 1  
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Table 25 Command MEAS Conc

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EME EME, "selected
unit", 3

   

ETE ETE, °C, 1    

Table 26 Command MEAS Cond

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

EME EME, mS/cm, 4 RTE, °C, 1   

ETE ETE, °C, 1    

FP# FP#.MEA, mS/cm,
4

FP#.TIM, s,1 FP#.TEM,°C, 1  

MI MI.MEA, mS/cm, 4 MI.TIM, s, 1 MI.TEM, °C, 1  

MA MA.MEA, mS/cm,
4

MA.TIM, s, 1 MA.TEM, °C, 1  

BP# BP#.MEA, mS/cm,
4

BP#.TIM, s, 1 BP#.TEM, °C, 1  

For the salinity, the unit for EME, FP#.MEA, MI.MEA, MA.MEA and BP#MEA is "Sal"; for TDS it is "mg/L", and for the
specific resistance it is "kOhm·cm".

Table 27 Command CAL LOOP pH

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

SLO SLO, %, 1    

ENP ENP, –, 3    

Table 28 Command CAL LOOP Conc

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

SLO SLO, mV, 1    

ENP ENP, –, 3    

BLV BLV, "unit from
configuration", 2

   

Table 29 Command CAL Cond

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

CLC CLC, /cm, 3    
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Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

RTE RTE, °C, 1    

Table 30 Command STDADD

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

SLO SLO, mV, 1    

ENP ENP, mV, 1    

RES RES, "selected
unit", 1

   

VAR VAR, "empty", 3    

Table 31 Command DOS pH

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

MR MR.MRT, mL/min,
4

MR.MRS, mL/min,
4

MR.MRC, "empty",
3

 

Table 32 Command DOS U

Column 2: Varia-
ble

Column 3 Column 4 Column 5 Column 6

MR MR.MRT, mL/min,
4

MR.MRS, mL/min,
4

MR.MRC, "empty",
3

 

4.7.4 Results - Calculation #
Tab: Database ▶ Results ▶ Command name

For each calculation command the results and (if existent and desired) the
corresponding statistical evaluations are displayed on a separate tab Cal-
culation_#. The sequence of the shown results corresponds to that
defined in the calculation command. The display of the statistical evalua-
tions can be selected in the dialog window Properties result window

For every single result a maximum of the following information is dis-
played:

Result "Result name"

Result "Result name"

Display of the result with variable name.
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NOTE

Only the last results having been calculated will be shown. For example,
if there are several commands that generate a result with the same
name, then the corresponding result data will be shown only for that
command that was the last to calculate the result. Nothing will be
shown for the other commands.

"Result"

Shows the result name and result value with the defined number of deci-
mal places and units.

NOTE

If a result value is monitored and lies within the limit value defined in
the CALC command then the text will be shown in green, if it lies out-
side the limits it will be shown in red text color.

Mean value:

Shows the mean value for statistically evaluated results.

s(abs):

Shows the absolute standard deviation for statistically evaluated results.

s(rel):

Shows the relative standard deviation for statistically evaluated results.

Minimum:

Shows the minimum value for statistically evaluated results.

Maximum:

Shows the maximum value for statistically evaluated results.

n:

Shows the number of measurements for statistically evaluated results.

Assignment:

Assigns the result to one of the result columns RS01...RS25 in the
Determination overview.

Formula:

Shows the formula used for calculating the result.
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'Variable name':

'Displays the variables used in the formula.

NOTE

Variables that have not been created during the determination are not
displayed and lead to invalid results.

4.7.5 Results - Properties
Dialog window Database ▶ View ▶ Properties ▶ Properties ▶ Properties result
window

In the dialog window Properties result window the information to be
displayed in the result window can be selected.

Display for results overview

Selection of the information to be displayed on the tab Results over-
view.

Results

on | off (Default value: on)

Shows all results.

Statistics

on | off (Default value: off)

Shows the statistics results.

Display for calculation commands

Selection of the information to be displayed on the tabs Calculation_#.

Results

on | off (Default value: on)

Shows the results defined in the calculation command.

Statistics

on | off (Default value: off)

Shows the statistics results.

Assignment

on | off (Default value: on)

Shows the assignment.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 4 Database

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 283

Formula

on | off (Default value: on)

Shows the calculation formula.

Variables

on | off (Default value: off)

Displays the variables used in the formula.

4.8 Curves subwindow

4.8.1 Curves - General
Subwindow: Database ▶ Curves

Curves subwindow

The Curves 1 - 5 subwindows are subwindows in the Database pro-
gram part. In these subwindows, the measuring points generated by the
measuring commands for the focused determination in the Determina-
tion table are shown as a graph. When navigating in the determination
overview, this data will be updated automatically (after a certain time
delay).

The Curves 1 - 5 subwindows can be switched on in the Database pro-
gram part and thus made visible when the layout is defined. They can be
enlarged and reduced as required, and they can also be maximized.

Tabs

In the curve window a tab with the corresponding command name and
the run index (e.g. Chloride.1) is provided for each run of a measuring
command; their sequence is determined by the method.

Display of curves

The curves of the selected determination are shown on the tabs with the
properties defined per window and per command type. The command
type (e.g. DET pH) is shown above the left-hand y axis.

Curves can be zoomed as often as required by spanning a section of the
curve display with the left mouse button pressed down. Zooming can be
undone by double-clicking on the section of the graph or with the con-
text-sensitive Show All menu command.
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NOTE

When a new determination is selected the complete curve is always
shown, i.e. the zoom range is not retained when the determination is
changed.

Curves can be copied to the clipboard with the context-sensitive Copy
graphics menu command.

4.8.2 Curves - Measuring point list
Subwindow: Database ▶ Curves

The context-sensitive Measuring point list… menu item in the curve
window opens the Measuring point list - 'Command name.#' dialog
window for showing the measuring point list for the selected curve.

The display of the measuring points in the table can be defined per win-
dow and per command type in the Properties - Curve #.

4.8.3 Properties

4.8.3.1 Curve properties - Overview
Dialog window: Database ▶ Curves ▶ Properties curves #

The properties for the display of curves can be set on the following 5 tabs:

￭ x axis
Parameters for the graphical display of the curves on the x axis.

￭ y1 axis
Parameters for the graphical display of the curves on the y1 axis (left-
hand y axis).

￭ y2 axis
Parameters for the graphical display of the curves on the y2 axis (right-
hand y axis).

￭ Options
Options for graphical display of curves.

￭ Measuring point list
Parameters for showing the measuring point list.

4.8.3.2 Curve properties - x axis
Dialog window: Database ▶ Curves ▶ Properties curves # ▶ x axis

Parameters for the graphical display of the curves on the x axis.

Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved
per curve window and per client.
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Selection DET | MET | SET | KFT | KFC | BRC | STAT |
 MEAS | DOS

Default value DET

NOTE

When the dialog window is opened, those Command type will be
selected as standard which applies for the curve shown in the curve
window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be
scaled automatically. In this case the fields Start value and End value
cannot be edited.

Size

Selection of the quantity to be shown on the x axis.

For DET commands
Selection Volume [mL] | Measured value | ERC | Time [s] |

 Temperature [°C] | Calculated 1...3 | External
1...3

Default value Volume [mL]

For MET commands
Selection Volume [mL] | Measured value | dMW | Time

[s] | Temperature [°C] | Calculated 1...3 | Exter-
nal 1...3

Default value Volume [mL]

For SET, STAT, DOS and KFT commands
Selection Time [s] | Measured value | Volume [mL] | dV/

dt [µL/min] | Temperature [°C] | Calculated
1...3 | External 1...3

Default value Time [s]

For KFC commands
Selection Time [s] | Measured value | Amount [µg] |

 Charge [mAs] | Drift [µg/min] | dV/dt [µ/min] |
 Ugen | Igen [mA] | Calculated 1...3 | External
1...3

Default value Time [s]
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For BRC commands
Selection Time [s] | Measured value | Amount [µg] |

 Charge [mAs] | Drift [µg/min] | dV/dt [µ/min] |
 Ugen | Igen [mA] | Calculated 1...3 | External
1...3

Default value Time [s]

For MEAS commands
Selection Time [s] | Measured value | dMW/dt | Temper-

ature [°C] | Calculated 1...3 | External 1...3
Default value Time [s]

Label

Freely definable axis label for the x axis. With auto the designation from
the field Size will be used.

Selection 50 characters | auto
Default value auto

Scaling

Start value

Initial value for scaling the x axis.

Only editable when autoscaling is disabled.
Input range -1.00E+12 - +1.00E+12 
Default value 0 

End value

End value for scaling the x axis.

Only editable when autoscaling is disabled.
Input range -1.00E+12 - +1.00E+12 
Default value 1000 

4.8.3.3 Curve properties - y1 axis
Dialog window: Database ▶ Curves ▶ Properties curves # ▶ y1 axis

Parameters for the graphical display of the curves on the y1 axis (left-hand
y axis).

Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved
per curve window and per client.
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Selection DET | MET | SET | KFT | KFC | BRC | STAT |
 MEAS | DOS

Default value DET

NOTE

When the dialog window is opened, those Command type will be
selected as standard which applies for the curve shown in the curve
window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be
scaled automatically. In this case the fields Start value and End value
cannot be edited.

Size

Selection of the quantity to be shown on the y1 axis.

For DET commands
Selection Volume [mL] | Measured value | ERC | Time [s] |

 Temperature [°C] | Calculated 1...3 | External
1...3

Default value Measured value

For MET commands
Selection Volume [mL] | Measured value | dMW | Time

[s] | Temperature [°C] | Calculated 1...3 | Exter-
nal 1...3

Default value Measured value

For SET, STAT, DOS and KFT commands
Selection Time [s] | Measured value | Volume [mL] | dV/

dt [µL/min] | Temperature [°C] | Calculated
1...3 | External 1...3

Default value Volume [mL]

For KFC commands
Selection Time [s] | Measured value | Amount [µg] |

 Charge [mAs] | Drift [µg/min] | dV/dt [µ/min] |
 Ugen | Igen [mA] | Calculated 1...3 | External
1...3

Default value Amount [µg]
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For BRC commands
Selection Time [s] | Measured value | Amount [µg] |

 Charge [mAs] | Drift [µg/min] | dV/dt [µ/min] |
 Ugen | Igen [mA] | Calculated 1...3 | External
1...3

Default value Amount [µg]

For MEAS commands
Selection Time [s] | Measured value | dMW/dt | Temper-

ature [°C] | Calculated 1...3 | External 1...3
Default value Measured value

Label

Freely definable axis label for the y1 axis. With auto the designation from
the field Size will be used.

Selection 50 characters | auto
Default value auto

Scaling

Start value

Initial value for scaling the y1 axis.

Only editable when autoscaling is disabled.
Input range -1.00E+12 - +1.00E+12 
Default value 0 

End value

End value for scaling the y1 axis.

Only editable when autoscaling is disabled.
Input range -1.00E+12 - +1.00E+12 
Default value 1000 

Curve

Curve color

Selection of the color for the curve line.

Selection 13 colors | blue
Default value blue

Symbol

Selection of the symbol for the display of the individual measuring points.
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Selection ●  |  ╳  |  ✸  |  ￭  |  ▲  | No symbol
Default value No symbol

No symbol
Measuring points are not shown.

NOTE

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols
again.

Symbol color

Selection of the color for the measuring point symbol.

Selection 13 colors | blue
Default value blue

Smoothing

Smoothing

on | off (Default value: on)

Switches smoothing on/off for the curve.

Smoothing factor x axis

Factor for smoothing on the x axis.

Input range 0.01 - 1000 
Default value 0.01 

Smoothing factor y-axis

Factor for smoothing on the y axis.

Input range 0.01 - 1000 
Default value 0.01 

Show with original curve

on | off (Default value: off)

If this check box is activated, then the original curve (solid line, same
color) will be shown in addition to the smoothed curve (dotted line).
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4.8.3.4 Curve properties - y2 axis
Dialog window: Database ▶ Curves ▶ Properties curves # ▶ y2 axis

Parameters for the graphical display of the curves on the y2 axis (right-
hand y axis).

Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved
per curve window and per client.

Selection DET | MET | SET | KFT | KFC | BRC | STAT |
 MEAS | DOS

Default value DET

NOTE

When the dialog window is opened, those Command type will be
selected as standard which applies for the curve shown in the curve
window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be
scaled automatically. In this case the fields Start value and End value
cannot be edited.

Size

Selection of the quantity to be shown on the y2 axis.

For DET commands
Selection Volume [mL] | Measured value | ERC | Time [s] |

 Temperature [°C] | Calculated 1...3 | External
1...3 | off

Default value off

For MET commands
Selection Volume [mL] | Measured value | dMW | Time

[s] | Temperature [°C] | Calculated 1...3 | Exter-
nal 1...3 | off

Default value off
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For SET, STAT, DOS and KFT commands
Selection Time [s] | Measured value | Volume [mL] | dV/

dt [µL/min] | Temperature [°C] | Calculated
1...3 | External 1...3 | off

Default value off

For KFC commands
Selection Time [s] | Measured value | Charge [mAs] |

 Amount [µg] | Drift [µg/min] | Ugen | Igen
[mA] | Calculated 1...3 | External 1...3 | off

Default value off

For BRC commands
Selection Time [s] | Measured value | Amount [mAs] |

 Water [µg] | Drift [µg/min] | Ugen | Igen [mA] |
 Calculated 1...3 | External 1...3 | off

Default value off

Label

Freely definable axis label for the y1 axis. With auto the designation from
the field Size will be used.

Selection 50 characters | auto
Default value auto

Curve

Curve color

Selection of the color for the curve line.

Selection 13 colors | pink
Default value pink

Symbol

Selection of the symbol for the display of the individual measuring points.

Selection 5 symbols | No symbol
Default value No symbol

No symbol
Measuring points are not shown.
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NOTE

With curves, for which the distance between to measuring points is
smaller than 5 pixels, the separate measuring points are not displayed
anymore, even if a symbol has been selected. In this case, the graphics
window can eventually be enlarged in order to display the symbols
again.

Symbol color

Selection of the color for the measuring point symbol.

Selection 13 colors | pink
Default value pink

Smoothing

Smoothing

on | off (Default value: on)

Enables/disables the smoothing for curves.

Smoothing factor x axis

Factor for smoothing on the x axis.

Input range 0.01 - 1000 
Default value 0.01 

Smoothing factor y-axis

Factor for smoothing on the y axis.

Input range 0.01 - 1000 
Default value 0.01 

4.8.3.5 Curve properties - Options
Dialog window: Database ▶ Curves ▶ Properties curves # ▶ Options

Options for graphical display of curves.

Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved
per curve window and per client.

Selection DET | MET | SET | KFT | KFC | BRC | STAT |
 MEAS | DOS

Default value DET
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NOTE

When the dialog window is opened, those Command type will be
selected as standard which applies for the curve shown in the curve
window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be
scaled automatically. In this case the fields Start value and End value
cannot be edited.

Display grid

Display grid

on | off (Default value: off)

If this check box is actjvated then a grid will be shown against the back-
ground.

Grid type

Selection of the type of grid line.

Selection Line types | dotted
Default value dotted

Grid color

Selection of the grid line color.

Selection 13 colors | gray
Default value gray

Background

Background color

Selection of the color for the curve background.

Selection 13 colors | white
Default value white
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Show endpoints

Show endpoints

on | off (Default value: on)

If this check box is activated then the endpoints found will be shown on
the curve by the symbol ♦ and labeled with EP# (potentiometric end-
point), BP# (break point), FP# (fixed endpoint), HP (HNP), MI (minimum
value) or MA (maximum value).

Automatic EPs

Selection of the color for automatically set endpoints.

Selection 13 colors | black
Default value black

Manual EPs

Selects the color for manually set endpoints.

Selection 13 colors | pink
Default value pink

Show evaluation lines

Show evaluation lines

on | off (Default value: off)

If this check box is activated the evaluation lines (tangents, auxiliary lines)
will be shown.

Tangents

Selection of the color for the tangents and auxiliary lines.

Selection 13 colors | light green
Default value light green

Auxiliary lines

Selection of the color for the auxiliary lines.

Selection 13 colors | blue
Default value blue

4.8.3.6 Curve properties - Measuring point list
Dialog window: Database ▶ Curves ▶ Properties curves # ▶ Options

Parameters for showing the measuring point list.
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Command type

Selection of the command type for which the curve properties are to be
defined. The curve properties defined for each command type are saved
per curve window and per client.

Selection DET | MET | SET | KFT | KFC | BRC | STAT |
 MEAS | DOS

Default value DET

NOTE

When the dialog window is opened, those Command type will be
selected as standard which applies for the curve shown in the curve
window.

Autoscaling

on | off (Default value: on)

If this option is switched on then all axes in the curve window will be
scaled automatically. In this case the fields Start value and End value
cannot be edited.

Available columns

Shows all fields that can be displayed as columns in the measuring point
list.

Displayed columns

Shows all fields that will be shown as columns in the measuring point list.

Adds the selected column to the measuring point list.

Removes the selected column from the measuring point list.

 

Modifies the sequence of displayed columns by moving the selected col-
umn up and down.
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5 How to proceed?

5.1 Backup

5.1.1 Backing up a database
How to proceed?

General

The determination databases that, in contrast to the configuration
database, can be generated by the user and contain the determination
data, are referred to as databases in tiBase. Included among such deter-
mination data is the method data used for the determination, the mea-
sured data generated during the determination and the results calculated
from it.

In local server systems (tiBase full), the databases are stored on the
drives administered by the computer and are only available to those users
registered on that computer who have the appropriate access rights. In
client/server systems (tiBase multi), the databases are stored on drives
administered centrally by the server and are globally available throughout
the entire client/server system, i.e. all users with the appropriate access
rights can use these databases.

NOTE

Each determination database has to be backed up separately. After-
wards, it is recommended that all backed-up files be copied to an exter-
nal directory or to a CD/DVD.

Backing up a database manually

 

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Database manager… menu
item.

The Database manager dialog window opens.

 

3 Select database.

 

4 Click on [Backup] in the Database manager dialog window.
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The Backup database 'Database name' dialog window opens.

 

5 Select the directory for the backup in the Backup directory field.

 

6 Select or enter the name for the Backup file. If an existing backup
file is selected, it will be overwritten.

NOTE

If the backup directory is on a network drive, the backup date
should be added manually to the Backup name field because the
backup date information is not available when the data is restored.

 

7 Click on [Start].

The manual backup of the database is started and the database is
backed up to the selected directory.

Backing up a database automatically

 

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Database manager… menu
item.

The Database manager dialog window opens.

 

3 Select desired database and click on [Properties].

The Properties - Database - 'Database name' dialog window
opens for editing the database properties.

 

4 On the General tab, enter a comment on the database in the Com-
ment field.

 

5 On the Backup tab, enable the Backup monitoring check box.

 

6 Enter an Interval for backup monitoring or a date for the next
backup in the Next backup field.

 

7 Activate the Start backup automatically check box.
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8 Select the directory for the backup in the Backup directory field.

 

9 Click on [OK].

The Properties - Database dialog window closes and the database
will be backed up automatically to the selected directory at the
desired time.

5.1.2 Restoring the database
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Database manager… menu
item.

The Database manager window opens.

 

3 Click on [Restore] in the Database manager dialog window.

The Restore databases dialog window opens.

 

4 Select the directory in the Backup directory field in which the
desired database was backed up.

 

5 Select the name for the desired backup file in the Backup name list
box.

 

6 Enter the name under Save As under which the database is to be
restored.

 

7 Click on [Start].

The database restoring is started.

NOTE

Existing databases cannot be overwritten, i.e. they must first be
deleted so that the database can be restored under its old name.
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5.1.3 Backing up configuration data
How to proceed?

General

The configuration data is saved in tiBase in the Configuration data-
base. Included among the configuration data are settings for the data
import, Security settings (see Chapter 3.2.2.1, page 87), User admin-
istration (see Chapter 3.2.1.1, page 79), Program administration (see
Chapter 3.2.3.1, page 97) and templates.

In local server systems (tiBase full), the configuration database is located
in the program directory of the computer on which the program has been
installed. In client/server systems (tiBase multi), the configuration data-
base is stored centrally on the server and contains all the configuration
data of all computers (clients) that are connected to this server.

NOTE

It is strongly recommended that the configuration database be backed
up periodically.

Backing up configuration data manually

 

1 Select Configuration program part.

 

2 Click on the File ▶ Backup ▶ Manually menu item.

The Backup configuration data manually dialog window opens.

 

3 Select the directory for the backup in the Backup directory field.

 

4 Select or enter a new name for the backup file in the Backup name
list box. If an existing backup file is selected, it will be overwritten.

NOTE

If the backup directory is on a network drive, the backup date
should be added manually to the Backup name because the
backup date information is not available when the data is restored.

 

5 Click on [Start].
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The manual backup is started and the configuration database is
backed up to the selected directory.

Backing up configuration data automatically

 

1 Select Configuration program part.

 

2 Click on the File ▶ Backup ▶ Automatically menu item.

The Backup configuration data automatically dialog window
opens.

 

3 Activate the Automatic backup check box.

 

4 Enter an Interval for backup monitoring or a date for the next
backup in the Next backup field.

 

5 Select the directory for the backup in the Backup directory field.

 

6 Click on [OK].

The Backup configuration data automatically dialog window
closes and the configuration database will be backed up automati-
cally to the selected directory at the desired time.

5.1.4 Restoring configuration data
How to proceed?

tiBase full

1 Exit tiBase.

 

2 Start the ConfigRestore.exe file in the …\tiBase\bin program
directory.

The Restore configuration data dialog window opens.

 

3 Select the directory in the Backup directory field in which the con-
figuration database was backed up.

 

4 Select or enter the name for the desired backup file in the Backup
name list box.

 

5 Click on [Start].
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The restoring of the configuration database is started.

tiBase multi

 

1 Make sure that tiBase is closed on all clients connected to the server
and on the server itself.

 

2 Start the ConfigRestore.exe file in the …\tiBase\bin program
directory on the server.

The Restore configuration data dialog window opens.

 

3 Select the directory in the Backup directory field in which the con-
figuration database was backed up.

 

4 Select or enter the name for the desired backup file in the Backup
name list box.

 

5 Click on [Start].

The restoring of the configuration database is started.

5.2 Determinations

5.2.1 Searching for determinations
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.

 

3 Select desired database or enter name in the Database name field.

 

4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview.

 

5 Click on the  symbol or the Determinations ▶ Find... menu
item.

The Search - Database 'Database name' dialog window opens.
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6 Enter or select desired search terms and search options.

 

7 Click on [Search next].

The next determination containing the search term is highlighted in
the Determination overview.

5.2.2 Filtering determinations
How to proceed?

Opening a database

 

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.

 

3 Select desired database or enter name in the Database name field.

 

4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview.

Filtering can now be done via quick filter or special filter in the Determi-
nation overview window.

Quick filter

 

1 Click on the  symbol or on Filter ▶ Quick filter in the context
menu.

After this function has been selected, the field in which the cursor is
located will have a yellow background when navigating in the deter-
mination table.

 

2 Double-click on the desired field with the left mouse button.

The contents of the field selected in the table will be set as a filter
criterion and this filter will be applied directly to the table.
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NOTE

The quick filter can be applied again within the filtered table, so
that the number of entries can be limited step by step.

Defining and using special filter

 

1 Click on the  symbol or on Filter ▶ Special filter... in the context
menu.

The Special filter dialog window for the definition of user-specific
filters opens.

 

2 Use the Edit ▶ Edit line menu item to open the Edit filter crite-
rion New filter dialog window.

 

3 Define filter criteria.

 

4 Click on [Save filter].

 

5 Click on [Apply filter].

The table will be filtered.

Using special filter

 

1 In the Filter selection list, select the desired special filter.

The table will be filtered.

5.2.3 Signing determination
How to proceed?

Selecting a determination

 

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.
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3 Select desired database or enter name in the Database name field.

 

4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview.

 

5 Select desired determination.

Signature 1

NOTE

Determinations can only be signed at level 1 if the user belongs to a
user group with the corresponding permission (see Chapter 3.2.1.2.3,
page 82).

 

1 Click on the  symbol or Determinations ▶ Sign ▶ Signature
1… menu item.

The Signature Level 1 window opens. If the selected determination
can be signed, Signature possible is displayed in the Info field.

 

2 Enter or select User, Password, Reason and Comment.

 

3 Click on [Sign].

The selected determination will be signed on level 1.

NOTE

Determinations that have been signed at level 1 can be repro-
cessed and deleted. If the modified determination is saved as a
new determination version, then all existing signatures will be
deleted automatically, i.e. the determination must be signed again.
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Signature 2

NOTE

Determinations can only be signed at level 2 if the user belongs to a
user group with the corresponding permission (see Chapter 3.2.1.2.3,
page 82).

 

1 Click on the  symbol or the Determinations ▶ Sign ▶ Signature
2… menu item.

The Signature Level 2 window opens. If the selected determination
can be signed, Signature possible is displayed in the Info field.

 

2 Enter or select User, Password, Reason and Comment and click
on [Sign].

The selected determination will be signed on level 2.

NOTE

Determinations signed at level 2 are locked, i.e. they can neither
be reprocessed nor deleted. In order to be able to edit such deter-
minations again the signatures on level 2 must first be deleted.

5.2.4 Exporting determinations
How to proceed?

Defining export templates

 

1 Select Database program part.

 

2 Click on the Tools ▶ Templates ▶ Export templates… menu
item.

The Export templates window opens.

 

3 Click on [New].

The window Export templates – 'New file' opens.
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4 Define the properties of the new export template.

 

5 Click on [OK].

The dialog window closes.

 

6 Click on [Close].

The Export templates dialog window closes.

Selecting determinations

 

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.

 

3 Select desired database or enter name in the Database name field.

 

4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview.

 

5 Select desired determinations.

Exporting determinations

 

1 Click on the Determinations ▶ Export... menu item.

The Export determinations window opens.

 

2 In the Selection field, select the desired option (All records or
Selected records).

 

3 In the Export template selection list, select an export template.

 

4 Click on [OK].

The selected determinations are exported into the directory defined
in the export template.
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5.2.5 Importing determinations
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.

 

3 Select desired database or enter name in the Database name field.

 

4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview.

 

5
Click on the Determinations ▶ Import.... menu item or the 
symbol.

The Import determinations window opens.

 

6 Select desired determinations.

 

7 Click on [Open].

The selected determinations are imported into the open database.

NOTE

Only determinations in the *.tdet and *.txt file formats can be
imported.

5.2.6 Deleting determinations
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.

 

3 Select desired database or enter name in the Database name field.
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4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview.

 

5 Select desired determinations.

 

6 Click on the  symbol or the Determinations ▶ Delete menu item.

 

7 Confirm deleting.

The selected determinations are deleted along with all Determina-
tion versions.

NOTE

If the Comment on modification of determinations option in
the Security settings is enabled, then the Modification com-
ment determination window will appear before the modifica-
tion is saved.

5.2.7 Making the determination version current
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.

 

3 Select desired database or enter name in the Database name field.

 

4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview.

 

5 Select desired determination.

 

6 Click on the  symbol or the Determinations ▶ Show history…
menu item.
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Only the currently selected determination as well as all the previous
versions of this determination will be shown in the determination
table.

 

7 Select desired determination that is once again to be made the cur-
rent determination version.

 

8 Click on the  symbol or the Determinations ▶ Make current
menu item.

The determination version selected in the determination table will
again be made the current determination version. This creates a new
determination, the version number of which is increased by +1 com-
pared with the last version to have been saved.

5.2.8 Reprocessing determinations
How to proceed?

NOTE

Determinations signed at level 2 cannot be reprocessed.

 

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

 

3 Select desired database or enter name in the Database name field.

The data sets of the selected database are displayed in the Determi-
nation overview.

 

4 Select desired determinations.

 

5 Click on the  symbol or the Determinations ▶ Reprocess...
menu item.

The Reprocessing dialog window opens. The first of the selected
determinations is displayed.

Modifying variables

 

1 Select the Variables tab.
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2 Select the desired variable in the table.

 

3 Click on [Modify].

The Modify variable dialog window opens.

 

4 In the Value field, enter a new value for the variable.

 

5 Click on [OK].

 

6 Click on [Recalculate].

The selected determinations are recalculated. The results of this recal-
culation are entered automatically in the Result view subwindow.

NOTE

If a variable is modified, then all selected determinations will be
recalculated with the new value by clicking on [Recalculate]. If a
variable is not modified, then the original variable values will be
used when several determinations are recalculated (i.e. variables
with the same name but different values will not be overwritten
until they are deliberately modified).

 

7 In the Reprocessing dialog window, click on [OK].

Each determination that has been modified by reprocessing will be
saved as a new version with a version number increased by +1 and
the Reprocessing dialog window will be closed. This button is disa-
bled for as long as recalculating has not yet been triggered and if not
all of the selected determinations could have been recalculated.

Modifying calculations

 

1 Change to the Calculations tab.

 

2 Click on [New].

The Result New result - RSxx dialog window opens.

 

3 Modify the new calculation as desired.

 

4 Click on [OK].
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5 Click on [Recalculate].

The selected determinations are recalculated. The results of this recal-
culation are entered automatically in the Result view subwindow.

 

6 If desired, save the modified method with [Save As…] under the
same name or under a new name.

If the modified method is saved under the name of an existing
method then all the earlier method versions will be deleted and a
new version with the number 1 will be generated.

 

7 In the Reprocessing dialog window, click on [OK].

Each determination that has been modified by reprocessing will be
saved as a new version with a version number increased by +1 and
the Reprocessing dialog window will be closed. This button is disa-
bled for as long as recalculating has not yet been triggered and if not
all of the selected determinations could have been recalculated.

Changing statistics

NOTE

The Statistics tab will only be shown when the last determination (and
only this one) is selected from a set of determinations which belong
together because of the statistics defined in the method.

 

1 Change to the Statistics tab.

 

2 In the Result name field, select the result whose Result value is to
be displayed.

 

3 Select desired determination whose result value(s) should be
switched on or off for the statistics.

 

4 If only the selected result of the determination is to be switched on
or off for the statistics, click on [Result on/off].

If the result is switched off, an asterisk (*) appears after the result
value; if it is switched on again, the asterisk disappears.
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5 If all results of the selected determination are to be switched on or
off for the statistics, click on [Determination on/off].

If the determination is switched off, then an asterisk (*) appears after
all result values in the table and the line is shown as inactive (gray); if
it is switched on again then the asterisks will disappear.

NOTE

If the results of a determination are switched off, the statistics for
these results will be switched off when this determination is recal-
culated, i.e. no data for the mean value and standard deviations
will be shown. However, the determinations remain statistically
linked to each other so that the results can also be switched on
again.

 

6 Click on [Recalculate].

The selected determinations are recalculated. The results of this recal-
culation are entered automatically in the Result view subwindow.

 

7 In the Reprocessing dialog window, click on [OK].

Each determination that has been modified by reprocessing will be
saved as a new version with a version number increased by +1 and
the Reprocessing dialog window will be closed. This button is disa-
bled for as long as recalculating has not yet been triggered and if not
all of the selected determinations could have been recalculated.

Editing curve evaluations

NOTE

The Curve evaluation tab is only shown when a single determination
is selected that contains curves that can be evaluated.

 

1 Change to the Curve evaluation tab.

 

2 In the Command name field, select the command whose curve is to
be displayed.

 

3 Click on [Edit].
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The Curve evaluation dialog window opens for manually reprocess-
ing the curve evaluation.

 

4 Modify curve evaluation manually.

 

5 Then close the window with [OK].

 

6 Click on [Recalculate].

The selected determinations are recalculated. The results of this recal-
culation are entered automatically in the Result view subwindow.

 

7 In the Reprocessing dialog window, click on [OK].

Each determination that has been modified by reprocessing will be
saved as a new version with a version number increased by +1 and
the Reprocessing subwindow will be closed. This button is inactive
for as long as reprocessing has not yet been triggered and if not all
of the selected determinations were able to have been recalculated.

5.2.9 Printing determination reports
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.

 

3 Select desired database or enter name in the Database name field.

 

4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview. The database name is displayed in the title bar of
the program, the number of currently opened databases is displayed
in the left upper corner of the database symbol.

NOTE

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is exited will be automatically opened the next time the
program is started.
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5 Select desired determinations.

 

6 Click on the File ▶ Print ▶ Report… menu item.

The Report output dialog window opens.

 

7 Under Selection, select desired determinations for report output.

 

8 Under Report type select the option Original report or Report
template.

 

9 Under Output target, enable the Printer check box and/or select
PDF file.

NOTE

If several reports are produced simultaneously as a PDF file, then
an index will be automatically appended to the file name.

 

10 In the Report output dialog window, click on [OK].

The reports of the selected determinations will be output.

5.2.10 Printing determination overviews
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.

 

3 Select desired database or enter name in the Database name field.

 

4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview. The database name is displayed in the title bar of
the program, the number of currently opened databases is displayed
in the left upper corner of the database symbol.
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NOTE

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is exited will be automatically opened the next time the
program is started.

 

5 Select desired determinations.

 

6 Click on the File ▶ Print ▶ Determination overview… menu
item.

The Print determination overview (PDF) dialog window opens.

 

7 Under Selection, select desired determinations for report output.

 

8 Under Orientation, select the Portrait format or Landscape for-
mat option.

 

9 Click on [OK].

The determination overview opens as a PDF file.

5.3 Databases

5.3.1 Database in general
The determination databases that, in contrast to the configuration
database, can be generated by the user and contain the determination
data, are referred to as databases in tiBase. Included among such deter-
mination data is the method data used for the determination, the mea-
sured data generated during the determination and the results calculated
from it.

In local server systems (tiBase full), the databases are stored on the
drives administered by the computer and are only available to those users
registered on that computer who have the appropriate access rights. In
client/server systems (tiBase multi), the databases are stored on drives
administered centrally by the server and are globally available throughout
the entire client/server system, i.e. all users with the appropriate access
rights can use these databases.
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NOTE

Each determination database has to be backed up separately. After-
wards, it is recommended that all backed-up files be copied to an exter-
nal directory or to a CD/DVD.

5.3.2 Opening a database
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Open... menu item.

The Open database dialog window opens.

 

3 Select desired database or enter name in the Database name field.

 

4 Click on [Open].

The data sets of the selected database are displayed in the Determi-
nation overview. The database name is displayed in the title bar of
the program, the number of currently opened databases is displayed
in the left upper corner of the database symbol.

NOTE

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is exited will be automatically opened the next time the
program is started.

5.3.3 Closing a database
How to proceed?

Closing a single database

 

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Close… menu item.

The focused database will be closed.
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Closing all databases

 

1 Select Database program part.

 

2 Click on the File ▶ Close all… menu item.

All opened databases will be closed.

5.3.4 Creating a database
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Database manager… menu
item.

The Database manager dialog window opens.

 

3 Click on the Edit ▶ New... menu item.

The New database dialog window opens.

 

4 Enter a name for the new database.

 

5 Click on [OK].

The Properties - Database - 'Database name' dialog window
opens for editing the database properties.

NOTE

The database name must be unique in the entire client/server sys-
tem.

 

6 On the General tab, enter a comment on the database in the Com-
ment field.

 

7 On the Access rights tab, define access rights for reading and edit-
ing the new database for the different user groups.

 

8 On the Backup tab, define backup monitoring and automatic
backup for the newly created database.
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9 On the Monitoring tab, define the monitoring of the size and num-
ber of data sets.

5.3.5 Backing up a database
How to proceed?

Backing up a database manually

 

1 Select Database program part.

 

2 Click on the  symbol or File ▶ Database manager… menu item.

The Database manager window opens.

 

3 Click on [Backup].

The Backup database window opens.

 

4 Select the directory for the backup in the Backup directory field.

 

5 Select or enter the name for the Backup file. If an existing backup
file is selected, it will be overwritten.

NOTE

If the backup directory is on a network drive, the backup date
should be added manually to the Backup name because the
backup date information is not available when the data is restored.

 

6 Click on [Start].

The manual backup is started and the database is backed up to the
selected directory.

Backing up a database automatically

 

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Database manager… menu
item.

The Database manager dialog window opens.
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3 Select desired database.

 

4 Click on [Properties].

The Properties - Database - 'Database name' dialog window
opens for editing the database properties.

 

5 On the General tab, enter a comment on the database in the Com-
ment field.

 

6 On the Backup tab, enable the Backup monitoring check box.

 

7 Enter an Interval for backup monitoring or a date for the Next
backup.

 

8 Activate the Start backup automatically check box.

 

9 Select the directory for the backup in the Backup directory field.

 

10 Click on [OK].

 

11 The Properties - Database dialog window closes.

The database is automatically saved in the selected directory at the
desired time.

5.3.6 Restoring the database
How to proceed?

1 Select Database program part.

 

2 Click on the  symbol or the File ▶ Database manager… menu
item.

The Database manager dialog window opens.

 

3 Click on [Restore].

The Restore databases dialog window opens.

 

4 Select the directory in the Backup directory in which the desired
database was backed up.

 

5 Select or enter the name for the desired Backup file.
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6 Enter the name under Save As under which the database is to be
restored.

 

7 Click on [Start].

The database restoring is started.

NOTE

Existing databases cannot be overwritten, i.e. they must first be
deleted so that the database can be restored under its old name.

5.3.7 Deleting a database
How to proceed?

1 Select Database program part.

 

2 Click on the symbol  or File ▶ Database manager… menu item.

The Database manager dialog window opens.

 

3 Select desired database.

 

4 Click on the Edit ▶ Delete... menu item.

The selected database is deleted.

NOTE

Databases that are open cannot be deleted.
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5.4 Configuration data

5.4.1 Configuration data in general
The configuration data is saved in tiBase in the Configuration data-
base. Included among the configuration data are settings for the data
import, Security settings (see Chapter 3.2.2.1, page 87), User admin-
istration (see Chapter 3.2.1.1, page 79), Program administration (see
Chapter 3.2.3.1, page 97) and templates.

In local server systems (tiBase full), the configuration database is located
in the program directory of the computer on which the program has been
installed. In client/server systems (tiBase multi), the configuration data-
base is stored centrally on the server and contains all the configuration
data of all computers (clients) that are connected to this server.

5.4.2 Exporting configuration data
How to proceed?

1 Select Configuration program part.

 

2 Click on the File ▶ Export... menu item.

The Export configuration data dialog window opens.

 

3 Select desired configuration data.

 

4 Click on [OK].

The Export configuration data dialog window closes and the
Save dialog window opens.

 

5 Select or enter name and directory for the export file. If an existing
export file is selected, it will be overwritten.

 

6 Click on [Save].

The export of the configuration data is started.

The selected configuration data is then saved in a file with the exten-
sion .mcfg.
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5.4.3 Importing configuration data
How to proceed?

1 Select Configuration program part.

 

2 Click on the Import ▶ file... menu item.

The Open dialog window opens.

 

3 Select or enter a new name and directory for the *.mcfg import file.

 

4 Click on [Open].

The Import configuration data dialog window opens.

 

5 Select desired configuration data.

NOTE

Data that is not present in the export file cannot be selected.

 

6 Click on [OK].

The import is started and the selected configuration data is imported.

5.4.4 Backing up configuration data
How to proceed?

NOTE

It is strongly recommended that the configuration database be backed
up periodically.

Backing up configuration data manually

 

1 Select Configuration program part.

 

2 Click on the File ▶ Backup ▶ Manually menu item.

The Backup configuration data manually dialog window opens.

 

3 Select the directory for the backup in the Backup directory field.
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4 Select or enter the name for the Backup file. If an existing backup
file is selected, it will be overwritten.

NOTE

If the backup directory is on a network drive, the backup date
should be added manually to the Backup name because the
backup date information is not available when the data is restored.

 

5 Click on [Start].

The manual backup is started and the configuration database is
backed up to the selected directory.

Backing up configuration data automatically

 

1 Select Configuration program part.

 

2 Click on the File ▶ Backup ▶ Automatically menu item.

The Backup configuration data automatically dialog window
opens.

 

3 Activate the Automatic backup check box.

 

4 Enter an Interval for backup monitoring or a date for the Next
backup.

 

5 Select a directory for the backup in the Backup directory field.

 

6 Click on [OK].

The Backup configuration data automatically dialog window
closes.

The configuration database is automatically saved in the selected
directory at the desired time.
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5.4.5 Restoring configuration data
How to proceed?

tiBase full

1 Exit tiBase.

 

2 Start the ConfigRestore.exe file in the …\tiBase\bin program
directory.

The Restore configuration data dialog window opens.

 

3 Select the directory in the Backup directory field in which the con-
figuration database was backed up.

 

4 Select or enter the name for the desired Backup file.

 

5 Click on [Start].

The restoring of the configuration database is started.

tiBase multi

 

1 Make sure that tiBase is closed on all clients connected to the server
and on the server itself.

 

2 Start the ConfigRestore.exe file in the …\tiBase\bin program
directory on the server.

The Restore configuration data dialog window opens.

 

3 Select the directory in the Backup directory field in which the con-
figuration database was backed up.

 

4 Select or enter the name for the desired Backup file.

 

5 Click on [Start].

The restoring of the configuration database is started.
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5.5 Import of PC/LIMS reports

5.5.1 Import - automatic
How to proceed?

1 Select Configuration program part.

 

2 In the Import processes subwindow, click on the Edit ▶ New
menu item.

The Properties import process dialog window opens.

 

3 Enter the name of the import process.

 

4 Click on the  symbol.

The Select directory dialog window opens.

 

5 Select the source directory with the PC/LIMS reports to be imported
to the database.

 

6 Click on [Select].

The path is entered in the Data source field.

 

7 Select the database in which the PC/LIMS reports are to be saved.

 

8 Enter a comment (optional).

 

9 If importing the PC/LIMS reports is to run automatically at the start of
tiBase, then activate the Start automatically check box.

If the check box is deactivated, then the PC/LIMS reports have to be
imported manually.

 

10 Activate the Delete file radio button if the PC/LIMS reports are to be
deleted in the source directory after the import into the tiBase data-
base.

 

11 Activate the Move file radio button if the PC/LIMS reports are to be
moved from the source directory to another directory after the
import into the tiBase database.

 

12 Click on the  symbol.
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The Select directory dialog window opens.

 

13 Select the folder (create new) to which the PC/LIMS reports are to be
moved.

 

14 Click on [Select].

The path is entered in the Directory field.

NOTE

Faulty determination data

Faulty data are saved to a sub-directory during the automatic import.

The import of the additional data then continues.

5.5.2 Import - manual
How to proceed?

1 Select Database program part.

 

2
Click on the Determinations ▶ Import.... menu item or the 
symbol.

The Import determinations dialog window opens.

 

3 Select the PC/LIMS reports.

 

4 Click on [Open].

5.5.3 Editing the import
How to proceed?

1 Select Configuration program part.

 

2 In the Import processes subwindow, click on the Edit ▶ New
menu item.

The Properties Import process dialog window opens.

 

3 Edit the name of the import process.

 

4 Click on the  symbol.
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The Select directory dialog window opens.

 

5 Select the folder with the PC/LIMS reports to be imported to the
database.

 

6 Click on [Select].

The path is entered in the Data source field.

 

7 Enter a comment (optional).

 

8 If importing the PC/LIMS reports is to run automatically at the start of
tiBase, then activate the Start automatically check box.

If the check box is deactivated, then the PC/LIMS reports have to be
imported manually.

 

9 Activate the Delete file radio button if the PC/LIMS reports are to be
deleted in the source directory after the import into the tiBase data-
base.

 

10 Activate the Move file radio button if the PC/LIMS reports are to be
moved from the source directory to another directory after the
import into the tiBase database.

 

11 Click on the  symbol.

The Select directory dialog window opens.

 

12 Select the folder (create new) to which the PC/LIMS reports are to be
moved.

 

13 Click on [Select].

The path is entered in the Directory field.

5.5.4 Import - one USB flash drive
How to proceed?

Defining the properties of the import

 

1 Select Configuration program part.
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2 In the Import processes subwindow, click on the Edit ▶ New
menu item.

The Properties import process dialog window opens.

 

3 Enter the name of the import process.

 

4 Click on the  symbol.

The Select directory dialog window opens.

 

5 As the data source, select a path which can access a USB flash drive.

 

6 Click on [Select].

The path is entered in the Data source field.

 

7 Select the database in which the PC/LIMS reports are to be saved.

 

8 Enter a comment (optional).

 

9 If importing the PC/LIMS reports is to run automatically at the start of
tiBase, then activate the Start automatically check box.

If the check box is deactivated, then the PC/LIMS reports have to be
imported manually.

 

10 Activate the Delete file radio button if the PC/LIMS reports are to be
deleted in the source directory after the import into the tiBase data-
base.

 

11 Activate the Move file radio button if the PC/LIMS reports are to be
moved from the source directory to another directory after the
import into the tiBase database.

 

12 Click on the  symbol.

The Select directory dialog window opens.

 

13 Select the folder (create new) to which the PC/LIMS reports are to be
moved.

 

14 Click on [Select].

The path is entered in the Directory field.
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Importing with USB flash drive

The PC/LIMS reports are saved on a USB flash drive by the Titrino plus.

 

1 Connect the USB flash drive to the PC.

tiBase imports the PC/LIMS reports directly from the USB flash drive.

5.5.5 Import - several USB sticks
How to proceed?

When importing via several USB flash drives, each flash drive must be
assigned its own drive letter.

Assigning a drive letter - Windows XP

 

1 Connect the USB flash drive to the PC.

 

2 Open the context menu of the Workplace with the right mouse
button.

 

3 Click on the Administration menu item.

The Computer administration dialog window opens.

 

4 Click on Storage device administration.

 

5 In the list of storage devices, right-click on the drive letter of the USB
flash drive.

 

6 In the context menu, click on Modify drive letter and paths.

The Modify drive letter and path for 'Name' dialog window
opens.

 

7 Click on [Modify...].

 

8 Select a new drive letter in the selection list.

The new drive letter must not be in use. This also includes a USB flash
drive which is not connected.

 

9 Confirm with [OK].
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NOTE

If the USB flash drive is used on another PC, then the drive letter must
be checked.

Assigning a drive letter - Windows Vista

 

1 Connect the USB flash drive to the PC.

 

2 Click on Start ▶ Computer.

 

3 Click on the Administration menu item.

The Computer administration dialog window opens.

 

4 Click on Storage device administration.

 

5 In the list of storage devices, right-click on the drive letter of the USB
flash drive.

 

6 In the context menu, click on Modify drive letter and paths.

The Modify drive letter and path for 'Name' dialog window
opens.

 

7 Click on [Modify...].

 

8 Select a new drive letter in the selection list.

The new drive letter must not be in use. This also includes a USB flash
drive which is not connected.

 

9 Confirm with [OK].

NOTE

If the USB flash drive is used on another PC, then the drive letter must
be checked.



￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭￭ 5 How to proceed?

tiBase 1.1 Patch 1 ￭￭￭￭￭￭￭￭ 331

Defining the properties of the import

 

1 Select Configuration program part.

 

2 In the Import processes subwindow, click on the Edit ▶ New
menu item.

The Properties import process dialog window opens.

 

3 Enter the name of the import process.

 

4 Click on the  symbol.

The Select directory dialog window opens.

 

5 As the data source, select a path which can access a USB flash drive.

 

6 Click on [Select].

The path is entered in the Data source field.

 

7 Select the database in which the PC/LIMS reports are to be saved.

 

8 Enter a comment (optional).

 

9 If importing the PC/LIMS reports is to run automatically at the start of
tiBase, then activate the Start automatically check box.

If the check box is deactivated, then the PC/LIMS reports have to be
imported manually.

 

10 Activate the Delete file radio button if the PC/LIMS reports are to be
deleted in the source directory after the import into the tiBase data-
base.

 

11 Activate the Move file radio button if the PC/LIMS reports are to be
moved from the source directory to another directory after the
import into the tiBase database.

 

12 Click on the  symbol.

The Select directory dialog window opens.
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13 Select the folder (create new) to which the PC/LIMS reports are to be
moved.

 

14 Click on [Select].

The path is entered in the Directory field.

Importing with USB flash drive

The PC/LIMS reports are saved on a USB flash drive by the Titrino plus.

 

1 Connect the USB flash drive to the PC.

tiBase imports the PC/LIMS reports directly from the USB flash drive.

5.5.6 Import - via RS Server
How to proceed?

Configuring analysis instrument

Installing RS Server

 

1 Install RS Server by downloading it from ...

 

2
With the right mouse button, click on the  symbol in the status
bar.

 

3 Select RS Server settings.

 

4 Click on [New].

 

5 In the Target directory field, select the directory in which the PC/
LIMS reports sent by the analysis instrument are stored.

 

6 In the Autostart part, activate the Automatically start with Win-
dows check box.

 

7 Click on [OK].
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Defining the import process

 

1 Select Configuration program part.

 

2 In the Import processes subwindow, click on the Edit ▶ New
menu item.

The Properties import process dialog window opens.

 

3 Enter the name of the import process.

 

4 Click on the  symbol.

The Select directory dialog window opens.

 

5 Select the source directory with the PC/LIMS reports to be imported
to the database.

 

6 Click on [Select].

The path is entered in the Data source field.

 

7 Select the database in which the PC/LIMS reports are to be saved.

 

8 Enter a comment (optional).

 

9 If importing the PC/LIMS reports is to run automatically at the start of
tiBase, then activate the Start automatically check box.

If the check box is deactivated, then the PC/LIMS reports have to be
imported manually.

 

10 Activate the Delete file radio button if the PC/LIMS reports are to be
deleted in the source directory after the import into the tiBase data-
base.

 

11 Activate the Move file radio button if the PC/LIMS reports are to be
moved from the source directory to another directory after the
import into the tiBase database.

 

12 Click on the  symbol.

The Select directory dialog window opens.
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13 Select the folder (create new) to which the PC/LIMS reports are to be
moved.

 

14 Click on [Select].

The path is entered in the Directory field.

5.5.7 Import protocol - properties
How to proceed?

1 Select Configuration program part.

 

2 In the Import protocol subwindow, click on the Edit ▶ Options...
menu item.

The Properties Import protocol dialog window opens.

 

3 Activate the check box for the required filter options.

 

4 Enter the required maximum number of log entries.

 

5 Click on [OK].

5.5.8 Deleting an import protocol
How to proceed?

1 Select Configuration program part.

 

2 In the Import protocol subwindow, click on the Edit ▶ Delete all
messages menu item.
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5.6 Reports

5.6.1 Creating report template
How to proceed?

1 Select program part Database.

 

2 NOTE

A database must be open in order to carry out subsequent steps.

Click on the menu item Tools ▶ Report tem-
plates ▶ New ▶ Form report… or Tools ▶ Report tem-
plates ▶ New ▶ Tabular Report….

The program window Report template with an empty report tem-
plate opens.

 

3 Click on the menu item File ▶ Page setup… in the program win-
dow Report template.

The dialog window Page setup opens.

 

4 Define desired settings for the report format.

 

5 Click on [OK].

The dialog window Page setup is closed.

 

6 In the program window Report template, click on the menu item
Tools ▶ Options....

The dialog window Options for report templates opens.

 

7 Define desired settings for the report template.

 

8 Close the dialog window with [OK].

 

9 Select desired module symbol on the Module bar and place it on the
report template by creating a field with the left mouse button.

The properties window for the corresponding module opens auto-
matically.
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10 Enter desired settings for the module.

 

11 Click on [OK].

The properties window is closed.

 

12 Repeat steps 7 and 8 for each desired module. 

 

13 Click on the symbol  or the menu item File ▶ Save as....

The dialog window Save report template opens.

 

14 In the field Name enter a name.

 

15 Click on [Save].

The report template is saved under the name entered.

5.6.2 Edit report template
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or on the menu item Tools ▶ Report tem-
plates ▶ Open….

The program window Open report template opens.

 

3 Open desired report template.

 

4 Click on [Open].

The program window with the selected report template opens.

 

5 Click on the menu item File ▶ Page setup....

The dialog window Page setup opens.

 

6 Define desired settings for the report format.

 

7 Close the dialog window with [OK].

 

8 In the program window Report template, click on the menu item
Tools ▶ Options....
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The dialog window Options for report templates opens.

 

9 Define desired settings for the report template.

 

10 Close the window with [OK].

Editing existing modules

 

1
Select the symbol  on the module bar and double-click on the
desired module in the report template.

The properties window of the selected module opens automatically.

 

2 Enter desired settings for the module.

 

3 Close the properties window with [OK].

 

4 Repeat steps 1 and 2 for each desired module. 

Creating new modules

 

1 Select desired module symbol on the Module bar and place it on the
report template by creating a field with the left mouse button.

The properties window for the corresponding module opens auto-
matically.

 

2 Define desired setttings for the module.

 

3 Close the properties window with [OK].

 

4 Repeat steps 1 and 2 for each desired new module.

 

5 Click on the symbol  or the menu item File ▶ Save.

The report template is saved.
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5.6.3 Printing determination report 
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview. The database name is displayed in the
title bar of the program, the number of currently opened databases
is displayed in the left upper corner of the database symbol.

NOTE

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is ended will be automatically opened the next time the
program is started.

 

5 Select desired determinations.

 

6 Click on the menu item File ▶ Print ▶ Report....

The dialog window Report output opens.

 

7 Under Selection, select desired determinations.

 

8 Under Report type, select the option Original report or Report
template.

 

9 Under Output target, enable the check box Printer and/or select
PDF file.
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NOTE

If several reports are produced simultaneously as a PDF file then an
index will be automatically appended to the file name.

 

10 In the dialog window Report output, click on [OK].

The reports of the selected determination are put out.

5.6.4 Printing determination overview 
How to proceed?

1 Select program part Database.

 

2 Click on the symbol  or the menu item File ▶ Open....

The dialog window Open database opens.

 

3 Select desired database or enter name in the field Database name.

 

4 Click on [Open].

The selected database opens and its data sets are displayed in the
Determination overview. The database name is displayed in the
title bar of the program, the number of currently opened databases
is displayed in the left upper corner of the database symbol.

NOTE

A maximum of 4 databases can be opened, but only 2 can be dis-
played at the same time. Databases that are open at the time the
program is ended will be automatically opened the next time the
program is started.

 

5 Select desired determinations.

 

6 Click on menu item File ▶ Print ▶ Determination overview….

The dialog window Print determination overview (PDF) opens.

 

7 Under Selection, select desired determinations.
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8 Under Orientation, select the option Portrait format or Land-
scape format.

 

9 Click on [OK].

The determination overview is opened as PDF file.
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