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Installation tiamo 2.x

1 System requirements (minimal)

Operating system Windows 2000 SP4, Windows XP Professional SP2,
Windows Vista

RAM 1 GB (Windows 2000 / Windows XP)

2 GB (Windows Vista)

Memory Program: 500 MB

Data: 2 GB (for about 5000 determinations)

Serial ports for devices with RS232 interface

USB ports for devices with USB interface

The windows user must have administrator rights in order to be able to install
the tiamo software.

Additional requirements for the tiamo server:

Network 10 MBit/s, stable and permanent

Communication via TCP/IP

Operating system Windows 2000 SP4, Windows XP Professional SP2,
Windows 2000 Server, Windows 2003 Server,
Windows Vista

Caution

During a determination data loss may occur when the PC switches over to the
standby mode. In the energy settings of the operating system the standby
mode should therefore be deactivated.

2 Single workplace installation

With the single workplace version tiamo light or tiamo full the workplace and
database will be installed on your computer.
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1 On inserting the CD into the drive of your computer the installation will be
started automatically. If this option is deactivated on your computer, double
click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nevertheless.

Afterwards, click on [Next].

 

2 After having read the license agreement for tiamo and accepting it with
[Yes] a window will appear where you can enter the license code.

 

3 Enter the license code for tiamo light or tiamo full and click on [Next].

Note

If you have entered the license code of an update license, then the license
code of the previous full version will additionally be requested.



8.101.8002EN 3

 

4 Now enter the target folder for the tiamo installation and confirm with
[Next].

 

5 In the dialog window Additional installation information you can
define the path for the database and backup files:

Note

The default paths differ in Windows Vista and Windows 2000 or Win-
dows XP.

Under [Advanced...] it is possible to change the ports tiamo uses to com-
municate with the database and administration server. If the ports are used
already, an appropriate error message will appear. Ask your system admin-
istrator for more information about this. Continue with [Next].
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6 Follow the instructions of the program until the following message appears:

This message points out which ports tiamo uses. Write down these ports
and inform your system administrator in case tiamo is not able to connect
to the database. Confirm the message with [OK].

 

7 As soon as the copying procedure has been terminated you can set further
workplace settings:

The option "The client ID must exist in the current tiamo system." is
only activatable if a database from a previous installation already exists on
your computer or if you want to connect to a database server which has
been installed on another computer.

If you activate this option tiamo checks whether the identifier you have
entered exists in the database. If this is true the identifier and all associated
settings will be adopted. With this option a renewed installation of a client
is much easier.

Click on [Next]. If the database ports are not available, an appropriate error
message will appear and the installation will be canceled. In this case, check
your server and firewall settings before installing the program again.

 

8 At the end of the installation the file info.txt will be created which contains
all relevant information concerning your current tiamo installation. Save
this file on your hard disk in case of need in future and print it (add to IQ).
Complete the installation with [Finish].
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An InstallLog file with a list of all files having been copied to your computer
and with a confirmation for a successful installation is saved in the tiamo
installation folder (default: C:\Program Files\Metrohm\tiamo) under bin
\InstallLog.

3 Client/Server installation

With the tiamo multi version (multiple workplace version with 3 licenses) you
can choose during the installation whether you want to install a Client (work-
place) or the Server (incl. client) on your computer.

If you only want to install a client on your computer, in advance the server the
client will be connected to must have been installed on another computer.

1 On inserting the CD into the drive of your computer the installation will be
started automatically. If this option is deactivated on your computer, double
click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nevertheless.

Afterwards, click on [Next].

 

2 After having read the license agreement for tiamo and accepting it with
[Yes] a window will appear where you can enter the license code.

 

3 Enter the license code for tiamo multi and click on [Next].

Note

If you have entered the license code of an update license, then the license
code of the previous full version will additionally be requested.
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4 Now enter the target folder for the tiamo installation and confirm with
[Next].

 

5 The dialog window Additional installation information appears where
you can choose whether you want to install a client or the server:

The option workplace installs the client and the database server on your
computer. Choose this option if your computer will be used as server.

With Client only the workplace will be installed and with  you have to
choose the database server (has to be installed in advance!) to which you
want to connect. The network server name or the IP address are accepted.

Under [Advanced...] it is possible to change the ports tiamo uses to com-
municate with the database and administration server. If the ports are used
already, an appropriate error message will appear. Ask your system admin-
istrator for more information about this. Continue with [Next].
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6 All further installation steps correspond to those of the single workplace
installation on from point 6.

4 Modify / repair / remove installation and upgrade
license

In order to carry out modifications on the current tiamo start the file
setup.exe on the installation CD or click on Metrohm tiamo under Control
Panel ▶ Software. Then select Change/Remove:

Modify

With this option you can change the path to the database and backup files and
set the ports which tiamo uses for communication. With the tiamo multi ver-
sion you can additionally change the path to the database server.

If the database path is changed, the existing databases are automatically copied
to the new location.

Repairing/Updating the program

With this option you can repair an existing defective installation or update an
older installation.

￭ Repair installation
In case of a defective tiamo installation because e.g. a DLL file is missing or
a program file has been deleted by mistake tiamo can be repaired with this
option.

￭ Update installation
In case an older version of tiamo is installed, it will be updated to the new
version of tiamo, see Program update with tiamo light/full or Program
update with tiamo multi.
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Caution

During updating older tiamo versions to tiamo 2.x the databases will be con-
verted to the new version. Depending on the size of the database, this can
take some time. For each database a progress bar is displayed which informs
about the status of the conversion.

The computer or Windows must not be restarted or shut down as long as the
conversion runs!

License upgrade

A direct upgrade of your current installation to a tiamo version with additional
features is possible:

￭ tiamo light to
tiamo full or tiamo multi

￭ tiamo full to
tiamo multi

In order to do this enter your new license code in the next dialog window.

Remove

This option removes your tiamo installation. Data which has been generated
after the installation (e.g. database entries, log files, exported data etc.) will
remain on your hard disk.

5 Program update with tiamo light/full

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically updated
for further use with tiamo light/full.

Note

The files in the database and backup directory will be retained when updating
the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories not having been overwritten
by the update will be deleted. The deleted files are listed in the InstallLog.

1 Save the configuration database into an external directory using the backup
function of tiamo. For that, select the menu item File ▶ Save ▶ Man-
ually in the program part Configuration. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is carried
out automatically. It is recommended to copy the backup file to CD/DVD.



8.101.8002EN 9

 

2 If desired, export the methods in addition to the automatic backup with the
configuration database (see above) into an external directory. For that,
select the menu item File ▶ Method manager... in the program part
Method. Select the desired Method group, mark all methods to be expor-
ted and click on [Edit] ▶ Export.... Select the desired export directory and
click on [OK]. The methods are exported into the desired directory. It is
recommended to copy the exported methods to CD/DVD.

 

3 Save all determination databases created by yourself into an external direc-
tory using the backup function of tiamo. For that, select the menu item
File  ▶ Database manager... in the program part Database. Select the
desired database and click on [Backup]. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is carried
out automatically. It is recommended to copy the backup file to CD/DVD.

 

4 Save further files created by yourself in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

 

5 Close tiamo. Insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next].

 

6 Enter the update license code for tiamo light or tiamo full and click on
[Next].
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7 Caution

During updating older tiamo versions to tiamo 2.x the databases will be
converted to the new version. Depending on the size of the database,
this can take some time. For each database a progress bar is displayed
which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion runs!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to your com-
puter and with a confirmation for a successful installation is saved in the
tiamo installation folder (default: C:\Program Files\Metrohm\tiamo) under
bin\InstallLog.

6 Program update with tiamo multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with tiamo
multi.
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Note

The files in the database and backup directory will be retained when updating
the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories not having been overwritten
by the update will be deleted. The deleted files are listed in the InstallLog.

1 Make sure tiamo multi is closed on all clients.

Note

In the subdirectory bin of the tiamo installation there is the application
Clients.exe with which all clients and their status can be displayed.

 

2 Open tiamo multi on the server and save the configuration database into
an external directory using the backup function of tiamo. For that, select
the menu item File ▶ Save ▶ Manually in the program part Configura-
tion. Select the Backup directory, enter a name for the backup file and
click on [Start]. The backup is carried out automatically. It is recommended
to copy the backup file to CD/DVD.

 

3 If desired, export the methods in addition to the automatic backup with the
configuration database (see above) into an external directory. For that,
select the menu item File ▶ Method manager... in the program part
Method. Select the desired Method group, mark all methods to be expor-
ted and click on [Edit] ▶ Export.... Select the desired export directory and
click on [OK]. The methods are exported into the desired directory. It is
recommended to copy the exported methods to CD/DVD.

 

4 Save all determination databases on the server into an external directory
using the backup function of tiamo. For that, select the menu item
File ▶ Database manager... in the program part Database. Select the
desired database and click on [Backup]. Select the Backup directory,
enter a name for the backup file and click on [Start]. The backup is carried
out automatically. It is recommended to copy the backup file to CD/DVD.

 

5 Save further files in the installation directory (e.g. export files) into an exter-
nal directory or to CD/DVD.

 

6 Update server

Close tiamo multi on the server and on all clients. Insert the installation CD
on the server and double click the file setup.exe. Then select Repair/
Update and click on [Next].
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7 Enter the update license code for tiamo multi and click on [Next].

 

8 Note

The update of tiamo multi consists of the server license and three client
licenses. If an existing installation contains additional licenses, these will
be deleted.

Click on [OK] in the corresponding message in order to continue the instal-
lation.



8.101.8002EN 13

 

9 Caution

During updating older tiamo versions to tiamo 2.x the databases will be
converted to the new version. Depending on the size of the database,
this can take some time. For each database a progress bar is displayed
which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion runs!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to the server
and with a confirmation for a successful installation is saved in the tiamo
installation folder (default: C:\Program Files\Metrohm\tiamo) under bin
\InstallLog.

 

10 In case additional licenses have been removed during the server update, of
if further additional licenses are to be added, the Administrator can enter
them in tiamo (dialog: Configuration ▶ Tools ▶ Program administra-
tion ▶ Licenses ▶ Add licenses).

 

11 Update clients

For each client, insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next]. Complete the
installation with [Finish].

Note

In order to facilitate updating many clients, the installation can be copied
from the CD to a writeable medium and the file tiamo_init.ini can be
modified. There, user-defined parameters (license code, installation path,
server name, ...) for the installation can be set in order one will only have
to click through the installation.

An UpdateLog file with a list of all files having been copied to the client
computer and with a confirmation for a successful installation is saved in
the tiamo installation folder (default: C:\Program Files\Metrohm\tiamo)
under bin\InstallLog.
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